summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-astronomy')
-rw-r--r--sci-astronomy/ftools/Manifest2
-rw-r--r--sci-astronomy/ftools/ftools-6.9.ebuild84
2 files changed, 86 insertions, 0 deletions
diff --git a/sci-astronomy/ftools/Manifest b/sci-astronomy/ftools/Manifest
index 7a747a3..5f243f3 100644
--- a/sci-astronomy/ftools/Manifest
+++ b/sci-astronomy/ftools/Manifest
@@ -2,6 +2,8 @@ AUX installManPage-S-namecollision.patch 786 RMD160 82f9911c5922d02f9f0870c19b96
DIST heasoft6.6.2src.tar.gz 41784019 RMD160 5237ddde4c25d0230de3a924985a3147ee2701e1 SHA1 30aac17d03df9b09171572f29be6d0a81a523957 SHA256 ef18ed517db0e2d8874d1febe8fece13e95783b6a7060156d3f7e22d9ceb613c
DIST heasoft6.7src.tar.gz 60248795 RMD160 65d0bb699012d00971a61ed980f47b9ec8447d37 SHA1 c8591dbedee825520b67d27532c2bcd2c9bbd926 SHA256 7cf45f44a4302654c8fe6f395e3f886733abd897d94535220856192b122ee1b1
DIST heasoft6.8src.tar.gz 64583616 RMD160 ec40e117b579d14aa33af28f6f1f84d7ebdc0833 SHA1 338e64a60aa4f6380a34e84e5b8f45f7e4fd9168 SHA256 a364a224f8684d560602c51af201c1409fbd07aa2a111d23f89f8bf8c3d0c9fe
+DIST heasoft6.9src.tar.gz 64709171 RMD160 e70eade8c125c47ed10bb83e1bb21fb7f3f5e229 SHA1 4c8b51f9a3a528d89065a0967bb6e0dc5f25ea30 SHA256 83df06147dc772441427c888c3c7c9d810486aad9a45208586bba56baf160ab4
EBUILD ftools-6.6.2.ebuild 2169 RMD160 d4d62667999476326b68323addfea6cdfc3736a0 SHA1 c2871e847c13beff01b94ea7bc0e5a0ae3c82dd9 SHA256 f84dd94446cda6449f1732a545aeebd81d9f1123b81eacbec9b1a3b9d51751f4
EBUILD ftools-6.7.ebuild 2179 RMD160 bdb5af3cd6501ffb4a7162da661b95a08025974e SHA1 a07e14af03bc70175434b811790f54cb38b981ea SHA256 fc8c7b3e23beb4157dc627d309b7bd08637093b57fcd4b822c47d744b86c428b
EBUILD ftools-6.8.ebuild 2227 RMD160 e3d2dac8636dd9911218336761d8f7b16436809b SHA1 def4ff79151373888c25707766de7b4a6e48fb7b SHA256 7da6b6be1e2c2e3a5447af4a25737398485b121bb44002b8ad51d0fbbab0f255
+EBUILD ftools-6.9.ebuild 2227 RMD160 e3d2dac8636dd9911218336761d8f7b16436809b SHA1 def4ff79151373888c25707766de7b4a6e48fb7b SHA256 7da6b6be1e2c2e3a5447af4a25737398485b121bb44002b8ad51d0fbbab0f255
diff --git a/sci-astronomy/ftools/ftools-6.9.ebuild b/sci-astronomy/ftools/ftools-6.9.ebuild
new file mode 100644
index 0000000..6569e17
--- /dev/null
+++ b/sci-astronomy/ftools/ftools-6.9.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=2
+
+inherit eutils
+
+DESCRIPTION="General-Use FTools for manipulating and inspecting FITS files"
+HOMEPAGE="http://heasarc.gsfc.nasa.gov/docs/software/ftools/ftools_menu.html"
+SRC_URI="http://localhost/heasoft${PV}src.tar.gz"
+LICENSE="UNKOWN freedist as-is GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+RESTRICT="test"
+
+DEPEND="x11-base/xorg-server
+ >=dev-lang/perl-5.6.0"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/heasoft-${PV}/BUILD_DIR"
+PREFIX="/usr/heasoft-${PV}"
+
+MSG="The HEASOFT General-Use FTools have been installed into
+${PREFIX}.
+
+To use the HEASOFT, you need to source the headas init script,
+like so
+ . \${HEADAS}/headas-init.sh
+if you are using a bourne-shell. As a shortcut you can put an
+alias in your ~/.bashrc:
+ alias heainit=\". \${HEADAS}/headas-init.sh\"
+
+C-shells should source \${HEADAS}/headas-init.csh instead.
+
+The environment vairable \${HEADAS} has been defined for you
+globally in /etc/env.d/99headas."
+
+pkg_setup() {
+ [[ -d "${PREFIX}" ]] && die "Please unmerge previous installation."
+ ewarn "This ebuild works but doesn't do things as god intended..."
+}
+
+src_prepare() {
+ for subdir in tcl tk; do
+ cd "${S}"/../tcltk/${subdir}/unix
+ epatch "${FILESDIR}"/installManPage-S-namecollision.patch \
+ || die "epatch failed"
+ done
+ cd "${S}"/../ftools/guis/xdf
+ sed -i '27iClientData Tk_MainWindow (Tcl_Interp *) ;' xdfShared.c || die
+}
+
+src_configure() {
+ econf --prefix="${PREFIX}" || die "econf failed"
+}
+
+src_compile() {
+ # -j1 and -j2 are ok, but -j3 is not.
+ emake -j2 || die "emake failed"
+}
+
+src_install() {
+ # The heasoft install scripts don't allow for $DESTDIR. Thus we
+ # must let headas install itself. This is very, very bad.
+ addwrite "${PREFIX}"
+ einfo "Installing into ${PREFIX} directly..."
+ # -j1 is needed, don't know why exactly
+ emake -j1 install || die "emake install failed"
+ einfo "Moving ${PREFIX} to image directory..."
+ mkdir "${D}"/usr
+ mv "${PREFIX}" "${D}"/usr
+
+ echo "${MSG}" > WTF
+ dodoc WTF
+
+ echo "HEADAS=\"`grep "HD_TOP_EXEC_PFX.*= " Makefile | sed "s#^HD_TOP_EXEC_PFX.*= ##"`\"" > 99headas
+ doenvd 99headas
+}
+
+pkg_postinst() {
+ elog "${MSG}"
+}