summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-astronomy')
-rw-r--r--sci-astronomy/ftools/Manifest2
-rw-r--r--sci-astronomy/ftools/ftools-6.6.2.ebuild77
2 files changed, 79 insertions, 0 deletions
diff --git a/sci-astronomy/ftools/Manifest b/sci-astronomy/ftools/Manifest
index 6ccd4af..0d59763 100644
--- a/sci-astronomy/ftools/Manifest
+++ b/sci-astronomy/ftools/Manifest
@@ -8,5 +8,7 @@ AUX lhea-fixpfiles-destdir.patch 562 RMD160 fd1af4e68bb7885652a6e81404371bba5fe8
AUX no-tk-docs.patch 738 RMD160 d69e261c402d2e545f109495be999eaeb5d37620 SHA1 35ff2466c06df162e584b76ad3ef15d05b9e2f42 SHA256 0782fe89fc4d29eb4ba2c01f8d6420762060a156db7cb7cf7847f3a5a366f44c
AUX par2-destdir.patch 580 RMD160 56efb9a0049486f7736fe6bcd08947de45599ffa SHA1 97e12b9bb9feccf1be3d3bc1b83a6e79d4078f37 SHA256 aba4b7ba28204b6863c5e8ade5528874ef0606e15d03b1ea167ab9732ac481d4
DIST heasoft6.6.1src.tar.gz 41783649 RMD160 b03d23ad61023d9f9d8df247a448c8ad4d66f98d SHA1 58376bd6ce4dbc9cdb3a901c977602d120d0609e SHA256 f73e78e5a5b6af8b9db0aee66957bf450980455fc78a8d7aa056e6013b49285d
+DIST heasoft6.6.2src.tar.gz 41784152 RMD160 17b852cc9d1b9b9f26d7eda3e0cb83f44d917c7a SHA1 dbe47ac58cecb6cc83ecf17ff9af9af0b5f95ccd SHA256 a72ce51c4de32f85ca79d1eacdd0fa48459eabfee3d0c9857e989aaec80d5abf
EBUILD ftools-6.6.1-r1.ebuild 2003 RMD160 4eb8cb1f649f80cc259e4b9610a9b8aaf1f8a4ee SHA1 ac10d3fcad4aa7b7446d58bdbd0948cf85ea54b3 SHA256 871d835dbbdb71314f8d90a94a22a7519d8c648d442746066363ac3c2c170538
EBUILD ftools-6.6.1.ebuild 1911 RMD160 ba849617b62ddbac13c1fab45157d1bbd05db7bf SHA1 078a2aa8bf1a5e5af3b2da31c835f2c630f677e9 SHA256 4e389dd716cb9e4e9243178c4c067b96f2839ced5ea5446b57c163f918069be7
+EBUILD ftools-6.6.2.ebuild 2003 RMD160 4eb8cb1f649f80cc259e4b9610a9b8aaf1f8a4ee SHA1 ac10d3fcad4aa7b7446d58bdbd0948cf85ea54b3 SHA256 871d835dbbdb71314f8d90a94a22a7519d8c648d442746066363ac3c2c170538
diff --git a/sci-astronomy/ftools/ftools-6.6.2.ebuild b/sci-astronomy/ftools/ftools-6.6.2.ebuild
new file mode 100644
index 0000000..527998d
--- /dev/null
+++ b/sci-astronomy/ftools/ftools-6.6.2.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=2
+
+inherit eutils
+
+DESCRIPTION="General-Use FTools for manipulating and inspecting FITS files"
+HOMEPAGE="http://heasarc.gsfc.nasa.gov/docs/software/ftools/ftools_menu.html"
+SRC_URI="heasoft${PV}src.tar.gz"
+LICENSE="UNKOWN"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+RESTRICT="test"
+
+DEPEND="x11-base/xorg-server
+ >=dev-lang/perl-5.6.0"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/heasoft-${PV}/BUILD_DIR"
+PREFIX="/usr/heasoft-${PV}"
+
+MSG="The HEASOFT General-Use FTools have been installed into
+${PREFIX}.
+
+To use the HEASOFT, you need to source the headas init script,
+like so
+ . \${HEADAS}/headas-init.sh
+if you are using a bourne-shell. As a shortcut you can put an
+alias in your ~/.bashrc:
+ alias heainit=\". \${HEADAS}/headas-init.sh\"
+
+C-shells should source \${HEADAS}/headas-init.csh instead.
+
+The environment vairable \${HEADAS} has been defined for you
+globally in /etc/env.d/99headas."
+
+pkg_setup() {
+ [[ -d "${PREFIX}" ]] && die "Please unmerge previous installation."
+ ewarn "This ebuild works but doesn't do things as god intended..."
+}
+
+src_prepare() {
+ for subdir in tcl tk; do
+ cd "${S}"/../tcltk/${subdir}/unix
+ epatch "${FILESDIR}"/installManPage-S-namecollision.patch \
+ || die "epatch failed"
+ done
+}
+
+src_configure() {
+ econf --prefix="${PREFIX}" || die "econf failed"
+}
+
+src_install() {
+ # The heasoft install scripts don't allow for $DESTDIR. Thus we
+ # must let headas install itself. This is very, very bad.
+ addwrite "${PREFIX}"
+ einfo "Installing into ${PREFIX} directly..."
+ # Hell knows why we need -j1 here. But we sure need it.
+ emake -j1 install || die "emake install failed"
+ einfo "Moving ${PREFIX} to image directory..."
+ mkdir "${D}"/usr
+ mv "${PREFIX}" "${D}"/usr
+
+ echo "${MSG}" > WTF
+ dodoc WTF
+
+ echo "HEADAS=\"`grep "HD_TOP_EXEC_PFX.*= " Makefile | sed "s#^HD_TOP_EXEC_PFX.*= ##"`\"" > 99headas
+ doenvd 99headas
+}
+
+pkg_postinst() {
+ elog "${MSG}"
+}