summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-astronomy')
-rw-r--r--sci-astronomy/ds9/Manifest5
-rw-r--r--sci-astronomy/ds9/ds9-5.1-r1.ebuild70
-rw-r--r--sci-astronomy/ds9/files/ds9-5.1-Makefile.patch30
-rw-r--r--sci-astronomy/ds9/files/ds9-5.1-gcc4.2-x86.patch26
-rw-r--r--sci-astronomy/ds9/files/ds9-5.1-tk-gif.patch15
-rw-r--r--sci-astronomy/fpipe/Manifest1
-rw-r--r--sci-astronomy/fpipe/fpipe-0.0.0.ebuild44
-rw-r--r--sci-astronomy/ftools/Manifest5
-rw-r--r--sci-astronomy/ftools/files/hd_install-DESTDIR.patch24
-rw-r--r--sci-astronomy/ftools/ftools-6.4.1.ebuild77
-rw-r--r--sci-astronomy/ftools/ftools-6.4.ebuild60
-rw-r--r--sci-astronomy/ftools/ftools-6.5.ebuild77
12 files changed, 434 insertions, 0 deletions
diff --git a/sci-astronomy/ds9/Manifest b/sci-astronomy/ds9/Manifest
new file mode 100644
index 0000000..32b19e6
--- /dev/null
+++ b/sci-astronomy/ds9/Manifest
@@ -0,0 +1,5 @@
+AUX ds9-5.1-Makefile.patch 1154 RMD160 1fa279839fecd4cc56a8445d34036ade9ad92406 SHA1 84dcb1a7d6e3fe1583d8ff9cf25a81091364cc9a SHA256 632d64d27f14e73c9ccb0e16874f652d556edbff0be34e38f53ec5cbd1f1b59b
+AUX ds9-5.1-gcc4.2-x86.patch 1022 RMD160 40c9c5da3fefae0a67af6750965df797dd2f4a7b SHA1 26a7c740fceb19f5277d2528f0ab4d3e45a46507 SHA256 30a2cabeb66fc2dccc081c04d4895ceab6d62e321f317d1e8c779b6128b41da3
+AUX ds9-5.1-tk-gif.patch 460 RMD160 bc670457e0424041d4fe4022f569cd78457c9b7b SHA1 aa90e00e34c026bf8776f973644cfebc09abaa32 SHA256 f46964aea235b2da8ae294a151668ede2dab46e83a0fbe1549de19b3305a477b
+DIST ds9.5.1.tar.gz 27331599 RMD160 46d915ff098f13911858320d33f5cda6c8ee0ea1 SHA1 7c2bb56e0a8a222b0d13d1d255aaa98fd2979d45 SHA256 aea981ea5714ca4dd9125aacebf2676a85e7045da7d1f97492fbe0e84a22aaf8
+EBUILD ds9-5.1-r1.ebuild 1985 RMD160 a01698ff9b072c9f8e1d25ab34424ca23b453b3d SHA1 f1184d78c3c69175b5b6edf5c030064d3a7730cf SHA256 c44ef2e01441d34e6ea16e13791b5b7bec21e2b7f494e3f48b1ff58180939c97
diff --git a/sci-astronomy/ds9/ds9-5.1-r1.ebuild b/sci-astronomy/ds9/ds9-5.1-r1.ebuild
new file mode 100644
index 0000000..8bc8b9b
--- /dev/null
+++ b/sci-astronomy/ds9/ds9-5.1-r1.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/ds9/ds9-5.1.ebuild,v 1.3 2008/02/14 23:32:16 bicatali Exp $
+
+inherit flag-o-matic eutils toolchain-funcs
+
+DESCRIPTION="Data visualization application for astronomical FITS images"
+HOMEPAGE="http://hea-www.harvard.edu/RD/ds9"
+SRC_URI="http://hea-www.harvard.edu/saord/download/${PN}/source/${PN}.${PV}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+RDEPEND="x11-libs/libX11
+ x11-libs/libXdmcp
+ x11-libs/libXau"
+DEPEND="${RDEPEND}
+ app-arch/zip"
+
+RESTRICT="strip test mirror"
+
+S="${WORKDIR}/sao${PN}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ # patch to speed up compilation (no man pages generation)
+ epatch "${FILESDIR}"/${P}-Makefile.patch
+
+ # fix stack smashing on x86 with gcc-4.2
+ if [[ "${ARCH}" == "x86" ]]; then
+ epatch "${FILESDIR}"/${P}-gcc4.2-x86.patch
+ fi
+ # security fix in embedded tk (bug #208464)
+ epatch "${FILESDIR}"/${P}-tk-gif.patch
+
+ # remove build-time dependency on etags (i.e. emacs or xemacs)
+ sed -i -e '/^all/s/TAGS//' saotk/*/Makefile || die "sed failed"
+}
+
+src_compile() {
+ local ds9arch
+ case ${ARCH} in
+ x86) ds9arch=linux ;;
+ amd64) ds9arch=linux64 ;;
+ ppc) ds9arch=linuxppc ;;
+ x86-fbsd) ds9arch=freebsd ;;
+ *) die "ds9 not supported upstream for this architecture";;
+ esac
+ ln -s make.${ds9arch} make.include
+
+ # This is a long and fragile compilation
+ # which recompiles tcl/tk, tkimg, blt, funtools,
+ # and a lot of other packages
+ emake -j1 \
+ CC="$(tc-getCC)" \
+ CXX="$(tc-getCXX)" \
+ OPTS="${CXXFLAGS}" \
+ || die "emake failed"
+}
+
+src_install () {
+ dobin bin/ds9 || die "failed installing ds9 binary"
+ dobin bin/xpa* || die "failed installing xpa* binaries"
+ doman man/man?/xpa* || die " failed installing man pages"
+ dodoc README acknowledgement || die "failed installing basic doc"
+ if use doc; then
+ dohtml -r doc/* || die "failed installing html doc"
+ fi
+}
diff --git a/sci-astronomy/ds9/files/ds9-5.1-Makefile.patch b/sci-astronomy/ds9/files/ds9-5.1-Makefile.patch
new file mode 100644
index 0000000..6e1d6a8
--- /dev/null
+++ b/sci-astronomy/ds9/files/ds9-5.1-Makefile.patch
@@ -0,0 +1,30 @@
+--- Makefile.orig 2008-01-15 15:19:48.367764731 +0000
++++ Makefile 2008-01-15 16:04:54.805517099 +0000
+@@ -235,23 +235,23 @@
+ tcl : FORCE
+ @echo "Installing Tcl..."
+ cd $(TCLDIRDIR); CC='$(CC)' CFLAGS='$(OPTS) $(TCLOPTS)' LDFLAGS='$(LIBS)' ./configure $(TCLFLAGS) --disable-shared
+- cd $(TCLDIRDIR); $(MAKE) install
++ cd $(TCLDIRDIR); $(MAKE) install-binaries install-libraries
+
+ tk : FORCE
+ @echo "Installing Tk..."
+ cd $(TKDIRDIR); CC='$(CC)' CFLAGS='$(OPTS) $(TCLOPTS)' LDFLAGS='$(LIBS)' ./configure $(TCLFLAGS) --disable-shared
+- cd $(TKDIRDIR); $(MAKE) install
++ cd $(TKDIRDIR); $(MAKE) install-binaries install-libraries
+ $(RM) -r lib/$(TKVER)/demos
+
+ tktable : FORCE
+ @echo "Installing TkTable..."
+ cd $(TKTABLEDIR); CC='$(CC)' CFLAGS='$(OPTS)' LDFLAGS='$(LIBS)' ./configure $(TKTABLEFLAGS) --disable-shared
+- cd $(TKTABLEDIR); $(MAKE); $(MAKE) install
++ cd $(TKTABLEDIR); $(MAKE); $(MAKE) install-binaries install-libraries
+
+ tcllib : FORCE
+ @echo "Installing TCLLIB..."
+ cd $(TCLLIBDIR); ./configure $(TCLLIBFLAGS)
+- cd $(TCLLIBDIR); $(MAKE) install
++ cd $(TCLLIBDIR); $(MAKE) install-libraries
+
+ ifeq ($(OS),macosx)
+ blt : optincl
diff --git a/sci-astronomy/ds9/files/ds9-5.1-gcc4.2-x86.patch b/sci-astronomy/ds9/files/ds9-5.1-gcc4.2-x86.patch
new file mode 100644
index 0000000..99465ca
--- /dev/null
+++ b/sci-astronomy/ds9/files/ds9-5.1-gcc4.2-x86.patch
@@ -0,0 +1,26 @@
+diff -Naur saods9/make.linux saods9.new/make.linux
+--- saods9/make.linux 2007-12-18 17:54:57.000000000 -0500
++++ saods9.new/make.linux 2008-01-23 08:58:46.000000000 -0500
+@@ -9,15 +9,15 @@
+
+ # note: bug with gcc 4.1 and 4.2
+ # can't use -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64
++CXX = g++
++CXXOPT = ${OPTS} -fPIC -DHAVE_SYS_UN_H -DHAVE_SYS_SHM_H
++CC = gcc
++CCOPT = ${OPTS} -fPIC -DHAVE_SYS_UN_H -DHAVE_SYS_SHM_H
++
+ #CXX = g++
+-#CXXOPT = ${OPTS} -fPIC -DHAVE_SYS_UN_H -DHAVE_SYS_SHM_H
++#CXXOPT = ${OPTS} -fPIC -DHAVE_SYS_UN_H -DHAVE_SYS_SHM_H -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64
+ #CC = gcc
+-#CCOPT = ${OPTS} -fPIC -DHAVE_SYS_UN_H -DHAVE_SYS_SHM_H
+-
+-CXX = g++34
+-CXXOPT = ${OPTS} -fPIC -DHAVE_SYS_UN_H -DHAVE_SYS_SHM_H -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64
+-CC = gcc34
+-CCOPT = ${OPTS} -fPIC -DHAVE_SYS_UN_H -DHAVE_SYS_SHM_H -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64
++#CCOPT = ${OPTS} -fPIC -DHAVE_SYS_UN_H -DHAVE_SYS_SHM_H -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64
+
+ STRIP = strip
+ ZCAT = zcat
diff --git a/sci-astronomy/ds9/files/ds9-5.1-tk-gif.patch b/sci-astronomy/ds9/files/ds9-5.1-tk-gif.patch
new file mode 100644
index 0000000..4649a56
--- /dev/null
+++ b/sci-astronomy/ds9/files/ds9-5.1-tk-gif.patch
@@ -0,0 +1,15 @@
+--- tk8.4.17/generic/tkImgGIF.c.orig 2008-02-14 23:20:53.683962654 +0000
++++ tk8.4.17/generic/tkImgGIF.c 2008-02-14 23:21:42.762759495 +0000
+@@ -826,6 +826,12 @@
+ Tcl_PosixError(interp), (char *) NULL);
+ return TCL_ERROR;
+ }
++
++ if (initialCodeSize > MAX_LWZ_BITS) {
++ Tcl_SetResult(interp, "malformed image", TCL_STATIC);
++ return TCL_ERROR;
++ }
++
+ if (transparent != -1) {
+ cmap[transparent][CM_RED] = 0;
+ cmap[transparent][CM_GREEN] = 0;
diff --git a/sci-astronomy/fpipe/Manifest b/sci-astronomy/fpipe/Manifest
new file mode 100644
index 0000000..3c5818c
--- /dev/null
+++ b/sci-astronomy/fpipe/Manifest
@@ -0,0 +1 @@
+EBUILD fpipe-0.0.0.ebuild 899 RMD160 9f43b689a627b817fc9481b2fdeb6c31a94ad607 SHA1 5b323118d046df47bf1d8cd5512f224d5a78c62d SHA256 06d4c517210113e595ab2e7690c1b495cd0a25b49ba3fc3a57fec31d2a054495
diff --git a/sci-astronomy/fpipe/fpipe-0.0.0.ebuild b/sci-astronomy/fpipe/fpipe-0.0.0.ebuild
new file mode 100644
index 0000000..0230296
--- /dev/null
+++ b/sci-astronomy/fpipe/fpipe-0.0.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit subversion eutils
+
+DESCRIPTION="The fpipe: a CCD and high energy astrophysics data analysis package"
+HOMEPAGE=""
+ESVN_REPO_URI="http://pulsar.sternwarte.uni-erlangen.de/repos/fpipe/trunk/software"
+SRC_URI=""
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="+debug"
+
+DEPEND="x11-base/xorg-server
+ >=sci-libs/cfitsio-3.000
+ >=x11-libs/gtk+-2.8
+ x11-libs/cairo
+ sys-libs/readline
+ sci-libs/xpalib
+ dev-libs/pth"
+# and from CPAN: Tk::DataTree, IPC::XPA
+RDEPEND="${DEPEND}
+ dev-lang/perl
+ dev-perl/perl-tk
+ dev-perl/XML-Simple
+ virtual/perl-Time-HiRes"
+
+# ESVN_OFFLINE="yes"
+ESVN_UP_FREQ="1"
+ESVN_BOOTSTRAP="bootstrap.sh"
+
+
+src_compile () {
+ econf $(use_enable debug) CFLAGS="-fPIC" || die "econf failed"
+ emake || die "emake failed"
+}
+
+
+src_install () {
+ einstall || die "einstall failed"
+}
diff --git a/sci-astronomy/ftools/Manifest b/sci-astronomy/ftools/Manifest
new file mode 100644
index 0000000..f339872
--- /dev/null
+++ b/sci-astronomy/ftools/Manifest
@@ -0,0 +1,5 @@
+AUX hd_install-DESTDIR.patch 891 RMD160 00597fd6c53357f4dd7e03d47303de86ee0cb07b SHA1 27a84b5ea95d0b318b8d08a4781d4aa9a8d845dd SHA256 66d0478f2936b56165e2237578e6bb78dcc6a4ca7f197470b5164a043500b92f
+DIST heasoft6.4.1src.tar.gz 36639100 RMD160 ffeb7ef5dc637f2f52052de82bcb9dc71c524716 SHA1 9f1f3dfbcbe6bc88ebfcb755b6fcd567b7a9e966 SHA256 a0d4eccad7385acb42e9001b22ed8a9f1bd4a58fc57f7984c8340282d31820d2
+DIST heasoft6.4src.tar.gz 41516159 RMD160 44c91a6b28ddea96de0bd7d28b8e20ccfbd0edd8 SHA1 fad10e23242fb01e0a2e0ae71e22ec264d743540 SHA256 c681a0a40306ef17b0b1338b4927babaf606c0ab74cd43e2c73454da98f1270f
+EBUILD ftools-6.4.1.ebuild 1893 RMD160 08eab4ce73f0d31c896e605cfc161809f854d74f SHA1 d50c73720e37e5214ceea408367de4c94b48aab0 SHA256 a0196ece0e290c7d70fb2438f6ff07b505ed4539259d57f0ab5bcbaa8fd56040
+EBUILD ftools-6.4.ebuild 1558 RMD160 f9efee4336743493253fc938ea8027567749be21 SHA1 c4bad50031b28fb21859df057c46e9dcc00969e6 SHA256 53643ce6d1d4b1d16a1660796a58759b2be84c87e636a8d68be9978be97f4576
diff --git a/sci-astronomy/ftools/files/hd_install-DESTDIR.patch b/sci-astronomy/ftools/files/hd_install-DESTDIR.patch
new file mode 100644
index 0000000..f0c47e5
--- /dev/null
+++ b/sci-astronomy/ftools/files/hd_install-DESTDIR.patch
@@ -0,0 +1,24 @@
+--- heasoft-6.4.1.orig/BUILD_DIR/hd_install.c 2004-04-09 20:33:04.000000000 +0200
++++ heasoft-6.4.1/BUILD_DIR/hd_install.c 2008-06-24 22:57:00.000000000 +0200
+@@ -1548,6 +1548,21 @@
+ /* Next argument is required to be the name of the destination. */
+ if(NULL != *nextArg && '\0' != **nextArg) {
+ status = CleanPath(*nextArg, &dest, status);
++
++ /* add $DESTDIR to filename */
++ char *newdest = NULL;
++ char *destdir = getenv("DESTDIR");
++ fprintf(stderr, "DESTDIR=%s.\n", destdir);
++ fprintf(stderr, "dest=%s.\n", dest);
++ if (NULL != destdir) {
++ status = AppendPath(destdir, dest, &newdest, status);
++ fprintf(stderr, "newdest=%s.\n", newdest);
++ if (OK != status)
++ continue;
++ free(dest);
++ dest = newdest;
++ }
++
+ ++nextArg;
+ } else {
+ fprintf(stderr, sErrFmt, sBanner, usage);
diff --git a/sci-astronomy/ftools/ftools-6.4.1.ebuild b/sci-astronomy/ftools/ftools-6.4.1.ebuild
new file mode 100644
index 0000000..76de0d9
--- /dev/null
+++ b/sci-astronomy/ftools/ftools-6.4.1.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils fortran autotools
+
+# This package only includes the futils.
+
+DESCRIPTION="HEASOFT/HEADAS: The FTools (futils only) from NASA's GSFC for viewing and manipulating FITS files. Includes CFITSIO."
+HOMEPAGE="http://heasarc.gsfc.nasa.gov/docs/software/"
+SRC_URI="ftp://heasarc.gsfc.nasa.gov/software/fitsio/c/heasoft${PV}src.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+# Recommend >=dev-lang/perl-5.6.0.
+# Possibly we can have cfitsio installed side-by-side.
+DEPEND=">=dev-lang/perl-5.6.0
+ x11-base/xorg-server
+ !sci-libs/cfitsio"
+RDEPEND="${DEPEND}"
+
+
+S="${WORKDIR}/heasoft-${PV}"
+
+# INSTDIR="${D}/headas-${PV}"
+# INSTDIR_ARCH="${INSTDIR}/<arch-and-lib>"
+
+INSTPREFIX=/usr/heasoft
+ARCHPREFIX=/usr
+
+pkg_setup() {
+ fortran_pkg_setup
+}
+
+src_unpack() {
+ unpack "${A}"
+
+ # All occurrences of hd_install.c are the same, and need the same patch.
+ HD_INSTALL_C_DIR=". tcltk ftools heacore demo"
+ for rdir in ${HD_INSTALL_C_DIR}; do
+ cd "${S}/${rdir}"
+ einfo "Entering \"${rdir}\" ..."
+ EPATCH_OPTS="-p1" epatch "${FILESDIR}/hd_install-DESTDIR.patch"
+ done
+}
+
+src_compile() {
+ cd "${S}/BUILD_DIR/"
+ econf || die "econf failed"
+ emake || die "emake failed"
+}
+
+
+src_install() {
+ cd "${S}/BUILD_DIR/"
+ emake DESTDIR="${D}" install || die "Install failed"
+ dodoc "${S}/Release_Notes_6.4.1" || die "dodoc failed"
+}
+
+pkg_postinst() {
+ ewarn "In order to use heasoft and the ftools, put in your ~/.bashrc"
+ einfo
+ ewarn " export HEADAS=\"${INSTDIR_ARCH}\""
+ ewarn " alias heainit=\". $HEADAS/headas-init.sh"
+ einfo
+ ewarn "and initialize the ftools with"
+ einfo
+ ewarn " $ heainit"
+ einfo
+ ewarn "every time you start a new shell."
+ ewarn "This is necessary since heasoft does not comply exactly with"
+ ewarn "GNU software conventions."
+ elog "Happy fitsing."
+}
diff --git a/sci-astronomy/ftools/ftools-6.4.ebuild b/sci-astronomy/ftools/ftools-6.4.ebuild
new file mode 100644
index 0000000..9dafd23
--- /dev/null
+++ b/sci-astronomy/ftools/ftools-6.4.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils fortran autotools
+
+DESCRIPTION="HEASOFT/HEADAS: The FTools from NASA's GSFC for viewing and manipulating FITS files. Includes CFITSIO."
+HOMEPAGE="http://heasarc.gsfc.nasa.gov/docs/software/"
+SRC_URI="ftp://heasarc.gsfc.nasa.gov/software/fitsio/c/heasoft${PV}src.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 x86"
+IUSE=""
+
+# Recommend >=dev-lang/perl-5.6.0.
+# Possibly we can have cfitsio installed side-by-side.
+DEPEND="dev-lang/perl
+ x11-base/xorg-server
+ !sci-libs/cfitsio"
+RDEPEND="${DEPEND}"
+
+
+S="${WORKDIR}/headas-${PV}"
+
+INSTDIR="${D}/headas-${PV}"
+INSTDIR_ARCH="${INSTDIR}/<arch-and-lib>"
+
+pkg_setup() {
+ fortran_pkg_setup
+}
+
+
+src_compile() {
+ cd "${S}/BUILD_DIR/"
+ econf --x-include="${ROOT}/usr/include" --x-libraries="${ROOT}/usr/lib" || die "econf failed"
+ emake || die "emake failed"
+}
+
+
+src_install () {
+ emake install || die "emake install failed"
+ dodoc "${S}/Release_Notes_6.3" "${S}/Release_Notes_6.3.1" "${S}/HEASOFT-INSTALL.TXT" || die "dodoc failed"
+}
+
+pkg_postinst() {
+ ewarn "In order to use heasoft and the ftools, put in your ~/.bashrc"
+ einfo
+ ewarn " export HEADAS=\"${INSTDIR_ARCH}\""
+ ewarn " alias heainit=\". $HEADAS/headas-init.sh"
+ einfo
+ ewarn "and initialize the ftools with"
+ einfo
+ ewarn " $ heainit"
+ einfo
+ ewarn "every time you start a new shell."
+ ewarn "This is necessary since heasoft does not comply exactly with"
+ ewarn "GNU software conventions."
+ elog "Happy fitsing."
+}
diff --git a/sci-astronomy/ftools/ftools-6.5.ebuild b/sci-astronomy/ftools/ftools-6.5.ebuild
new file mode 100644
index 0000000..3a4b95a
--- /dev/null
+++ b/sci-astronomy/ftools/ftools-6.5.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils fortran autotools
+
+# This package only includes the futils.
+
+DESCRIPTION="HEASOFT/HEADAS: The FTools (futils only) from NASA's GSFC for viewing and manipulating FITS files. Includes CFITSIO."
+HOMEPAGE="http://heasarc.gsfc.nasa.gov/docs/software/"
+SRC_URI="ftp://heasarc.gsfc.nasa.gov/software/fitsio/c/heasoft${PV}src.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+# Recommend >=dev-lang/perl-5.6.0.
+# Possibly we can have cfitsio installed side-by-side.
+DEPEND=">=dev-lang/perl-5.6.0
+ x11-base/xorg-server
+ !sci-libs/cfitsio"
+RDEPEND="${DEPEND}"
+
+
+S="${WORKDIR}/heasoft-${PV}"
+
+# INSTDIR="${D}/headas-${PV}"
+# INSTDIR_ARCH="${INSTDIR}/<arch-and-lib>"
+
+INSTPREFIX=/usr/heasoft
+ARCHPREFIX=/usr
+
+pkg_setup() {
+ fortran_pkg_setup
+}
+
+# src_unpack() {
+ # unpack "${A}"
+
+ # # All occurrences of hd_install.c are the same, and need the same patch.
+ # # HD_INSTALL_C_DIR=". tcltk ftools heacore demo"
+ # # for rdir in ${HD_INSTALL_C_DIR}; do
+ # # cd "${S}/${rdir}"
+ # # einfo "Entering \"${rdir}\" ..."
+ # # EPATCH_OPTS="-p1" epatch "${FILESDIR}/hd_install-DESTDIR.patch"
+ # # done
+# }
+
+src_compile() {
+ cd "${S}/BUILD_DIR/"
+ econf || die "econf failed"
+ emake || die "emake failed"
+}
+
+
+src_install() {
+ cd "${S}/BUILD_DIR/"
+ emake DESTDIR="${D}" install || die "Install failed"
+ dodoc "${S}/Release_Notes_6.4.1" || die "dodoc failed"
+}
+
+pkg_postinst() {
+ ewarn "In order to use heasoft and the ftools, put in your ~/.bashrc"
+ einfo
+ ewarn " export HEADAS=\"${INSTDIR_ARCH}\""
+ ewarn " alias heainit=\". $HEADAS/headas-init.sh"
+ einfo
+ ewarn "and initialize the ftools with"
+ einfo
+ ewarn " $ heainit"
+ einfo
+ ewarn "every time you start a new shell."
+ ewarn "This is necessary since heasoft does not comply exactly with"
+ ewarn "GNU software conventions."
+ elog "Happy fitsing."
+}