aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Healy <lmiphay@gmail.com>2021-06-06 11:17:24 +0100
committerPaul Healy <lmiphay@gmail.com>2021-06-06 11:17:24 +0100
commit45835828fa48728b284c0b84072b17fa6f938643 (patch)
treee347fe0a1e89dd6caacab5cd4f596833b78ab861
parentadd libratbag with py3.9 (diff)
downloadlmiphay-45835828fa48728b284c0b84072b17fa6f938643.tar.gz
lmiphay-45835828fa48728b284c0b84072b17fa6f938643.tar.bz2
lmiphay-45835828fa48728b284c0b84072b17fa6f938643.zip
add piper with py3.9
Signed-off-by: Paul Healy <lmiphay@gmail.com>
-rw-r--r--sys-apps/piper/Manifest2
-rw-r--r--sys-apps/piper/piper-0.5.1.ebuild36
2 files changed, 38 insertions, 0 deletions
diff --git a/sys-apps/piper/Manifest b/sys-apps/piper/Manifest
new file mode 100644
index 0000000..8aa61eb
--- /dev/null
+++ b/sys-apps/piper/Manifest
@@ -0,0 +1,2 @@
+DIST piper-0.5.1.tar.gz 234944 BLAKE2B 1df33ca6e2d0dae95b34f8e3a98c6829a8f113ae68fb60980ff40374090b9272f86d69103c33fe0a4e1b0ac21a84724e7cabccca4ce8dd23d02f6d56e67d072b SHA512 13368521a9c32b2dc3300b129ed3bb07a6204623fa750f8f75ca31d2a3b60f43ae5f5066ef755814960d4890a489bdfd21b0e1b8f456b3445e0ba35ac06bc877
+EBUILD piper-0.5.1.ebuild 650 BLAKE2B 4bb804ae9b94f50d9ab2b9bd872466d6d23da336e4a4d1fdfe8df89dfbf596c9d16a929f1072e7fb890bcab649c995decd691913ea0f134a6debc75e49017c6a SHA512 487d33f9ed11a58330258f6d3df6f8fcc4b44f86024d75d6efc3b4ff7dac5e29c04ad4b7ae280f7e9f907289886b21b859642d704a18e45bc10d2d1b468e518a
diff --git a/sys-apps/piper/piper-0.5.1.ebuild b/sys-apps/piper/piper-0.5.1.ebuild
new file mode 100644
index 0000000..ed7df47
--- /dev/null
+++ b/sys-apps/piper/piper-0.5.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_9 )
+
+inherit meson python-r1
+
+DESCRIPTION="GTK application to configure gaming mice"
+HOMEPAGE="https://github.com/libratbag/piper"
+SRC_URI="https://github.com/libratbag/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ >=dev-libs/libratbag-0.14:=
+ virtual/pkgconfig
+"
+RDEPEND="
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/python-evdev[${PYTHON_USEDEP}]
+"
+
+pkg_setup() {
+ python_setup
+}
+
+src_install() {
+ meson_src_install
+ python_optimize
+}
+