aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Healy <lmiphay@gmail.com>2022-02-20 21:00:05 +0000
committerPaul Healy <lmiphay@gmail.com>2022-02-20 21:00:05 +0000
commit464e08833dcacfd4f605332199b7574c9d0e68b4 (patch)
tree0bd5d3180914fa33b10ce2e0dbaead47b6e4c780 /games-simulation/llbase
parentupdate fd to ubuntu 18.04 (diff)
downloadlmiphay-464e08833dcacfd4f605332199b7574c9d0e68b4.tar.gz
lmiphay-464e08833dcacfd4f605332199b7574c9d0e68b4.tar.bz2
lmiphay-464e08833dcacfd4f605332199b7574c9d0e68b4.zip
add ebuild for llbase
Signed-off-by: Paul Healy <lmiphay@gmail.com>
Diffstat (limited to 'games-simulation/llbase')
-rw-r--r--games-simulation/llbase/Manifest1
-rw-r--r--games-simulation/llbase/llbase-1.2.11.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/games-simulation/llbase/Manifest b/games-simulation/llbase/Manifest
new file mode 100644
index 0000000..9b6238f
--- /dev/null
+++ b/games-simulation/llbase/Manifest
@@ -0,0 +1 @@
+EBUILD llbase-1.2.11.ebuild 753 BLAKE2B 2ee92082a526d5b263bbe5432247f6ce09eca9081ac337d10d4c59133050d8a17fba7f2b8d2c91a55f2f3581e76d4b702facc8875566563cc22465042066d4e7 SHA512 d29502ccee85e8ea03c009056d9c77f7a564f5a96af1e0326fe566b063b9e8b9b4778e45f79c5094f5aef995b88a2c349a5899f51902cea87d258aea60e3f889
diff --git a/games-simulation/llbase/llbase-1.2.11.ebuild b/games-simulation/llbase/llbase-1.2.11.ebuild
new file mode 100644
index 0000000..476e125
--- /dev/null
+++ b/games-simulation/llbase/llbase-1.2.11.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=(python3_9)
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit eutils distutils-r1 git-r3
+
+DESCRIPTION="Utility modules used from Linden Lab"
+HOMEPAGE="https://bitbucket.org/lindenlab/llbase/src/master/"
+EGIT_REPO_URI="https://bitbucket.org/lindenlab/llbase.git"
+EGIT_COMMIT="85b2b7d38f91e1c1f76cf742f26d5cdc9e0e1ced"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+"
+DEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ )
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ ${RDEPEND}
+"
+
+DOCS="README.md"
+
+distutils_enable_tests nose