aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Healy <lmiphay@gmail.com>2018-05-27 17:27:45 +0100
committerPaul Healy <lmiphay@gmail.com>2018-05-27 17:27:45 +0100
commit64a4e176a739b77ab9adf06e5755b0893e2534c4 (patch)
tree53daca00ffe8cdf0e1ac2b8df74abafb70a04b27 /games-simulation/radegast-bin/radegast-bin-2.25.134.ebuild
parentupdate for latest plasma use flags (diff)
downloadlmiphay-64a4e176a739b77ab9adf06e5755b0893e2534c4.tar.gz
lmiphay-64a4e176a739b77ab9adf06e5755b0893e2534c4.tar.bz2
lmiphay-64a4e176a739b77ab9adf06e5755b0893e2534c4.zip
add ebuild for latest radegast
Diffstat (limited to 'games-simulation/radegast-bin/radegast-bin-2.25.134.ebuild')
-rw-r--r--games-simulation/radegast-bin/radegast-bin-2.25.134.ebuild71
1 files changed, 71 insertions, 0 deletions
diff --git a/games-simulation/radegast-bin/radegast-bin-2.25.134.ebuild b/games-simulation/radegast-bin/radegast-bin-2.25.134.ebuild
new file mode 100644
index 0000000..3ebf0aa
--- /dev/null
+++ b/games-simulation/radegast-bin/radegast-bin-2.25.134.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit gnome2-utils eutils xdg desktop
+
+MY_PN="${PN/-bin/}"
+
+DESCRIPTION="A messaging app for teams"
+HOMEPAGE="https://radegast.life"
+SRC_URI="https://bitbucket.org/cinderblocks/radegast/downloads/Radegast-${PV}.tbz -> ${MY_PN}-${PV}.tar.bz2"
+LICENSE="BSD"
+RESTRICT="mirror"
+
+SLOT="0"
+KEYWORDS="~amd64 -*"
+IUSE=""
+
+QA_PREBUILT="opt/${PN}/*"
+
+DEPEND=""
+RDEPEND="
+ dev-dotnet/libgdiplus[cairo]
+ dev-lang/mono
+ media-libs/fmod
+"
+
+S=${WORKDIR}/bin
+
+src_prepare() {
+ rm license.txt
+
+ # Login error:
+ # Failed to initialize the sound system: System.DllNotFoundException: fmod
+ # at (wrapper managed-to-native) FMOD.Factory:FMOD_System_Create (intptr&) ...
+ rm libfmod.so libfmod.so.8 libfmodstudio.so libfmodstudio.so.8
+ ln -s libfmod.so.8.14 libfmod.so.8
+ ln -s libfmod.so.8.14 libfmod.so
+ ln -s libfmodstudio.so.8.14 libfmodstudio.so.8
+ ln -s libfmodstudio.so.8.14 libfmodstudio.so
+
+ eapply_user
+}
+
+src_install() {
+ doicon ${MY_PN}.png
+
+ mkdir -p "${D}/opt/${PN}/"
+ cp -pr . ${D}/opt/${PN}
+
+ make_wrapper "${PN}" "mono ./Radegast.exe" "/opt/${PN}" "/opt/${PN}:/opt/fmodex/api/lib"
+ make_desktop_entry "${PN}" "Radegast" "/usr/share/pixmaps/${MY_PN}.png"
+}
+
+pkg_preinst() {
+ xdg_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+ gnome2_icon_cache_update
+}