aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--kde-misc/semantik/Manifest1
-rw-r--r--kde-misc/semantik/semantik-9999.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/kde-misc/semantik/Manifest b/kde-misc/semantik/Manifest
new file mode 100644
index 0000000..ebc3972
--- /dev/null
+++ b/kde-misc/semantik/Manifest
@@ -0,0 +1 @@
+EBUILD semantik-9999.ebuild 866 BLAKE2B 2aeaa7a4f82d9472931437c566805b49df8e7dde7b787851595e25478705c9dd04cf58359a73de0d9d3340e69b88db15025c6289a48ee6c43c50ad751ae42029 SHA512 0f32a3a930dfbdbae6e6f30f739cf02c6fe7d5200e272cc18acb7048b79501984dfdb03e7cbae3891b016822b1d98ab0bbe78240d986f7303467f6bd3d47d8ae
diff --git a/kde-misc/semantik/semantik-9999.ebuild b/kde-misc/semantik/semantik-9999.ebuild
new file mode 100644
index 0000000..bc429df
--- /dev/null
+++ b/kde-misc/semantik/semantik-9999.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PY_SEMANTIK="3.6"
+PYTHON_COMPAT=( python3_6 )
+
+inherit kde5 distutils-r1 git-r3
+
+DESCRIPTION="A mind-mapping application for KDE"
+HOMEPAGE="https://waf.io/semantik.html"
+EGIT_REPO_URI="https://gitlab.com/ita1024/semantik.git"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ $(add_frameworks_dep kio)
+ $(add_qt_dep qtpositioning)
+ $(add_qt_dep qtsvg)
+ $(add_qt_dep qtwebengine 'widgets')
+ dev-lang/python:${PY_SEMANTIK}
+ dev-python/pygments[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+"
+
+#S="${WORKDIR}/plasma-containmentactions-customdesktopmenu"
+
+src_configure() {
+ ./waf configure --prefix=/usr || die
+}
+
+src_compile() {
+ ./waf build || die
+}
+
+src_install() {
+ DESTDIR="${D}" ./waf install --noldconfig --nomimes --nogtkicons || die
+}