aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-simulation')
-rw-r--r--games-simulation/radegast-bin/Manifest2
-rw-r--r--games-simulation/radegast-bin/radegast-bin-2.25.134.ebuild71
2 files changed, 73 insertions, 0 deletions
diff --git a/games-simulation/radegast-bin/Manifest b/games-simulation/radegast-bin/Manifest
new file mode 100644
index 0000000..652ab33
--- /dev/null
+++ b/games-simulation/radegast-bin/Manifest
@@ -0,0 +1,2 @@
+DIST radegast-2.25.134.tar.bz2 14381099 BLAKE2B 81366e7d154d59228d71c3e9d9aca90e215635a7d46015e87ba7c9abdfd95883abfb875b0bb1c007356390e24920d415f7f891929527f43856208d1d11821274 SHA512 fe047b176bb8d48a45c9207698fe6c02077e6a2146f3d66ddb1df25199a55771d16eeed5e4a4c8c3dde4da762bfe07d08da4da1a07d81e4596fd6782f7b83ef0
+EBUILD radegast-bin-2.25.134.ebuild 1536 BLAKE2B df457d1e93206e7db895cfe21478b1a2b06b3010ece3052c9cabcd8e4f33398a80e194dcab9ed50923448f7193d4c480fc3fba734af2c840c0ed750190e51c21 SHA512 549e76a79b28376d2bd9057003df7b1d5c24653d97bd8069d00df3c001e684dfc5584cf5e15d24ab6da529d448dbafb5a26c5963951a7f8632ee39fad082445e
diff --git a/games-simulation/radegast-bin/radegast-bin-2.25.134.ebuild b/games-simulation/radegast-bin/radegast-bin-2.25.134.ebuild
new file mode 100644
index 0000000..3ebf0aa
--- /dev/null
+++ b/games-simulation/radegast-bin/radegast-bin-2.25.134.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit gnome2-utils eutils xdg desktop
+
+MY_PN="${PN/-bin/}"
+
+DESCRIPTION="A messaging app for teams"
+HOMEPAGE="https://radegast.life"
+SRC_URI="https://bitbucket.org/cinderblocks/radegast/downloads/Radegast-${PV}.tbz -> ${MY_PN}-${PV}.tar.bz2"
+LICENSE="BSD"
+RESTRICT="mirror"
+
+SLOT="0"
+KEYWORDS="~amd64 -*"
+IUSE=""
+
+QA_PREBUILT="opt/${PN}/*"
+
+DEPEND=""
+RDEPEND="
+ dev-dotnet/libgdiplus[cairo]
+ dev-lang/mono
+ media-libs/fmod
+"
+
+S=${WORKDIR}/bin
+
+src_prepare() {
+ rm license.txt
+
+ # Login error:
+ # Failed to initialize the sound system: System.DllNotFoundException: fmod
+ # at (wrapper managed-to-native) FMOD.Factory:FMOD_System_Create (intptr&) ...
+ rm libfmod.so libfmod.so.8 libfmodstudio.so libfmodstudio.so.8
+ ln -s libfmod.so.8.14 libfmod.so.8
+ ln -s libfmod.so.8.14 libfmod.so
+ ln -s libfmodstudio.so.8.14 libfmodstudio.so.8
+ ln -s libfmodstudio.so.8.14 libfmodstudio.so
+
+ eapply_user
+}
+
+src_install() {
+ doicon ${MY_PN}.png
+
+ mkdir -p "${D}/opt/${PN}/"
+ cp -pr . ${D}/opt/${PN}
+
+ make_wrapper "${PN}" "mono ./Radegast.exe" "/opt/${PN}" "/opt/${PN}:/opt/fmodex/api/lib"
+ make_desktop_entry "${PN}" "Radegast" "/usr/share/pixmaps/${MY_PN}.png"
+}
+
+pkg_preinst() {
+ xdg_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+ gnome2_icon_cache_update
+}