summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/ccze/files')
-rw-r--r--app-admin/ccze/files/ccze-fbsd.patch25
-rw-r--r--app-admin/ccze/files/ccze-ldflags.patch11
-rw-r--r--app-admin/ccze/files/ccze-segfault.patch30
3 files changed, 66 insertions, 0 deletions
diff --git a/app-admin/ccze/files/ccze-fbsd.patch b/app-admin/ccze/files/ccze-fbsd.patch
new file mode 100644
index 0000000..d1f684a
--- /dev/null
+++ b/app-admin/ccze/files/ccze-fbsd.patch
@@ -0,0 +1,25 @@
+--- src/ccze-compat.h.old 2006-10-13 12:50:16 +0200
++++ src/ccze-compat.h 2006-10-13 12:49:21 +0200
+@@ -29,6 +29,11 @@
+ #include <stddef.h>
+ #include <stdio.h>
+
++# ifndef __error_t_defined
++typedef int error_t;
++# define __error_t_defined 1
++# endif
++
+ #ifndef HAVE_STRNDUP
+ char *strndup (const char *s, size_t size);
+ #endif
+--- src/ccze-compat.c.old 2006-10-13 12:51:35 +0200
++++ src/ccze-compat.c 2006-10-13 12:51:44 +0200
+@@ -275,7 +275,7 @@
+ char **valuep)
+ {
+ int i = getsubopt (optionp, tokens, valuep);
+-#if HAVE_SUBOPTARg
++#if HAVE_SUBOPTARG
+ if (!*valuep && suboptarg)
+ *valuep = strdup (suboptarg);
+ #endif
diff --git a/app-admin/ccze/files/ccze-ldflags.patch b/app-admin/ccze/files/ccze-ldflags.patch
new file mode 100644
index 0000000..acef31a
--- /dev/null
+++ b/app-admin/ccze/files/ccze-ldflags.patch
@@ -0,0 +1,11 @@
+--- ccze-0.2.1/src/Makefile.in.org 2010-01-22 17:06:57.000000000 +0100
++++ ccze-0.2.1/src/Makefile.in 2010-01-22 18:00:28.000000000 +0100
+@@ -75,7 +75,7 @@
+ ${PROGRAM}: ${OBJECTS} ${PLUGIN_SOBJS}
+ ${CC} -rdynamic ${ALL_CFLAGS} -o $@ $^ ${ALL_LDFLAGS}
+ ccze-dump ccze-cssdump: %: %.o ccze-compat.o ccze-color.c
+- ${CC} ${ALL_CFLAGS} -o $@ $@.o ccze-compat.o
++ ${CC} ${ALL_CFLAGS} ${ALL_LDFLAGS} -o $@ $@.o ccze-compat.o
+ ccze-builtins.c: Makefile
+ echo '#include <ccze.h>' >$@
+ echo '#include "ccze-private.h"' >>$@
diff --git a/app-admin/ccze/files/ccze-segfault.patch b/app-admin/ccze/files/ccze-segfault.patch
new file mode 100644
index 0000000..fa30d2f
--- /dev/null
+++ b/app-admin/ccze/files/ccze-segfault.patch
@@ -0,0 +1,30 @@
+diff -ruN ccze-0.2.1.orig/src/ccze.c ccze-0.2.1/src/ccze.c
+--- ccze-0.2.1.orig/src/ccze.c 2003-05-13 20:09:30.000000000 +0200
++++ ccze-0.2.1/src/ccze.c 2006-12-12 20:36:09.000000000 +0100
+@@ -209,7 +209,7 @@
+ }
+ break;
+ case 'a':
+- plugin = strtok (optarg, "=");
++ plugin = strtok (arg, "=");
+ value = strtok (NULL, "\n");
+ ccze_plugin_argv_set (plugin, value);
+ break;
+@@ -249,7 +249,7 @@
+ ccze_config.remfac = 1;
+ break;
+ case 'm':
+- subopts = optarg;
++ subopts = arg;
+ while (*subopts != '\0')
+ {
+ switch (getsubopt (&subopts, m_subopts, &value))
+@@ -273,7 +273,7 @@
+ }
+ break;
+ case 'o':
+- subopts = optarg;
++ subopts = arg;
+ while (*subopts != '\0')
+ {
+ switch (getsubopt (&subopts, o_subopts, &value))