summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLukas Elsner <open@mindrunner.de>2013-07-13 13:24:53 +0200
committerLukas Elsner <open@mindrunner.de>2013-07-13 13:24:53 +0200
commit1ef20ab2a86ba34a3a1924574348c90a0feb100e (patch)
tree49dbb140297fdb68db73ab45c2332c7dc63c89bb /app-portage/gcruft/gcruft-0.1-r1.ebuild
parentintellij idea version bump (diff)
downloadluman-1ef20ab2a86ba34a3a1924574348c90a0feb100e.tar.gz
luman-1ef20ab2a86ba34a3a1924574348c90a0feb100e.tar.bz2
luman-1ef20ab2a86ba34a3a1924574348c90a0feb100e.zip
added gcruft
Diffstat (limited to 'app-portage/gcruft/gcruft-0.1-r1.ebuild')
-rw-r--r--app-portage/gcruft/gcruft-0.1-r1.ebuild65
1 files changed, 65 insertions, 0 deletions
diff --git a/app-portage/gcruft/gcruft-0.1-r1.ebuild b/app-portage/gcruft/gcruft-0.1-r1.ebuild
new file mode 100644
index 0000000..60dc100
--- /dev/null
+++ b/app-portage/gcruft/gcruft-0.1-r1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="3"
+
+inherit eutils multilib
+
+DESCRIPTION="helps finding orphaned files on a gentoo system"
+HOMEPAGE="http://www.genoetigt.de/site/projects/gcruft"
+SRC_URI="http://files.keksbude.net/gentoo/distfiles/${P}.tar.bz2"
+KEYWORDS="~x86 ~amd64"
+LICENSE="GPL-2"
+RESTRICT="mirror"
+SLOT="0"
+IUSE=""
+DEPEND=""
+RDEPEND=""
+
+src_prepare() {
+ if has_multilib_profile; then
+ local multilib="yes";
+ else
+ local multilib="no";
+ fi
+ echo -e "
+our \$DISTDIR = '${PORTAGE_ACTUAL_DISTDIR}';
+our \$CHOST = '${CHOST}';
+our \$PKGDIR = '${PKGDIR}';
+our \$PORTAGE_TMPDIR = '${PORTAGE_TMPDIR}';
+our \$PORTDIR = '${PORTDIR}';
+our @PORTDIR_OVERLAY = ('$(env -i portageq portdir_overlay 2>/dev/null|sed -e "s/ /', '/g")');
+our \$installedbase = '$(portageq vdb_path)';
+our \$multilib = '$multilib';
+our \$libmap = '$(get_libdir)';
+our \$man_ext = '$(ecompress --suffix)';
+" > config.pm.new
+ sed -e '1,/^# == PORTAGE VARIABLES BEGIN ==/ w config.pm.start' "${S}"/config.pm >/dev/null
+ sed -e '/^# == PORTAGE VARIABLES END ==/,999 w config.pm.end' "${S}"/config.pm >/dev/null
+ cat config.pm.{start,new,end} > "${S}"/config.pm
+ sed -e 's/^\(use warnings;use diagnostics;\)/#\1/' -i "${S}"/gcruft.pl
+}
+
+src_install() {
+ local cfdir='/etc/gcruft'
+ dodir /usr/share/gcruft
+ mv "${S}"/share/{exceptions,functions.pl} "${D}"/usr/share/gcruft || die "couldn't move directories"
+ dobin "${S}"/gcruft.pl
+ dodoc "${S}"/README
+ dodoc "${S}"/README.html
+ dodoc "${S}"/exception.example.pl
+ insinto $cfdir
+ doins "${S}"/config.pm
+ dodir $cfdir/exceptions
+}
+
+pkg_postinst() {
+ einfo "Please check the files gcruft reports carefully"
+ einfo "before deleting them! There are most probably false positives!"
+ einfo "For further information take a look at the provided"
+ einfo "README/README.html in /usr/share/doc/${PF}"
+ einfo "Examples for custom exceptions can be found in the"
+ einfo "exception.example.pl, which can also be found in"
+ einfo "/usr/share/doc/${PF}"
+}