summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLukas Elsner <open@mindrunner.de>2012-10-09 21:04:52 +0200
committerLukas Elsner <open@mindrunner.de>2012-10-09 21:04:52 +0200
commit9cdeec08df866bbc6e100a9434997957ca68e01f (patch)
tree573523471f92bb22564d6b294a8d6bea6e46f6ee /dev-db/fastdb/fastdb-3.71.ebuild
parentadded nightshade (diff)
downloadluman-9cdeec08df866bbc6e100a9434997957ca68e01f.tar.gz
luman-9cdeec08df866bbc6e100a9434997957ca68e01f.tar.bz2
luman-9cdeec08df866bbc6e100a9434997957ca68e01f.zip
added fastdb for nightshade
Diffstat (limited to 'dev-db/fastdb/fastdb-3.71.ebuild')
-rw-r--r--dev-db/fastdb/fastdb-3.71.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-db/fastdb/fastdb-3.71.ebuild b/dev-db/fastdb/fastdb-3.71.ebuild
new file mode 100644
index 0000000..d88978b
--- /dev/null
+++ b/dev-db/fastdb/fastdb-3.71.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+inherit eutils
+
+DESCRIPTION="Main Memory Relational Database Management System"
+HOMEPAGE="http://www.garret.ru/fastdb.html"
+# SRC_URI="http://www.garret.ru/${P}.tar.gz"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE=""
+
+DEPEND="sys-devel/bison
+ sys-devel/flex
+"
+RDEPEND=""
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ edos2unix "${S}/configure"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ mv "${ED}"usr/bin/subsql "${ED}"usr/bin/subsql-fdb || die "mv failed"
+ sed -i '/^#include "acconfig.h"/d' "${ED}"usr/include/${PN}/config.h \
+ || die "sed failed"
+ #insinto /usr/include/${PN}
+ #doins inc/acconfig.h
+ dodoc CHANGES AUTHORS
+ dohtml FastDB.htm
+}
+
+pkg_postinst() {
+ elog "The subsql binary has been renamed to subsql-fdb,"
+ elog "to avoid a name clash with the GigaBase version of subsql"
+}