summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLukas Elsner <open@mindrunner.de>2012-04-15 14:42:02 +0200
committerLukas Elsner <open@mindrunner.de>2012-04-15 14:42:02 +0200
commit0701ffb6aa11773788c68253b9aaa659dfca36c0 (patch)
treeff6dd78750dd55b72c34fd51580470387248e0b4 /gnome-extra/cinnamon/files
parent.. (diff)
downloadluman-0701ffb6aa11773788c68253b9aaa659dfca36c0.tar.gz
luman-0701ffb6aa11773788c68253b9aaa659dfca36c0.tar.bz2
luman-0701ffb6aa11773788c68253b9aaa659dfca36c0.zip
..
Diffstat (limited to 'gnome-extra/cinnamon/files')
-rw-r--r--gnome-extra/cinnamon/files/cinnamon-1.1.3-automagic-gnome-bluetooth.patch44
-rw-r--r--gnome-extra/cinnamon/files/cinnamon-1.3.1-optional-networkmanager.patch171
-rw-r--r--gnome-extra/cinnamon/files/cinnamon-1.4-notification.patch115
3 files changed, 330 insertions, 0 deletions
diff --git a/gnome-extra/cinnamon/files/cinnamon-1.1.3-automagic-gnome-bluetooth.patch b/gnome-extra/cinnamon/files/cinnamon-1.1.3-automagic-gnome-bluetooth.patch
new file mode 100644
index 0000000..ae23a6c
--- /dev/null
+++ b/gnome-extra/cinnamon/files/cinnamon-1.1.3-automagic-gnome-bluetooth.patch
@@ -0,0 +1,44 @@
+From 84568fa9454f279ff519a2a11174e112786e46db Mon Sep 17 00:00:00 2001
+From: root <admin@catmur.co.uk>
+Date: Sun, 8 Jan 2012 13:55:05 +0000
+Subject: [PATCH] Fix automagic gnome-bluetooth dependency
+
+https://bugs.gentoo.org/show_bug.cgi?id=398145
+
+Ed Catmur 2012-01-08 13:46:22 UTC
+libgnome-bluetooth-applet is a private library so they shouldn't be linking
+against it anyway. I tried to work out how to tell libtool to add it to rpath
+but got totally lost.
+
+I'll see if I can work out how to fix the automagic gnome-bluetooth dependency
+so I can at least merge USE=-bluetooth.
+---
+ configure.ac | 5 +++++
+ 1 files changed, 5 insertions(+), 0 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 1c64122..a699838 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -127,6 +127,8 @@ PKG_CHECK_MODULES(GVC, libpulse libpulse-mainloop-glib gobject-2.0)
+ PKG_CHECK_MODULES(DESKTOP_SCHEMAS, gsettings-desktop-schemas >= 0.1.7)
+
+ AC_MSG_CHECKING([for bluetooth support])
++AC_ARG_WITH([bluetooth], AS_HELP_STRING([--without-bluetooth], [Build without gnome-bluetooth library (default: auto)]))
++AS_IF([test "x$with_bluetooth" != "xno"], [
+ PKG_CHECK_EXISTS([gnome-bluetooth-1.0 >= 3.1.0],
+ [BLUETOOTH_DIR=`$PKG_CONFIG --variable=applet_libdir gnome-bluetooth-1.0`
+ BLUETOOTH_LIBS=`$PKG_CONFIG --variable=applet_libs gnome-bluetooth-1.0`
+@@ -138,6 +140,9 @@ PKG_CHECK_EXISTS([gnome-bluetooth-1.0 >= 3.1.0],
+ [AC_DEFINE([HAVE_BLUETOOTH],[0])
+ AC_SUBST([HAVE_BLUETOOTH],[0])
+ AC_MSG_RESULT([no])])
++], [AC_DEFINE([HAVE_BLUETOOTH],[0])
++ AC_SUBST([HAVE_BLUETOOTH],[0])
++ AC_MSG_RESULT([no])])
+
+ PKG_CHECK_MODULES(CALENDAR_SERVER, libecal-1.2 >= $LIBECAL_MIN_VERSION libedataserver-1.2 >= $LIBEDATASERVER_MIN_VERSION libedataserverui-3.0 >= $LIBEDATASERVERUI_MIN_VERSION gio-2.0)
+ AC_SUBST(CALENDAR_SERVER_CFLAGS)
+--
+1.7.8.2
+
diff --git a/gnome-extra/cinnamon/files/cinnamon-1.3.1-optional-networkmanager.patch b/gnome-extra/cinnamon/files/cinnamon-1.3.1-optional-networkmanager.patch
new file mode 100644
index 0000000..6e2d431
--- /dev/null
+++ b/gnome-extra/cinnamon/files/cinnamon-1.3.1-optional-networkmanager.patch
@@ -0,0 +1,171 @@
+From aebde5fad2f477f40b62c96118128011bd821be0 Mon Sep 17 00:00:00 2001
+From: Alexandre Rostovtsev <tetromino@gentoo.org>
+Date: Wed, 25 Jan 2012 01:58:07 -0500
+Subject: [PATCH] Make NM optional
+
+Derived from a patch for gnome-shell by Michael Biebl <biebl@debian.org>
+(see http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=652482#29)
+---
+ configure.ac | 48 ++++++++++++++++++++++++++++++++++++++++++++++--
+ js/misc/config.js.in | 2 ++
+ js/ui/main.js | 7 +++++--
+ src/Makefile.am | 13 ++++++++-----
+ 4 files changed, 61 insertions(+), 9 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 49b5401..508a8cd 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -94,8 +94,40 @@ PKG_CHECK_MODULES(CINNAMON, gio-2.0 >= $GIO_MIN_VERSION
+ libcanberra
+ telepathy-glib >= $TELEPATHY_GLIB_MIN_VERSION
+ telepathy-logger-0.2 >= $TELEPATHY_LOGGER_MIN_VERSION
+- polkit-agent-1 >= $POLKIT_MIN_VERSION xfixes
+- libnm-glib libnm-util gnome-keyring-1)
++ polkit-agent-1 >= $POLKIT_MIN_VERSION xfixes)
++
++##########################
++# Check for NetworkManager
++##########################
++NM_MIN_VERSION=0.9
++AC_ARG_ENABLE(networkmanager,
++ AS_HELP_STRING([--disable-networkmanager],
++ [disable NetworkManager support @<:@default=auto@:>@]),,
++ [enable_networkmanager=auto])
++
++if test "x$enable_networkmanager" != "xno"; then
++ PKG_CHECK_MODULES(NETWORKMANAGER,
++ [libnm-glib libnm-util gnome-keyring-1],
++ [have_networkmanager=yes],
++ [have_networkmanager=no])
++
++ CINNAMON_CFLAGS="$CINNAMON_CFLAGS $NETWORKMANAGER_CFLAGS"
++ CINNAMON_LIBS="$CINNAMON_LIBS $NETWORKMANAGER_LIBS"
++else
++ have_networkmanager="no (disabled)"
++fi
++
++if test "x$have_networkmanager" = "xyes"; then
++ AC_DEFINE(HAVE_NETWORKMANAGER, [1], [Define if we have NetworkManager])
++ AC_SUBST([HAVE_NETWORKMANAGER], [1])
++else
++ if test "x$enable_networkmanager" = "xyes"; then
++ AC_MSG_ERROR([Couldn't find NetworkManager.])
++ fi
++ AC_SUBST([HAVE_NETWORKMANAGER], [0])
++fi
++
++AM_CONDITIONAL(HAVE_NETWORKMANAGER, test "$have_networkmanager" = "yes")
+
+ PKG_CHECK_MODULES(CINNAMON_PERF_HELPER, gtk+-3.0 gio-2.0)
+
+@@ -250,3 +282,15 @@ AC_CONFIG_FILES([
+ files/Makefile
+ ])
+ AC_OUTPUT
++
++echo "
++Build configuration:
++
++ Prefix: ${prefix}
++ Source code location: ${srcdir}
++ Compiler: ${CC}
++ Compiler Warnings: $enable_compile_warnings
++
++ Support for NetworkManager: $have_networkmanager
++ Support for GStreamer recording: $build_recorder
++"
+diff --git a/js/misc/config.js.in b/js/misc/config.js.in
+index 704989b..df7e014 100644
+--- a/js/misc/config.js.in
++++ b/js/misc/config.js.in
+@@ -8,5 +8,7 @@ const PACKAGE_VERSION = '@PACKAGE_VERSION@';
+ const GJS_VERSION = '@GJS_VERSION@';
+ /* 1 if gnome-bluetooth is available, 0 otherwise */
+ const HAVE_BLUETOOTH = @HAVE_BLUETOOTH@;
++/* 1 if networkmanager is available, 0 otherwise */
++const HAVE_NETWORKMANAGER = @HAVE_NETWORKMANAGER@;
+ /* The system TLS CA list */
+ const CINNAMON_SYSTEM_CA_FILE = '@CINNAMON_SYSTEM_CA_FILE@';
+diff --git a/js/ui/main.js b/js/ui/main.js
+index ae15997..803e6f4 100644
+--- a/js/ui/main.js
++++ b/js/ui/main.js
+@@ -14,6 +14,7 @@ const St = imports.gi.St;
+
+ const AutomountManager = imports.ui.automountManager;
+ const AutorunManager = imports.ui.autorunManager;
++const Config = imports.misc.config;
+ const EndSessionDialog = imports.ui.endSessionDialog;
+ const PolkitAuthenticationAgent = imports.ui.polkitAuthenticationAgent;
+ const Environment = imports.ui.environment;
+@@ -27,7 +28,7 @@ const PlacesManager = imports.ui.placesManager;
+ const RunDialog = imports.ui.runDialog;
+ const Layout = imports.ui.layout;
+ const LookingGlass = imports.ui.lookingGlass;
+-const NetworkAgent = imports.ui.networkAgent;
++const NetworkAgent = Config.HAVE_NETWORKMANAGER ? imports.ui.networkAgent : null;
+ const NotificationDaemon = imports.ui.notificationDaemon;
+ const WindowAttentionHandler = imports.ui.windowAttentionHandler;
+ const Scripting = imports.ui.scripting;
+@@ -88,7 +89,9 @@ function _createUserSession() {
+ placesManager = new PlacesManager.PlacesManager();
+ automountManager = new AutomountManager.AutomountManager();
+ autorunManager = new AutorunManager.AutorunManager();
+- networkAgent = new NetworkAgent.NetworkAgent();
++ if (Config.HAVE_NETWORKMANAGER) {
++ networkAgent = new NetworkAgent.NetworkAgent();
++ }
+ }
+
+ function _createGDMSession() {
+diff --git a/src/Makefile.am b/src/Makefile.am
+index 182bf17..54770e7 100644
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -108,9 +108,7 @@ cinnamon_public_headers_h = \
+ cinnamon-generic-container.h \
+ cinnamon-gtk-embed.h \
+ cinnamon-global.h \
+- cinnamon-mobile-providers.h \
+ cinnamon-mount-operation.h \
+- cinnamon-network-agent.h \
+ cinnamon-perf-log.h \
+ cinnamon-slicer.h \
+ cinnamon-stack.h \
+@@ -145,9 +143,7 @@ libcinnamon_la_SOURCES = \
+ cinnamon-generic-container.c \
+ cinnamon-gtk-embed.c \
+ cinnamon-global.c \
+- cinnamon-mobile-providers.c \
+ cinnamon-mount-operation.c \
+- cinnamon-network-agent.c \
+ cinnamon-perf-log.c \
+ cinnamon-polkit-authentication-agent.h \
+ cinnamon-polkit-authentication-agent.c \
+@@ -161,6 +157,10 @@ libcinnamon_la_SOURCES = \
+ cinnamon-wm.c \
+ cinnamon-xfixes-cursor.c
+
++if HAVE_NETWORKMANAGER
++libcinnamon_la_SOURCES += cinnamon-mobile-providers.h cinnamon-mobile-providers.c cinnamon-network-agent.h cinnamon-network-agent.c
++endif
++
+ libcinnamon_la_gir_sources = \
+ $(filter-out %-private.h $(cinnamon_recorder_non_gir_sources), $(cinnamon_public_headers_h) $(libcinnamon_la_SOURCES))
+
+@@ -272,7 +272,10 @@ libcinnamon_la_LIBADD = \
+ libcinnamon_la_CPPFLAGS = $(cinnamon_cflags)
+
+ Cinnamon-0.1.gir: libcinnamon.la St-1.0.gir
+-Cinnamon_0_1_gir_INCLUDES = Clutter-1.0 ClutterX11-1.0 Meta-3.0 TelepathyGLib-0.12 TelepathyLogger-0.2 Soup-2.4 GMenu-3.0 NetworkManager-1.0 NMClient-1.0 Folks-0.6
++Cinnamon_0_1_gir_INCLUDES = Clutter-1.0 ClutterX11-1.0 Meta-3.0 TelepathyGLib-0.12 TelepathyLogger-0.2 Soup-2.4 GMenu-3.0 Folks-0.6
++if HAVE_NETWORKMANAGER
++Cinnamon_0_1_gir_INCLUDES += NetworkManager-1.0 NMClient-1.0
++endif
+ Cinnamon_0_1_gir_CFLAGS = $(libcinnamon_la_CPPFLAGS) -I $(srcdir)
+ Cinnamon_0_1_gir_LIBS = libcinnamon.la
+ Cinnamon_0_1_gir_FILES = $(libcinnamon_la_gir_sources)
+--
+1.7.8.4
+
diff --git a/gnome-extra/cinnamon/files/cinnamon-1.4-notification.patch b/gnome-extra/cinnamon/files/cinnamon-1.4-notification.patch
new file mode 100644
index 0000000..83d6938
--- /dev/null
+++ b/gnome-extra/cinnamon/files/cinnamon-1.4-notification.patch
@@ -0,0 +1,115 @@
+From 3af53231970861564c01c5f64fe18fe128d2e246 Mon Sep 17 00:00:00 2001
+From: Lukas Elsner <open@mindrunner.de>
+Date: Sun, 15 Apr 2012 14:33:34 +0200
+Subject: [PATCH] implemented rat4's patch
+
+---
+ data/org.cinnamon.gschema.xml | 6 ++++
+ data/org.cinnamon.gschema.xml.in | 5 ++++
+ js/ui/windowAttentionHandler.js | 48 +++++++++++++++++++++++++++++++++++--
+ 3 files changed, 56 insertions(+), 3 deletions(-)
+
+diff --git a/data/org.cinnamon.gschema.xml b/data/org.cinnamon.gschema.xml
+index a413619..28ad28b 100644
+--- a/data/org.cinnamon.gschema.xml
++++ b/data/org.cinnamon.gschema.xml
+@@ -127,6 +127,12 @@
+ <description>Layout styles: traditional (1 panel at the bottom), flipped (1 panel on top), classic (1 panel on top, 1 panel at the bottom)</description>
+ </key>
+
++ <key type="i" name="notification-style">
++ <range min="0" max="2"/>
++ <default>2</default>
++ <summary>Notification style</summary>
++ </key>
++
+ <key type="s" name="date-format">
+ <default>"YYYY-MM-DD"</default>
+ <summary>Auto-hide panel</summary>
+diff --git a/data/org.cinnamon.gschema.xml.in b/data/org.cinnamon.gschema.xml.in
+index c496c3d..e598146 100644
+--- a/data/org.cinnamon.gschema.xml.in
++++ b/data/org.cinnamon.gschema.xml.in
+@@ -175,6 +175,11 @@
+ </_description>
+ </key>
+
++ <key type="i" name="notification-style">
++ <default>2</default>
++ <_summary>Notification style</_summary>
++ </key>
++
+ <key name="date-format" type="s">
+ <default>"YYYY-MM-DD"</default>
+ <_summary>Auto-hide panel</_summary>
+diff --git a/js/ui/windowAttentionHandler.js b/js/ui/windowAttentionHandler.js
+index a81f10c..7594ed0 100644
+--- a/js/ui/windowAttentionHandler.js
++++ b/js/ui/windowAttentionHandler.js
+@@ -12,8 +12,18 @@ function WindowAttentionHandler() {
+
+ WindowAttentionHandler.prototype = {
+ _init : function() {
+- this._tracker = Cinnamon.WindowTracker.get_default();
+- global.display.connect('window-demands-attention', Lang.bind(this, this._onWindowDemandsAttention));
++ this.notification_style = global.settings.get_int("notification-style");
++ global.settings.connect("changed::notification-style", Lang.bind(this, function() {
++ this.notification_style = global.settings.get_int("notification-style");
++ }));
++ this._tracker = Cinnamon.WindowTracker.get_default();
++ global.display.connect('window-demands-attention', Lang.bind(this, this._onWindowDemandsAttention));
++ },
++
++ _getTitleAndBanner: function(app, window) {
++ let title = app.get_name();
++ let banner = _("'%s' is ready").format(window.get_title());
++ return [title, banner]
+ },
+
+ _onWindowDemandsAttention : function(display, window) {
+@@ -28,9 +38,41 @@ WindowAttentionHandler.prototype = {
+ if (!window || window.has_focus() || window.is_skip_taskbar())
+ return;
+
+- if (this._tracker.is_window_interesting(window)) {
++ switch (this.notification_style) {
++ case 0:
++ break;
++ case 1:
++ this.bringToFront(window);
++ break;
++ case 2:
++ this.showBanner(window);
++ break;
++ default:
++ global.log('Unknown notification style: ' + this.notification_style);
++ }
++
++ },
++
++ bringToFront : function(window) {
++ if (this._tracker.is_window_interesting(window)) {
+ window.activate(global.get_current_time());
+ }
++ },
++
++ showBanner : function(window) {
++ let app = this._tracker.get_window_app(window);
++ let source = new Source(app, window);
++ if (Main.messageTray) Main.messageTray.add(source);
++
++ let [title, banner] = this._getTitleAndBanner(app, window);
++
++ let notification = new MessageTray.Notification(source, title, banner);
++ source.notify(notification);
++
++ source.signalIDs.push(window.connect('notify::title', Lang.bind(this, function() {
++ let [title, banner] = this._getTitleAndBanner(app, window);
++ notification.update(title, banner);
++ })));
+ }
+ };
+
+--
+1.7.8.5
+