summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-portage/gcruft/Manifest4
-rw-r--r--app-portage/gcruft/gcruft-0.1-r1.ebuild65
-rw-r--r--app-portage/gcruft/gcruft-0.1.1.ebuild65
3 files changed, 134 insertions, 0 deletions
diff --git a/app-portage/gcruft/Manifest b/app-portage/gcruft/Manifest
new file mode 100644
index 0000000..0767444
--- /dev/null
+++ b/app-portage/gcruft/Manifest
@@ -0,0 +1,4 @@
+DIST gcruft-0.1.1.tar.bz2 18095 SHA256 cc9862b70fc8856c55b81dc3915c10df79bf3f226e42471962fed81de5238a26 SHA512 d54674461ecc827bd26aa51fd15d53194faad343de51ced74ccc8b68e4dfab5130e168c26d5fe1adb0600d003f309d3ed288c6bb4976d2ad8a1f2952608af0b5 WHIRLPOOL 87e6d3de8019efb4e719b94b33cf116c9bd70c4d7850e6048748aabf5360bb0d8da588e12fa2eaf82ce88b4029b1732531f388f36f1166c903904b868071a23a
+DIST gcruft-0.1.tar.bz2 14040 SHA256 54fea63863d0078292e83933ae2f0b1ca051c49dd7a2455fef99dcb9704c8581 SHA512 ea491d47a89981e7f754968c9df2ecfb6878a95622b487a3279567b4681eaafae7ba82c90447e13de12e83572bc4e87610f3dd259aefaec9486c410ddd4f0827 WHIRLPOOL 492bd9cd2a77cfbcf44b7d0fe972287aaf224285ed43fdcb055d39d68aa441b11a9b06bd6d4ec56cc141070ef51cd4e7080398ad905f09426d8962653a4fc96b
+EBUILD gcruft-0.1-r1.ebuild 2048 SHA256 e5a0b90ae4e28f95ae18d8864e726bded5807acef1455c2a6c53fbd1ffdf791c SHA512 e95e2b8f5c3d8451203c9f561791a06d4bf01a1b760806b2b7126d9b8ed062d2f4d518ec965fc9e8c34d446a8ab27a6ddb2e29ec54c98f973083b26cc16806f7 WHIRLPOOL 88bbcbc394f7ebabc82024128381ae77664d102a48ae8c544a22033d772e4445c63978d45b29b1d7fb73c7c4a1944fb5880e0922c6906fba5cb9b3d84408386d
+EBUILD gcruft-0.1.1.ebuild 2046 SHA256 a3f47fd0703e0f30b2ade0f799ee63766d95ccc4ce994f4e54e3b1cf7cc44981 SHA512 83a2f0dad6b7db0d4fdd1ecdf66416564f2ecdc176adf26782fac5980e35a1c8bb416fd34febd1b8a99649a70353104cdf349f18adfd25c976fc3d2799c3cded WHIRLPOOL 1d0505c2f833157da3f9aa2f9793a644960e5977109bccfaf6fcc1d70a70f6845a62e660bfb4c0226536d1ab4ae268210054ea3048813145bcb560b74651ec6c
diff --git a/app-portage/gcruft/gcruft-0.1-r1.ebuild b/app-portage/gcruft/gcruft-0.1-r1.ebuild
new file mode 100644
index 0000000..60dc100
--- /dev/null
+++ b/app-portage/gcruft/gcruft-0.1-r1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="3"
+
+inherit eutils multilib
+
+DESCRIPTION="helps finding orphaned files on a gentoo system"
+HOMEPAGE="http://www.genoetigt.de/site/projects/gcruft"
+SRC_URI="http://files.keksbude.net/gentoo/distfiles/${P}.tar.bz2"
+KEYWORDS="~x86 ~amd64"
+LICENSE="GPL-2"
+RESTRICT="mirror"
+SLOT="0"
+IUSE=""
+DEPEND=""
+RDEPEND=""
+
+src_prepare() {
+ if has_multilib_profile; then
+ local multilib="yes";
+ else
+ local multilib="no";
+ fi
+ echo -e "
+our \$DISTDIR = '${PORTAGE_ACTUAL_DISTDIR}';
+our \$CHOST = '${CHOST}';
+our \$PKGDIR = '${PKGDIR}';
+our \$PORTAGE_TMPDIR = '${PORTAGE_TMPDIR}';
+our \$PORTDIR = '${PORTDIR}';
+our @PORTDIR_OVERLAY = ('$(env -i portageq portdir_overlay 2>/dev/null|sed -e "s/ /', '/g")');
+our \$installedbase = '$(portageq vdb_path)';
+our \$multilib = '$multilib';
+our \$libmap = '$(get_libdir)';
+our \$man_ext = '$(ecompress --suffix)';
+" > config.pm.new
+ sed -e '1,/^# == PORTAGE VARIABLES BEGIN ==/ w config.pm.start' "${S}"/config.pm >/dev/null
+ sed -e '/^# == PORTAGE VARIABLES END ==/,999 w config.pm.end' "${S}"/config.pm >/dev/null
+ cat config.pm.{start,new,end} > "${S}"/config.pm
+ sed -e 's/^\(use warnings;use diagnostics;\)/#\1/' -i "${S}"/gcruft.pl
+}
+
+src_install() {
+ local cfdir='/etc/gcruft'
+ dodir /usr/share/gcruft
+ mv "${S}"/share/{exceptions,functions.pl} "${D}"/usr/share/gcruft || die "couldn't move directories"
+ dobin "${S}"/gcruft.pl
+ dodoc "${S}"/README
+ dodoc "${S}"/README.html
+ dodoc "${S}"/exception.example.pl
+ insinto $cfdir
+ doins "${S}"/config.pm
+ dodir $cfdir/exceptions
+}
+
+pkg_postinst() {
+ einfo "Please check the files gcruft reports carefully"
+ einfo "before deleting them! There are most probably false positives!"
+ einfo "For further information take a look at the provided"
+ einfo "README/README.html in /usr/share/doc/${PF}"
+ einfo "Examples for custom exceptions can be found in the"
+ einfo "exception.example.pl, which can also be found in"
+ einfo "/usr/share/doc/${PF}"
+}
diff --git a/app-portage/gcruft/gcruft-0.1.1.ebuild b/app-portage/gcruft/gcruft-0.1.1.ebuild
new file mode 100644
index 0000000..6f6efd9
--- /dev/null
+++ b/app-portage/gcruft/gcruft-0.1.1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="3"
+
+inherit eutils multilib
+
+DESCRIPTION="helps finding orphaned files on a gentoo system"
+HOMEPAGE="http://www.genoetigt.de/site/projects/gcruft"
+SRC_URI="http://files.keksbude.net/gentoo/distfiles/${P}.tar.bz2"
+KEYWORDS="~x86 ~amd64"
+LICENSE="GPL-2"
+RESTRICT="mirror"
+SLOT="0"
+IUSE=""
+DEPEND=""
+RDEPEND=""
+
+src_prepare() {
+ if has_multilib_profile; then
+ local multilib="yes";
+ else
+ local multilib="no";
+ fi
+ echo -e "
+our \$DISTDIR = '${PORTAGE_ACTUAL_DISTDIR}';
+our \$CHOST = '${CHOST}';
+our \$PKGDIR = '${PKGDIR}';
+our \$PORTAGE_TMPDIR = '${PORTAGE_TMPDIR}';
+our \$PORTDIR = '${PORTDIR}';
+our @PORTDIR_OVERLAY = ('$(env -i portageq portdir_overlay 2>/dev/null|sed -e "s/ /', '/g")');
+our \$installedbase = '$(portageq vdb_path)';
+our \$multilib = '$multilib';
+our \$libmap = '$(get_libdir)';
+our \$man_ext = '$(ecompress --suffix)';
+" > config.pm.new
+ sed -e '1,/^# == PORTAGE VARIABLES BEGIN ==/ w config.pm.start' "${S}"/config.pm >/dev/null
+ sed -e '/^# == PORTAGE VARIABLES END ==/,$ w config.pm.end' "${S}"/config.pm >/dev/null
+ cat config.pm.{start,new,end} > "${S}"/config.pm
+ sed -e 's/^\(use warnings;use diagnostics;\)/#\1/' -i "${S}"/gcruft.pl
+}
+
+src_install() {
+ local cfdir='/etc/gcruft'
+ dodir /usr/share/gcruft
+ mv "${S}"/share/{exceptions,functions.pl} "${D}"/usr/share/gcruft || die "couldn't move directories"
+ dobin "${S}"/gcruft.pl
+ dodoc "${S}"/README
+ dodoc "${S}"/README.html
+ dodoc "${S}"/exception.example.pl
+ insinto $cfdir
+ doins "${S}"/config.pm
+ dodir $cfdir/exceptions
+}
+
+pkg_postinst() {
+ einfo "Please check the files gcruft reports carefully"
+ einfo "before deleting them! There are most probably false positives!"
+ einfo "For further information take a look at the provided"
+ einfo "README/README.html in /usr/share/doc/${PF}"
+ einfo "Examples for custom exceptions can be found in the"
+ einfo "exception.example.pl, which can also be found in"
+ einfo "/usr/share/doc/${PF}"
+}