summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'gnome-extra/cinnamon/files/cinnamon-1.3.1-optional-networkmanager.patch')
-rw-r--r--gnome-extra/cinnamon/files/cinnamon-1.3.1-optional-networkmanager.patch171
1 files changed, 171 insertions, 0 deletions
diff --git a/gnome-extra/cinnamon/files/cinnamon-1.3.1-optional-networkmanager.patch b/gnome-extra/cinnamon/files/cinnamon-1.3.1-optional-networkmanager.patch
new file mode 100644
index 0000000..6e2d431
--- /dev/null
+++ b/gnome-extra/cinnamon/files/cinnamon-1.3.1-optional-networkmanager.patch
@@ -0,0 +1,171 @@
+From aebde5fad2f477f40b62c96118128011bd821be0 Mon Sep 17 00:00:00 2001
+From: Alexandre Rostovtsev <tetromino@gentoo.org>
+Date: Wed, 25 Jan 2012 01:58:07 -0500
+Subject: [PATCH] Make NM optional
+
+Derived from a patch for gnome-shell by Michael Biebl <biebl@debian.org>
+(see http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=652482#29)
+---
+ configure.ac | 48 ++++++++++++++++++++++++++++++++++++++++++++++--
+ js/misc/config.js.in | 2 ++
+ js/ui/main.js | 7 +++++--
+ src/Makefile.am | 13 ++++++++-----
+ 4 files changed, 61 insertions(+), 9 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 49b5401..508a8cd 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -94,8 +94,40 @@ PKG_CHECK_MODULES(CINNAMON, gio-2.0 >= $GIO_MIN_VERSION
+ libcanberra
+ telepathy-glib >= $TELEPATHY_GLIB_MIN_VERSION
+ telepathy-logger-0.2 >= $TELEPATHY_LOGGER_MIN_VERSION
+- polkit-agent-1 >= $POLKIT_MIN_VERSION xfixes
+- libnm-glib libnm-util gnome-keyring-1)
++ polkit-agent-1 >= $POLKIT_MIN_VERSION xfixes)
++
++##########################
++# Check for NetworkManager
++##########################
++NM_MIN_VERSION=0.9
++AC_ARG_ENABLE(networkmanager,
++ AS_HELP_STRING([--disable-networkmanager],
++ [disable NetworkManager support @<:@default=auto@:>@]),,
++ [enable_networkmanager=auto])
++
++if test "x$enable_networkmanager" != "xno"; then
++ PKG_CHECK_MODULES(NETWORKMANAGER,
++ [libnm-glib libnm-util gnome-keyring-1],
++ [have_networkmanager=yes],
++ [have_networkmanager=no])
++
++ CINNAMON_CFLAGS="$CINNAMON_CFLAGS $NETWORKMANAGER_CFLAGS"
++ CINNAMON_LIBS="$CINNAMON_LIBS $NETWORKMANAGER_LIBS"
++else
++ have_networkmanager="no (disabled)"
++fi
++
++if test "x$have_networkmanager" = "xyes"; then
++ AC_DEFINE(HAVE_NETWORKMANAGER, [1], [Define if we have NetworkManager])
++ AC_SUBST([HAVE_NETWORKMANAGER], [1])
++else
++ if test "x$enable_networkmanager" = "xyes"; then
++ AC_MSG_ERROR([Couldn't find NetworkManager.])
++ fi
++ AC_SUBST([HAVE_NETWORKMANAGER], [0])
++fi
++
++AM_CONDITIONAL(HAVE_NETWORKMANAGER, test "$have_networkmanager" = "yes")
+
+ PKG_CHECK_MODULES(CINNAMON_PERF_HELPER, gtk+-3.0 gio-2.0)
+
+@@ -250,3 +282,15 @@ AC_CONFIG_FILES([
+ files/Makefile
+ ])
+ AC_OUTPUT
++
++echo "
++Build configuration:
++
++ Prefix: ${prefix}
++ Source code location: ${srcdir}
++ Compiler: ${CC}
++ Compiler Warnings: $enable_compile_warnings
++
++ Support for NetworkManager: $have_networkmanager
++ Support for GStreamer recording: $build_recorder
++"
+diff --git a/js/misc/config.js.in b/js/misc/config.js.in
+index 704989b..df7e014 100644
+--- a/js/misc/config.js.in
++++ b/js/misc/config.js.in
+@@ -8,5 +8,7 @@ const PACKAGE_VERSION = '@PACKAGE_VERSION@';
+ const GJS_VERSION = '@GJS_VERSION@';
+ /* 1 if gnome-bluetooth is available, 0 otherwise */
+ const HAVE_BLUETOOTH = @HAVE_BLUETOOTH@;
++/* 1 if networkmanager is available, 0 otherwise */
++const HAVE_NETWORKMANAGER = @HAVE_NETWORKMANAGER@;
+ /* The system TLS CA list */
+ const CINNAMON_SYSTEM_CA_FILE = '@CINNAMON_SYSTEM_CA_FILE@';
+diff --git a/js/ui/main.js b/js/ui/main.js
+index ae15997..803e6f4 100644
+--- a/js/ui/main.js
++++ b/js/ui/main.js
+@@ -14,6 +14,7 @@ const St = imports.gi.St;
+
+ const AutomountManager = imports.ui.automountManager;
+ const AutorunManager = imports.ui.autorunManager;
++const Config = imports.misc.config;
+ const EndSessionDialog = imports.ui.endSessionDialog;
+ const PolkitAuthenticationAgent = imports.ui.polkitAuthenticationAgent;
+ const Environment = imports.ui.environment;
+@@ -27,7 +28,7 @@ const PlacesManager = imports.ui.placesManager;
+ const RunDialog = imports.ui.runDialog;
+ const Layout = imports.ui.layout;
+ const LookingGlass = imports.ui.lookingGlass;
+-const NetworkAgent = imports.ui.networkAgent;
++const NetworkAgent = Config.HAVE_NETWORKMANAGER ? imports.ui.networkAgent : null;
+ const NotificationDaemon = imports.ui.notificationDaemon;
+ const WindowAttentionHandler = imports.ui.windowAttentionHandler;
+ const Scripting = imports.ui.scripting;
+@@ -88,7 +89,9 @@ function _createUserSession() {
+ placesManager = new PlacesManager.PlacesManager();
+ automountManager = new AutomountManager.AutomountManager();
+ autorunManager = new AutorunManager.AutorunManager();
+- networkAgent = new NetworkAgent.NetworkAgent();
++ if (Config.HAVE_NETWORKMANAGER) {
++ networkAgent = new NetworkAgent.NetworkAgent();
++ }
+ }
+
+ function _createGDMSession() {
+diff --git a/src/Makefile.am b/src/Makefile.am
+index 182bf17..54770e7 100644
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -108,9 +108,7 @@ cinnamon_public_headers_h = \
+ cinnamon-generic-container.h \
+ cinnamon-gtk-embed.h \
+ cinnamon-global.h \
+- cinnamon-mobile-providers.h \
+ cinnamon-mount-operation.h \
+- cinnamon-network-agent.h \
+ cinnamon-perf-log.h \
+ cinnamon-slicer.h \
+ cinnamon-stack.h \
+@@ -145,9 +143,7 @@ libcinnamon_la_SOURCES = \
+ cinnamon-generic-container.c \
+ cinnamon-gtk-embed.c \
+ cinnamon-global.c \
+- cinnamon-mobile-providers.c \
+ cinnamon-mount-operation.c \
+- cinnamon-network-agent.c \
+ cinnamon-perf-log.c \
+ cinnamon-polkit-authentication-agent.h \
+ cinnamon-polkit-authentication-agent.c \
+@@ -161,6 +157,10 @@ libcinnamon_la_SOURCES = \
+ cinnamon-wm.c \
+ cinnamon-xfixes-cursor.c
+
++if HAVE_NETWORKMANAGER
++libcinnamon_la_SOURCES += cinnamon-mobile-providers.h cinnamon-mobile-providers.c cinnamon-network-agent.h cinnamon-network-agent.c
++endif
++
+ libcinnamon_la_gir_sources = \
+ $(filter-out %-private.h $(cinnamon_recorder_non_gir_sources), $(cinnamon_public_headers_h) $(libcinnamon_la_SOURCES))
+
+@@ -272,7 +272,10 @@ libcinnamon_la_LIBADD = \
+ libcinnamon_la_CPPFLAGS = $(cinnamon_cflags)
+
+ Cinnamon-0.1.gir: libcinnamon.la St-1.0.gir
+-Cinnamon_0_1_gir_INCLUDES = Clutter-1.0 ClutterX11-1.0 Meta-3.0 TelepathyGLib-0.12 TelepathyLogger-0.2 Soup-2.4 GMenu-3.0 NetworkManager-1.0 NMClient-1.0 Folks-0.6
++Cinnamon_0_1_gir_INCLUDES = Clutter-1.0 ClutterX11-1.0 Meta-3.0 TelepathyGLib-0.12 TelepathyLogger-0.2 Soup-2.4 GMenu-3.0 Folks-0.6
++if HAVE_NETWORKMANAGER
++Cinnamon_0_1_gir_INCLUDES += NetworkManager-1.0 NMClient-1.0
++endif
+ Cinnamon_0_1_gir_CFLAGS = $(libcinnamon_la_CPPFLAGS) -I $(srcdir)
+ Cinnamon_0_1_gir_LIBS = libcinnamon.la
+ Cinnamon_0_1_gir_FILES = $(libcinnamon_la_gir_sources)
+--
+1.7.8.4
+