summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-fs/netatalk/files')
-rw-r--r--net-fs/netatalk/files/afpd.init.322
-rw-r--r--net-fs/netatalk/files/cnid_metad.init.215
-rw-r--r--net-fs/netatalk/files/netatalk-3.0-gentoo.patch146
3 files changed, 0 insertions, 183 deletions
diff --git a/net-fs/netatalk/files/afpd.init.3 b/net-fs/netatalk/files/afpd.init.3
deleted file mode 100644
index 449bb77..0000000
--- a/net-fs/netatalk/files/afpd.init.3
+++ /dev/null
@@ -1,22 +0,0 @@
-#!/sbin/runscript
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/netatalk/files/afpd.init.3,v 1.1 2012/04/08 21:04:02 flameeyes Exp $
-
-command="/usr/sbin/${SVCNAME}"
-command_args="${EXTRA_CONF}"
-pidfile="/var/run/${SVCNAME}.pid"
-
-depend() {
- need net cnid_metad
- use logger dns atalkd
- after entropy
-
- config /etc/netatalk/afpd.conf
-
- sed -e 's:#.*::' /etc/netatalk/afpd.conf | fgrep -q -e -ddp \
- && need atalkd
-
- need avahi-daemon
- need slpd
-}
diff --git a/net-fs/netatalk/files/cnid_metad.init.2 b/net-fs/netatalk/files/cnid_metad.init.2
deleted file mode 100644
index 997603d..0000000
--- a/net-fs/netatalk/files/cnid_metad.init.2
+++ /dev/null
@@ -1,15 +0,0 @@
-#!/sbin/runscript
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/netatalk/files/cnid_metad.init.2,v 1.1 2011/10/18 07:37:57 flameeyes Exp $
-
-: ${CNID_CONFIG:=-l log_note}
-
-command="/usr/sbin/${SVCNAME}"
-command_args="${CNID_CONFIG}"
-pidfile="/var/run/${SVCNAME}.pid"
-
-depend() {
- need net
- use logger
-}
diff --git a/net-fs/netatalk/files/netatalk-3.0-gentoo.patch b/net-fs/netatalk/files/netatalk-3.0-gentoo.patch
deleted file mode 100644
index 59663ad..0000000
--- a/net-fs/netatalk/files/netatalk-3.0-gentoo.patch
+++ /dev/null
@@ -1,146 +0,0 @@
- Makefile.am | 8 +-------
- etc/afpd/afp_avahi.c | 2 +-
- etc/netatalk/Makefile.am | 7 ++++---
- etc/uams/Makefile.am | 20 ++++++++++----------
- libatalk/dsi/Makefile.am | 1 +
- libatalk/vfs/Makefile.am | 1 +
- macros/netatalk.m4 | 15 ++++++++-------
- 7 files changed, 26 insertions(+), 28 deletions(-)
-
-diff --git a/Makefile.am b/Makefile.am
-index 448375a..67ea35f 100644
---- a/Makefile.am
-+++ b/Makefile.am
-@@ -1,6 +1,6 @@
- # Makefile.am for top level of netatalk package
-
--SUBDIRS = libatalk libevent bin config etc man contrib distrib include doc macros test
-+SUBDIRS = libatalk bin config etc man contrib distrib include doc macros test
-
- EXTRA_DIST = CONTRIBUTORS COPYRIGHT COPYING NEWS VERSION
-
-@@ -11,9 +11,3 @@ if USE_BUILTIN_LIBEVENT
- SUBDIRS += libevent
- endif
-
--if RUN_LDCONFIG
--install-exec-hook:
-- @printf "Running ldconfig to ensure libraries installed in system library directories are added to the dynamic linker cache ... "
-- @-@NETA_LDCONFIG@
-- @printf "done\n"
--endif
-diff --git a/etc/afpd/afp_avahi.c b/etc/afpd/afp_avahi.c
-index 5218d51..b68c266 100644
---- a/etc/afpd/afp_avahi.c
-+++ b/etc/afpd/afp_avahi.c
-@@ -174,8 +174,8 @@ static void register_stuff(void) {
- return;
-
- fail:
-- time(NULL);
- // avahi_threaded_poll_quit(ctx->threaded_poll);
-+ return;
- }
-
- /* Called when publishing of service data completes */
-diff --git a/etc/netatalk/Makefile.am b/etc/netatalk/Makefile.am
-index 10f90ce..7897055 100644
---- a/etc/netatalk/Makefile.am
-+++ b/etc/netatalk/Makefile.am
-@@ -10,8 +10,7 @@ netatalk_CFLAGS = \
- -D_PATH_AFPD=\"$(sbindir)/afpd\" \
- -D_PATH_CNID_METAD=\"$(sbindir)/cnid_metad\"
-
--netatalk_LDADD = \
-- $(top_builddir)/libatalk/libatalk.la
-+netatalk_LDADD = $(top_builddir)/libatalk/libatalk.la
-
- if USE_BUILTIN_LIBEVENT
- netatalk_CFLAGS += \
-@@ -20,4 +19,6 @@ netatalk_CFLAGS += \
-
- netatalk_LDADD += \
- $(top_builddir)/libevent/libevent.la
--endif
-\ No newline at end of file
-+else
-+netatalk_LDADD += $(LIBEVENT_LIBS)
-+endif
-diff --git a/etc/uams/Makefile.am b/etc/uams/Makefile.am
-index 3a02b83..70a2f76 100644
---- a/etc/uams/Makefile.am
-+++ b/etc/uams/Makefile.am
-@@ -95,16 +95,16 @@ uams_dhx_pam_la_CFLAGS = @SSL_CFLAGS@ @PAM_CFLAGS@
- uams_dhx2_pam_la_CFLAGS = @LIBGCRYPT_CFLAGS@ @PAM_CFLAGS@
- uams_gss_la_CFLAGS = @GSSAPI_CFLAGS@
-
--uams_guest_la_LDFLAGS = -module -avoid-version
--uams_randnum_la_LDFLAGS = -module -avoid-version @SSL_LIBS@
--uams_passwd_la_LDFLAGS = -module -avoid-version @CRYPT_LIBS@
--uams_pam_la_LDFLAGS = -module -avoid-version @PAM_LIBS@
--uams_pgp_la_LDFLAGS = -module -avoid-version @SSL_LIBS@
--uams_dhx_passwd_la_LDFLAGS = -module -avoid-version @CRYPT_LIBS@ @SSL_LIBS@
--uams_dhx_pam_la_LDFLAGS = -module -avoid-version @CRYPT_LIBS@ @SSL_LIBS@ @PAM_LIBS@
--uams_dhx2_passwd_la_LDFLAGS = -module -avoid-version @CRYPT_LIBS@ @LIBGCRYPT_LIBS@
--uams_dhx2_pam_la_LDFLAGS = -module -avoid-version @LIBGCRYPT_LIBS@ @PAM_LIBS@
--uams_gss_la_LDFLAGS = -module -avoid-version @GSSAPI_LIBS@
-+uams_guest_la_LDFLAGS = -shared -module -avoid-version
-+uams_randnum_la_LDFLAGS = -shared -module -avoid-version @SSL_LIBS@
-+uams_passwd_la_LDFLAGS = -shared -module -avoid-version @CRYPT_LIBS@
-+uams_pam_la_LDFLAGS = -shared -module -avoid-version @PAM_LIBS@
-+uams_pgp_la_LDFLAGS = -shared -module -avoid-version @SSL_LIBS@
-+uams_dhx_passwd_la_LDFLAGS = -shared -module -avoid-version @CRYPT_LIBS@ @SSL_LIBS@
-+uams_dhx_pam_la_LDFLAGS = -shared -module -avoid-version @CRYPT_LIBS@ @SSL_LIBS@ @PAM_LIBS@
-+uams_dhx2_passwd_la_LDFLAGS = -shared -module -avoid-version @CRYPT_LIBS@ @LIBGCRYPT_LIBS@
-+uams_dhx2_pam_la_LDFLAGS = -shared -module -avoid-version @LIBGCRYPT_LIBS@ @PAM_LIBS@
-+uams_gss_la_LDFLAGS = -shared -module -avoid-version @GSSAPI_LIBS@
-
- #
- # module compilation
-diff --git a/libatalk/dsi/Makefile.am b/libatalk/dsi/Makefile.am
-index 34fa76e..757c458 100644
---- a/libatalk/dsi/Makefile.am
-+++ b/libatalk/dsi/Makefile.am
-@@ -7,3 +7,4 @@ LIBS = @LIBS@
- noinst_LTLIBRARIES = libdsi.la
-
- libdsi_la_SOURCES = dsi_attn.c dsi_close.c dsi_cmdreply.c dsi_getsess.c dsi_getstat.c dsi_init.c dsi_opensess.c dsi_read.c dsi_tcp.c dsi_tickle.c dsi_write.c dsi_stream.c
-+libdsi_la_LIBADD = $(WRAP_LIBS)
-diff --git a/libatalk/vfs/Makefile.am b/libatalk/vfs/Makefile.am
-index aa62aeb..8ac2045 100644
---- a/libatalk/vfs/Makefile.am
-+++ b/libatalk/vfs/Makefile.am
-@@ -6,4 +6,5 @@ libvfs_la_SOURCES = vfs.c unix.c ea_ad.c ea_sys.c extattr.c
-
- if HAVE_ACLS
- libvfs_la_SOURCES += acl.c
-+libvfs_la_LIBADD = $(ACL_LIBS)
- endif
-diff --git a/macros/netatalk.m4 b/macros/netatalk.m4
-index 3e57077..765ce7a 100644
---- a/macros/netatalk.m4
-+++ b/macros/netatalk.m4
-@@ -19,15 +19,16 @@ AC_DEFUN([AC_NETATALK_LIBEVENT], [
- AC_ARG_ENABLE(
- bundled-libevent,
- [AS_HELP_STRING([--disable-bundled-libevent],[whether the bundled version of libevent shall not be used (define CPPFLAGS and LDFLAGS otherwise appropiately to pick up installed version)
-- ])],
-- use_bundled_libevent=$enableval,
-- use_bundled_libevent=yes
-+ ])]
- )
-
-- if test x"$use_bundled_libevent" = x"yes" ; then
-- AC_CONFIG_SUBDIRS([libevent])
-- fi
-- AM_CONDITIONAL(USE_BUILTIN_LIBEVENT, test x"$use_bundled_libevent" = x"yes")
-+ AS_IF([test x"$enable_bundled_libevent" != x"no"],
-+ [AC_CONFIG_SUBDIRS([libevent])
-+ AC_MSG_RESULT([no])],
-+ [AC_MSG_RESULT([yes])
-+ PKG_CHECK_MODULES([LIBEVENT], [libevent])])
-+
-+ AM_CONDITIONAL(USE_BUILTIN_LIBEVENT, test x"$bundled_libevent" = x"no")
- ])
-
- dnl Filesystem Hierarchy Standard (FHS) compatibility