summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorroot <root@zonker.localdomain>2011-08-21 14:16:44 +0200
committerroot <root@zonker.localdomain>2011-08-21 14:16:44 +0200
commit705c4bd055b54ceaea30ce4361f9d0d57785f924 (patch)
tree3a3e4b6f0151d82f7fb1e5026a2beadbefce3495 /media-libs/opensg
downloadmistafunk-705c4bd055b54ceaea30ce4361f9d0d57785f924.tar.gz
mistafunk-705c4bd055b54ceaea30ce4361f9d0d57785f924.tar.bz2
mistafunk-705c4bd055b54ceaea30ce4361f9d0d57785f924.zip
import from svn
Diffstat (limited to 'media-libs/opensg')
-rw-r--r--media-libs/opensg/Manifest6
-rw-r--r--media-libs/opensg/files/opensg-2.0_alpha2284-fix-gdal-png.patch51
-rw-r--r--media-libs/opensg/opensg-2.0_alpha2284.ebuild79
3 files changed, 136 insertions, 0 deletions
diff --git a/media-libs/opensg/Manifest b/media-libs/opensg/Manifest
new file mode 100644
index 0000000..cc995f6
--- /dev/null
+++ b/media-libs/opensg/Manifest
@@ -0,0 +1,6 @@
+AUX opensg-2.0_alpha2284-fix-gdal-png.patch 2161 RMD160 9e0369fdca0591f568218607f50204fe822c861e SHA1 7233c5ecfcf1bb673397c3f848fa8006444c5531 SHA256 a0bf320fe191176007c35d1954d8f9a85e98febf0ccb5600c91f9bbde708b57d
+AUX opensg-fix-gdal-includes.patch 1249 RMD160 8a24de16050faa3603b728aee5959de8856dc153 SHA1 87d21aea8bab1951986516c2159315588b6e6057 SHA256 ccfb4aa874c8455f6ffc47f30877aba3f8af06ad93d4f5d4e16b0d465d2c6f26
+DIST opensg-2.0_alpha2284.tar.bz2 9746821 RMD160 a46e7e09c7f60a1ec9e1c8bce877cf81d0e246c8 SHA1 af3beac3cbbdf054233ad7a07a0372f6f2033689 SHA256 a96f45d113aa51ff8209a5aa7a7f5e861e4e2776c606f1b9da4b521414dcbb28
+EBUILD opensg-2.0_alpha2284.ebuild 1526 RMD160 454eeafff34bd38bb47695b78699f9dd2023f4ef SHA1 29641b930f7e12bd8634540e467822a307f5be61 SHA256 68e9470f5ff772d3ae3acdf67600795083aee4265fa8267b99dc4c7abf7338b7
+MISC ChangeLog 3658 RMD160 b46694ce0f8a7327a112d7d3749e5a5ec3c3e979 SHA1 4a4463924f20d3c15763455a66c9b05ff1c4a292 SHA256 140d10ec72e83274e3a844b6796f4abce81528c0adef66c628deaea8e5587e3c
+MISC opensg-2.0_alpha2321.ebuild.disabled 1531 RMD160 78f1177a2c18ffebe3217a89d8d94e018e424916 SHA1 8510956d2ac70e2f2aa8ea0ea3b1b8a1fbf4218f SHA256 0bfbc1055af8820e899716fdbe4a8972d6618ab4e44da824e4a05f8f392ed79b
diff --git a/media-libs/opensg/files/opensg-2.0_alpha2284-fix-gdal-png.patch b/media-libs/opensg/files/opensg-2.0_alpha2284-fix-gdal-png.patch
new file mode 100644
index 0000000..6f9fe7a
--- /dev/null
+++ b/media-libs/opensg/files/opensg-2.0_alpha2284-fix-gdal-png.patch
@@ -0,0 +1,51 @@
+diff -urN opensg-2.0_alpha2284-original/Source/System/Image/FileIO/OSGGDALImageFileType.cpp opensg-2.0_alpha2284/Source/System/Image/FileIO/OSGGDALImageFileType.cpp
+--- opensg-2.0_alpha2284-original/Source/System/Image/FileIO/OSGGDALImageFileType.cpp 2009-11-30 09:59:08.000000000 +0100
++++ opensg-2.0_alpha2284/Source/System/Image/FileIO/OSGGDALImageFileType.cpp 2010-07-28 14:09:40.000000000 +0200
+@@ -48,9 +48,9 @@
+ #include "OSGGeoReferenceAttachment.h"
+
+ #ifdef OSG_WITH_GDAL
+-#include "gdal/gdal_priv.h"
+-#include "gdal/ogr_srs_api.h"
+-#include "gdal/cpl_multiproc.h"
++#include "gdal_priv.h"
++#include "ogr_srs_api.h"
++#include "cpl_multiproc.h"
+ #endif
+
+
+diff -urN opensg-2.0_alpha2284-original/Source/System/Image/FileIO/OSGGDALImageFileType.h opensg-2.0_alpha2284/Source/System/Image/FileIO/OSGGDALImageFileType.h
+--- opensg-2.0_alpha2284-original/Source/System/Image/FileIO/OSGGDALImageFileType.h 2009-11-30 07:49:49.000000000 +0100
++++ opensg-2.0_alpha2284/Source/System/Image/FileIO/OSGGDALImageFileType.h 2010-07-28 14:09:59.000000000 +0200
+@@ -48,8 +48,8 @@
+ #include "boost/shared_ptr.hpp"
+
+ #ifdef OSG_WITH_GDAL
+-#include "gdal/gdal_priv.h"
+-#include "gdal/ogr_srs_api.h"
++#include "gdal_priv.h"
++#include "ogr_srs_api.h"
+ #endif
+
+ OSG_BEGIN_NAMESPACE
+diff -urN opensg-2.0_alpha2284-original/Source/System/Image/FileIO/OSGPNGImageFileType.cpp opensg-2.0_alpha2284/Source/System/Image/FileIO/OSGPNGImageFileType.cpp
+--- opensg-2.0_alpha2284-original/Source/System/Image/FileIO/OSGPNGImageFileType.cpp 2009-10-05 23:40:17.000000000 +0200
++++ opensg-2.0_alpha2284/Source/System/Image/FileIO/OSGPNGImageFileType.cpp 2010-07-28 13:56:14.000000000 +0200
+@@ -206,7 +206,7 @@
+ // Convert < 8 bit to 8 bit
+ if(color_type == PNG_COLOR_TYPE_GRAY && bit_depth < 8)
+ {
+- png_set_gray_1_2_4_to_8(png_ptr);
++ png_set_expand_gray_1_2_4_to_8(png_ptr);
+ bit_depth = 8;
+ }
+
+@@ -683,7 +683,7 @@
+ // Convert < 8 bit to 8 bit
+ if(color_type == PNG_COLOR_TYPE_GRAY && bit_depth < 8)
+ {
+- png_set_gray_1_2_4_to_8(png_ptr);
++ png_set_expand_gray_1_2_4_to_8(png_ptr);
+ bit_depth = 8;
+ }
+
diff --git a/media-libs/opensg/opensg-2.0_alpha2284.ebuild b/media-libs/opensg/opensg-2.0_alpha2284.ebuild
new file mode 100644
index 0000000..1cbebfe
--- /dev/null
+++ b/media-libs/opensg/opensg-2.0_alpha2284.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+
+inherit cmake-utils
+
+DESCRIPTION="OpenSG is a portable scenegraph system to create realtime graphics programs, e.g. for virtual reality applications."
+HOMEPAGE="http://www.opensg.org/"
+
+SRC_URI="http://vision.ee.ethz.ch/shaegler/gentoo/${P}.tar.bz2"
+LICENSE="LGPL-2.1"
+
+SLOT="2"
+KEYWORDS="~x86"
+
+IUSE="tests doc examples"
+DEPEND="virtual/opengl
+ media-libs/freeglut
+ media-libs/glew
+
+ sys-devel/flex
+ sys-devel/bison
+
+ dev-libs/boost
+ sys-libs/zlib
+ media-libs/freetype
+ media-libs/tiff
+ media-libs/libpng
+ media-libs/jpeg
+ media-libs/openexr
+ sci-libs/gdal
+
+ x11-libs/qt-gui:4
+ x11-libs/qt-opengl:4
+
+ sci-libs/vtk
+
+ doc? ( app-doc/doxygen )
+"
+RDEPEND="${DEPEND}"
+
+EPATCH_OPTS="-p1"
+PATCHES=(
+ "${FILESDIR}/${P}-fix-gdal-png.patch"
+)
+
+src_configure() {
+ mycmakeargs=(
+ -DOSG_USE_OSGSUPPORT_LIBS=OFF
+ -DBOOST_ROOT=/usr
+ -DOSG_DOXY_DOC_TYPE=User
+ -DOSGBUILD_EXAMPLES_SIMPLE=ON
+ -DOSGBUILD_EXAMPLES_ADVANCED=ON
+ -DCOLLADA_ROOT_DIR=/opt/collada-dom
+ )
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+ if use doc; then
+ cd "${CMAKE_BUILD_DIR}"
+ emake Doc || die "building documentation failed"
+ fi
+}
+
+src_install() {
+ cmake-utils_src_install
+ if use doc; then
+ cd "${CMAKE_BUILD_DIR}"/Doc
+ dohtml -r html/* || die "dohtml failed"
+ fi
+ if use examples; then
+ cd "${CMAKE_BUILD_DIR}"/demos
+ dobin mandelbrot/mandelbrot opengl/quaternion_demo || die "dobin failed"
+ fi
+}