summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/alembic/Manifest3
-rw-r--r--media-libs/alembic/alembic-1.0.2011080800.ebuild84
-rw-r--r--media-libs/colladadom/Manifest2
-rw-r--r--media-libs/colladadom/colladadom-2.2.ebuild38
-rw-r--r--media-libs/glfw/Manifest4
-rw-r--r--media-libs/glfw/files/glfw-2.7.2-compile.patch38
-rw-r--r--media-libs/glfw/files/glfw-2.7.2-dyn.patch20
-rw-r--r--media-libs/glfw/glfw-2.7.2.ebuild79
-rw-r--r--media-libs/opencollada/Manifest2
-rw-r--r--media-libs/opencollada/files/opencollada-r736-expat-and-include-fixes.patch47
-rw-r--r--media-libs/opencollada/opencollada-9999.ebuild34
-rw-r--r--media-libs/opensg/Manifest6
-rw-r--r--media-libs/opensg/files/opensg-2.0_alpha2284-fix-gdal-png.patch51
-rw-r--r--media-libs/opensg/opensg-2.0_alpha2284.ebuild79
14 files changed, 487 insertions, 0 deletions
diff --git a/media-libs/alembic/Manifest b/media-libs/alembic/Manifest
new file mode 100644
index 0000000..248d2f8
--- /dev/null
+++ b/media-libs/alembic/Manifest
@@ -0,0 +1,3 @@
+DIST Alembic_1.0_2011080800.tgz 589273 RMD160 644f5e735cea8ae0412dc060bf861590d2ac7e24 SHA1 dd1e8340ce4c69d5c4ccb7364537bc4e8653baa1 SHA256 e15f1ad07c873ac27dd08812ae481c46f87b456f936d38d0224f91fdd1c47487
+EBUILD alembic-1.0.2011080800.ebuild 2230 RMD160 3fdc0b19d8a59fdb8a34ac020d8203d1b1f80393 SHA1 d1642421da25da097b1c67c903426b6a5066129f SHA256 0fa2bc72baefc2e068761122b03e7bd06731822cec0752f7379bdbbd1ab1531b
+EBUILD alembic-9999.ebuild 2041 RMD160 de599413bfd7288f9677743dc44287bd18276ee2 SHA1 1f1acbd5537952f324f5dccd11079e401f6574ab SHA256 363446482e107d4ab87c513327e23341fe1524911dcc424f0e556c086fd01198
diff --git a/media-libs/alembic/alembic-1.0.2011080800.ebuild b/media-libs/alembic/alembic-1.0.2011080800.ebuild
new file mode 100644
index 0000000..67495c8
--- /dev/null
+++ b/media-libs/alembic/alembic-1.0.2011080800.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+# TODO: replace the alembic_bootstrap.py with proper gentoo methods (cmake eclass)
+# TODO: add tests, add help
+
+EAPI=2
+
+inherit eutils versionator
+
+DESCRIPTION="Alembic is an open framework for storing and sharing 3D geometry data that includes a C++ library, a file format, and client plugins and applications."
+HOMEPAGE="http://code.google.com/p/alembic"
+
+MY_PN="Alembic"
+MY_PV=$(replace_version_separator 2 '_')
+MY_P="${MY_PN}_${MY_PV}"
+
+SRC_URI="http://alembic.googlecode.com/files/${MY_P}.tgz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="examples doc"
+RDEPEND=""
+DEPEND=">=dev-util/cmake-2.8
+ >=dev-libs/boost-1.44[static-libs]
+ >=media-libs/ilmbase-1.0.1[static-libs]
+ >=sci-libs/hdf5-1.8.7[-mpi]
+ doc? ( >=app-doc/doxygen-1.7.3 )"
+
+TMPBUILD="${WORKDIR}/alembic-build"
+TMPINSTALL="${WORKDIR}/alembic-install"
+
+src_configure() {
+ mkdir ${TMPBUILD} && cd ${TMPBUILD}
+ S=${TMPBUILD}
+
+ python ${WORKDIR}/${MY_P}/build/bootstrap/alembic_bootstrap.py \
+ --disable-prman --disable-maya --disable-arnold \
+ --hdf5_include_dir=/usr/include \
+ --hdf5_hdf5_library=/usr/lib/libhdf5.a \
+ --boost_include_dir=${LIBS}/boost_install/include \
+ --boost_thread_library=/usr/lib/libboost_thread-mt.a \
+ --zlib_include_dir=/usr/include \
+ --zlib_library=/usr/lib/libz.a \
+ --ilmbase_include_dir=/usr/include/OpenEXR \
+ --ilmbase_imath_library=/usr/lib/libImath.a \
+ .
+}
+
+src_compile() {
+ emake
+
+ if use examples; then
+ cd ${S}/examples
+ emake all
+ fi
+}
+
+src_install() {
+ mkdir ${TMPINSTALL}
+
+ cd ${S}
+ emake DESTDIR=${TMPINSTALL} install
+
+ dolib.a ${TMPINSTALL}/usr/local/alembic-1.0.0/lib/static/*.a
+ cp -r ${TMPINSTALL}/usr/local/alembic-1.0.0/include/Alembic ${D}/usr/include
+
+ if use examples; then
+ dobin ${TMPBUILD}/examples/bin/AbcEcho/abcecho
+ dobin ${TMPBUILD}/examples/bin/AbcEcho/abcechobounds
+ dobin ${TMPBUILD}/examples/bin/AbcStitcher/abcstitcher
+ dobin ${TMPBUILD}/examples/bin/SimpleAbcViewer/SimpleAbcViewer
+ fi
+
+ dodoc ${WORKDIR}/${MY_P}/{ACKNOWLEDGEMENTS,FEEDBACK,LICENSE,MANIFEST,NEWS,README}.txt
+
+ if use doc; then
+ cd ${WORKDIR}/${MY_P}
+ doxygen
+ dohtml -r doc/html/*
+ fi
+} \ No newline at end of file
diff --git a/media-libs/colladadom/Manifest b/media-libs/colladadom/Manifest
new file mode 100644
index 0000000..1127b56
--- /dev/null
+++ b/media-libs/colladadom/Manifest
@@ -0,0 +1,2 @@
+DIST collada-dom-2.2.zip 29651798 RMD160 b2d4387dfe97d97b30b702f39e4ee312dba6d13a SHA1 e6b72ca4c0327fbc342ab87a1d9d76530a980b5d SHA256 3cba41643815045bc9073d1d0ca0337eeda79ce03a31f249078e04973eeecff5
+EBUILD colladadom-2.2.ebuild 787 RMD160 29def9e59a53e037a55246153e9a46dbff64f078 SHA1 0cb86083bb25ee7e09e6e560c1594f882d9c2b59 SHA256 79a5f2cd8d4cf6a72b4d60b8ca98a19fafd3c23f58941d17ef5ed44f759303ed
diff --git a/media-libs/colladadom/colladadom-2.2.ebuild b/media-libs/colladadom/colladadom-2.2.ebuild
new file mode 100644
index 0000000..9c1b9df
--- /dev/null
+++ b/media-libs/colladadom/colladadom-2.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+
+inherit eutils
+
+DESCRIPTION="The COLLADA Document Object Model (DOM) is an application programming interface (API) that provides a C++ object representation of a COLLADA XML instance document."
+HOMEPAGE="http://sourceforge.net/projects/collada-dom/"
+
+SRC_URI="mirror://sourceforge/collada-dom/files/Collada%20DOM/Collada%20DOM%202.2/collada-dom-2.2.zip"
+LICENSE="MIT"
+
+SLOT="0"
+KEYWORDS="~x86"
+
+IUSE=""
+DEPEND="virtual/opengl
+ virtual/glut
+ media-gfx/nvidia-cg-toolkit
+"
+RDEPEND="${DEPEND}"
+
+EPATCH_OPTS=""
+PATCHES=()
+
+S="${WORKDIR}/collada-dom"
+
+#src_configure() {
+#}
+
+src_compile() {
+ emake -f Makefile.linux || die "emake failed"
+}
+
+#src_install() {
+#}
diff --git a/media-libs/glfw/Manifest b/media-libs/glfw/Manifest
new file mode 100644
index 0000000..49d3550
--- /dev/null
+++ b/media-libs/glfw/Manifest
@@ -0,0 +1,4 @@
+AUX glfw-2.7.2-compile.patch 1115 RMD160 bc2f9a5aa05017f869d6b1c5deea79c88f3ead4d SHA1 f595dc8f44d3c14e62922967e36fb9d441415977 SHA256 89bd4c770e1187526eb747d0d39e8f024be76f96829e86330366a5260d7fb931
+AUX glfw-2.7.2-dyn.patch 806 RMD160 fa6cfd4f6770acd154e4cb73ccc5656395e5b824 SHA1 a845f0d5e1753e5bd73eb097af109a10f3726eea SHA256 9efb0b7d14c62e636c8896c278773afa1b09aef8ddfa945038407ae2b64e29a6
+DIST glfw-2.7.2.tar.bz2 902680 RMD160 409a0ebb121b8d13f30e0d626ca48ba141f06ff4 SHA1 19033c4d55ec98e85bb96954dddf213006857516 SHA256 c328f43351a1f935661d95970730a551d3207d6067260809155efb1a67eab537
+EBUILD glfw-2.7.2.ebuild 1950 RMD160 d5a7eab221e5ab61e44480420a38182a9f8cbcd7 SHA1 fbbf669aa78d5e03947cb530c8e6e7550c28a1e9 SHA256 97070c1a4816c56ab3ade1f3487946adfd7531872c56f5261911b019fc55a184
diff --git a/media-libs/glfw/files/glfw-2.7.2-compile.patch b/media-libs/glfw/files/glfw-2.7.2-compile.patch
new file mode 100644
index 0000000..f212f96
--- /dev/null
+++ b/media-libs/glfw/files/glfw-2.7.2-compile.patch
@@ -0,0 +1,38 @@
+--- compile.sh.old 2011-08-19 11:20:37.927080832 +0200
++++ compile.sh 2011-08-19 11:21:59.910080833 +0200
+@@ -88,7 +88,7 @@
+ case "x`uname 2> /dev/null`" in
+ xLinux)
+ GLFW_LIB_CFLAGS="$GLFW_LIB_CFLAGS -D_GLFW_USE_LINUX_JOYSTICKS"
+- SOFLAGS="-shared -Wl,-soname,libglfw.so"
++ SOFLAGS="-shared -Wl,-soname,libglfw.so.2.7"
+ echo "Linux" 1>&6
+ ;;
+ xDarwin)
+@@ -96,7 +96,7 @@
+ echo "Mac OS X" 1>&6
+ ;;
+ *)
+- SOFLAGS="-shared -soname libglfw.so"
++ SOFLAGS="-shared -soname libglfw.so.2.7"
+ echo "Generic Unix" 1>&6
+ ;;
+ esac
+@@ -627,7 +627,7 @@
+ CFLAGS = $GLFW_BIN_CFLAGS $GLFW_CFLAGS
+
+ LIB = ../lib/x11/libglfw.a
+-SOLIB = ../lib/x11/libglfw.so
++SOLIB = ../lib/x11/libglfw.so.2.7
+ LFLAGS = \$(LIB) $GLFW_LIB_LFLAGS $GLFW_BIN_LFLAGS $GLFW_LFLAGS
+ SO_LFLAGS = \$(SOLIB) $GLFW_BIN_LFLAGS $GLFW_LFLAGS
+
+@@ -652,7 +652,7 @@
+ CFLAGS = $GLFW_BIN_CFLAGS $GLFW_CFLAGS
+
+ LIB = ../lib/x11/libglfw.a
+-SOLIB = ../lib/x11/libglfw.so
++SOLIB = ../lib/x11/libglfw.so.2.7
+ LFLAGS = \$(LIB) $GLFW_LIB_LFLAGS $GLFW_BIN_LFLAGS $GLFW_LFLAGS
+ SO_LFLAGS = \$(SOLIB) $GLFW_BIN_LFLAGS $GLFW_LFLAGS
+
diff --git a/media-libs/glfw/files/glfw-2.7.2-dyn.patch b/media-libs/glfw/files/glfw-2.7.2-dyn.patch
new file mode 100644
index 0000000..e524e6d
--- /dev/null
+++ b/media-libs/glfw/files/glfw-2.7.2-dyn.patch
@@ -0,0 +1,20 @@
+--- lib/x11/Makefile.x11.in.old 2011-08-19 11:14:45.190080831 +0200
++++ lib/x11/Makefile.x11.in 2011-08-19 11:14:08.950080832 +0200
+@@ -8,7 +8,7 @@
+ ##########################################################################
+ # Default: Build GLFW static library
+ ##########################################################################
+-all: libglfw.a libglfw.so
++all: libglfw.a libglfw.so.2.7
+
+
+ ##########################################################################
+@@ -118,7 +118,7 @@
+ ##########################################################################
+ # Rule for building shared library
+ ##########################################################################
+-libglfw.so: $(SHARED_OBJS)
++libglfw.so.2.7: $(SHARED_OBJS)
+ $(CC) $(SOFLAGS) -o $@ $(SHARED_OBJS) $(LFLAGS) $(LIBS)
+
+
diff --git a/media-libs/glfw/glfw-2.7.2.ebuild b/media-libs/glfw/glfw-2.7.2.ebuild
new file mode 100644
index 0000000..3cd434e
--- /dev/null
+++ b/media-libs/glfw/glfw-2.7.2.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/glfw/glfw-2.6.ebuild,v 1.6 2010/09/13 12:09:46 tupone Exp $
+
+EAPI=2
+inherit eutils multilib
+
+DESCRIPTION="The Portable OpenGL FrameWork"
+HOMEPAGE="http://glfw.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="examples"
+
+DEPEND="x11-libs/libXrandr
+ virtual/opengl"
+
+S=${WORKDIR}/${P}
+
+src_prepare() {
+ sed -i -e "s:\"docs/:\"/usr/share/doc/${PF}/pdf/:" readme.html || die "sed failed"
+ epatch "${FILESDIR}/${PF}-dyn.patch"
+ epatch "${FILESDIR}/${PF}-compile.patch"
+}
+
+src_configure() {
+ sh compile.sh
+}
+
+src_compile() {
+ emake -C lib/x11 PREFIX=/usr -f Makefile.x11 all libglfw.pc || die "emake failed"
+ if use examples; then
+ emake -C examples -f Makefile.x11 all || die "emake failed"
+ fi
+}
+
+src_install() {
+ dolib.a lib/x11/libglfw.a || die "dolib.a failed"
+ dolib.so lib/x11/libglfw.so.2.7 || die "dolib.so failed"
+ dosym libglfw.so.2.7 /usr/$(get_libdir)/libglfw.so
+
+ insinto /usr/$(get_libdir)/pkgconfig
+ doins lib/x11/libglfw.pc || die "doins failed"
+ insinto /usr/include/GL
+ doins include/GL/glfw.h || die "doins failed"
+
+ dohtml -r readme.html
+ #insinto /usr/share/doc/${PF}/html/images
+ #doins images/*
+ insinto /usr/share/doc/${PF}/pdf
+ doins docs/*.pdf
+
+ if use examples; then
+ local f
+ local MY_EXAMPLES="boing gears listmodes mipmaps
+ mtbench mthello particles pong3d splitview
+ triangle wave"
+ local MY_PICS="mipmaps.tga pong3d_field.tga pong3d_instr.tga
+ pong3d_menu.tga pong3d_title.tga
+ pong3d_winner1.tga pong3d_winner2.tga"
+
+ insinto /usr/share/doc/${PF}/examples
+
+ doins examples/Makefile.x11
+ for f in $MY_EXAMPLES; do
+ doins examples/${f}.c
+ done
+ for f in $MY_PICS; do
+ doins examples/${f}
+ done
+
+ insopts -m0755
+ for f in $MY_EXAMPLES; do
+ doins examples/${f}
+ done
+ fi
+}
diff --git a/media-libs/opencollada/Manifest b/media-libs/opencollada/Manifest
new file mode 100644
index 0000000..4e69392
--- /dev/null
+++ b/media-libs/opencollada/Manifest
@@ -0,0 +1,2 @@
+AUX opencollada-r736-expat-and-include-fixes.patch 1622 RMD160 121524c0cc9c376bef119a871fdd1b9ce3b2889d SHA1 51f1bf309f296960f95ad81bf897e82180535244 SHA256 49e5897338ebdb15757eadd7f7448b662a115204ee99327a1d2b5b969eeb409e
+EBUILD opencollada-9999.ebuild 817 RMD160 5498e42844d50f7b33ddd3cf3986018364f30bba SHA1 9fff10dbae1c002cbd308f1b247c07ce56262a3b SHA256 a91dd588b2770ad37280dfff7ab9c40f401e25bcc5d9b6e4c92f870af281237a
diff --git a/media-libs/opencollada/files/opencollada-r736-expat-and-include-fixes.patch b/media-libs/opencollada/files/opencollada-r736-expat-and-include-fixes.patch
new file mode 100644
index 0000000..d23aa69
--- /dev/null
+++ b/media-libs/opencollada/files/opencollada-r736-expat-and-include-fixes.patch
@@ -0,0 +1,47 @@
+Index: common/libBuffer/src/CommonFWriteBufferFlusher.cpp
+===================================================================
+--- common/libBuffer/src/CommonFWriteBufferFlusher.cpp (revision 736)
++++ common/libBuffer/src/CommonFWriteBufferFlusher.cpp (working copy)
+@@ -10,7 +10,8 @@
+
+ #include "CommonFWriteBufferFlusher.h"
+
+- #include <errno.h>
++#include <errno.h>
++#include <cstdio>
+
+ namespace Common
+ {
+Index: dae2ogre/include/DAE2OgreSerializer.h
+===================================================================
+--- dae2ogre/include/DAE2OgreSerializer.h (revision 736)
++++ dae2ogre/include/DAE2OgreSerializer.h (working copy)
+@@ -30,6 +30,8 @@
+ #ifndef __DAE2OGRE_OGRESERIALIZER_H__
+ #define __DAE2OGRE_OGRESERIALIZER_H__
+
++#include <cstdio>
++
+ #include "DAE2OgrePrerequisites.h"
+
+ namespace DAE2Ogre
+Index: Externals/expat/SConscript
+===================================================================
+--- Externals/expat/SConscript (revision 736)
++++ Externals/expat/SConscript (working copy)
+@@ -11,7 +11,7 @@
+ targetPath = outputDir + libName
+
+
+-incDirs = ['include/']
++incDirs = ['include/', '.']
+
+ src = [ variantDir + str(p) for p in Glob(srcDir + '*.c')]
+ VariantDir(variant_dir=variantDir + srcDir, src_dir=srcDir, duplicate=False)
+@@ -19,5 +19,5 @@
+ if env['SHAREDLIB']:
+ SharedLibrary(target=targetPath, source=src, CPPPATH=incDirs, CCFLAGS=env['CPPFLAGS'])
+ else:
+- StaticLibrary(target=targetPath, source=src, CPPPATH=incDirs, CCFLAGS=env['CPPFLAGS'])
++ StaticLibrary(target=targetPath, source=src, CPPPATH=incDirs, CCFLAGS=env['CPPFLAGS'] + ' -DHAVE_EXPAT_CONFIG_H')
+
diff --git a/media-libs/opencollada/opencollada-9999.ebuild b/media-libs/opencollada/opencollada-9999.ebuild
new file mode 100644
index 0000000..0573425
--- /dev/null
+++ b/media-libs/opencollada/opencollada-9999.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils
+inherit subversion
+
+DESCRIPTION="OpenCOLLADA is a stream based reader and writer library for COLLADA files"
+HOMEPAGE="http://www.opencollada.org/"
+LICENSE="MIT"
+
+ESVN_REPO_URI="http://opencollada.googlecode.com/svn/trunk"
+ESVN_PROJECT="opencollada-trunk"
+ESVN_PATCHES="${FILESDIR}/opencollada-r736-expat-and-include-fixes.patch"
+
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ # call configure for bundled expat to generate a missing header file
+ cd $S/Externals/expat
+ sh configure
+
+ cd $S
+ scons RELEASE=1 XMLPARSER=expat PCRENATIVE=0 || die "emake failed"
+}
+
+#src_install() {
+ #dodir /usr/include/opencollada/
+ #dodir /usr/lib/opencollada/
+#}
diff --git a/media-libs/opensg/Manifest b/media-libs/opensg/Manifest
new file mode 100644
index 0000000..cc995f6
--- /dev/null
+++ b/media-libs/opensg/Manifest
@@ -0,0 +1,6 @@
+AUX opensg-2.0_alpha2284-fix-gdal-png.patch 2161 RMD160 9e0369fdca0591f568218607f50204fe822c861e SHA1 7233c5ecfcf1bb673397c3f848fa8006444c5531 SHA256 a0bf320fe191176007c35d1954d8f9a85e98febf0ccb5600c91f9bbde708b57d
+AUX opensg-fix-gdal-includes.patch 1249 RMD160 8a24de16050faa3603b728aee5959de8856dc153 SHA1 87d21aea8bab1951986516c2159315588b6e6057 SHA256 ccfb4aa874c8455f6ffc47f30877aba3f8af06ad93d4f5d4e16b0d465d2c6f26
+DIST opensg-2.0_alpha2284.tar.bz2 9746821 RMD160 a46e7e09c7f60a1ec9e1c8bce877cf81d0e246c8 SHA1 af3beac3cbbdf054233ad7a07a0372f6f2033689 SHA256 a96f45d113aa51ff8209a5aa7a7f5e861e4e2776c606f1b9da4b521414dcbb28
+EBUILD opensg-2.0_alpha2284.ebuild 1526 RMD160 454eeafff34bd38bb47695b78699f9dd2023f4ef SHA1 29641b930f7e12bd8634540e467822a307f5be61 SHA256 68e9470f5ff772d3ae3acdf67600795083aee4265fa8267b99dc4c7abf7338b7
+MISC ChangeLog 3658 RMD160 b46694ce0f8a7327a112d7d3749e5a5ec3c3e979 SHA1 4a4463924f20d3c15763455a66c9b05ff1c4a292 SHA256 140d10ec72e83274e3a844b6796f4abce81528c0adef66c628deaea8e5587e3c
+MISC opensg-2.0_alpha2321.ebuild.disabled 1531 RMD160 78f1177a2c18ffebe3217a89d8d94e018e424916 SHA1 8510956d2ac70e2f2aa8ea0ea3b1b8a1fbf4218f SHA256 0bfbc1055af8820e899716fdbe4a8972d6618ab4e44da824e4a05f8f392ed79b
diff --git a/media-libs/opensg/files/opensg-2.0_alpha2284-fix-gdal-png.patch b/media-libs/opensg/files/opensg-2.0_alpha2284-fix-gdal-png.patch
new file mode 100644
index 0000000..6f9fe7a
--- /dev/null
+++ b/media-libs/opensg/files/opensg-2.0_alpha2284-fix-gdal-png.patch
@@ -0,0 +1,51 @@
+diff -urN opensg-2.0_alpha2284-original/Source/System/Image/FileIO/OSGGDALImageFileType.cpp opensg-2.0_alpha2284/Source/System/Image/FileIO/OSGGDALImageFileType.cpp
+--- opensg-2.0_alpha2284-original/Source/System/Image/FileIO/OSGGDALImageFileType.cpp 2009-11-30 09:59:08.000000000 +0100
++++ opensg-2.0_alpha2284/Source/System/Image/FileIO/OSGGDALImageFileType.cpp 2010-07-28 14:09:40.000000000 +0200
+@@ -48,9 +48,9 @@
+ #include "OSGGeoReferenceAttachment.h"
+
+ #ifdef OSG_WITH_GDAL
+-#include "gdal/gdal_priv.h"
+-#include "gdal/ogr_srs_api.h"
+-#include "gdal/cpl_multiproc.h"
++#include "gdal_priv.h"
++#include "ogr_srs_api.h"
++#include "cpl_multiproc.h"
+ #endif
+
+
+diff -urN opensg-2.0_alpha2284-original/Source/System/Image/FileIO/OSGGDALImageFileType.h opensg-2.0_alpha2284/Source/System/Image/FileIO/OSGGDALImageFileType.h
+--- opensg-2.0_alpha2284-original/Source/System/Image/FileIO/OSGGDALImageFileType.h 2009-11-30 07:49:49.000000000 +0100
++++ opensg-2.0_alpha2284/Source/System/Image/FileIO/OSGGDALImageFileType.h 2010-07-28 14:09:59.000000000 +0200
+@@ -48,8 +48,8 @@
+ #include "boost/shared_ptr.hpp"
+
+ #ifdef OSG_WITH_GDAL
+-#include "gdal/gdal_priv.h"
+-#include "gdal/ogr_srs_api.h"
++#include "gdal_priv.h"
++#include "ogr_srs_api.h"
+ #endif
+
+ OSG_BEGIN_NAMESPACE
+diff -urN opensg-2.0_alpha2284-original/Source/System/Image/FileIO/OSGPNGImageFileType.cpp opensg-2.0_alpha2284/Source/System/Image/FileIO/OSGPNGImageFileType.cpp
+--- opensg-2.0_alpha2284-original/Source/System/Image/FileIO/OSGPNGImageFileType.cpp 2009-10-05 23:40:17.000000000 +0200
++++ opensg-2.0_alpha2284/Source/System/Image/FileIO/OSGPNGImageFileType.cpp 2010-07-28 13:56:14.000000000 +0200
+@@ -206,7 +206,7 @@
+ // Convert < 8 bit to 8 bit
+ if(color_type == PNG_COLOR_TYPE_GRAY && bit_depth < 8)
+ {
+- png_set_gray_1_2_4_to_8(png_ptr);
++ png_set_expand_gray_1_2_4_to_8(png_ptr);
+ bit_depth = 8;
+ }
+
+@@ -683,7 +683,7 @@
+ // Convert < 8 bit to 8 bit
+ if(color_type == PNG_COLOR_TYPE_GRAY && bit_depth < 8)
+ {
+- png_set_gray_1_2_4_to_8(png_ptr);
++ png_set_expand_gray_1_2_4_to_8(png_ptr);
+ bit_depth = 8;
+ }
+
diff --git a/media-libs/opensg/opensg-2.0_alpha2284.ebuild b/media-libs/opensg/opensg-2.0_alpha2284.ebuild
new file mode 100644
index 0000000..1cbebfe
--- /dev/null
+++ b/media-libs/opensg/opensg-2.0_alpha2284.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+
+inherit cmake-utils
+
+DESCRIPTION="OpenSG is a portable scenegraph system to create realtime graphics programs, e.g. for virtual reality applications."
+HOMEPAGE="http://www.opensg.org/"
+
+SRC_URI="http://vision.ee.ethz.ch/shaegler/gentoo/${P}.tar.bz2"
+LICENSE="LGPL-2.1"
+
+SLOT="2"
+KEYWORDS="~x86"
+
+IUSE="tests doc examples"
+DEPEND="virtual/opengl
+ media-libs/freeglut
+ media-libs/glew
+
+ sys-devel/flex
+ sys-devel/bison
+
+ dev-libs/boost
+ sys-libs/zlib
+ media-libs/freetype
+ media-libs/tiff
+ media-libs/libpng
+ media-libs/jpeg
+ media-libs/openexr
+ sci-libs/gdal
+
+ x11-libs/qt-gui:4
+ x11-libs/qt-opengl:4
+
+ sci-libs/vtk
+
+ doc? ( app-doc/doxygen )
+"
+RDEPEND="${DEPEND}"
+
+EPATCH_OPTS="-p1"
+PATCHES=(
+ "${FILESDIR}/${P}-fix-gdal-png.patch"
+)
+
+src_configure() {
+ mycmakeargs=(
+ -DOSG_USE_OSGSUPPORT_LIBS=OFF
+ -DBOOST_ROOT=/usr
+ -DOSG_DOXY_DOC_TYPE=User
+ -DOSGBUILD_EXAMPLES_SIMPLE=ON
+ -DOSGBUILD_EXAMPLES_ADVANCED=ON
+ -DCOLLADA_ROOT_DIR=/opt/collada-dom
+ )
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+ if use doc; then
+ cd "${CMAKE_BUILD_DIR}"
+ emake Doc || die "building documentation failed"
+ fi
+}
+
+src_install() {
+ cmake-utils_src_install
+ if use doc; then
+ cd "${CMAKE_BUILD_DIR}"/Doc
+ dohtml -r html/* || die "dohtml failed"
+ fi
+ if use examples; then
+ cd "${CMAKE_BUILD_DIR}"/demos
+ dobin mandelbrot/mandelbrot opengl/quaternion_demo || die "dobin failed"
+ fi
+}