summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2012-12-17 09:12:00 +0100
committerMartin Väth <martin@mvath.de>2015-10-11 10:48:34 +0200
commit0ab81b1b1288c9d5fdc6f07f6476a313dc293ac9 (patch)
treec06a43bc2864a14e610acd37354c40b4c102f8ad
parentRename martian->martian-modem and update from tree. Bump squash_dir, duckduckgo (diff)
downloadmv-0ab81b1b1288c9d5fdc6f07f6476a313dc293ac9.tar.gz
mv-0ab81b1b1288c9d5fdc6f07f6476a313dc293ac9.tar.bz2
mv-0ab81b1b1288c9d5fdc6f07f6476a313dc293ac9.zip
Make aufs3 work with kernel-3.7
-rw-r--r--sys-fs/aufs/ChangeLog4
-rw-r--r--sys-fs/aufs/aufs-99999999.2-r1.ebuild20
-rw-r--r--sys-fs/aufs/aufs-99999999.3-r2.ebuild35
-rw-r--r--sys-fs/aufs/files/grsecurity-2.9.1.patch15
4 files changed, 55 insertions, 19 deletions
diff --git a/sys-fs/aufs/ChangeLog b/sys-fs/aufs/ChangeLog
index 9a3d7185..10c14e88 100644
--- a/sys-fs/aufs/ChangeLog
+++ b/sys-fs/aufs/ChangeLog
@@ -2,6 +2,10 @@
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 17 Dec 2012; Martin Väth <martin@mvath.de>
+ Add patch for hardened-sources-3.7.0. Improve documentation.
+ Special case of kernel-3.7 branch name.
+
21 Sep 2012; Martin Väth <martin@mvath.de>
Bump to EAPI=5. Bump revision to force correct subslot
diff --git a/sys-fs/aufs/aufs-99999999.2-r1.ebuild b/sys-fs/aufs/aufs-99999999.2-r1.ebuild
index 5e904e0d..e01f235f 100644
--- a/sys-fs/aufs/aufs-99999999.2-r1.ebuild
+++ b/sys-fs/aufs/aufs-99999999.2-r1.ebuild
@@ -36,7 +36,8 @@ fill_my_patchlist() {
my_patchlist=()
for i
do case ${i} in
- *.patch|*.diff) ! test -f "${i}" || my_patchlist+=("${i}");;
+ *.patch|*.diff)
+ ! test -f "${i}" || my_patchlist+=("${i}");;
esac
done
}
@@ -67,8 +68,10 @@ apply_my_patchlist() {
set --
for i in "${my_patchlist[@]}"
do if use all-patches || case ${i} in
- aufs*) :;;
- *) false;;
+ aufs*)
+ :;;
+ *)
+ false;;
esac
then apply_my_patch ${r} "${i}" || set -- "${@}" "${i}"
else einfo "Kernel patch ${i} - skipping as all-patches is not set"
@@ -126,14 +129,17 @@ pkg_setup() {
src_prepare() {
local i j w v newest all
epatch_user
- all="2.2.0 2.2.1 2.2.2 2.2.2.r1"
+ all="2.9.1 2.2.0 2.2.1 2.2.2 2.2.2.r1"
newest=${all##* }
v=
for i in ${GRSECURITYPATCHVER-+}
do case ${i} in
- '+') j=${newest};;
- '*') j=${all};;
- *) w=:
+ '+')
+ j=${newest};;
+ '*')
+ j=${all};;
+ *)
+ w=:
for j in ${all}
do [ "${i}" = "${j}" ] && w=false && continue
done
diff --git a/sys-fs/aufs/aufs-99999999.3-r2.ebuild b/sys-fs/aufs/aufs-99999999.3-r2.ebuild
index da139c2c..7ccc5768 100644
--- a/sys-fs/aufs/aufs-99999999.3-r2.ebuild
+++ b/sys-fs/aufs/aufs-99999999.3-r2.ebuild
@@ -36,7 +36,8 @@ fill_my_patchlist() {
my_patchlist=()
for i
do case ${i} in
- *.patch|*.diff) ! test -f "${i}" || my_patchlist+=("${i}");;
+ *.patch|*.diff)
+ ! test -f "${i}" || my_patchlist+=("${i}");;
esac
done
}
@@ -67,8 +68,10 @@ apply_my_patchlist() {
set --
for i in "${my_patchlist[@]}"
do if use all-patches || case "${i}" in
- aufs*) :;;
- *) false;;
+ aufs*)
+ :;;
+ *)
+ false;;
esac
then apply_my_patch ${r} "${i}" || set -- "${@}" "${i}"
else einfo "Kernel patch ${i} - skipping as all-patches is not set"
@@ -81,7 +84,6 @@ apply_my_patchlist() {
}
pkg_setup() {
- local msg
linux-info_pkg_setup
# kernel version check
@@ -98,17 +100,23 @@ pkg_setup() {
then [ -n "${KV_PATCH}" ] && EGIT_BRANCH="aufs2.2-${KV_PATCH}"
else [ -n "${KV_MINOR}" ] && EGIT_BRANCH="aufs${KV_MAJOR}.${KV_MINOR}"
fi
+ case ${EGIT_BRANCH} in
+ aufs3.7)
+ EGIT_BRANCH="aufs3.x-rcN";;
+ esac
fi
elog
elog "Using aufs branch: ${EGIT_BRANCH}"
elog "If this guess for the branch is wrong, set AUFSBRANCH."
elog "For example, to use the aufs3.0 branch for kernel version 3.0, use:"
elog " AUFSBRANCH=aufs3.0 emerge -1 aufs"
- msg=
- if [ -n "${msg}" ]
- then
+ elog
+ elog "To find out names of testing branches you might want to use"
+ elog "( cd ${EGIT_DIR} && git log --decorate --graph --all --full-history )"
+ if [ -n "${EVCS_OFFLINE}" ]
+ then elog
elog "Note that it might be necessary in addition to fetch the newest aufs:"
- elog "Set ${msg# } and be sure to be online during emerge."
+ elog "Set EVCS_OFFLINE='' in the environment and be online during emerge."
fi
elog
EGIT_COMMIT=${EGIT_BRANCH}
@@ -124,14 +132,17 @@ pkg_setup() {
src_prepare() {
local i j w v newest all
epatch_user
- all="2.2.0 2.2.1 2.2.2 2.2.2.r1"
+ all="2.2.0 2.2.1 2.2.2 2.2.2.r1 2.9.1"
newest=${all##* }
v=
for i in ${GRSECURITYPATCHVER-+}
do case ${i} in
- '+') j=${newest};;
- '*') j=${all};;
- *) w=:
+ '+')
+ j=${newest};;
+ '*')
+ j=${all};;
+ *)
+ w=:
for j in ${all}
do [ "${i}" = "${j}" ] && w=false && continue
done
diff --git a/sys-fs/aufs/files/grsecurity-2.9.1.patch b/sys-fs/aufs/files/grsecurity-2.9.1.patch
new file mode 100644
index 00000000..699419fd
--- /dev/null
+++ b/sys-fs/aufs/files/grsecurity-2.9.1.patch
@@ -0,0 +1,15 @@
+--- linux/include/linux/fs.h
++++ linux/include/linux/fs.h
+@@ -385,7 +385,11 @@
+ int (*swap_activate)(struct swap_info_struct *sis, struct file *file,
+ sector_t *span);
+ void (*swap_deactivate)(struct file *file);
+-};
++}
++#ifdef CONFIG_GRKERNSEC
++__no_const
++#endif
++;
+
+ extern const struct address_space_operations empty_aops;
+