summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2016-08-14 20:55:25 +0200
committerMartin Väth <martin@mvath.de>2016-08-14 20:55:25 +0200
commit199195c11b50a2f5c25de7bc8b8985f70b0004c2 (patch)
treed7130a624fb5728f574eaf99757f1a3113e2eae3
parentmedia-tv/sundtek-tv: Version bump (diff)
downloadmv-199195c11b50a2f5c25de7bc8b8985f70b0004c2.tar.gz
mv-199195c11b50a2f5c25de7bc8b8985f70b0004c2.tar.bz2
mv-199195c11b50a2f5c25de7bc8b8985f70b0004c2.zip
app-shells/dash: provide uncrippled bump
-rw-r--r--app-shells/dash/Manifest1
-rw-r--r--app-shells/dash/dash-0.5.9.ebuild55
-rw-r--r--app-shells/dash/dash-99999999.ebuild27
-rw-r--r--app-shells/dash/metadata.xml4
4 files changed, 73 insertions, 14 deletions
diff --git a/app-shells/dash/Manifest b/app-shells/dash/Manifest
new file mode 100644
index 00000000..af942a5a
--- /dev/null
+++ b/app-shells/dash/Manifest
@@ -0,0 +1 @@
+DIST dash-0.5.9.tar.gz 224831 SHA256 92793b14c017d79297001556389442aeb9e3c1cc559fd178c979169b1a47629c
diff --git a/app-shells/dash/dash-0.5.9.ebuild b/app-shells/dash/dash-0.5.9.ebuild
new file mode 100644
index 00000000..0f99ce64
--- /dev/null
+++ b/app-shells/dash/dash-0.5.9.ebuild
@@ -0,0 +1,55 @@
+# Copyright 2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+case ${PV} in
+99999999*)
+ EGIT_REPO_URI="git://git.kernel.org/pub/scm/utils/dash/dash.git"
+ WANT_LIBTOOL=none
+ AT_NOELIBTOOLIZE=true
+ inherit autotools git-r3
+ PROPERTIES="live"
+ KEYWORDS=""
+ SRC_URI="";;
+*)
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+ SRC_URI="http://gondor.apana.org.au/~herbert/dash/files/${P}.tar.gz";;
+esac
+
+inherit eutils flag-o-matic toolchain-funcs
+
+DESCRIPTION="Descendant of the NetBSD ash. Vanilla, without the gentoo XSI cripple patches"
+HOMEPAGE="http://gondor.apana.org.au/~herbert/dash/"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="libedit static"
+
+RDEPEND="!static? ( libedit? ( dev-libs/libedit ) )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ libedit? ( static? ( dev-libs/libedit[static-libs] ) )"
+
+src_prepare() {
+ # Use pkg-config for libedit linkage
+ sed -i \
+ -e "/LIBS/s:-ledit:\`$(tc-getPKG_CONFIG) --libs libedit $(usex static --static '')\`:" \
+ configure.ac || die
+
+ eapply_user
+ eautoreconf
+}
+
+src_configure() {
+ append-cppflags -DJOBS=$(usex libedit 1 0)
+ use static && append-ldflags -static
+ # Do not pass --enable-glob due to #443552.
+ # Autotools use $LINENO as a proxy for extended debug support
+ # (i.e. they're running bash), so disable that. #527644
+ econf \
+ --bindir="${EPREFIX}"/bin \
+ --enable-fnmatch \
+ --disable-lineno \
+ $(use_with libedit)
+}
diff --git a/app-shells/dash/dash-99999999.ebuild b/app-shells/dash/dash-99999999.ebuild
index b7ee2e98..0f99ce64 100644
--- a/app-shells/dash/dash-99999999.ebuild
+++ b/app-shells/dash/dash-99999999.ebuild
@@ -3,20 +3,27 @@
EAPI=6
-EGIT_REPO_URI="git://git.kernel.org/pub/scm/utils/dash/dash.git"
-WANT_LIBTOOL=none
-AT_NOELIBTOOLIZE=true
-inherit autotools eutils flag-o-matic git-r3 toolchain-funcs
-
-DESCRIPTION="DASH is a direct descendant of the NetBSD version of ash (the Almquist SHell) and is POSIX compliant"
+case ${PV} in
+99999999*)
+ EGIT_REPO_URI="git://git.kernel.org/pub/scm/utils/dash/dash.git"
+ WANT_LIBTOOL=none
+ AT_NOELIBTOOLIZE=true
+ inherit autotools git-r3
+ PROPERTIES="live"
+ KEYWORDS=""
+ SRC_URI="";;
+*)
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+ SRC_URI="http://gondor.apana.org.au/~herbert/dash/files/${P}.tar.gz";;
+esac
+
+inherit eutils flag-o-matic toolchain-funcs
+
+DESCRIPTION="Descendant of the NetBSD ash. Vanilla, without the gentoo XSI cripple patches"
HOMEPAGE="http://gondor.apana.org.au/~herbert/dash/"
-SRC_URI=""
-
-PROPERTIES="live"
LICENSE="BSD"
SLOT="0"
-KEYWORDS=""
IUSE="libedit static"
RDEPEND="!static? ( libedit? ( dev-libs/libedit ) )"
diff --git a/app-shells/dash/metadata.xml b/app-shells/dash/metadata.xml
index 1a2794fa..fbb0e9c7 100644
--- a/app-shells/dash/metadata.xml
+++ b/app-shells/dash/metadata.xml
@@ -10,10 +10,6 @@
<email>base-system@gentoo.org</email>
<name>Gentoo Base System</name>
</maintainer>
- <maintainer type="project">
- <email>base-system@gentoo.org</email>
- <name>Gentoo Base System</name>
- </maintainer>
<upstream>
<remote-id type="cpe">cpe:/a:dash:dash</remote-id>
</upstream>