summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2013-10-18 22:40:33 +0200
committerMartin Väth <martin@mvath.de>2015-10-11 10:48:59 +0200
commit2013b6b4cf1cf0cb907dc902068d5a24d6081f03 (patch)
tree6281f57d48396b27d570a5307c033fd7dd05a1e3
parentBump firewall-mv (diff)
downloadmv-2013b6b4cf1cf0cb907dc902068d5a24d6081f03.tar.gz
mv-2013b6b4cf1cf0cb907dc902068d5a24d6081f03.tar.bz2
mv-2013b6b4cf1cf0cb907dc902068d5a24d6081f03.zip
Add pqiv[gtk2]. Bump noscript
-rw-r--r--media-gfx/pqiv/ChangeLog8
-rw-r--r--media-gfx/pqiv/Manifest1
-rw-r--r--media-gfx/pqiv/files/pqiv-2.0-ldflags.patch11
-rw-r--r--media-gfx/pqiv/metadata.xml14
-rw-r--r--media-gfx/pqiv/pqiv-2.0.ebuild50
-rw-r--r--profiles/use.local.desc1
-rw-r--r--www-plugins/noscript/ChangeLog5
-rw-r--r--www-plugins/noscript/Manifest2
-rw-r--r--www-plugins/noscript/noscript-2.6.8.3.ebuild (renamed from www-plugins/noscript/noscript-2.6.8.2.ebuild)0
9 files changed, 91 insertions, 1 deletions
diff --git a/media-gfx/pqiv/ChangeLog b/media-gfx/pqiv/ChangeLog
new file mode 100644
index 00000000..7ea570bb
--- /dev/null
+++ b/media-gfx/pqiv/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for media-gfx/pqiv
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/pqiv/ChangeLog,v 1.37 2013/09/08 05:09:05 radhermit Exp $
+
+*pqiv-2.0 (18 Oct 2013)
+
+ 18 Oct 2013; Martin Väth <martin@mvath.de>:
+ Bump from tree to allow optional gtk:2 dependency. Remove previous history.
diff --git a/media-gfx/pqiv/Manifest b/media-gfx/pqiv/Manifest
new file mode 100644
index 00000000..30ccc027
--- /dev/null
+++ b/media-gfx/pqiv/Manifest
@@ -0,0 +1 @@
+DIST pqiv-2.0.tar.gz 39749 SHA256 6e1cd46df9b398b7d27d9f6179475cd7f525b6db44f5d72d8607746ae0ce35c0 SHA512 810022f8a8c4e07371b99a81b4cf179e33dadaed7bf124b85b3808e2a404514308161ac2b33310366db2cebb49436ac9847560239e04c9f5f2f4158e9d84353c WHIRLPOOL 056f011477e6ad36c2a7848d3d9b25f64b10691919df427a7da839c941923bd744f4786750cb96d8bdd9dedce99becb09db462fe041ecce62b1580b8b1bf4d51
diff --git a/media-gfx/pqiv/files/pqiv-2.0-ldflags.patch b/media-gfx/pqiv/files/pqiv-2.0-ldflags.patch
new file mode 100644
index 00000000..a141e53b
--- /dev/null
+++ b/media-gfx/pqiv/files/pqiv-2.0-ldflags.patch
@@ -0,0 +1,11 @@
+--- pqiv-2.0/Makefile.orig
++++ pqiv-2.0/Makefile
+@@ -28,7 +28,7 @@
+ endif
+
+ pqiv$(EXECUTABLE_EXTENSION): pqiv.c lib/strnatcmp.o
+- $(CROSS)$(CC) $(PQIV_WARNING_FLAGS) -std=gnu99 -o $@ `$(CROSS)pkg-config --cflags $(LIBS)` $+ `$(CROSS)pkg-config --libs $(LIBS)` $(CFLAGS)
++ $(CROSS)$(CC) $(PQIV_WARNING_FLAGS) -std=gnu99 -o $@ `$(CROSS)pkg-config --cflags $(LIBS)` $+ `$(CROSS)pkg-config --libs $(LIBS)` $(CFLAGS) $(LDFLAGS)
+
+ lib/strnatcmp.o: lib/strnatcmp.c
+ $(CROSS)$(CC) -c -o $@ $+ $(CFLAGS)
diff --git a/media-gfx/pqiv/metadata.xml b/media-gfx/pqiv/metadata.xml
new file mode 100644
index 00000000..1dadc3ec
--- /dev/null
+++ b/media-gfx/pqiv/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>graphics</herd>
+ <upstream>
+ <maintainer>
+ <email>phillip.berndt@googlemail.com</email>
+ <name>Phillip Berndt</name>
+ </maintainer>
+ </upstream>
+ <use>
+ <flag name="gtk2">Use gtk:2 instead of gtk:3</flag>
+ </use>
+</pkgmetadata>
diff --git a/media-gfx/pqiv/pqiv-2.0.ebuild b/media-gfx/pqiv/pqiv-2.0.ebuild
new file mode 100644
index 00000000..5f3220bf
--- /dev/null
+++ b/media-gfx/pqiv/pqiv-2.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+inherit linux-info toolchain-funcs eutils
+
+DESCRIPTION="Modern rewrite of Quick Image Viewer"
+HOMEPAGE="http://github.com/phillipberndt/pqiv http://www.pberndt.com/Programme/Linux/pqiv/"
+SRC_URI="https://github.com/phillipberndt/pqiv/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gtk2 kernel_linux"
+
+RDEPEND="dev-libs/glib:2
+ x11-libs/cairo
+ gtk2? ( x11-libs/gtk+:2 )
+ !gtk2? ( x11-libs/gtk+:3 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+pkg_setup() {
+ if use kernel_linux; then
+ CONFIG_CHECK="~INOTIFY_USER"
+ linux-info_pkg_setup
+ fi
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-ldflags.patch
+ epatch_user
+}
+
+src_configure() {
+ local gtkver=3
+ ! use gtk2 || gtkver=2
+ ./configure --gtk-version=${gtkver} --prefix=/usr --destdir="${D}" || die
+}
+
+src_compile() {
+ tc-export CC
+ emake CFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ default
+ dodoc README.markdown
+}
diff --git a/profiles/use.local.desc b/profiles/use.local.desc
index dc37e6dd..fed9d6de 100644
--- a/profiles/use.local.desc
+++ b/profiles/use.local.desc
@@ -67,6 +67,7 @@ games-rpg/magus:konqueror - Depend on konqueror browser instead of firefox
games-rpg/magus:pngcrush - Use pngcrush for opimizing png before installation
games-rpg/magus:postgres - Use postgresql instead of sqlite
games-rpg/magus:seamonkey - Depend on seamonkey browser instead of firefox
+media-gfx/pqiv:gtk2 - Use gtk:2 instead of gtk:3
net-misc/sshstart:keychain - Pull in keychain as dependency. Not required, but recommended for smoother operation.
sys-apps/less:less-select - Add the less-select feature (additional options and a binary helper).
sys-apps/less:lesspipe - Use sys-apps/lesspipe instead of Gentoo's default lesspipe.sh.
diff --git a/www-plugins/noscript/ChangeLog b/www-plugins/noscript/ChangeLog
index a648f8ac..b19c8a21 100644
--- a/www-plugins/noscript/ChangeLog
+++ b/www-plugins/noscript/ChangeLog
@@ -2,6 +2,11 @@
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+*noscript-2.3.2 (16 Oct 2013)
+
+ 16 Oct 2013; Martin Väth <martin@mvath.de>:
+ Version bump, remove old ebuild.
+
*noscript-2.8.2 (03 Oct 2013)
03 Oct 2013; Martin Väth <martin@mvath.de>:
diff --git a/www-plugins/noscript/Manifest b/www-plugins/noscript/Manifest
index 5092ea9e..7430febd 100644
--- a/www-plugins/noscript/Manifest
+++ b/www-plugins/noscript/Manifest
@@ -1 +1 @@
-DIST noscript-2.6.8.2.xpi 534789 SHA256 52b309f2e5ca1bee4d0f97cbb342fdac3be6a447c35f744a90348df55eea635f SHA512 15d6a26c242f8d0480b91b8ac8c676bb94f670f1fdb4a259d9e54378051fd3ea12998051065a14e90eb412d247cf3732c73b666aed2de2ce77dc436f18480cf1 WHIRLPOOL 8f7a4b8f43cb2ae4a718f7347f445f17cf9655070159f9390db4d43f87206902969928ba875601b0bd6668e0b40b7477ee175fc94bde4206766cc52d19ca4704
+DIST noscript-2.6.8.3.xpi 534870 SHA256 979968f5d0980032e0c8077ad6c5c4db93d1ad1a3e24ea73edd6227c44362679 SHA512 99453e56b4031ebb0ba61775252a0f9c35a9069fba8b0adf62c3d6342cbf2c2ccbea12f6e23be4b11c57edb995e2fd5e636cec0cf66efc015c73dea949f1e8a9 WHIRLPOOL c1ee95fe9e9b82eab401b9957fab3711166a4619b19b562264c168897e964e3583facc48c3ae465fd79fd8a7b572b8da94fb03ecd93d53c6da847216bc2d44e6
diff --git a/www-plugins/noscript/noscript-2.6.8.2.ebuild b/www-plugins/noscript/noscript-2.6.8.3.ebuild
index 64528ac0..64528ac0 100644
--- a/www-plugins/noscript/noscript-2.6.8.2.ebuild
+++ b/www-plugins/noscript/noscript-2.6.8.3.ebuild