summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2014-09-21 14:57:53 +0200
committerMartin Väth <martin@mvath.de>2015-10-11 10:49:18 +0200
commit297b65014e9125e37d539f47c6d959506f383a45 (patch)
tree5331f1fbdfe229c5085d6bf43f67ac494d381b32
parentBump emount, mv_perl (diff)
downloadmv-297b65014e9125e37d539f47c6d959506f383a45.tar.gz
mv-297b65014e9125e37d539f47c6d959506f383a45.tar.bz2
mv-297b65014e9125e37d539f47c6d959506f383a45.zip
Add File-lchown, ExtUtils-CChecker. Udate mv_perl. Fix lesspipe
-rw-r--r--dev-perl/ExtUtils-CChecker/ChangeLog10
-rw-r--r--dev-perl/ExtUtils-CChecker/ExtUtils-CChecker-0.90.0.ebuild35
-rw-r--r--dev-perl/ExtUtils-CChecker/Manifest1
-rw-r--r--dev-perl/ExtUtils-CChecker/metadata.xml9
-rw-r--r--dev-perl/File-lchown/ChangeLog8
-rw-r--r--dev-perl/File-lchown/File-lchown-0.20.ebuild22
-rw-r--r--dev-perl/File-lchown/Manifest1
-rw-r--r--dev-util/mv_perl/ChangeLog5
-rw-r--r--dev-util/mv_perl/Manifest2
-rw-r--r--dev-util/mv_perl/mv_perl-2.41.ebuild (renamed from dev-util/mv_perl/mv_perl-2.40.ebuild)4
-rw-r--r--sys-apps/lesspipe/ChangeLog5
-rw-r--r--sys-apps/lesspipe/lesspipe-1.82.ebuild1
12 files changed, 101 insertions, 2 deletions
diff --git a/dev-perl/ExtUtils-CChecker/ChangeLog b/dev-perl/ExtUtils-CChecker/ChangeLog
new file mode 100644
index 00000000..df3c2540
--- /dev/null
+++ b/dev-perl/ExtUtils-CChecker/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-perl/ExtUtils-CChecker
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*ExtUtils-CChecker-0.90.0 (21 Sep 2014)
+
+ 21 Sep 2014; Martin Väth <martin@mvath.de>:
+ Copy from perl-experimental overlay to satisfy dev-perl/File-lchown.
+ Remove previous ChangeLog
+
diff --git a/dev-perl/ExtUtils-CChecker/ExtUtils-CChecker-0.90.0.ebuild b/dev-perl/ExtUtils-CChecker/ExtUtils-CChecker-0.90.0.ebuild
new file mode 100644
index 00000000..5ef90e9d
--- /dev/null
+++ b/dev-perl/ExtUtils-CChecker/ExtUtils-CChecker-0.90.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+RESTRICT="mirror"
+MODULE_AUTHOR=PEVANS
+MODULE_VERSION=0.09
+inherit perl-module
+
+DESCRIPTION='configure-time utilities for using C headers,'
+LICENSE=" || ( Artistic GPL-2 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+perl_meta_build() {
+ # Module::Build
+ echo virtual/perl-Module-Build
+ # Test::Fatal
+ echo dev-perl/Test-Fatal
+ # Test::More
+ echo virtual/perl-Test-Simple
+}
+perl_meta_runtime() {
+ # ExtUtils::CBuilder
+ echo virtual/perl-ExtUtils-CBuilder
+}
+DEPEND="
+ $(perl_meta_build)
+ $(perl_meta_runtime)
+"
+RDEPEND="
+ $(perl_meta_runtime)
+"
+SRC_TEST="do parallel"
diff --git a/dev-perl/ExtUtils-CChecker/Manifest b/dev-perl/ExtUtils-CChecker/Manifest
new file mode 100644
index 00000000..4fc72f16
--- /dev/null
+++ b/dev-perl/ExtUtils-CChecker/Manifest
@@ -0,0 +1 @@
+DIST ExtUtils-CChecker-0.09.tar.gz 21237 SHA256 ebf167e3f98b4b1ff8e7a5e98d084558b87d0b19442f5da33233ef6b2eb66ad7 SHA512 51068985b7c62af407a600dc665031966abf45775ac1e4ce97d49474af070df86622db47a1248aaa8f89e3544f4937665287162cf3f80cbc930bf56d57d8d6b3 WHIRLPOOL 827940320cf1acb1f3ea8d208fee43215227dedb5bda7ef068f32c5f64f966de55ab7e78aebd20701f5a0b704563685af8577fab535dfafd19ef5781b3d889ef
diff --git a/dev-perl/ExtUtils-CChecker/metadata.xml b/dev-perl/ExtUtils-CChecker/metadata.xml
new file mode 100644
index 00000000..d70ab9d4
--- /dev/null
+++ b/dev-perl/ExtUtils-CChecker/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>perl</herd>
+ <upstream>
+ <remote-id type="cpan">ExtUtils-CChecker</remote-id>
+ <remote-id type="cpan-module">ExtUtils::CChecker</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-perl/File-lchown/ChangeLog b/dev-perl/File-lchown/ChangeLog
new file mode 100644
index 00000000..2e6d2387
--- /dev/null
+++ b/dev-perl/File-lchown/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for dev-perl/File-lchown
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*File-lchown-0.2 (21 Sep 2014)
+
+ 21 Sep 2014; Martin Väth <martin@mvaeth.de>:
+ New ebuild from scratch
diff --git a/dev-perl/File-lchown/File-lchown-0.20.ebuild b/dev-perl/File-lchown/File-lchown-0.20.ebuild
new file mode 100644
index 00000000..7d6ea288
--- /dev/null
+++ b/dev-perl/File-lchown/File-lchown-0.20.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+RESTRICT="mirror"
+
+MODULE_AUTHOR=PEVANS
+MODULE_VERSION=0.02
+inherit perl-module
+
+DESCRIPTION="Use the lchown(2) and lutimes(2) system call from Perl"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="
+ ${RDEPEND}
+ dev-perl/ExtUtils-CChecker
+ virtual/perl-Module-Build"
diff --git a/dev-perl/File-lchown/Manifest b/dev-perl/File-lchown/Manifest
new file mode 100644
index 00000000..5d63218e
--- /dev/null
+++ b/dev-perl/File-lchown/Manifest
@@ -0,0 +1 @@
+DIST File-lchown-0.02.tar.gz 11821 SHA256 a02fbf285406a8a4d9399284f032f2d55c56975154c2e1674bd109837b8096ec SHA512 0673176423465cd18d41708977216a3785e4d6204928472499be25be3f86f376646dc2636406855ae75a0bfbce26bc36d2fbf410950febc2978b4c6d5fb99922 WHIRLPOOL 7a78c507c527b2caa667edf536f4f56d3419d00a41a3404b372ec262b4419114f31291fa0d0ec6453e937821fdc9fdbda40cfc5a3e4968c33bd18e13ee196b79
diff --git a/dev-util/mv_perl/ChangeLog b/dev-util/mv_perl/ChangeLog
index 5072208f..a30e2538 100644
--- a/dev-util/mv_perl/ChangeLog
+++ b/dev-util/mv_perl/ChangeLog
@@ -2,6 +2,11 @@
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+*mv_perl-2.41 (21 Sep 2014)
+
+ 21 Sep 2014; Martin Väth <martin@mvath.de>:
+ Version bump, remove old ebuild. Support File-lchown for lutimes
+
*mv_perl-2.40 (20 Sep 2014)
20 Sep 2014; Martin Väth <martin@mvath.de>:
diff --git a/dev-util/mv_perl/Manifest b/dev-util/mv_perl/Manifest
index 0d75dc1c..74300e04 100644
--- a/dev-util/mv_perl/Manifest
+++ b/dev-util/mv_perl/Manifest
@@ -1 +1 @@
-DIST mv_perl-v2.40.tar.gz 66291 SHA256 bd21e455a542284fc6035be7d15cbc7be60ea276826033d7b64270f961f9bfeb SHA512 52ace5364c801d5c1ee70e7476af43c67ae1b05653c1cdab3dad390d98d6d395f6fb68d14d58581a62c8f793da6b749f7c96c914f6fabdf175251747293a4cde WHIRLPOOL b6774f7e36c96269105a6203681b963615ae65326e4160a12c0da692c2c30b9b423d9cdb4d510cf870891b5f2387ea22743be26b111d0b74b3b04670e4f6be10
+DIST mv_perl-v2.41.tar.gz 66681 SHA256 75736e2470628d1a5e4273f2573c3a4fcd9fdae9921d90d1ca8ba09347c72b1d SHA512 e85c2b0f430cb1c2a4e9ca1ea1fe4847609d614676729163ac1d235991db1594197476f2479a5e6c2f270d263b415b7b60ea38d35fd8de361b2e7e2b3e9eabee WHIRLPOOL 51eecd66dde435d9ccc5099eab774963cd7d960af7d768906cbb20b60bc2059b127cd9657959ccd1694f903e5fe371cbc27ff4286958300a91f6b591b4146974
diff --git a/dev-util/mv_perl/mv_perl-2.40.ebuild b/dev-util/mv_perl/mv_perl-2.41.ebuild
index c8f9234e..6823664e 100644
--- a/dev-util/mv_perl/mv_perl-2.40.ebuild
+++ b/dev-util/mv_perl/mv_perl-2.41.ebuild
@@ -31,3 +31,7 @@ src_install() {
insinto /usr/share/zsh/site-functions
doins zsh/_*
}
+
+pkg_postinst() {
+ optfeature "support to set timestamps of symlinks" 'dev-perl/File-lchown'
+}
diff --git a/sys-apps/lesspipe/ChangeLog b/sys-apps/lesspipe/ChangeLog
index 8dcae8a8..2118f928 100644
--- a/sys-apps/lesspipe/ChangeLog
+++ b/sys-apps/lesspipe/ChangeLog
@@ -4,8 +4,11 @@
*lsespipe-1.82 (24 Dec 2013)
+ 21 Sep 2014; Martin Väth <martin@mvath.de>:
+ Add RESTRICT=mirror
+
24 Dec 2013; Martin Väth <martin@mvath.de>:
- Version bump, remove old ebuild.
+ Version bump, remove old ebuild
*lesspipe-1.72 (11 Nov 2012)
diff --git a/sys-apps/lesspipe/lesspipe-1.82.ebuild b/sys-apps/lesspipe/lesspipe-1.82.ebuild
index 92fdc042..7e16ba44 100644
--- a/sys-apps/lesspipe/lesspipe-1.82.ebuild
+++ b/sys-apps/lesspipe/lesspipe-1.82.ebuild
@@ -3,6 +3,7 @@
# $Header: $
EAPI=5
+RESTRICT="mirror"
inherit eutils