summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2018-01-27 11:27:46 +0100
committerMartin Väth <martin@mvath.de>2018-01-27 11:27:46 +0100
commit36220746e1288fb50feeda90558016914527824a (patch)
tree6dcdb64fff22f1917e583bb8aaf519e3a2987ec6
parentapp-portage/portage-bashrc-mv: Version bump (diff)
downloadmv-36220746e1288fb50feeda90558016914527824a.tar.gz
mv-36220746e1288fb50feeda90558016914527824a.tar.bz2
mv-36220746e1288fb50feeda90558016914527824a.zip
app-portage/eix: Alpha version bump. Enable available spectre mitigation
-rw-r--r--app-portage/eix/Manifest1
-rw-r--r--app-portage/eix/eix-0.33.2_alpha20180127.ebuild154
-rw-r--r--app-portage/eix/eix-99999999.ebuild4
-rw-r--r--metadata/pkg_desc_index2
4 files changed, 158 insertions, 3 deletions
diff --git a/app-portage/eix/Manifest b/app-portage/eix/Manifest
index 72a4d9f9..ebcd803b 100644
--- a/app-portage/eix/Manifest
+++ b/app-portage/eix/Manifest
@@ -1 +1,2 @@
DIST eix-0.33.1.tar.xz 614564 SHA512 1b68e39f5acfd90c6c4a45783060cb6896f819f57f42546ed386d38850ec99c208bc3db0f98e88b8086815c9e67c47cd8505f92f79c0cdd019e0337f442f1e1c
+DIST eix-0.33.2_alpha20180127.tar.gz 673009 SHA512 6264a2e771bd5ec25c63308df3f593cc116e9df81b9b0f760eab4f561af9809a37ad8335d473a15ecd961fe83108266ab829210de47b6d38a153bcb0b1159f82
diff --git a/app-portage/eix/eix-0.33.2_alpha20180127.ebuild b/app-portage/eix/eix-0.33.2_alpha20180127.ebuild
new file mode 100644
index 00000000..ebf12079
--- /dev/null
+++ b/app-portage/eix/eix-0.33.2_alpha20180127.ebuild
@@ -0,0 +1,154 @@
+# Copyright 2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+WANT_LIBTOOL=none
+AUTOTOOLS_AUTO_DEPEND=no
+MESON_AUTO_DEPEND=no
+inherit autotools bash-completion-r1 meson tmpfiles toolchain-funcs
+
+case ${PV} in
+99999999*)
+ EGIT_REPO_URI="https://github.com/vaeth/${PN}.git"
+ inherit git-r3
+ SRC_URI=""
+ PROPERTIES="live";;
+*)
+ RESTRICT="mirror"
+ EGIT_COMMIT="e72ba76919f9bbe2a6c5e097436c035d35c54fa8"
+ SRC_URI="https://github.com/vaeth/${PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}-${EGIT_COMMIT}";;
+esac
+
+DESCRIPTION="Search and query ebuilds"
+HOMEPAGE="https://github.com/vaeth/eix/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+PLOCALES="de ru"
+IUSE="debug +dep doc"
+for i in ${PLOCALES}; do
+ IUSE+=" l10n_${i}"
+done
+IUSE+=" +meson nls optimization +required-use security strong-optimization strong-security sqlite swap-remote tools"
+
+BOTHDEPEND="nls? ( virtual/libintl )
+ sqlite? ( >=dev-db/sqlite-3:= )"
+RDEPEND="${BOTHDEPEND}
+ >=app-shells/push-2.0-r2
+ >=app-shells/quoter-3.0-r2"
+DEPEND="${BOTHDEPEND}
+ meson? (
+ >=dev-util/meson-0.41.0
+ >=dev-util/ninja-1.7.2
+ strong-optimization? ( >=sys-devel/gcc-config-1.9.1 )
+ )
+ !meson? ( ${AUTOTOOLS_DEPEND} )
+ >=sys-devel/gettext-0.19.6"
+
+pkg_setup() {
+ # remove stale cache file to prevent collisions
+ local old_cache="${EROOT}var/cache/${PN}"
+ test -f "${old_cache}" && rm -f -- "${old_cache}"
+}
+
+src_prepare() {
+ sed -i -e "s'/'${EPREFIX}/'" -- "${S}"/tmpfiles.d/eix.conf || die
+ default
+ use meson || {
+ eautopoint
+ eautoreconf
+ }
+}
+
+src_configure() {
+ local i
+ export LINGUAS=
+ for i in ${PLOCALES}; do
+ use l10n_${i} && LINGUAS+=${LINGUAS:+ }${i}
+ done
+ if use meson; then
+ local emesonargs=(
+ -Ddocdir="${EPREFIX}/usr/share/doc/${P}"
+ -Dhtmldir="${EPREFIX}/usr/share/doc/${P}/html"
+ $(meson_use sqlite)
+ $(meson_use doc extra-doc)
+ $(meson_use nls)
+ $(meson_use tools separate-tools)
+ $(meson_use security)
+ $(meson_use optimization)
+ $(meson_use strong-security)
+ $(meson_use strong-optimization)
+ $(meson_use debug debugging)
+ $(meson_use swap-remote)
+ $(meson_use prefix always-accept-keywords)
+ $(meson_use dep dep-default)
+ $(meson_use required-use required-use-default)
+ -Dzsh-completion="${EPREFIX}/usr/share/zsh/site-functions"
+ -Dportage-rootpath="${ROOTPATH}"
+ -Deprefix-default="${EPREFIX}"
+ )
+ meson_src_configure
+ else
+ local myconf=(
+ $(use_with sqlite)
+ $(use_with doc extra-doc)
+ $(use_enable nls)
+ $(use_enable tools separate-tools)
+ $(use_enable security)
+ $(use_enable optimization)
+ $(use_enable strong-security)
+ $(use_enable strong-optimization)
+ $(use_enable debug debugging)
+ $(use_enable swap-remote)
+ $(use_with prefix always-accept-keywords)
+ $(use_with dep dep-default)
+ $(use_with required-use required-use-default)
+ --with-zsh-completion
+ --with-portage-rootpath="${ROOTPATH}"
+ --with-eprefix-default="${EPREFIX}"
+ )
+ econf "${myconf[@]}"
+ fi
+}
+
+src_compile() {
+ if use meson; then
+ meson_src_compile
+ else
+ default
+ fi
+}
+
+src_test() {
+ if use meson; then
+ meson_src_test
+ else
+ default
+ fi
+}
+
+src_install() {
+ if use meson; then
+ meson_src_install
+ else
+ default
+ fi
+ dobashcomp bash/eix
+ dotmpfiles tmpfiles.d/eix.conf
+}
+
+pkg_postinst() {
+ local obs="${EROOT}var/cache/eix.previous"
+ if test -f "${obs}"; then
+ ewarn "Found obsolete ${obs}, please remove it"
+ fi
+ tmpfiles_process eix.conf
+}
+
+pkg_postrm() {
+ if [ -z "${REPLACED_BY_VERSION}" ]; then
+ rm -rf -- "${EROOT}var/cache/${PN}"
+ fi
+}
diff --git a/app-portage/eix/eix-99999999.ebuild b/app-portage/eix/eix-99999999.ebuild
index 619ec51b..ebf12079 100644
--- a/app-portage/eix/eix-99999999.ebuild
+++ b/app-portage/eix/eix-99999999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2017 Gentoo Foundation
+# Copyright 2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -15,7 +15,7 @@ case ${PV} in
PROPERTIES="live";;
*)
RESTRICT="mirror"
- EGIT_COMMIT="5d71a314c881828fa5f7429bfc6d95f2558e326e"
+ EGIT_COMMIT="e72ba76919f9bbe2a6c5e097436c035d35c54fa8"
SRC_URI="https://github.com/vaeth/${PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
S="${WORKDIR}/${PN}-${EGIT_COMMIT}";;
esac
diff --git a/metadata/pkg_desc_index b/metadata/pkg_desc_index
index 7625b888..30ece65c 100644
--- a/metadata/pkg_desc_index
+++ b/metadata/pkg_desc_index
@@ -22,7 +22,7 @@ app-emacs/mv_emacs 1.3: (X)Emacs extensions: block support, macrorecorder, verif
app-eselect/eselect-net 0.2: eselect module for managing network open-rc service configurations
app-misc/knapsack 7.2.1: A fast solver for the 0/1-knapsack problem with multiple knapsacks
app-misc/machine-learning-mv 1.2: Some machine learning experiments
-app-portage/eix 0.33.1 99999999: Search and query ebuilds
+app-portage/eix 0.33.1 0.33.2_alpha20180127 99999999: Search and query ebuilds
app-portage/etcat 1.0.1 99999999: Updated version of an old Portage information extractor
app-portage/find_cruft 5: find cruft files not managed by portage
app-portage/gentoolkit 0.4.0-r1 9999: Collection of administration scripts for Gentoo