summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2013-04-29 21:59:14 +0200
committerMartin Väth <martin@mvath.de>2015-10-11 10:48:43 +0200
commit3fc772847d87c924ca5dc4bc382d2d144949ff69 (patch)
treefa1fd9e0bd0520f60aea340adda064032f1bb442
parentRemove heirloom-sh since it is now in the main tree (diff)
downloadmv-3fc772847d87c924ca5dc4bc382d2d144949ff69.tar.gz
mv-3fc772847d87c924ca5dc4bc382d2d144949ff69.tar.bz2
mv-3fc772847d87c924ca5dc4bc382d2d144949ff69.zip
Bump noscript. Avoid redundent zsh link. Support EPREFIX. Simplify code
-rw-r--r--app-shells/zsh/ChangeLog3
-rw-r--r--app-shells/zsh/zsh-5.0.2-r2.ebuild5
-rw-r--r--net-print/foo2zjs/ChangeLog3
-rw-r--r--net-print/foo2zjs/foo2zjs-20081129-r1.ebuild7
-rw-r--r--www-plugins/noscript/ChangeLog5
-rw-r--r--www-plugins/noscript/Manifest2
-rw-r--r--www-plugins/noscript/noscript-2.6.6.1.ebuild (renamed from www-plugins/noscript/noscript-2.6.6.ebuild)0
7 files changed, 18 insertions, 7 deletions
diff --git a/app-shells/zsh/ChangeLog b/app-shells/zsh/ChangeLog
index 5d83b9d0..affa4778 100644
--- a/app-shells/zsh/ChangeLog
+++ b/app-shells/zsh/ChangeLog
@@ -4,6 +4,9 @@
*zsh-5.0.2-r2 (15 Apr 2013)
+ 29 Apr 2013; Martin Väth <martin@mvath.de>:
+ Honour EPREFIX. Remove redundant link of binary before installing.
+
15 Apr 2013; Martin Väth <martin@mvath.de>:
Override LC_CTYPE, using some heuristics, unless USE=custom-ctype is chosen.
diff --git a/app-shells/zsh/zsh-5.0.2-r2.ebuild b/app-shells/zsh/zsh-5.0.2-r2.ebuild
index 5111c272..b2b9b493 100644
--- a/app-shells/zsh/zsh-5.0.2-r2.ebuild
+++ b/app-shells/zsh/zsh-5.0.2-r2.ebuild
@@ -231,13 +231,14 @@ src_test() {
local i
addpredict /dev/ptmx
for i in C02cond.ztst Y01completion.ztst Y02compmatch.ztst Y03arguments.ztst ; do
- rm "${S}"/Test/${i} || die
+ rm -- "${S}"/Test/${i} || die
done
emake check
}
src_install() {
- emake DESTDIR="${D}" install install.info
+ emake DESTDIR="${ED}" install install.info
+ rm -- "${ED}/bin/${P%_*}"
if use run-help
then insinto /usr/share/zsh/site-contrib/help
diff --git a/net-print/foo2zjs/ChangeLog b/net-print/foo2zjs/ChangeLog
index a6e74f63..e9d62297 100644
--- a/net-print/foo2zjs/ChangeLog
+++ b/net-print/foo2zjs/ChangeLog
@@ -2,6 +2,9 @@
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 29 Apr 2013; Martin Väth <martin@mvath.de>:
+ Simplify for EAPI=5
+
02 Jan 2013; Martin Väth <martin@mvath.de>:
Depend only on virtual/udev
diff --git a/net-print/foo2zjs/foo2zjs-20081129-r1.ebuild b/net-print/foo2zjs/foo2zjs-20081129-r1.ebuild
index d2f57b82..6c0abb4e 100644
--- a/net-print/foo2zjs/foo2zjs-20081129-r1.ebuild
+++ b/net-print/foo2zjs/foo2zjs-20081129-r1.ebuild
@@ -99,7 +99,7 @@ src_unpack() {
}
src_compile() {
- emake getweb || die "Failed building getweb script"
+ emake getweb
# remove wget as we got the firmware with portage
sed -i -e "s/.*wget .*//" \
@@ -116,7 +116,7 @@ src_compile() {
done
if [ ${GOT} == 0 ]; then ./getweb all; fi
- emake || die "emake failed"
+ emake
}
src_install() {
@@ -124,6 +124,5 @@ src_install() {
use cups && dodir /usr/share/cups/model
- emake DESTDIR="${D}" install install-udev \
- || die "emake install failed"
+ emake DESTDIR="${ED}" install install-udev
}
diff --git a/www-plugins/noscript/ChangeLog b/www-plugins/noscript/ChangeLog
index 2a1a95d2..0dea550e 100644
--- a/www-plugins/noscript/ChangeLog
+++ b/www-plugins/noscript/ChangeLog
@@ -2,6 +2,11 @@
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+*noscript-2.6.6.1 (29 Apr 2013)
+
+ 29 Apr 2013; Martin Väth <martin@mvath.de>:
+ Version bump, remove old ebuild.
+
*noscript-2.6.6 (07 Apr 2013)
07 Apr 2013; Martin Väth <martin@mvath.de>:
diff --git a/www-plugins/noscript/Manifest b/www-plugins/noscript/Manifest
index 507d5bdd..e4d4c7b3 100644
--- a/www-plugins/noscript/Manifest
+++ b/www-plugins/noscript/Manifest
@@ -1 +1 @@
-DIST noscript-2.6.6.xpi 532430 SHA256 435b457e9fd76400b0e81715c4deab0e35878c90cee20b9921482b79d286583c SHA512 cdc2a713b86034a93a6cede899fe1eb4c19360483f4872fd0315b4cf0eda032c77ed92e97b9cb37b236dbefde05225d1a9bf4efcf31183d5548bd7afe90fff8f WHIRLPOOL 8c33528d5d018b699fe7cba7105e2efa4f2e7593dba4eb3810f8eced263d03be22fde1b96b4d080c7c9e660e1916663b5cde38e9745720041341e89fad33ce2e
+DIST noscript-2.6.6.1.xpi 534214 SHA256 ad6067cd52baf53e9e0e7274c48600a30513921299a224976c9c43a4019e8765 SHA512 e50d404f6fe3c19ce5e37a48504892f9cc3fd864d3ba409ae35ec1a63adf4ed38c9eb431ef3a342289021411592fe97641da591d90f5a6a5742fed4fafe63c7b WHIRLPOOL 36dcbe8f446dac24e40ba33217a10e60ada7ced3a5fa9de46199f9fc6d121a61143bde57d65d2e43138a6eb3007564e3297a2cb17d715a9279fdfca5726c1ca2
diff --git a/www-plugins/noscript/noscript-2.6.6.ebuild b/www-plugins/noscript/noscript-2.6.6.1.ebuild
index 64528ac0..64528ac0 100644
--- a/www-plugins/noscript/noscript-2.6.6.ebuild
+++ b/www-plugins/noscript/noscript-2.6.6.1.ebuild