summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2016-01-05 00:09:09 +0100
committerMartin Väth <martin@mvath.de>2016-01-05 00:09:09 +0100
commit402917e510cd8bb168406dfcf33839b1a68808eb (patch)
tree7dc34f24be5d85e34feba379ce254b1722caaea2
parentgames-rpg/m5figur-mv: Version bump (diff)
downloadmv-402917e510cd8bb168406dfcf33839b1a68808eb.tar.gz
mv-402917e510cd8bb168406dfcf33839b1a68808eb.tar.bz2
mv-402917e510cd8bb168406dfcf33839b1a68808eb.zip
x11-themes/fvwm-crystal: Honour upstream suggestion, see gentoo bug 499644
-rw-r--r--profiles/use.local.desc3
-rw-r--r--x11-themes/fvwm-crystal/fvwm-crystal-3.4.0.ebuild53
-rw-r--r--x11-themes/fvwm-crystal/fvwm-crystal-99999999.ebuild83
-rw-r--r--x11-themes/fvwm-crystal/metadata.xml5
4 files changed, 127 insertions, 17 deletions
diff --git a/profiles/use.local.desc b/profiles/use.local.desc
index 9c41a9e0..5616991f 100644
--- a/profiles/use.local.desc
+++ b/profiles/use.local.desc
@@ -121,3 +121,6 @@ x11-drivers/nvidia-drivers:kernel3-14 - Install unofficial patches for linux-3.1
x11-drivers/nvidia-drivers:kernel3-17 - Install unofficial patches for linux-3.17 and newer
x11-drivers/nvidia-drivers:pax_kernel - Patch to compile with hardened-sources/grsecurity
x11-drivers/nvidia-drivers:tools - Install additional tools such as nvidia-settings
+x11-themes/fvwm-crystal:amixer - Enable alsamixer support (alsa-sound/alsa-utils)
+x11-themes/fvwm-crystal:pm-utils - Enable support for suspend/resume the system through sys-power/pm-utils
+x11-themes/fvwm-crystal:xdg - Enable xdg localized user directrories support via x11-misc/xdg-user-dirs
diff --git a/x11-themes/fvwm-crystal/fvwm-crystal-3.4.0.ebuild b/x11-themes/fvwm-crystal/fvwm-crystal-3.4.0.ebuild
index 01ca3213..b2a59f3c 100644
--- a/x11-themes/fvwm-crystal/fvwm-crystal-3.4.0.ebuild
+++ b/x11-themes/fvwm-crystal/fvwm-crystal-3.4.0.ebuild
@@ -6,27 +6,43 @@ EAPI=6
RESTRICT=mirror
PYTHON_COMPAT=( python2_7 )
-inherit eutils readme.gentoo-r1 python-r1
+inherit eutils readme.gentoo-r1 python-r1 user
DESCRIPTION="Configurable FVWM theme with transparency and freedesktop compatible menu"
-HOMEPAGE="http://fvwm-crystal.sourceforge.net/"
+HOMEPAGE="http://fvwm-crystal.org/"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-LICENSE="GPL-2"
+LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
-IUSE=""
+IUSE="+amixer jack +pm-utils +xdg"
+
+case ${PV} in
+*9999)
+ PROPERTIES="live"
+ inherit subversion
+ ESVN_REPO_URI="svn://svn.code.sf.net/p/fvwm-crystal/code"
+ SRC_URI=""
+ KEYWORDS=""
+ S="${WORKDIR}/${PN}"
+ src_unpack() {
+ subversion_src_unpack
+};;
+esac
RDEPEND="${PYTHON_DEPS}
- x11-misc/xdg-user-dirs
- >=x11-wm/fvwm-2.6.5[png]
+ >=x11-wm/fvwm-2.5.26[png]
|| ( media-gfx/imagemagick media-gfx/graphicsmagick[imagemagick] )
|| ( >=x11-misc/stalonetray-0.6.2-r2 x11-misc/trayer )
|| ( x11-misc/hsetroot media-gfx/feh )
sys-apps/sed
sys-devel/bc
virtual/awk
- x11-apps/xwd"
+ x11-apps/xwd
+ xdg? ( x11-misc/xdg-user-dirs )
+ pm-utils? ( sys-power/pm-utils )
+ amixer? ( media-sound/alsa-utils )
+ jack? ( media-sound/jack-audio-connection-kit )"
DISABLE_AUTOFORMATTING="true"
DOC_CONTENTS="After installation, execute the following commands:
@@ -36,19 +52,22 @@ DOC_CONTENTS="After installation, execute the following commands:
Many applications can extend functionality of fvwm-crystal.
They are listed in "${EROOT}"usr/share/doc/"${PF}"/INSTALL.*
-Some icons fixes were committed recently.
-To achieve the same fixes on your private icon files,
-please read "${EROOT}"usr/share/doc/"${PF}"/INSTALL.*
-This will fix the libpng warnings at stderr.
+To be able to use the exit menu, each user using ${PN}
+must be in the group fvwm-crystal.
+You can do that as root with:
+ useradd -G fvwm-crystal <user_name>
+and log out and in again.
+"
-The color themes was updated to Fvwm InfoStore.
-To know how to update your custom color themes, please run
- "${EROOT}"usr/share/"${PN}"/addons/convert_colorsets"
+pkg_setup() {
+ enewgroup fvwm-crystal
+}
src_install() {
- emake DESTDIR="${ED}" \
- docdir="${EPREFIX%/}/usr/share/doc/${PF}" \
- prefix="${EPREFIX%/}/usr" \
+ emake \
+ DESTDIR="${ED}" \
+ docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ prefix="${EPREFIX}/usr" \
install
# GNU License is globally in the portage tree
rm -vf "${ED}/usr/share/doc/${PF}"/LICENSE
diff --git a/x11-themes/fvwm-crystal/fvwm-crystal-99999999.ebuild b/x11-themes/fvwm-crystal/fvwm-crystal-99999999.ebuild
new file mode 100644
index 00000000..b2a59f3c
--- /dev/null
+++ b/x11-themes/fvwm-crystal/fvwm-crystal-99999999.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+RESTRICT=mirror
+
+PYTHON_COMPAT=( python2_7 )
+inherit eutils readme.gentoo-r1 python-r1 user
+
+DESCRIPTION="Configurable FVWM theme with transparency and freedesktop compatible menu"
+HOMEPAGE="http://fvwm-crystal.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="+amixer jack +pm-utils +xdg"
+
+case ${PV} in
+*9999)
+ PROPERTIES="live"
+ inherit subversion
+ ESVN_REPO_URI="svn://svn.code.sf.net/p/fvwm-crystal/code"
+ SRC_URI=""
+ KEYWORDS=""
+ S="${WORKDIR}/${PN}"
+ src_unpack() {
+ subversion_src_unpack
+};;
+esac
+
+RDEPEND="${PYTHON_DEPS}
+ >=x11-wm/fvwm-2.5.26[png]
+ || ( media-gfx/imagemagick media-gfx/graphicsmagick[imagemagick] )
+ || ( >=x11-misc/stalonetray-0.6.2-r2 x11-misc/trayer )
+ || ( x11-misc/hsetroot media-gfx/feh )
+ sys-apps/sed
+ sys-devel/bc
+ virtual/awk
+ x11-apps/xwd
+ xdg? ( x11-misc/xdg-user-dirs )
+ pm-utils? ( sys-power/pm-utils )
+ amixer? ( media-sound/alsa-utils )
+ jack? ( media-sound/jack-audio-connection-kit )"
+
+DISABLE_AUTOFORMATTING="true"
+DOC_CONTENTS="After installation, execute the following commands:
+\ \$ cp -r "${EROOT}"usr/share/doc/"${PF}"/addons/Xresources ~/.Xresources
+\ \$ cp -r "${EROOT}"usr/share/doc/"${PF}"/addons/Xsession ~/.xinitrc
+
+Many applications can extend functionality of fvwm-crystal.
+They are listed in "${EROOT}"usr/share/doc/"${PF}"/INSTALL.*
+
+To be able to use the exit menu, each user using ${PN}
+must be in the group fvwm-crystal.
+You can do that as root with:
+ useradd -G fvwm-crystal <user_name>
+and log out and in again.
+"
+
+pkg_setup() {
+ enewgroup fvwm-crystal
+}
+
+src_install() {
+ emake \
+ DESTDIR="${ED}" \
+ docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ prefix="${EPREFIX}/usr" \
+ install
+ # GNU License is globally in the portage tree
+ rm -vf "${ED}/usr/share/doc/${PF}"/LICENSE
+
+ python_replicate_script \
+ "${ED}/usr/bin/${PN}".{apps,wallpaper} \
+ "${ED}/usr/share/${PN}"/fvwm/scripts/FvwmMPD/*.py
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}
diff --git a/x11-themes/fvwm-crystal/metadata.xml b/x11-themes/fvwm-crystal/metadata.xml
index 5f357c6b..9bee3e57 100644
--- a/x11-themes/fvwm-crystal/metadata.xml
+++ b/x11-themes/fvwm-crystal/metadata.xml
@@ -18,4 +18,9 @@ with additional programs and scripts. Some of it's features are:
desktop pages
* transparent window titlebars, menus and panels on the desktop
</longdescription>
+<use>
+ <flag name="xdg">Enable xdg localized user directrories support via x11-misc/xdg-user-dirs</flag>
+ <flag name="amixer">Enable alsamixer support (alsa-sound/alsa-utils)</flag>
+ <flag name="pm-utils">Enable support for suspend/resume the system through sys-power/pm-utils</flag>
+</use>
</pkgmetadata>