summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2013-10-12 21:12:31 +0200
committerMartin Väth <martin@mvath.de>2015-10-11 10:48:59 +0200
commit5d21146b66819048d79903a55a151e52fc64749c (patch)
tree8f7da4a59d3c1d8a91d1f9f194285e38e81fd29d
parentBump firewall-mv (diff)
downloadmv-5d21146b66819048d79903a55a151e52fc64749c.tar.gz
mv-5d21146b66819048d79903a55a151e52fc64749c.tar.bz2
mv-5d21146b66819048d79903a55a151e52fc64749c.zip
Add fvwm-crystal. Use readme.gentoo.eclass
-rw-r--r--app-portage/getdelta/ChangeLog3
-rw-r--r--app-portage/getdelta/getdelta-0.7.9-r2.ebuild13
-rw-r--r--app-shells/oh-my-zsh/ChangeLog3
-rw-r--r--app-shells/oh-my-zsh/oh-my-zsh-99999999.ebuild16
-rw-r--r--app-shells/termcolors-mv/ChangeLog3
-rw-r--r--app-shells/termcolors-mv/termcolors-mv-3.0.ebuild23
-rw-r--r--app-shells/zsh-syntax-highlighting/ChangeLog3
-rw-r--r--app-shells/zsh-syntax-highlighting/zsh-syntax-highlighting-99999999.ebuild17
-rw-r--r--app-shells/zsh/ChangeLog3
-rw-r--r--app-shells/zsh/zsh-99999999.ebuild58
-rw-r--r--media-video/video-mv/ChangeLog3
-rw-r--r--media-video/video-mv/video-mv-7.9.ebuild17
-rw-r--r--sys-block/zram-init/ChangeLog3
-rw-r--r--sys-block/zram-init/zram-init-2.6.ebuild16
-rw-r--r--sys-fs/squash_dir/ChangeLog3
-rw-r--r--sys-fs/squash_dir/squash_dir-13.3.ebuild17
-rw-r--r--sys-fs/squashmount/ChangeLog3
-rw-r--r--sys-fs/squashmount/squashmount-3.5.ebuild12
-rw-r--r--www-plugins/stylish/ChangeLog3
-rw-r--r--www-plugins/stylish/stylish-1.3.3.ebuild27
-rw-r--r--x11-themes/fvwm-crystal/ChangeLog9
-rw-r--r--x11-themes/fvwm-crystal/Manifest1
-rw-r--r--x11-themes/fvwm-crystal/fvwm-crystal-3.2.7.ebuild108
-rw-r--r--x11-themes/fvwm-crystal/metadata.xml21
24 files changed, 279 insertions, 106 deletions
diff --git a/app-portage/getdelta/ChangeLog b/app-portage/getdelta/ChangeLog
index 4c9a7665..69f97d60 100644
--- a/app-portage/getdelta/ChangeLog
+++ b/app-portage/getdelta/ChangeLog
@@ -4,6 +4,9 @@
*getdelta-0.7.9-r2 (17 Mar 2013)
+ 12 Oct 2013; Martin Väth <martin@mvath.de>:
+ Use readme.gentoo.eclass
+
17 Mar 2012; Martin Väth <martin@mvath.de>:
Bump without any change to make clear our version is newer as in main tree
diff --git a/app-portage/getdelta/getdelta-0.7.9-r2.ebuild b/app-portage/getdelta/getdelta-0.7.9-r2.ebuild
index 0df19d4d..4add265d 100644
--- a/app-portage/getdelta/getdelta-0.7.9-r2.ebuild
+++ b/app-portage/getdelta/getdelta-0.7.9-r2.ebuild
@@ -3,7 +3,7 @@
# $Header: $
EAPI=5
-inherit eutils
+inherit eutils readme.gentoo
DESCRIPTION="dynamic deltup client"
HOMEPAGE="http://linux01.gwdg.de/~nlissne/"
@@ -17,6 +17,11 @@ S="${WORKDIR}"
RDEPEND="app-portage/deltup
dev-util/bdelta"
+DISABLE_AUTOFORMATTING="true"
+DOC_CONTENTS="You need to put
+FETCHCOMMAND=\"/usr/bin/getdelta.sh \\\"\\\${URI}\\\" \\\"\\\${FILE}\\\"\"
+into your /etc/make.conf to make use of getdelta"
+
src_prepare() {
epatch "${FILESDIR}/eapi2.patch"
sed -i -e "s:/bin/sh:/bin/bash:" getdelta.sh || die
@@ -25,14 +30,11 @@ src_prepare() {
src_install() {
dobin "${WORKDIR}"/getdelta.sh
+ readme.gentoo_src_install
}
pkg_postinst() {
local a b
- elog "You need to put"
- elog "FETCHCOMMAND=\"/usr/bin/getdelta.sh \\\"\\\${URI}\\\" \\\"\\\${FILE}\\\"\""
- elog "into your /etc/make.conf to make use of getdelta"
-
# make sure permissions are ok
a="${EROOT}"/var/log/getdelta.log
b="${EROOT}"/etc/deltup
@@ -40,4 +42,5 @@ pkg_postinst() {
mkdir -p -- "${b}"
use prefix || chown -R portage:portage -- "${a}" "${b}"
chmod -R ug+rwX -- "${a}" "${b}"
+ readme.gentoo_pkg_postinst
}
diff --git a/app-shells/oh-my-zsh/ChangeLog b/app-shells/oh-my-zsh/ChangeLog
index bcfb2d26..042ed43b 100644
--- a/app-shells/oh-my-zsh/ChangeLog
+++ b/app-shells/oh-my-zsh/ChangeLog
@@ -2,6 +2,9 @@
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 12 Oct 2013; Martin Väth <martin@mvath.de>:
+ Use readme.gentoo.eclass
+
14 Sep 2013; Martin Väth <martin@mvath.de>:
Bump to git-r3.eclass
diff --git a/app-shells/oh-my-zsh/oh-my-zsh-99999999.ebuild b/app-shells/oh-my-zsh/oh-my-zsh-99999999.ebuild
index 4103b9e1..16db5f9b 100644
--- a/app-shells/oh-my-zsh/oh-my-zsh-99999999.ebuild
+++ b/app-shells/oh-my-zsh/oh-my-zsh-99999999.ebuild
@@ -5,7 +5,7 @@
EAPI=5
EGIT_REPO_URI="git://github.com/robbyrussell/${PN}.git"
-inherit eutils git-r3
+inherit eutils git-r3 readme.gentoo
DESCRIPTION="A ready-to-use zsh configuration with plugins"
HOMEPAGE="https://github.com/robbyrussell/oh-my-zsh"
@@ -23,6 +23,12 @@ ZSH_DEST="/usr/share/zsh/site-contrib/${PN}"
ZSH_EDEST="${EPREFIX}${ZSH_DEST}"
ZSH_TEMPLATE="templates/zshrc.zsh-template"
+DISABLE_AUTOFORMATTING="true"
+DOC_CONTENTS="In order to use ${CATEGORY}/${PN} add to your ~/.zshrc
+source '${ZSH_DEST}/${ZSH_TEMPLATE}'
+or copy a modification of that file to your ~/.zshrc
+If you just want to try, enter the above command in your zsh."
+
src_prepare() {
local i
for i in "${S}"/tools/*install* "${S}"/tools/*upgrade*
@@ -39,11 +45,5 @@ src_prepare() {
src_install() {
insinto "${ZSH_DEST}"
doins -r *
-}
-
-pkg_postinst() {
- elog "In order to use ${CATEGORY}/${PN} add to your ~/.zshrc"
- elog "source '${ZSH_DEST}/${ZSH_TEMPLATE}'"
- elog "or copy a modification of that file to your ~/.zshrc"
- elog "If you just want to try, enter the above command in your zsh."
+ readme.gentoo_src_install
}
diff --git a/app-shells/termcolors-mv/ChangeLog b/app-shells/termcolors-mv/ChangeLog
index 591b7063..4e7eb6cd 100644
--- a/app-shells/termcolors-mv/ChangeLog
+++ b/app-shells/termcolors-mv/ChangeLog
@@ -4,6 +4,9 @@
*termcolors-3.0 (07 Aug 2013)
+ 12 Oct 2013; Martin Väth <martin@mvath.de>:
+ Use readme.gentoo.eclass
+
07 Aug 2013; Martin Väth <martin@mvath.de>:
Version bump, remove old ebuild.
diff --git a/app-shells/termcolors-mv/termcolors-mv-3.0.ebuild b/app-shells/termcolors-mv/termcolors-mv-3.0.ebuild
index 73b99521..b2b91128 100644
--- a/app-shells/termcolors-mv/termcolors-mv-3.0.ebuild
+++ b/app-shells/termcolors-mv/termcolors-mv-3.0.ebuild
@@ -4,7 +4,7 @@
EAPI=5
RESTRICT="mirror"
-inherit eutils vcs-snapshot
+inherit eutils readme.gentoo vcs-snapshot
DESCRIPTION="256colors sample script and dircolors configuration for standard or 256 colors"
HOMEPAGE="https://github.com/vaeth/termcolors-mv/"
@@ -18,6 +18,13 @@ DEPEND="dev-lang/perl"
RDEPEND="create? ( dev-lang/perl )
perl? ( dev-lang/perl )"
+DISABLE_AUTOFORMATTING="true"
+DOC_CONTENTS="To use the colorschemes of ${PN} call
+ eval \"\`dircolors-mv\`\"
+e.g. in your bashrc; make sure that SOLARIZED (if desired)
+and DEFAULTS is set appropriately, see the documentation.
+For zsh, this happens if you use zshrc-mv"
+
src_prepare() {
epatch_user
}
@@ -33,17 +40,5 @@ src_install() {
use perl && dobin bin/256colors
insinto /etc/dir_colors
doins DIR_COLORS*
-}
-
-pkg_postinst() {
- case "${REPLACING_VERSIONS:-1.1}" in
- 1.1)
- elog "To use the colorschemes of ${PN} call"
- elog " eval \"\`dircolors-mv\`\""
- elog "e.g. in your bashrc; make sure that SOLARIZED (if desired)"
- elog "and DEFAULTS is set appropriately, see the documentation."
- if ! has_version app-shells/zshrc-mv
- then elog "For zsh, this happens if you use zshrc-mv"
- fi;;
- esac
+ readme.gentoo_src_install
}
diff --git a/app-shells/zsh-syntax-highlighting/ChangeLog b/app-shells/zsh-syntax-highlighting/ChangeLog
index 5fa5ebb7..228874d7 100644
--- a/app-shells/zsh-syntax-highlighting/ChangeLog
+++ b/app-shells/zsh-syntax-highlighting/ChangeLog
@@ -4,6 +4,9 @@
*zsh-syntax-highlighting-0.2.0, -99999999 (14 Sep 2013)
+ 12 Oct 2013; Martin Väth <martin@mvath.de>:
+ Use readme.gentoo.eclass
+
14 Sep 2013; Martin Väth <martin@mvath.de>:
Rename back. Bump to git-r3.eclass
diff --git a/app-shells/zsh-syntax-highlighting/zsh-syntax-highlighting-99999999.ebuild b/app-shells/zsh-syntax-highlighting/zsh-syntax-highlighting-99999999.ebuild
index 1f1f434b..98667da3 100644
--- a/app-shells/zsh-syntax-highlighting/zsh-syntax-highlighting-99999999.ebuild
+++ b/app-shells/zsh-syntax-highlighting/zsh-syntax-highlighting-99999999.ebuild
@@ -4,7 +4,7 @@
EAPI=5
-inherit eutils
+inherit eutils readme.gentoo
case ${PV} in
99999999*)
@@ -30,6 +30,12 @@ IUSE=""
RDEPEND="app-shells/zsh"
DEPEND=""
+DISABLE_AUTOFORMATTING="true"
+DOC_CONTENTS="In order to use ${CATEGORY}/${PN} add
+. /usr/share/zsh/site-contrib/${PN}/zsh-syntax-highlighting.zsh
+at the end of your ~/.zshrc
+For testing, you can also execute the above command in your zsh."
+
src_prepare() {
grep -q 'local .*cdpath_dir' >/dev/null 2>&1 || \
sed -i -e '/for cdpath_dir/ilocal cdpath_dir' \
@@ -42,12 +48,5 @@ src_install() {
insinto /usr/share/zsh/site-contrib/${PN}
doins *.zsh
doins -r highlighters
-}
-
-pkg_postinst() {
- [ -n "${REPLACING_VERSIONS}" ] && return
- elog "In order to use ${CATEGORY}/${PN} add"
- elog ". /usr/share/zsh/site-contrib/${PN}/zsh-syntax-highlighting.zsh"
- elog "at the end of your ~/.zshrc"
- elog "For testing, you can also execute the above command in your zsh."
+ readme.gentoo_src_install
}
diff --git a/app-shells/zsh/ChangeLog b/app-shells/zsh/ChangeLog
index 0f821aea..cfe4f5fc 100644
--- a/app-shells/zsh/ChangeLog
+++ b/app-shells/zsh/ChangeLog
@@ -4,6 +4,9 @@
*zsh-99999999 (29 May 2013)
+ 12 Oct 2013; Martin Väth <martin@mvath.de>:
+ Use readme.gentoo.eclass
+
14 Sep 2013; Martin Väth <martin@mvath.de>:
Bump to git-r3.eclass
diff --git a/app-shells/zsh/zsh-99999999.ebuild b/app-shells/zsh/zsh-99999999.ebuild
index a0b47bca..bb9598c2 100644
--- a/app-shells/zsh/zsh-99999999.ebuild
+++ b/app-shells/zsh/zsh-99999999.ebuild
@@ -7,7 +7,7 @@ EAPI=5
# doc package for -dev version exists?
doc_available=true
-inherit eutils flag-o-matic multilib prefix
+inherit eutils flag-o-matic multilib prefix readme.gentoo
MY_PV=${PV/_p/-dev-}
S=${WORKDIR}/${PN}-${MY_PV}
@@ -87,6 +87,31 @@ PDEPEND="
examples? ( app-doc/zsh-lovers )
"
+DISABLE_AUTOFORMATTING="true"
+DOC_CONTENTS="
+If you want to enable Portage completions and Gentoo prompt,
+emerge app-shells/zsh-completion and add
+ autoload -U compinit promptinit
+ compinit
+ promptinit; prompt gentoo
+to your ~/.zshrc
+
+Also, if you want to enable cache for the completions, add
+ zstyle ':completion::complete:*' use-cache 1
+to your ~/.zshrc
+"
+
+pkg_setup() {
+ if use run-help
+ then DOC_CONTENTS="
+If you want to use run-help add to your ~/.zshrc
+ unalias run-help
+ autoload -Uz run-help
+ HELPDIR=/usr/share/zsh/site-contrib/help
+${DOC_CONTENTS}"
+ fi
+}
+
src_prepare() {
# fix zshall problem with soelim
ln -s Doc man1
@@ -279,6 +304,7 @@ src_install() {
done
dodoc ChangeLog* META-FAQ NEWS README config.modules
+ readme.gentoo_src_install
if use doc ; then
pushd "${WORKDIR}/${PN}-${PV%_*}" >/dev/null
@@ -291,33 +317,3 @@ src_install() {
docinto StartupFiles
dodoc StartupFiles/z*
}
-
-pkg_postinst() {
- if use run-help ; then
- # In order to avoid confusion of the user, we print the following
- # unconditionally even if an older version of zsh was installed:
- # This older version might be without support for USE=run-help -
- # we cannot tell from the version number in ${REPLACING_VERSIONS}
- # alone and has_version does not work here as desired.
- elog
- elog "If you want to use run-help add to your ~/.zshrc"
- elog " unalias run-help"
- elog " autoload -Uz run-help"
- elog " HELPDIR=/usr/share/zsh/site-contrib/help"
- fi
- if [[ -z ${REPLACING_VERSIONS} ]] ; then
- # should link to http://www.gentoo.org/doc/en/zsh.xml
- elog
- elog "If you want to enable Portage completions and Gentoo prompt,"
- elog "emerge app-shells/zsh-completion and add"
- elog " autoload -U compinit promptinit"
- elog " compinit"
- elog " promptinit; prompt gentoo"
- elog "to your ~/.zshrc"
- elog
- elog "Also, if you want to enable cache for the completions, add"
- elog " zstyle ':completion::complete:*' use-cache 1"
- elog "to your ~/.zshrc"
- elog
- fi
-}
diff --git a/media-video/video-mv/ChangeLog b/media-video/video-mv/ChangeLog
index 0d1272c2..64567d43 100644
--- a/media-video/video-mv/ChangeLog
+++ b/media-video/video-mv/ChangeLog
@@ -4,6 +4,9 @@
*video-mv-7.9 (18 Aug 2013)
+ 12 Oct 2013; Martin Väth <martin@mvath.de>:
+ Use readme.gentoo.eclass
+
10 Sep 2013; Martin Väth <martin@mvath.de>:
Install zsh-completion unconditionally according to gentoo policy
diff --git a/media-video/video-mv/video-mv-7.9.ebuild b/media-video/video-mv/video-mv-7.9.ebuild
index f8dd3952..560d2ff4 100644
--- a/media-video/video-mv/video-mv-7.9.ebuild
+++ b/media-video/video-mv/video-mv-7.9.ebuild
@@ -4,7 +4,7 @@
EAPI=5
RESTRICT="mirror"
-inherit eutils vcs-snapshot
+inherit eutils readme.gentoo vcs-snapshot
DESCRIPTION="Frontends for using mplayer/mencoder, ffmpeg/libav, or tzap as video recorder"
HOMEPAGE="https://github.com/vaeth/video-mv/"
@@ -21,6 +21,11 @@ RDEPEND="app-shells/push
media-tv/linuxtv-dvb-apps )"
DEPEND=""
+DISABLE_AUTOFORMATTING="true"
+DOC_CONTENTS="If you use dvb-t with zsh completion, you might want to put
+zstyle ':completion:*' matcher-list '' 'm:{a-zA-Z}={A-Za-z}'
+into your ~/.zshrc or /etc/zshrc for case-insensitive matching."
+
src_prepare() {
epatch_user
}
@@ -39,15 +44,11 @@ src_install() {
insinto /usr/share/zsh/site-functions
doins zsh/*
dodoc README
+ readme.gentoo_src_install
}
-pkg_post_install() {
+pkg_postinst() {
has_version app-shells/runtitle || elog \
"Install app-shells/runtitle to let ${PN} update the status bar"
- case " ${REPLACING_VERSIONS:-5.}" in
- ' '5.*)
- elog "If you use dvb-t with zsh completion, you might want to put"
- elog "zstyle ':completion:*' matcher-list '' 'm:{a-zA-Z}={A-Za-z}'"
- elog "into your ~/.zshrc or /etc/zshrc for case-insensitive matching.";;
- esac
+ readme.gentoo_pkg_postinst
}
diff --git a/sys-block/zram-init/ChangeLog b/sys-block/zram-init/ChangeLog
index 026556d3..f4a82de0 100644
--- a/sys-block/zram-init/ChangeLog
+++ b/sys-block/zram-init/ChangeLog
@@ -4,6 +4,9 @@
*zram-init-2.6.ebuild (11 Oct 2013)
+ 12 Oct 2013; Martin Väth <martin@mvath.de>:
+ Use readme.gentoo.eclass
+
11 Oct 2013; Martin Väth <martin@mvath.de>:
Version bump, remove old ebuild. Fixes umounting
diff --git a/sys-block/zram-init/zram-init-2.6.ebuild b/sys-block/zram-init/zram-init-2.6.ebuild
index e47e141e..e44497da 100644
--- a/sys-block/zram-init/zram-init-2.6.ebuild
+++ b/sys-block/zram-init/zram-init-2.6.ebuild
@@ -4,7 +4,7 @@
EAPI=5
RESTRICT="mirror"
-inherit eutils systemd vcs-snapshot
+inherit eutils readme.gentoo systemd vcs-snapshot
DESCRIPTION="Scripts to support compressed swap devices or ramdisks with zram"
HOMEPAGE="https://github.com/vaeth/zram-init/"
@@ -15,6 +15,12 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
+DISABLE_AUTOFORMATTING="true"
+DOC_CONTENTS="To use zram, activate it in your kernel and add it to default runlevel:
+ rc-config add zram default
+If you use systemd enable zram_swap, tmp, and/or var_tmp with systemctl.
+You might need to modify /etc/modprobe.d/zram.conf"
+
src_prepare() {
epatch_user
}
@@ -28,11 +34,5 @@ src_install() {
doins modprobe.d/*
insinto /usr/share/zsh/site-functions
doins zsh/*
-}
-
-pkg_postinst() {
- elog "To use zram, activate it in your kernel and add it to default runlevel:"
- elog " rc-config add zram default"
- elog "If you use systemd enable zram_swap, tmp, and/or var_tmp with systemctl."
- elog "You might need to modify /etc/modprobe.d/zram.conf"
+ readme.gentoo_src_install
}
diff --git a/sys-fs/squash_dir/ChangeLog b/sys-fs/squash_dir/ChangeLog
index 09b0b699..28585086 100644
--- a/sys-fs/squash_dir/ChangeLog
+++ b/sys-fs/squash_dir/ChangeLog
@@ -4,6 +4,9 @@
*squash_dir-13.3 (31 Aug 2013)
+ 12 Oct 2013; Martin Väth <martin@mvath.de>:
+ Use readme.gentoo.eclass
+
10 Sep 2013; Martin Väth <martin@mvath.de>:
Install zsh-completion unconditionally according to gentoo policy
diff --git a/sys-fs/squash_dir/squash_dir-13.3.ebuild b/sys-fs/squash_dir/squash_dir-13.3.ebuild
index 5ce07a5f..0c8df83a 100644
--- a/sys-fs/squash_dir/squash_dir-13.3.ebuild
+++ b/sys-fs/squash_dir/squash_dir-13.3.ebuild
@@ -6,7 +6,7 @@ EAPI=5
RESTRICT="mirror"
WANT_LIBTOOL=none
AUTOTOOLS_IN_SOURCE_BUILD=true
-inherit autotools autotools-utils eutils linux-info systemd vcs-snapshot
+inherit autotools autotools-utils eutils linux-info readme.gentoo systemd vcs-snapshot
DESCRIPTION="Keep directories compressed with squashfs. Useful for portage tree, texmf-dist"
HOMEPAGE="http://forums.gentoo.org/viewtopic-t-465367.html"
@@ -27,6 +27,11 @@ RDEPEND="sys-fs/squashfs-tools
DEPEND=">=sys-devel/autoconf-2.65
${BOTHDEPEND}"
+DISABLE_AUTOFORMATTING="true"
+DOC_CONTENTS="Please adapt ${EPREFIX}/etc/conf.d/${PN} to your needs.
+It is recommended to put into your zshrc the line:
+alias squash_dir='noglob squash_dir'"
+
src_prepare() {
if [ -n "${EPREFIX}" ]
then sed -i \
@@ -66,6 +71,7 @@ linux_config_missing() {
}
pkg_postinst() {
+ readme.gentoo_pkg_postinst
local fs=overlayfs
use unionfs-fuse && fs=unionfs-fuse
use aufs && fs=aufs
@@ -85,19 +91,10 @@ pkg_postinst() {
then ewarn "To use ${PN} activate aufs in your kernel. Use e.g. sys-fs/aufs*"
fi;;
esac
- case " ${REPLACING_VERSIONS}" in
- ' '[0-9][0-9][0-9]*|' '[2-9][0-9]*|' '1[3-9]*|' '12.[0-9][0-9]*|' '12.[7-9]*) :;;
- *) elog "Please adopt ${EPREFIX}/etc/conf.d/${PN} to your needs.";;
- esac
if ! has_version sys-fs/squashfs-tools[progress-redirect]
then elog "For better output of ${PN}, it is recommended to install"
elog "sys-fs/squashfs-tools from the mv overlay with USE=progress-redirect."
fi
has_version app-shells/runtitle || elog \
"Install app-shells/runtitle to let ${PN} update the status bar."
- case " ${REPLACING_VERSIONS}" in
- ' '[0-9][0-9][0-9]*|' '[2-9][0-9]*|' '1[4-9]*|' '13.[0-9][0-9]*|' '13.[3-9]*) :;;
- *) elog "It is recommended to put into your zshrc the line:"
- elog "alias squash_dir='noglob squash_dir'";;
- esac
}
diff --git a/sys-fs/squashmount/ChangeLog b/sys-fs/squashmount/ChangeLog
index 4013e69d..7f0ba398 100644
--- a/sys-fs/squashmount/ChangeLog
+++ b/sys-fs/squashmount/ChangeLog
@@ -4,6 +4,9 @@
*squashmount-3.5 (09 Oct 2013)
+ 12 Oct 2013; Martin Väth <martin@mvath.de>:
+ Use readme.gentoo.eclass
+
09 Oct 2013; Martin Väth <martin@mvath.de>:
Version bump, remove old ebuild.
diff --git a/sys-fs/squashmount/squashmount-3.5.ebuild b/sys-fs/squashmount/squashmount-3.5.ebuild
index 840e160d..332b2f27 100644
--- a/sys-fs/squashmount/squashmount-3.5.ebuild
+++ b/sys-fs/squashmount/squashmount-3.5.ebuild
@@ -4,7 +4,7 @@
EAPI=5
RESTRICT="mirror"
-inherit eutils systemd vcs-snapshot
+inherit eutils readme.gentoo systemd vcs-snapshot
DESCRIPTION="Keep directories compressed with squashfs. Useful for portage tree, texmf-dist"
HOMEPAGE="http://forums.gentoo.org/viewtopic-t-465367.html"
@@ -26,6 +26,11 @@ RDEPEND=">=app-shells/runtitle-2.3
!<sys-fs/unionfs-fuse-0.25"
DEPEND=""
+DISABLE_AUTOFORMATTING="true"
+DOC_CONTENTS="Please adapt /etc/squashmount.pl to your needs.
+It is recommended to put into your zshrc the line:
+alias squashmount='noglob squashmount'"
+
src_prepare() {
epatch_user
}
@@ -41,6 +46,7 @@ src_install() {
doins tmpfiles.d/*
insinto /usr/share/zsh/site-functions
doins zsh/*
+ readme.gentoo_src_install
}
pkg_postinst() {
@@ -62,7 +68,7 @@ pkg_postinst() {
}
case " ${REPLACING_VERSIONS}" in
' '[0-9][0-9]*|' '[3-9]*|' '2.[0-9][0-9]*|' '2.[7-9]*) :;;
- *) elog "It is recommended to put into your zshrc the line:"
- elog "alias squashmount='noglob squashmount'";;
+ *) FORCE_PRINT_ELOG="true";;
esac
+ readme.gentoo_pkg_postinst
}
diff --git a/www-plugins/stylish/ChangeLog b/www-plugins/stylish/ChangeLog
index 04d3cff0..f26460b6 100644
--- a/www-plugins/stylish/ChangeLog
+++ b/www-plugins/stylish/ChangeLog
@@ -4,6 +4,9 @@
*stylish-1.3.3 (31 Aug 2013)
+ 12 Oct 2013; Martin Väth <martin@mvath.de>:
+ Use readme.gentoo.eclass
+
31 Aug 2013; Martin Väth <martin@mvath.de>:
Version bump, remove old ebuild.
diff --git a/www-plugins/stylish/stylish-1.3.3.ebuild b/www-plugins/stylish/stylish-1.3.3.ebuild
index ff34d22c..b44466cf 100644
--- a/www-plugins/stylish/stylish-1.3.3.ebuild
+++ b/www-plugins/stylish/stylish-1.3.3.ebuild
@@ -3,7 +3,7 @@
# $Header: $
EAPI=5
-inherit mv_mozextension
+inherit mv_mozextension readme.gentoo
RESTRICT="mirror"
DESCRIPTION="Mozilla plugin to modify style of certain web pages (e.g. Gentoo forums)"
@@ -15,13 +15,20 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
-src_postinst() {
- mv_mozextension_src_postinst
- elog
- elog "You will probably want to setup the \"Darker forum\" style."
- elog "The old version could be found at"
- elog " http://jesgue.homelinux.org/other-files/dark-gentoo-forums.css"
- elog "but now it is easier to surf with javascript activated to"
- elog " http://userstyles.org/users/8172"
- elog "Note that you have to temporarily disable noscript for that site."
+DISABLE_AUTOFORMATTING="true"
+DOC_CONTENTS="You will probably want to setup the \"Darker forum\" style.
+The old version could be found at
+ http://jesgue.homelinux.org/other-files/dark-gentoo-forums.css
+but meanwhile it is easier to surf with javascript activated to
+ http://userstyles.org/users/8172
+Note that you have to temporarily disable noscript for that site."
+
+src_install() {
+ mv_mozextension_src_install
+ readme.gentoo_src_install
+}
+
+pkg_postinst() {
+ mv_mozextension_pkg_postinst
+ readme.gentoo_pkg_postinst
}
diff --git a/x11-themes/fvwm-crystal/ChangeLog b/x11-themes/fvwm-crystal/ChangeLog
new file mode 100644
index 00000000..2817b8e4
--- /dev/null
+++ b/x11-themes/fvwm-crystal/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for x11-themes/fvwm-crystal
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*fvwm-crystal-3.2.7 (12 Oct 2013)
+
+ 12 Oct 2013; Martin Väth <martin@mvath.de>:
+ Fork from main tree to get earlier revbump: In particular, bashisms are
+ fixed in newer versions of fvwm-crystal. Removing previous ChangeLog.
diff --git a/x11-themes/fvwm-crystal/Manifest b/x11-themes/fvwm-crystal/Manifest
new file mode 100644
index 00000000..8e9cea5e
--- /dev/null
+++ b/x11-themes/fvwm-crystal/Manifest
@@ -0,0 +1 @@
+DIST fvwm-crystal-3.2.7.tar.gz 4461495 SHA256 fd3ef491a092af36060516907628744545486cb6f33bcdd738ffc9e2bb73b6e1 SHA512 4c5608d4b47df65cf8bcc4d17137dfaa006f1d332a9e33fec77e15ab7872449d94e2b9cac8e667cfd702032f6bada1327f0f14d113fd07fe0aa130ec6838f560 WHIRLPOOL ddb8f8bfbb2e9af2422db4591ab3aeeb6c1bc76de320ae1673c226bd2dd17787238fb37d47cf3901ab20e7ead05b98205895aadc6eca023398b69b6cbe2580c4
diff --git a/x11-themes/fvwm-crystal/fvwm-crystal-3.2.7.ebuild b/x11-themes/fvwm-crystal/fvwm-crystal-3.2.7.ebuild
new file mode 100644
index 00000000..43a466d6
--- /dev/null
+++ b/x11-themes/fvwm-crystal/fvwm-crystal-3.2.7.ebuild
@@ -0,0 +1,108 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/fvwm-crystal/fvwm-crystal-3.2.3.ebuild,v 1.1 2013/06/23 10:00:55 hwoarang Exp $
+
+EAPI="5"
+RESTRICT=mirror
+
+PYTHON_COMPAT=( python2_7 )
+inherit eutils readme.gentoo python-r1
+
+DESCRIPTION="Configurable and full featured FVWM theme, with lots of transparency and freedesktop compatible menu"
+HOMEPAGE="http://fvwm-crystal.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+#http://sourceforge.net/projects/fvwm-crystal/files/3.2.7/fvwm-crystal-3.2.7.tar.gz/download
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND="${PYTHON_DEPS}
+ >=x11-wm/fvwm-2.6.5[png]
+ || ( media-gfx/imagemagick media-gfx/graphicsmagick[imagemagick] )
+ || ( >=x11-misc/stalonetray-0.6.2-r2 x11-misc/trayer )
+ || ( x11-misc/hsetroot media-gfx/feh )
+ sys-apps/sed
+ sys-devel/bc
+ virtual/awk
+ x11-apps/xwd"
+
+DISABLE_AUTOFORMATTING="true"
+DOC_CONTENTS="After installation, execute following commands:
+ $ cp -r ${ROOT}usr/share/doc/${PF}/addons/Xresources ~/.Xresources
+ $ cp -r ${ROOT}usr/share/doc/${PF}/addons/Xsession ~/.xinitrc
+
+Many applications can extend functionality of fvwm-crystal.
+They are listed in ${ROOT}usr/share/doc/${PF}/INSTALL.gz.
+
+Some icons fixes was committed recently.
+To archive the same fixes on your private icon files,
+please read ${ROOT}usr/share/doc/${PF}/INSTALL.gz.
+This will fix the libpng warnings at stderr.
+
+The color themes was updated to Fvwm InfoStore.
+To know how to update your custom color themes, please run
+ ${ROOT}usr/share/${PN}/addons/convert_colorsets"
+
+src_prepare() {
+ find "${S}" -type d -name Applications -prune \
+ -o -type f -exec /bin/sh -c 'Echo() {
+ printf '\''%s\n'\'' "${*}"
+}
+Sed() {
+ text=${1:-bashisms}
+ shift
+ cp -p -- "${i}" "${i}.patched" && \
+ sed "${@}" \
+ -e '\''s/echo -e/echo/'\'' \
+ -e '\''s/\[\[ /\[ /g'\'' \
+ -e '\''s/ \]\]/ \]/g'\'' \
+ -e '\''/\[ | \]/{s/==/=/g}'\'' \
+ -e '\''s/source \([^a-z]\)/. \1/g'\'' \
+ -- "${i}" >|"${i}.patched" && \
+ if diff -q -- "${i}.patched" "${i}" >/dev/null 2>&1
+ then rm -f -- "${i}.patched"
+ else Echo "Fixing ${text} in ${i}"
+ mv -- "${i}.patched" "${i}"
+ fi && return
+ Echo "Failed to patch ${i}" >&2
+ exit 1
+}
+for i
+do case ${i} in
+ *.html|*.py|*.png|*.gif|*.jpg|*/ChangeLog)
+ continue;;
+ */fvwm-crystal)
+ Sed break -e '\''/break;/d'\''
+ continue;;
+ */DesktopActions)
+ Sed arrays \
+ -e '\''/Execs=/{s/[()]/'\''"'\''/g}" \
+ -e '\''s/Execs\[\*\]/Execs/'\''
+ continue;;
+ */fvwm-crystal.videomodeswitch*)
+ Sed shebang -e '\''s:^#!/bin/sh:#!/bin/bash:'\''
+ continue;;
+ esac
+ head -n1 -- "${i}" | grep bash >/dev/null && continue
+ if grep -q '\''echo \*'\'' -- "${i}" >/dev/null
+ then Sed quoting -e '\''s/echo \*/echo \\*/g'\''
+ else Sed ""
+ fi
+done' sh '{}' '+' || die "patching failed"
+ epatch_user
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ docdir="/usr/share/doc/${PF}" \
+ prefix="/usr" \
+ install
+
+ python_replicate_script \
+ "${D}/usr/bin/${PN}".{apps,wallpaper} \
+ "${D}/usr/share/${PN}"/fvwm/scripts/FvwmMPD/*.py
+ readme.gentoo_src_install
+}
diff --git a/x11-themes/fvwm-crystal/metadata.xml b/x11-themes/fvwm-crystal/metadata.xml
new file mode 100644
index 00000000..5f357c6b
--- /dev/null
+++ b/x11-themes/fvwm-crystal/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>proxy-maintainers</herd>
+<maintainer>
+ <email>dominique.michel@vtxnet.ch</email>
+ <name>Dominique Michel</name>
+</maintainer>
+<longdescription>
+FVWM-Crystal is a set of configuration files for FVWM window manager,
+with additional programs and scripts. Some of it's features are:
+ * quick launching of a terminal with just one click on a desktop
+ * a specially configured terminal window, similar to a console from FPP games
+ * builtin control over XMMS player and over aumix mixer from the keyboard and
+ buttons on the screen
+ * very good ability to control the desktop from the keyboard, including window
+ switching, moving, shading/unshading, maximizing, resizing, moving between
+ desktop pages
+ * transparent window titlebars, menus and panels on the desktop
+</longdescription>
+</pkgmetadata>