summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2020-07-18 07:52:14 +0200
committerMartin Väth <martin@mvath.de>2020-07-18 07:52:14 +0200
commit63cce948108fadc063e9a348279f72f3e0f33bcd (patch)
tree4be8fa1a0d78d6eca831e5e2dfb54583195828c1
parentsys-block/zram-init: Version bump (diff)
downloadmv-63cce948108fadc063e9a348279f72f3e0f33bcd.tar.gz
mv-63cce948108fadc063e9a348279f72f3e0f33bcd.tar.bz2
mv-63cce948108fadc063e9a348279f72f3e0f33bcd.zip
sys-kernel/kconfig-hardened-check: add slight modification from pentoo
Signed-off-by: Martin Väth <martin@mvath.de>
-rw-r--r--metadata/pkg_desc_index1
-rw-r--r--sys-kernel/kconfig-hardened-check/Manifest1
-rw-r--r--sys-kernel/kconfig-hardened-check/kconfig-hardened-check-0.5.7.ebuild35
-rw-r--r--sys-kernel/kconfig-hardened-check/kconfig-hardened-check-99999999.ebuild35
4 files changed, 72 insertions, 0 deletions
diff --git a/metadata/pkg_desc_index b/metadata/pkg_desc_index
index c3e60242..45fa0359 100644
--- a/metadata/pkg_desc_index
+++ b/metadata/pkg_desc_index
@@ -113,6 +113,7 @@ sys-fs/squashfs-tools 4.4 99999999: Tool for creating compressed filesystem type
sys-fs/squashfuse 0.1.103 0.1.104_alpha20180721: FUSE filesystem to mount squashfs archives
sys-fs/squashmount 22.0: Keep directories compressed with squashfs. Useful for portage tree, texmf-dist
sys-kernel/kccmp 0.3-r1: A simple tool for comparing two linux kernel .config files
+sys-kernel/kconfig-hardened-check 0.5.7 99999999: A script for checking the hardening options in the Linux kernel config
sys-kernel/kernel 6.1: A POSIX shell script to compile the kernel with user permissions
virtual/cdrtools 1: Virtual for command-line recorders cdrtools and cdrkit
virtual/freedesktop-icon-theme 0-r3: A virtual to choose between different icon themes
diff --git a/sys-kernel/kconfig-hardened-check/Manifest b/sys-kernel/kconfig-hardened-check/Manifest
new file mode 100644
index 00000000..2f8dd036
--- /dev/null
+++ b/sys-kernel/kconfig-hardened-check/Manifest
@@ -0,0 +1 @@
+DIST kconfig-hardened-check-0.5.7.tar.gz 1413247 SHA512 0eafb051babde90fc6a3a7be31a33ffd3e040c5b0876388b78c7dee6abf646fa380ac5c18bd76238e8df6abba0bdcb3ca23a9f2e36a22503e57a9bc21c524d80
diff --git a/sys-kernel/kconfig-hardened-check/kconfig-hardened-check-0.5.7.ebuild b/sys-kernel/kconfig-hardened-check/kconfig-hardened-check-0.5.7.ebuild
new file mode 100644
index 00000000..1813a692
--- /dev/null
+++ b/sys-kernel/kconfig-hardened-check/kconfig-hardened-check-0.5.7.ebuild
@@ -0,0 +1,35 @@
+ # Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8,9} )
+
+inherit distutils-r1
+
+DESCRIPTION="A script for checking the hardening options in the Linux kernel config"
+HOMEPAGE="https://github.com/a13xp0p0v/kconfig-hardened-check"
+
+case ${PV} in
+99999999)
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/a13xp0p0v/kconfig-hardened-check"
+;;
+*)
+ SRC_URI="https://github.com/a13xp0p0v/kconfig-hardened-check/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ RESTRICT="mirror"
+;;
+esac
+
+IUSE=""
+LICENSE="GPL-3"
+SLOT="0"
+
+RDEPEND="${PYTHON_DEPS}"
+BDEPEND="${RDEPEND}"
+
+src_install() {
+ distutils-r1_src_install
+ dodoc -r "${PN//-/_}"/config_files/ README.md
+}
diff --git a/sys-kernel/kconfig-hardened-check/kconfig-hardened-check-99999999.ebuild b/sys-kernel/kconfig-hardened-check/kconfig-hardened-check-99999999.ebuild
new file mode 100644
index 00000000..1813a692
--- /dev/null
+++ b/sys-kernel/kconfig-hardened-check/kconfig-hardened-check-99999999.ebuild
@@ -0,0 +1,35 @@
+ # Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8,9} )
+
+inherit distutils-r1
+
+DESCRIPTION="A script for checking the hardening options in the Linux kernel config"
+HOMEPAGE="https://github.com/a13xp0p0v/kconfig-hardened-check"
+
+case ${PV} in
+99999999)
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/a13xp0p0v/kconfig-hardened-check"
+;;
+*)
+ SRC_URI="https://github.com/a13xp0p0v/kconfig-hardened-check/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ RESTRICT="mirror"
+;;
+esac
+
+IUSE=""
+LICENSE="GPL-3"
+SLOT="0"
+
+RDEPEND="${PYTHON_DEPS}"
+BDEPEND="${RDEPEND}"
+
+src_install() {
+ distutils-r1_src_install
+ dodoc -r "${PN//-/_}"/config_files/ README.md
+}