summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2016-06-12 15:38:24 +0200
committerMartin Väth <martin@mvath.de>2016-06-12 15:38:24 +0200
commit6f47358e7459e757e04152a4edc7f3c1a6506c59 (patch)
tree6bf70345b2aa5779fc3a65f36eccba9053eac2bd
parentapp-shells/zsh: stabilize (diff)
downloadmv-6f47358e7459e757e04152a4edc7f3c1a6506c59.tar.gz
mv-6f47358e7459e757e04152a4edc7f3c1a6506c59.tar.bz2
mv-6f47358e7459e757e04152a4edc7f3c1a6506c59.zip
media-video/avinfo: Fix ebuild from main gentoo repository
-rw-r--r--media-video/avinfo/Manifest2
-rw-r--r--media-video/avinfo/avinfo-1.0_alpha15_p1.ebuild39
-rw-r--r--media-video/avinfo/files/no-bison.patch13
-rw-r--r--media-video/avinfo/metadata.xml8
4 files changed, 62 insertions, 0 deletions
diff --git a/media-video/avinfo/Manifest b/media-video/avinfo/Manifest
new file mode 100644
index 00000000..310f6f1a
--- /dev/null
+++ b/media-video/avinfo/Manifest
@@ -0,0 +1,2 @@
+DIST avinfo-1.0.a15unix-patch1.tar.gz 5665 SHA256 b239c7a414dc92e4a6d3881801e981e71f66242d0e38ffae774a3a0f8c8bdf81
+DIST avinfo-1.0.a15unix.tar.gz 105743 SHA256 3e3404a76e6057c1703e0c49b63910a8ffcb5ea15ae7b2d0a7d2ede4b4c19887
diff --git a/media-video/avinfo/avinfo-1.0_alpha15_p1.ebuild b/media-video/avinfo/avinfo-1.0_alpha15_p1.ebuild
new file mode 100644
index 00000000..a892f808
--- /dev/null
+++ b/media-video/avinfo/avinfo-1.0_alpha15_p1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+RESTRICT="mirror"
+inherit eutils toolchain-funcs
+
+MY_P=${PN}-1.0.a15unix
+
+DESCRIPTION="Utility for displaying AVI information"
+HOMEPAGE="http://shounen.ru/soft/avinfo/english.shtml"
+SRC_URI="http://shounen.ru/soft/${PN}/${MY_P}.tar.gz
+ http://shounen.ru/soft/${PN}/${MY_P}-patch1.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+S="${WORKDIR}"/${PN}-1.0.a15
+
+src_prepare() {
+ eapply "${WORKDIR}"/${MY_P}-patch1/${MY_P}-patch1.diff
+ eapply "${FILESDIR}"/no-bison.patch
+ sed -i -e 's/$(CC) $(OBJ)/$(CC) $(LDFLAGS) $(OBJ)/' src/Makefile || die
+ eapply_user
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ dobin src/avinfo
+ doman src/avinfo.1
+ dodoc CHANGELOG README "${WORKDIR}"/${MY_P}-patch1/FIXES
+ dodoc doc/*
+}
diff --git a/media-video/avinfo/files/no-bison.patch b/media-video/avinfo/files/no-bison.patch
new file mode 100644
index 00000000..8a1d7926
--- /dev/null
+++ b/media-video/avinfo/files/no-bison.patch
@@ -0,0 +1,13 @@
+--- 1/config.mk
++++ 2/config.mk
+@@ -8,8 +8,8 @@
+
+ CC=gcc
+ CFLAGS=-O2 -Wall
+-BISON=bison
+-#BISON=NONE
++#BISON=bison
++BISON=NONE
+
+ # --------------------- Installation options ----------------------
+
diff --git a/media-video/avinfo/metadata.xml b/media-video/avinfo/metadata.xml
new file mode 100644
index 00000000..b919c846
--- /dev/null
+++ b/media-video/avinfo/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>martin@mvath.de</email>
+ <name>Martin Väth</name>
+ </maintainer>
+</pkgmetadata>