summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2010-06-06 17:13:03 +0200
committerMartin Väth <martin@mvath.de>2015-10-11 10:45:30 +0200
commit72e481c815870f64fb00b3c2359348817320815a (patch)
tree64f71976be6371af6fc2833bfa91f82d24c95a2a
parentUpdate squash_dir to support new syntax of unionfs-fuse (diff)
downloadmv-72e481c815870f64fb00b3c2359348817320815a.tar.gz
mv-72e481c815870f64fb00b3c2359348817320815a.tar.bz2
mv-72e481c815870f64fb00b3c2359348817320815a.zip
Bump www-plugins and support seamonkey etc via mv_mozextension.eclass
-rw-r--r--eclass/mv_mozextension.eclass185
-rw-r--r--www-plugins/better-privacy/ChangeLog5
-rw-r--r--www-plugins/better-privacy/Manifest4
-rw-r--r--www-plugins/better-privacy/better-privacy-1.47.4-r1.ebuild32
-rw-r--r--www-plugins/better-privacy/better-privacy-1.47.4.ebuild62
-rw-r--r--www-plugins/flashgot/ChangeLog7
-rw-r--r--www-plugins/flashgot/Manifest6
-rw-r--r--www-plugins/flashgot/flashgot-1.2.1.21.ebuild39
-rw-r--r--www-plugins/flashgot/flashgot-1.2.1.23.ebuild16
-rw-r--r--www-plugins/noscript/ChangeLog6
-rw-r--r--www-plugins/noscript/Manifest6
-rw-r--r--www-plugins/noscript/noscript-1.9.9.69.ebuild76
-rw-r--r--www-plugins/noscript/noscript-1.9.9.81.ebuild19
-rw-r--r--www-plugins/stylish/ChangeLog7
-rw-r--r--www-plugins/stylish/Manifest6
-rw-r--r--www-plugins/stylish/stylish-1.0.8.ebuild50
-rw-r--r--www-plugins/stylish/stylish-1.0.9.ebuild27
-rw-r--r--www-plugins/video-downloadhelper/ChangeLog5
-rw-r--r--www-plugins/video-downloadhelper/Manifest4
-rw-r--r--www-plugins/video-downloadhelper/video-downloadhelper-4.7.3-r1.ebuild16
-rw-r--r--www-plugins/video-downloadhelper/video-downloadhelper-4.7.3.ebuild41
21 files changed, 338 insertions, 281 deletions
diff --git a/eclass/mv_mozextension.eclass b/eclass/mv_mozextension.eclass
new file mode 100644
index 00000000..c51699dd
--- /dev/null
+++ b/eclass/mv_mozextension.eclass
@@ -0,0 +1,185 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header $
+#
+# mv_mozextention.eclass: installing firefox extensions and language packs
+#
+# This is mozextension.eclass from the portage tree with the following changes:
+#
+# 1. Some compatibility fixes in xpi_install/xpi_unpack.
+# 2. A default src_unpack function is defined; set FILENAME to the archive name.
+# If FILENAME is unset or empty, the last part of the last SRC_URI is used.
+# 3. Default functions for installation for all browsers.
+# If you want only installation for some browser, define
+# MOZILLAS="firefox seamonkey icecat" (or to a subset thereof)
+# before inheriting the eclass.
+# If you define MOZILLA="" before inheriting the eclass,
+# no default functions get defined.
+
+: ${MOZILLAS="firefox seamonkey icecat"}
+
+[ -n "${MOZILLAS}" ] && inherit multilib
+
+case "${MOZILLAS}" in
+''|icecat)
+ RDEPEND=""
+ RDEPEND_END="";;
+*)
+ RDEPEND="|| ("
+ RDEPEND_END="
+)";;
+esac
+case "${MOZILLAS}" in
+*fire*)
+ RDEPEND="${RDEPEND}
+ >=www-client/mozilla-firefox-1.5
+ >=www-client/firefox-bin-1.5";;
+esac
+case "${MOZILLAS}" in
+*sea*)
+ RDEPEND="${RDEPEND}
+ >=www-client/seamonkey-1.1
+ >=www-client/seamonkey-bin-1.1";;
+esac
+case "${MOZILLAS}" in
+*ice*)
+ RDEPEND="${RDEPEND}
+ >=www-client/icecat-3.5";;
+esac
+RDEPEND="${RDEPEND}${RDEPEND_END}"
+
+DEPEND="app-arch/unzip"
+[ -n "${RDEPEND}" ] && DEPEND="${DEPEND}
+${RDEPEND}"
+
+mv_mozextension_src_unpack () {
+ local i
+ if [ -z "${FILENAME}" ]
+ then for i in ${SRC_URI}
+ do FILENAME="${i##*/}"
+ done
+ fi
+ xpi_unpack "${FILENAME}"
+}
+
+EXPORT_FUNCTIONS src_unpack
+
+if [ -n "${MOZILLAS}" ]
+then
+
+mv_mozextension_src_install () {
+ local MOZILLA_FIVE_HOME
+ INST_MOZILLAS=""
+ case "${MOZILLAS}" in
+ *fire*)
+ if has_version '>=www-client/mozilla-firefox-1.5'
+ then MOZILLA_FIVE_HOME="/usr/$(get_libdir)/mozilla-firefox"
+ xpi_install_dirs
+ INST_MOZILLAS="${INST_MOZILLAS} $(best_version www-client/mozilla-firefox)"
+ fi
+ if has_version '>=www-client/firefox-bin-1.5'
+ then MOZILLA_FIVE_HOME="/opt/firefox"
+ xpi_install_dirs
+ INST_MOZILLAS="${INST_MOZILLAS} $(best_version www-client/firefox-bin)"
+ fi;;
+ esac
+ case "${MOZILLAS}" in
+ *sea*)
+ if has_version '>=www-client/seamonkey-1.1'
+ then MOZILLA_FIVE_HOME="/usr/$(get_libdir)/seamonkey"
+ xpi_install_dirs
+ INST_MOZILLAS="${INST_MOZILLAS} $(best_version www-client/seamonkey)"
+ fi
+ if has_version '>=www-client/seamonkey-bin-1.1'
+ then MOZILLA_FIVE_HOME="/opt/seamonkey"
+ xpi_install_dirs
+ INST_MOZILLAS="${INST_MOZILLAS} $(best_version www-client/seamonkey-bin)"
+ fi;;
+ esac
+ case "${MOZILLAS}" in
+ *ice*)
+ if has_version '>=www-client/icecat-3.5'
+ then MOZILLA_FIVE_HOME="/usr/$(get_libdir)/icecat"
+ xpi_install_dirs
+ INST_MOZILLAS="${INST_MOZILLAS} $(best_version www-client/icecat)"
+ fi;;
+ esac
+}
+
+mv_mozextension_pkg_postinst () {
+ local i
+ elog "${CATEGORY}/${PN} has been installed for the following packages:"
+ for i in ${INST_MOZILLAS}
+ do elog " ${i}"
+ done
+ elog
+ elog "After installing other mozilla ebuilds, if you want to use it with them,"
+ elog "reemerge ${CATEGORY}/${PN}"
+}
+
+EXPORT_FUNCTIONS src_install pkg_postinst
+
+fi
+
+xpi_unpack () {
+ local xpi srcdir
+
+ # Not gonna use ${A} as we are looking for a specific option being passed to function
+ # You must specify which xpi to use
+ [ ${#} -eq 0 ] && die \
+ "Nothing passed to the ${FUNCNAME} command. Please pass which xpi to unpack"
+
+ for xpi
+ do einfo "Unpacking ${xpi} to ${WORKDIR}"
+ xpiname="${xpi%.*}"
+ xpiname="${xpiname##*/}"
+
+ case "${xpi}" in
+ ./*|/*)
+ srcdir=''
+ ;;
+ *)
+ srcdir="${DISTDIR}/"
+ ;;
+ esac
+
+ test -s "${srcdir}${xpi}" || die "${xpi} does not exist"
+
+ case "${xpi##*.}" in
+ ZIP|zip|jar|xpi)
+ mkdir -- "${WORKDIR}/${xpiname}" && \
+ cd -- "${WORKDIR}/${xpiname}" && \
+ unzip -qo -- "${srcdir}${xpi}" \
+ || die "failed to unpack ${xpi}"
+ ;;
+ *)
+ einfo "unpack ${xpi}: file format not recognized. Ignoring."
+ ;;
+ esac
+ done
+}
+
+xpi_install () {
+ local emid x
+
+ # You must tell xpi_install which dir to use
+ [ ${#} -ne 1 ] && die "${FUNCNAME} takes exactly one argument. Please specify the directory"
+
+ x="${1}"
+ cd -- "${x}"
+ # determine id for extension
+ emid="$(sed -n -e '/install-manifest/,$ { /<\?em:id>\?/!d; s/.*\([\"{].*[}\"]\).*/\1/; s/\"//g; p; q }' "${x}"/install.rdf)" \
+ && [ -n "${emid}" ] || die "failed to determine extension id"
+ insinto "${MOZILLA_FIVE_HOME}/extensions/${emid}"
+ doins -r "${x}"/* || die "failed to copy extension"
+}
+
+# This function is called by mv_mozextension_src_install
+# and should be overridden if the paths do not match:
+# It just should call xpi_install with the correct argument(s)
+xpi_install_dirs () {
+ local d
+ for d in "${WORKDIR}"/*
+ do [ -n "${d}" ] && test -d "${d}" && xpi_install "${d}"
+ done
+}
diff --git a/www-plugins/better-privacy/ChangeLog b/www-plugins/better-privacy/ChangeLog
index 81fed5bf..6945ee73 100644
--- a/www-plugins/better-privacy/ChangeLog
+++ b/www-plugins/better-privacy/ChangeLog
@@ -2,6 +2,11 @@
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
# $Header $
+ 06 Jun 2010; Martin Väth <martin@mvath.de>
+ +better-privacy-1.47.4-r1.ebuild -better-privacy-1.47.4.ebuild:
+ Switch to new mv_mozextension.eclass:
+ Installs also for other mozilla variants like seamonkey.
+
*better-privacy-1.47.4 (22 Apr 2010)
22 Apr 2010; Martin Väth <martin@mvath.de>
diff --git a/www-plugins/better-privacy/Manifest b/www-plugins/better-privacy/Manifest
index 18f6e55f..2b6ae5b8 100644
--- a/www-plugins/better-privacy/Manifest
+++ b/www-plugins/better-privacy/Manifest
@@ -1,4 +1,4 @@
DIST betterprivacy-1.47.4-sm+fx.xpi 110021 RMD160 8bae58a544312460d416c759f425780d92191bac SHA1 dae915b9337880aefc335947d5a37a3d0750a1e1 SHA256 e1f1e83ac608f0fdc33f66f60db4f47863e605eb8d8b52b1b99ca0b62ede1ba1
-EBUILD better-privacy-1.47.4.ebuild 1700 RMD160 3b323ed32a0c86a91411d84c2e5a10c703e36928 SHA1 49affddd6ce73bc8d704dee80640e36559f06618 SHA256 21bb4aa12f8d6db18efa9c7cd5d60260424c9300bc748b9c6550a724683939b4
-MISC ChangeLog 703 RMD160 1f3b1d03601d1430a44292ffb9d247dc33b6689c SHA1 477a89b9bf6d36bba696d976c23d9a2e2e07022a SHA256 4ae88b42f31f09a4ed37afa40212f5e8e7a82a7092856b5939fdf368f0f7a416
+EBUILD better-privacy-1.47.4-r1.ebuild 834 RMD160 cdfd4da9dad329b7af9feb9ec4c6db5a1ffca673 SHA1 f8d7fe7502520594b5b7b7d1fa5434834a82d9f1 SHA256 df03e3e2f83180fb9a67252b07b7c97edc0a0272f9797ad7302b6285c29b5965
+MISC ChangeLog 933 RMD160 3d5b2fd7b551ff570749f45fcc778810bd3fc854 SHA1 eec55368896c4035747119ad14aa9881339a4a3e SHA256 9f23bfb6af3504ccd07624b240d782f9ee3574e4a0353eb8589d5ceca06c0289
MISC metadata.xml 264 RMD160 4c10b5dfc6857fcb2e9cdc91ff64bb5d4a5c2204 SHA1 69886f7e401bdf99a78d428ff4361991607e86c6 SHA256 dd28333300fc1ec2dbd96450bddbdd9e1061c1eff809e687442c53c91c05d86d
diff --git a/www-plugins/better-privacy/better-privacy-1.47.4-r1.ebuild b/www-plugins/better-privacy/better-privacy-1.47.4-r1.ebuild
new file mode 100644
index 00000000..20513369
--- /dev/null
+++ b/www-plugins/better-privacy/better-privacy-1.47.4-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header $
+
+EAPI="3"
+inherit mv_mozextension
+RESTRICT="mirror"
+
+DESCRIPTION="Firefox plugin for long time cookies like ~/.adobe/Flash_Player/AssetCache/*/*"
+HOMEPAGE="https://addons.mozilla.org/firefox/addon/6623"
+MY_P="${P/-/}"
+MY_P="${MY_P%_alpha*}"
+MY_P="${MY_P%_beta*}"
+MY_P="${MY_P}-sm+fx"
+FILENAME="${MY_P}.xpi"
+SRC_URI="https://addons.mozilla.org/de/firefox/downloads/latest/6623/${FILENAME}"
+case "${PV}" in
+*_alpha*|*_beta*)
+SRC_URI="https://addons.mozilla.org/de/firefox/downloads/file/76929/${FILENAME}?confirmed -> ${FILENAME}"
+esac
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+flash"
+
+ALL_DEPEND="flash? ( www-plugins/adobe-flash )"
+RDEPEND="${RDEPEND}
+${ALL_DEPEND}"
+DEPEND="${DEPEND}
+${ALL_DEPEND}"
+
diff --git a/www-plugins/better-privacy/better-privacy-1.47.4.ebuild b/www-plugins/better-privacy/better-privacy-1.47.4.ebuild
deleted file mode 100644
index 16efdc35..00000000
--- a/www-plugins/better-privacy/better-privacy-1.47.4.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header $
-
-EAPI="2"
-inherit mozextension multilib
-RESTRICT="mirror"
-
-DESCRIPTION="Firefox plugin for long time cookies like ~/.adobe/Flash_Player/AssetCache/*/*"
-HOMEPAGE="https://addons.mozilla.org/firefox/addon/6623"
-MY_P="${P/-/}"
-MY_P="${MY_P%_alpha*}"
-MY_P="${MY_P%_beta*}"
-MY_P="${MY_P}-sm+fx"
-FILENAME="${MY_P}.xpi"
-SRC_URI="https://addons.mozilla.org/de/firefox/downloads/latest/6623/${FILENAME}"
-case "${PV}" in
-*_alpha*|*_beta*)
-SRC_URI="https://addons.mozilla.org/de/firefox/downloads/file/76929/${FILENAME}?confirmed -> ${FILENAME}"
-esac
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="+flash"
-
-RDEPEND="flash? ( www-plugins/adobe-flash )
-|| (
- >=www-client/mozilla-firefox-bin-1.5.0.7
- >=www-client/mozilla-firefox-1.5.0.7
-)"
-DEPEND="${RDEPEND}"
-
-S=${WORKDIR}
-
-src_unpack() {
- xpi_unpack "${FILENAME}"
-}
-
-# xpi_install is buggy: The detection of emid fails
-my_xpi_install() {
- local emid
- x="${1}"
- cd ${x}
- # determine id for extension
- emid=$(sed -n -e '/install-manifest/,$ { /<\?em:id>\?/!d; s/.*\([\"{].*[}\"]\).*/\1/; s/\"//g; p; q }' ${x}/install.rdf) \
- && [ -n "${emid}" ] || die "failed to determine extension id"
- insinto "${MOZILLA_FIVE_HOME}"/extensions/${emid}
- doins -r "${x}"/* || die "failed to copy extension"
-}
-
-src_install() {
- declare MOZILLA_FIVE_HOME
- if has_version '>=www-client/mozilla-firefox-1.5.0.7'; then
- MOZILLA_FIVE_HOME="/usr/$(get_libdir)/mozilla-firefox"
- my_xpi_install "${S}"/"${MY_P}"
- fi
- if has_version '>=www-client/mozilla-firefox-bin-1.5.0.7'; then
- MOZILLA_FIVE_HOME="/opt/firefox"
- my_xpi_install "${S}"/"${MY_P}"
- fi
-}
diff --git a/www-plugins/flashgot/ChangeLog b/www-plugins/flashgot/ChangeLog
index c9b5af63..ee927d59 100644
--- a/www-plugins/flashgot/ChangeLog
+++ b/www-plugins/flashgot/ChangeLog
@@ -2,6 +2,13 @@
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
# $Header $
+*flashgot-1.2.1.23 (06 Jun 2010)
+
+ 06 Jun 2010; Martin Väth <martin@mvath.de>
+ +flashgot-1.2.1.23.ebuild -flashgot-1.2.1.21.ebuild:
+ Version bump, remove old ebuild. Switch to new mv_mozextension.eclass:
+ Installs also for other mozilla variants like seamonkey.
+
*flashgot-1.2.1.21 (22 Apr 2010)
22 Apr 2010; Martin Väth <martin@mvath.de>
diff --git a/www-plugins/flashgot/Manifest b/www-plugins/flashgot/Manifest
index 29be22b0..e27ad4db 100644
--- a/www-plugins/flashgot/Manifest
+++ b/www-plugins/flashgot/Manifest
@@ -1,4 +1,4 @@
-DIST flashgot-1.2.1.21.xpi 330262 RMD160 09fdeac47be92d648a473a2a68ae06099ffa567d SHA1 8242eaf5dd37f98ff6d5eefb14844d0a0506eade SHA256 844015a2c21dc8e9a68b1cb1b8cf8ba1f70851248aa67c8bf663e72489d62ae9
-EBUILD flashgot-1.2.1.21.ebuild 872 RMD160 31f103cf89cf63aa05c3c51049616768f174e284 SHA1 1ed493cd6dce9311d024d402836351cf18ef49bb SHA256 686ff184e35dd9542e051139726cd67b5e8e25bc107071f9641a2387ff574a45
-MISC ChangeLog 674 RMD160 f9b824d31996684e7b477a9bd892fb4e951b12aa SHA1 eba142e869529d4eaa75b2e69f5e161ea76438e0 SHA256 db475b1a98084891acc1eafee0230a215511d49d9ba5015aada5cde3d04f5163
+DIST flashgot-1.2.1.23.xpi 334150 RMD160 3506761dad9a4f3170ae9774ec18b81a81d7ad77 SHA1 65898c90a603acd4aadeaa5d0b7d8af586003575 SHA256 d6a92c2ca82f60b111c7fc8c7e75c841c4026ba823272d884ce576a66e9dcbdb
+EBUILD flashgot-1.2.1.23.ebuild 374 RMD160 ba9ed3344e07da253ca37c1b0e10409d0831a9d1 SHA1 22aa41ef4037c7d94c75b187af89a51c7e7e237e SHA256 59e474c17bfd33ec412c52232d5667ee22be7b41bc1533af90e457e65555c1a7
+MISC ChangeLog 960 RMD160 76891b749d9e0bda9eb1359d3885e84e70352960 SHA1 bfb2bce1654936d7c14095212ad9c5e13db4d3c8 SHA256 d777499c7185307b7648b982b1c7ba3f512934bc5a4c52c3072b402c1fc32af6
MISC metadata.xml 264 RMD160 4c10b5dfc6857fcb2e9cdc91ff64bb5d4a5c2204 SHA1 69886f7e401bdf99a78d428ff4361991607e86c6 SHA256 dd28333300fc1ec2dbd96450bddbdd9e1061c1eff809e687442c53c91c05d86d
diff --git a/www-plugins/flashgot/flashgot-1.2.1.21.ebuild b/www-plugins/flashgot/flashgot-1.2.1.21.ebuild
deleted file mode 100644
index 3c67bfe0..00000000
--- a/www-plugins/flashgot/flashgot-1.2.1.21.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header $
-
-inherit mozextension multilib
-RESTRICT="mirror"
-
-DESCRIPTION="Firefox plugin: download manager"
-HOMEPAGE="http://flashgot.net/"
-SRC_URI="http://software.informaction.com/data/releases/${P}.xpi"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-RDEPEND="|| (
- >=www-client/mozilla-firefox-bin-1.5.0.7
- >=www-client/mozilla-firefox-1.5.0.7
-)"
-DEPEND="${RDEPEND}"
-
-S=${WORKDIR}
-
-src_unpack() {
- xpi_unpack "${P}".xpi
-}
-
-src_install() {
- declare MOZILLA_FIVE_HOME
- if has_version '>=www-client/mozilla-firefox-1.5.0.7'; then
- MOZILLA_FIVE_HOME="/usr/$(get_libdir)/mozilla-firefox"
- xpi_install "${S}"/"${P}"
- fi
- if has_version '>=www-client/mozilla-firefox-bin-1.5.0.7'; then
- MOZILLA_FIVE_HOME="/opt/firefox"
- xpi_install "${S}"/"${P}"
- fi
-}
diff --git a/www-plugins/flashgot/flashgot-1.2.1.23.ebuild b/www-plugins/flashgot/flashgot-1.2.1.23.ebuild
new file mode 100644
index 00000000..47789513
--- /dev/null
+++ b/www-plugins/flashgot/flashgot-1.2.1.23.ebuild
@@ -0,0 +1,16 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header $
+
+EAPI="3"
+inherit mv_mozextension
+RESTRICT="mirror"
+
+DESCRIPTION="Firefox plugin: download manager"
+HOMEPAGE="http://flashgot.net/"
+SRC_URI="http://software.informaction.com/data/releases/${P}.xpi"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
diff --git a/www-plugins/noscript/ChangeLog b/www-plugins/noscript/ChangeLog
index 730260fc..9e594dd7 100644
--- a/www-plugins/noscript/ChangeLog
+++ b/www-plugins/noscript/ChangeLog
@@ -2,6 +2,12 @@
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
# $Header $
+*noscript-1.9.9.81 (06 Jun 2010)
+
+ 06 Jun 2010; Martin Väth <martin@mvath.de>
+ +noscript-1.9.9.81.ebuild -flashgot-1.9.9.69.ebuild:
+ Version bump, remove old ebuild. Switch to new mv_mozextension.eclass
+
*noscript-1.9.9.69 (22 Apr 2010)
22 Apr 2010; Martin Väth <martin@mvath.de>
diff --git a/www-plugins/noscript/Manifest b/www-plugins/noscript/Manifest
index 797d1937..d0bd08dc 100644
--- a/www-plugins/noscript/Manifest
+++ b/www-plugins/noscript/Manifest
@@ -1,4 +1,4 @@
-DIST noscript-1.9.9.69.xpi 467732 RMD160 33506528b2c37609ab98b7757e28fdb6f497de0f SHA1 0972758174890ad3ea556096dfe82eccc1782463 SHA256 85db9fd34edc3bfea39bd09707eb7a2b9f8e2688cee9b529aee4fe82f0a74f77
-EBUILD noscript-1.9.9.69.ebuild 2030 RMD160 b28d09037f1bb8a15195e292832965c14a3d815d SHA1 d625aaf51b70dd21d12bf32e64806de76341684f SHA256 162032baae26731b75a63e68a9346d7203fadfee0fa5bba6b95452ff6fc11905
-MISC ChangeLog 563 RMD160 97916113ef7d9b99fd392daad8ee2293d006eb3d SHA1 fdf8431913f82b99d0e4dc34f80b6e96131c88f1 SHA256 8460120890006738248032118a31495ddb5755098b4b9a00872896f289acd324
+DIST noscript-1.9.9.81.xpi 483545 RMD160 212762c8fef02a6d00e6c975d7600afc25493aca SHA1 182070ba5f9d30666e4d5d25e7bca9e1b2bbafd9 SHA256 fb3fb2583a0e75eba91b7d7917ada95a2ecc4ee5344a1f9b8f3b6e41030d45a0
+EBUILD noscript-1.9.9.81.ebuild 472 RMD160 bf62135764a65da396ca5684c31aa53c7d0cce88 SHA1 2d1843406f6f433202070eeb3c8a9c51f6bb08f2 SHA256 e7a23ac29a1dbc2c2cb0a494f5cdae8ebcb270849f9b46aa35bdc7df095611b7
+MISC ChangeLog 789 RMD160 b827aad7a7a6acb69f4a5fcd53f8520badd8fb36 SHA1 1e7a6cc72176dc5fbcc81a44da5a05ef320b25fe SHA256 5ed0301bb3808a5b2f30e31cbe3ed7fd52f82753e47bd5e279116b3521009fd5
MISC metadata.xml 447 RMD160 4ec5ea6b99ff64f433b133a9347f0a57039b73b7 SHA1 a6af7ca7a606d2ddc4afbb9ba31ac694f22e9abd SHA256 927431d432628bf04ca3f6e6cd0fc9b5e40ac0f2d2ea70e4a795e0df527cba67
diff --git a/www-plugins/noscript/noscript-1.9.9.69.ebuild b/www-plugins/noscript/noscript-1.9.9.69.ebuild
deleted file mode 100644
index 78acc3b4..00000000
--- a/www-plugins/noscript/noscript-1.9.9.69.ebuild
+++ /dev/null
@@ -1,76 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header $
-
-inherit mozextension multilib
-RESTRICT="mirror"
-
-DESCRIPTION="Restrict active contents in your web browser"
-HOMEPAGE="http://noscript.net/"
-SRC_URI="http://software.informaction.com/data/releases/${P}.xpi"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-RDEPEND="
- || (
- >=www-client/mozilla-firefox-1.5
- >=www-client/firefox-bin-1.5
- >=www-client/seamonkey-1.1
- >=www-client/seamonkey-bin-1.1
- >=www-client/icecat-3.5
- )"
-DEPEND="${RDEPEND}"
-
-S=${WORKDIR}
-
-# NOTES:
-# can also be used for Flock, MidBrowser, eMusic, Toolkit, Songbird, Fennec
-
-src_unpack() {
- xpi_unpack "${P}".xpi
-}
-
-src_install() {
- local MOZILLA_FIVE_HOME
- mozillas=""
-
- if has_version '>=www-client/mozilla-firefox-1.5'; then
- MOZILLA_FIVE_HOME="/usr/$(get_libdir)/mozilla-firefox"
- xpi_install "${WORKDIR}/${P}"
- mozillas="$(best_version www-client/mozilla-firefox) ${mozillas}"
- fi
- if has_version '>=www-client/firefox-bin-1.5'; then
- MOZILLA_FIVE_HOME="/opt/firefox"
- xpi_install "${WORKDIR}/${P}"
- mozillas="$(best_version www-client/firefox-bin) ${mozillas}"
- fi
- if has_version '>=www-client/seamonkey-1.1'; then
- MOZILLA_FIVE_HOME="/usr/$(get_libdir)/seamonkey"
- xpi_install "${WORKDIR}/${P}"
- mozillas="$(best_version www-client/seamonkey) ${mozillas}"
- fi
- if has_version '>=www-client/seamonkey-bin-1.1'; then
- MOZILLA_FIVE_HOME="/opt/seamonkey"
- xpi_install "${WORKDIR}/${P}"
- mozillas="$(best_version www-client/seamonkey-bin) ${mozillas}"
- fi
- if has_version '>=www-client/icecat-3.5'; then
- MOZILLA_FIVE_HOME="/usr/$(get_libdir)/icecat"
- xpi_install "${WORKDIR}/${P}"
- mozillas="$(best_version www-client/icecat) ${mozillas}"
- fi
-
-}
-
-pkg_postinst() {
- elog "NoScript has been installed for the following packages:"
- for i in ${mozillas}; do
- elog " $i"
- done
- elog
- elog "After installing other mozilla ebuilds, if you want to use noscript with them"
- elog "reinstall www-plugins/noscript"
-}
diff --git a/www-plugins/noscript/noscript-1.9.9.81.ebuild b/www-plugins/noscript/noscript-1.9.9.81.ebuild
new file mode 100644
index 00000000..46341fff
--- /dev/null
+++ b/www-plugins/noscript/noscript-1.9.9.81.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header $
+
+EAPI="3"
+inherit mv_mozextension
+RESTRICT="mirror"
+
+DESCRIPTION="Restrict active contents in your web browser"
+HOMEPAGE="http://noscript.net/"
+SRC_URI="http://software.informaction.com/data/releases/${P}.xpi"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# NOTES:
+# can also be used for Flock, MidBrowser, eMusic, Toolkit, Songbird, Fennec
diff --git a/www-plugins/stylish/ChangeLog b/www-plugins/stylish/ChangeLog
index 7d885791..2cdb26cc 100644
--- a/www-plugins/stylish/ChangeLog
+++ b/www-plugins/stylish/ChangeLog
@@ -2,6 +2,13 @@
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
# $Header $
+*stylish-1.0.9 (06 Jun 2010)
+
+ 06 Jun 2010; Martin Väth <martin@mvath.de>
+ +stylish-1.0.9.ebuild -stylish-1.0.8.ebuild:
+ Version bump, remove old ebuild. Switch to new mv_mozextension.eclass:
+ Installs also for other mozilla variants like seamonkey.
+
*stylish-1.0.8 (02 Apr 2010)
02 Apr 2010; Martin Väth <martin@mvath.de>
diff --git a/www-plugins/stylish/Manifest b/www-plugins/stylish/Manifest
index 61efc514..dd7de2c0 100644
--- a/www-plugins/stylish/Manifest
+++ b/www-plugins/stylish/Manifest
@@ -1,4 +1,4 @@
-DIST stylish-1.0.8-fx+tb+sm.xpi 162282 RMD160 69e7c1b1d8f42a4890d80baf42d3baf1b3f2ff0c SHA1 7dad93162370d46e904ee28414e2689691105e23 SHA256 44611b9084b4a25d66ee96d10afa560376e155588765186bc1284aa4c79b04ff
-EBUILD stylish-1.0.8.ebuild 1412 RMD160 a72337e99bc8c1e1eb12056851166f15b226aa0c SHA1 6b15ee748fe5ab357c74e4899f7feb1f6c0a0a88 SHA256 c092281c504e8726dd4897781df04a0eda4d5026de39754cc46bb852bce3a3c3
-MISC ChangeLog 467 RMD160 a8f1daf8bd760632cd95cd4fbba806795a512055 SHA1 14e4b7c8cfd4c4eba5863b4b4f9e763784c5e138 SHA256 fa040a76893abc78a0cd98a8e7fbf49965c87c7e49e76ba47d6b2e4de1075f43
+DIST stylish-1.0.9-fx+tb+sm.xpi 172082 RMD160 6588c38c2cebcaea9514c05e1e0c1bbe12c9dd6c SHA1 e74ad59f2866d8002ce7efc27969344d60a247d6 SHA256 85c231b6a0f64fdad9bdd9d3d8d80005f8a1fe77c0e19e480c30a8827c88a128
+EBUILD stylish-1.0.9.ebuild 892 RMD160 78905480b8452272774b0c4039f5195298836983 SHA1 98ef4c13d6c91457e3cccabc8b114f44792b24a8 SHA256 8c30728e9219551f8668b722e645c4cf0231191a79eea194f1b1bd08ece667c7
+MISC ChangeLog 741 RMD160 c3a1bc566b5b460d18ef9bbb8d886633dd22804d SHA1 b6e28686e3c91377283abf079392de79dc090af7 SHA256 c01fc4f5ff9a82dc70cb8060cf09b04108ac7f12633b3e86ebfdccaec68b3d3f
MISC metadata.xml 264 RMD160 4c10b5dfc6857fcb2e9cdc91ff64bb5d4a5c2204 SHA1 69886f7e401bdf99a78d428ff4361991607e86c6 SHA256 dd28333300fc1ec2dbd96450bddbdd9e1061c1eff809e687442c53c91c05d86d
diff --git a/www-plugins/stylish/stylish-1.0.8.ebuild b/www-plugins/stylish/stylish-1.0.8.ebuild
deleted file mode 100644
index 0e9d4a66..00000000
--- a/www-plugins/stylish/stylish-1.0.8.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header $
-
-EAPI="1"
-inherit mozextension multilib
-RESTRICT="mirror"
-
-DESCRIPTION="Firefox plugin to modify style of certain web pages, in particular of gentoo forums"
-HOMEPAGE="https://addons.mozilla.org/firefox/addon/2108"
-MY_P="${P}-fx+tb+sm"
-FILENAME="${MY_P}.xpi"
-SRC_URI="https://addons.mozilla.org/de/firefox/downloads/latest/2108/${FILENAME}"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="|| (
- >=www-client/mozilla-firefox-bin-1.5.0.7
- >=www-client/mozilla-firefox-1.5.0.7
-)"
-DEPEND="${RDEPEND}"
-
-S=${WORKDIR}
-
-src_unpack() {
- xpi_unpack "${FILENAME}"
-}
-
-src_install() {
- declare MOZILLA_FIVE_HOME
- if has_version '>=www-client/mozilla-firefox-1.5.0.7'; then
- MOZILLA_FIVE_HOME="/usr/$(get_libdir)/mozilla-firefox"
- xpi_install "${S}"/"${MY_P}"
- fi
- if has_version '>=www-client/mozilla-firefox-bin-1.5.0.7'; then
- MOZILLA_FIVE_HOME="/opt/firefox"
- xpi_install "${S}"/"${MY_P}"
- fi
-}
-
-src_postinstall() {
- einfo "You will probably want to setup the \"Darker forum\" style."
- einfo "The old version could be found at"
- einfo " http://jesgue.homelinux.org/other-files/dark-gentoo-forums.css"
- einfo "but now it is easier to serve with javascript activated to"
- einfo " http://userstyles.org/users/8172"
- einfo "Note that you have to temporarily disable noscript for that site."
-}
diff --git a/www-plugins/stylish/stylish-1.0.9.ebuild b/www-plugins/stylish/stylish-1.0.9.ebuild
new file mode 100644
index 00000000..f5d21961
--- /dev/null
+++ b/www-plugins/stylish/stylish-1.0.9.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header $
+
+EAPI="3"
+inherit mv_mozextension
+RESTRICT="mirror"
+
+DESCRIPTION="Firefox plugin to modify style of certain web pages, in particular of gentoo forums"
+HOMEPAGE="https://addons.mozilla.org/firefox/addon/2108"
+SRC_URI="https://addons.mozilla.org/de/firefox/downloads/latest/2108/${P}-fx+tb+sm.xpi"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+src_postinst() {
+ mv_mozextension_src_postinst
+ elog
+ elog "You will probably want to setup the \"Darker forum\" style."
+ elog "The old version could be found at"
+ elog " http://jesgue.homelinux.org/other-files/dark-gentoo-forums.css"
+ elog "but now it is easier to surf with javascript activated to"
+ elog " http://userstyles.org/users/8172"
+ elog "Note that you have to temporarily disable noscript for that site."
+}
diff --git a/www-plugins/video-downloadhelper/ChangeLog b/www-plugins/video-downloadhelper/ChangeLog
index 1e3abc59..9cceffdd 100644
--- a/www-plugins/video-downloadhelper/ChangeLog
+++ b/www-plugins/video-downloadhelper/ChangeLog
@@ -2,6 +2,11 @@
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
# $Header $
+ 06 Jun 2010; Martin Väth <martin@mvath.de>
+ +video-downloadhelper-4.7.3-r1.ebuild -video-downloadhelper-4.7.3.ebuild:
+ Switch to new mv_mozextension.eclass:
+ Installs also for other mozilla variants like seamonkey.
+
*video-downloadhelper-4.7.3 (22 Apr 2010)
22 Apr 2010; Martin Väth <martin@mvath.de>
diff --git a/www-plugins/video-downloadhelper/Manifest b/www-plugins/video-downloadhelper/Manifest
index 399cb838..d53d6b73 100644
--- a/www-plugins/video-downloadhelper/Manifest
+++ b/www-plugins/video-downloadhelper/Manifest
@@ -1,4 +1,4 @@
DIST downloadhelper-4.7.3-fx+sm.xpi 577592 RMD160 19b1ec65ebaece5f0e1eb045b55fb1279ed8540e SHA1 b57a47b3b8c72e9c45f66b1693aa70a2ff3da5c9 SHA256 4973bdbed811b31ac09c359b3c8901276cd4178870e1163645d299169f602d11
-EBUILD video-downloadhelper-4.7.3.ebuild 1017 RMD160 f1cd7a24909132fddfde901d6b73de1ff486ee1d SHA1 62cc16869637b16bc26b7f411bf4789acad9d622 SHA256 97e14e49fbc7cb24393d3dfe587623fc9bc1221b28b02447f4e936cddca22e6f
-MISC ChangeLog 755 RMD160 68537643ee560277a8d0c76c3fed82125fc04ef6 SHA1 60110ec50d3981da847bbbe18322d8fd89a3671c SHA256 b57003fdcdbb0344b9e709c5116bb88cdbf39f6967cf77db0b9f0be854d36595
+EBUILD video-downloadhelper-4.7.3-r1.ebuild 472 RMD160 967e1af73513935b579e6598e180eb70403c9d43 SHA1 0cf22d07e7748511a19df0f071a602437fe755de SHA256 b36cb92e6c8ebd30bca8f7789f94560652b7b9835cc3ab1fbb9dbbf4aa540343
+MISC ChangeLog 995 RMD160 02167b0bb91b2f2d23287a8dac115b0d30982bff SHA1 6acfb80aeb8ef2481a8f932c5aa8f4ee5901dd17 SHA256 1ea70750e99578012faa17df7b22611d19a708352dc9fd0150b4a7c277da19ad
MISC metadata.xml 264 RMD160 4c10b5dfc6857fcb2e9cdc91ff64bb5d4a5c2204 SHA1 69886f7e401bdf99a78d428ff4361991607e86c6 SHA256 dd28333300fc1ec2dbd96450bddbdd9e1061c1eff809e687442c53c91c05d86d
diff --git a/www-plugins/video-downloadhelper/video-downloadhelper-4.7.3-r1.ebuild b/www-plugins/video-downloadhelper/video-downloadhelper-4.7.3-r1.ebuild
new file mode 100644
index 00000000..98df1ea4
--- /dev/null
+++ b/www-plugins/video-downloadhelper/video-downloadhelper-4.7.3-r1.ebuild
@@ -0,0 +1,16 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header $
+
+EAPI="3"
+inherit mv_mozextension
+RESTRICT="mirror"
+
+DESCRIPTION="Firefox plugin to modify style of certain web pages, in particular of gentoo forums"
+HOMEPAGE="https://addons.mozilla.org/firefox/addon/3006"
+SRC_URI="https://addons.mozilla.org/de/firefox/downloads/latest/3006/${P#*-}-fx+sm.xpi"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
diff --git a/www-plugins/video-downloadhelper/video-downloadhelper-4.7.3.ebuild b/www-plugins/video-downloadhelper/video-downloadhelper-4.7.3.ebuild
deleted file mode 100644
index 03059e61..00000000
--- a/www-plugins/video-downloadhelper/video-downloadhelper-4.7.3.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header $
-
-inherit mozextension multilib
-RESTRICT="mirror"
-
-DESCRIPTION="Firefox plugin to modify style of certain web pages, in particular of gentoo forums"
-HOMEPAGE="https://addons.mozilla.org/firefox/addon/3006"
-MY_P="${P#*-}-fx+sm"
-FILENAME="${MY_P}.xpi"
-SRC_URI="https://addons.mozilla.org/de/firefox/downloads/latest/3006/${FILENAME}"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-RDEPEND="|| (
- >=www-client/mozilla-firefox-bin-1.5.0.7
- >=www-client/mozilla-firefox-1.5.0.7
-)"
-DEPEND="${RDEPEND}"
-
-S=${WORKDIR}
-
-src_unpack() {
- xpi_unpack "${FILENAME}"
-}
-
-src_install() {
- declare MOZILLA_FIVE_HOME
- if has_version '>=www-client/mozilla-firefox-1.5.0.7'; then
- MOZILLA_FIVE_HOME="/usr/$(get_libdir)/mozilla-firefox"
- xpi_install "${S}"/"${MY_P}"
- fi
- if has_version '>=www-client/mozilla-firefox-bin-1.5.0.7'; then
- MOZILLA_FIVE_HOME="/opt/firefox"
- xpi_install "${S}"/"${MY_P}"
- fi
-}