summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2016-07-27 07:52:35 +0200
committerMartin Väth <martin@mvath.de>2016-07-27 07:52:35 +0200
commit818b4258067b2119420900bfd44599f03355902a (patch)
tree89e01a1a08c7436316ecebf169b389e1978e7404
parentapp-shells/schily-tools: Fix "read", set POSIX_BOTH_PATH (diff)
downloadmv-818b4258067b2119420900bfd44599f03355902a.tar.gz
mv-818b4258067b2119420900bfd44599f03355902a.tar.bz2
mv-818b4258067b2119420900bfd44599f03355902a.zip
app-shells/schily-tools: Fix test -eq
-rw-r--r--app-shells/schily-tools/files/testeq.patch11
-rw-r--r--app-shells/schily-tools/schily-tools-2016.07.25-r2.ebuild (renamed from app-shells/schily-tools/schily-tools-2016.07.25-r1.ebuild)6
2 files changed, 16 insertions, 1 deletions
diff --git a/app-shells/schily-tools/files/testeq.patch b/app-shells/schily-tools/files/testeq.patch
new file mode 100644
index 00000000..22c374e2
--- /dev/null
+++ b/app-shells/schily-tools/files/testeq.patch
@@ -0,0 +1,11 @@
+--- 1/sh/test.c
++++ 1/sh/test.c
+@@ -614,7 +614,7 @@
+ Intmax_t ll_1 = 0; /* Avoid warning from silly GCC */
+ Intmax_t ll_2 = 0; /* Avoid warning from silly GCC */
+
+- if (op > TEST_EQ) {
++ if (op >= TEST_EQ) {
+ ll_1 = str2imax(arg1);
+ ll_2 = str2imax(arg2);
+ }
diff --git a/app-shells/schily-tools/schily-tools-2016.07.25-r1.ebuild b/app-shells/schily-tools/schily-tools-2016.07.25-r2.ebuild
index b828feb9..d0034988 100644
--- a/app-shells/schily-tools/schily-tools-2016.07.25-r1.ebuild
+++ b/app-shells/schily-tools/schily-tools-2016.07.25-r2.ebuild
@@ -17,7 +17,11 @@ HOMEPAGE="https://sourceforge.net/projects/schilytools/"
KEYWORDS="~amd64 ~x86"
IUSE="acl caps static-libs system-libschily system-star xattr"
-PATCHES=("$FILESDIR"/setuarg.patch "$FILESDIR"/fix_read.patch)
+PATCHES=(
+ "$FILESDIR"/fix_read.patch
+ "$FILESDIR"/setuarg.patch
+ "$FILESDIR"/testeq.patch
+)
add_iuse_expand() {
local i j