summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorlayman <layman@localhost>2013-01-26 21:09:29 +0100
committerMartin Väth <martin@mvath.de>2015-10-11 10:48:35 +0200
commit864ccd9316b95dcaf27e23985f12e82eec371cb1 (patch)
treebc9e33ddd7837f9d9e2dbd56e96fc700d9740a6d
parentBump zshrc-mv and auto-fu-zsh. Shift kill-line to zshrc-mv (diff)
downloadmv-864ccd9316b95dcaf27e23985f12e82eec371cb1.tar.gz
mv-864ccd9316b95dcaf27e23985f12e82eec371cb1.tar.bz2
mv-864ccd9316b95dcaf27e23985f12e82eec371cb1.zip
eix: add IUSE=strong-security
-rw-r--r--app-portage/eix/ChangeLog3
-rw-r--r--app-portage/eix/eix-99999999.ebuild3
-rw-r--r--app-portage/eix/metadata.xml3
-rw-r--r--profiles/use.local.desc1
4 files changed, 8 insertions, 2 deletions
diff --git a/app-portage/eix/ChangeLog b/app-portage/eix/ChangeLog
index 184c59b5..d764f7ed 100644
--- a/app-portage/eix/ChangeLog
+++ b/app-portage/eix/ChangeLog
@@ -2,6 +2,9 @@
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 26 Jan 2013; Martin Väth <martin@mvath.de>
+ Add IUSE=strong-security
+
14 Jan 2013; Martin Väth <martin@mvath.de>
Simplify handling of REPLACING_VERSIONS
diff --git a/app-portage/eix/eix-99999999.ebuild b/app-portage/eix/eix-99999999.ebuild
index 62ae5021..7d90cfbb 100644
--- a/app-portage/eix/eix-99999999.ebuild
+++ b/app-portage/eix/eix-99999999.ebuild
@@ -19,7 +19,7 @@ PROPERTIES="live"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS=""
-IUSE="clang debug +dep doc nls optimization security strong-optimization sqlite tools zsh-completion"
+IUSE="clang debug +dep doc nls optimization security strong-optimization strong-security sqlite tools zsh-completion"
RDEPEND="app-shells/push
sqlite? ( >=dev-db/sqlite-3 )
@@ -47,6 +47,7 @@ src_configure() {
$(use_with zsh-completion) \
$(use_enable nls) $(use_enable tools separate-tools) \
$(use_enable security) $(use_enable optimization) \
+ $(use_enable strong-security) \
$(use_enable strong-optimization) $(use_enable debug debugging) \
$(use_with prefix always-accept-keywords) \
$(use_with dep dep-default) \
diff --git a/app-portage/eix/metadata.xml b/app-portage/eix/metadata.xml
index afca74cd..18f55b6a 100644
--- a/app-portage/eix/metadata.xml
+++ b/app-portage/eix/metadata.xml
@@ -26,8 +26,9 @@
<flag name="doc">Create description of the eix cache file additionally in html format</flag>
<flag name="nls">Support foreign language messages (experimental; currently only de)</flag>
<flag name="optimization">Accept upstream's choices for CXXFLAGS/LDFLAGS for optimization. Absense of this USE flag does not strip user's *FLAGS</flag>
- <flag name="security">This adds some checks which can prevent certain exploits if e.g. the eix code has a bug. If you use the hardened toolchain, using this flag does not increase security and can even lead to problems. </flag>
+ <flag name="security">This adds some checks which can prevent certain exploits if e.g. the eix code has a bug. If you use the hardened toolchain, using this flag does not increase security and can even lead to problems.</flag>
<flag name="strong-optimization">Adds several more agressive CXXFLAGS/LDFLAGS for optimization like graphite (if available). May cause trouble with some buggy compiler versions. Absense of this USE flag does not strip user's *FLAGS</flag>
+ <flag name="strong-security">Add many checks to prevent exploits if eix code has a bug. This will slow down eix considerably. Use only if you are paranoid or have reasons to suspect a bug.</flag>
<flag name="sqlite">Compile in support for portage's sqlite backend; to actually use it you need additional configuration of portage and eix</flag>
<flag name="tools">Create separate binary for script helper tools; useful if they are called extremely often</flag>
</use>
diff --git a/profiles/use.local.desc b/profiles/use.local.desc
index f5189711..3a010325 100644
--- a/profiles/use.local.desc
+++ b/profiles/use.local.desc
@@ -11,6 +11,7 @@ app-portage/eix:optimization - Accept upstream's choices for CXXFLAGS/LDFLAGS fo
app-portage/eix:security - This adds some checks which can prevent certain exploits if e.g. the eix code has a bug. If you use the hardened toolchain, using this flag does not increase security and can even lead to problems.
app-portage/eix:sqlite - Compile in support for portage's sqlite backend; to actually use it you need additional configuration of portage and eix
app-portage/eix:strong-optimization - Adds several more agressive CXXFLAGS/LDFLAGS for optimization like graphite (if available). May cause trouble with some buggy compiler versions. Absense of this USE flag does not strip user's *FLAGS
+app-portage/eix:strong-security - Add many checks to prevent exploits if eix code has a bug. This will slow down eix considerably. Use only if you are paranoid or have reasons to suspect a bug.
app-portage/eix:tools - Create separate binary for script helper tools; useful if they are called extremely often
app-shells/auto-fu-zsh:compile - Byte-compile to speed up
app-shells/zsh:completion_AIX - install completions for AIX