summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2012-11-04 21:32:54 +0100
committerMartin Väth <martin@mvath.de>2015-10-11 10:48:29 +0200
commit962bfcaecd4e545536a52f876ef4f0be9f021bf8 (patch)
tree598277111202f0e91c5399147c41bcca4d3c444b
parentBump portage-bashrc-mv. Rename gpo->pgo (diff)
downloadmv-962bfcaecd4e545536a52f876ef4f0be9f021bf8.tar.gz
mv-962bfcaecd4e545536a52f876ef4f0be9f021bf8.tar.bz2
mv-962bfcaecd4e545536a52f876ef4f0be9f021bf8.zip
Add auto-fu-zsh git. Fix duplicate inherit in aufs
-rw-r--r--app-shells/auto-fu-zsh/ChangeLog5
l---------[-rw-r--r--]app-shells/auto-fu-zsh/auto-fu-zsh-0.0.1.12-r1.ebuild92
-rw-r--r--app-shells/auto-fu-zsh/auto-fu-zsh-99999999.ebuild105
-rw-r--r--sys-fs/aufs/aufs-99999999.2-r1.ebuild2
-rw-r--r--sys-fs/aufs/aufs-99999999.3-r2.ebuild2
5 files changed, 113 insertions, 93 deletions
diff --git a/app-shells/auto-fu-zsh/ChangeLog b/app-shells/auto-fu-zsh/ChangeLog
index d1029ee4..77fdd737 100644
--- a/app-shells/auto-fu-zsh/ChangeLog
+++ b/app-shells/auto-fu-zsh/ChangeLog
@@ -2,6 +2,11 @@
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+*auto-fu-zsh-99999999 (04 Nov 2012)
+
+ 04 Nov 2012; Martin Väth <martin@mvath.de>
+ Provide git version which works nicely with zsh-syntax-highlighting
+
*auto-fu-zsh-0.0.1.12-r1 (16 Aug 2012)
28 Sep 2012; Martin Väth <martin@mvath.de>
diff --git a/app-shells/auto-fu-zsh/auto-fu-zsh-0.0.1.12-r1.ebuild b/app-shells/auto-fu-zsh/auto-fu-zsh-0.0.1.12-r1.ebuild
index af4cfc64..fe5fb670 100644..120000
--- a/app-shells/auto-fu-zsh/auto-fu-zsh-0.0.1.12-r1.ebuild
+++ b/app-shells/auto-fu-zsh/auto-fu-zsh-0.0.1.12-r1.ebuild
@@ -1,91 +1 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI=5
-RESTRICT="mirror"
-inherit eutils vcs-snapshot
-
-pPN=${PN%-zsh}
-mPN="${pPN}.zsh"
-DESCRIPTION="zsh automatic complete-word and list-choices: incremental completion"
-HOMEPAGE="https://github.com/hchbaw/auto-fu.zsh/"
-SRC_URI="http://github.com/hchbaw/${mPN}/tarball/v${PV} -> ${P}.tar.gz"
-
-LICENSE="HPND"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="+compile +kill-line"
-
-DEPEND="compile? ( app-shells/zsh )"
-
-DESTPATH="/usr/share/zsh/site-contrib/${pPN}"
-
-generate_example() {
- echo "# Put something like the following into your ~/.zshrc
-# The interplay with zsh-syntax-highlighting is not perfect yet, but it
-# somewhat works if you source zsh-syntax-highlighting after that code.
-
-# First, we set sane options for the standard completion system:
-
-autoload -Uz compinit is-at-least
-compinit -D -u
-zstyle ':completion:*' completer _oldlist _complete
-zstyle ':completion:*' list-colors \${(s.:.)LS_COLORS}
-zstyle ':completion:*' menu select=1 # interactive
-zstyle ':completion:*' accept-exact-dirs true
-zstyle ':completion:*' path-completion false
-if is-at-least 4.3.10
-then zstyle ':completion:*' format \"%B%F{yellow}%K{blue}%d%k%f%b\"
-else zstyle ':completion:*' format \"%B%d%b\"
-fi
-
-# Now we source ${PN}"
- if use compile
- then echo ". ${DESTPATH}/${pPN}
-auto-fu-install"
- else echo ". ${DESTPATH}/${pPN}.zsh"
- fi
- echo "
-# Finally, we configure ${PN}
-
-zstyle ':auto-fu:highlight' input
-zstyle ':auto-fu:highlight' completion bold,fg=blue
-zstyle ':auto-fu:highlight' completion/one fg=blue
-zstyle ':auto-fu:var' postdisplay # \$'\\n-azfu-'
-#zstyle ':auto-fu:var' enable all
-#zstyle ':auto-fu:var' track-keymap-skip opp
-#zstyle ':auto-fu:var' disable magic-space
-zle-line-init() auto-fu-init
-zle -N zle-line-init
-zle -N zle-keymap-select auto-fu-zle-keymap-select"
-}
-
-src_prepare() {
- (
- umask 022
- generate_example >"${S}"/zshrc-example
- )
- # Make Ctrl-D return correctly.
- # In case of nonempty buffer act like kill-line or kill-whole-line.
- if use kill-line
- then epatch "${FILESDIR}"/kill-line.patch
- else epatch "${FILESDIR}"/exit.patch
- fi
- # Reset color with "return":
- epatch "${FILESDIR}"/reset-color.patch
- # Make it work with older zsh versions:
- epatch "${FILESDIR}"/zsh-compatibility.patch
- epatch_user
-}
-
-src_compile() {
- ! use compile || zsh -c "source ${mPN} && auto-fu-zcompile ${mPN} ." || die
-}
-
-src_install() {
- insinto "${DESTPATH}"
- doins "${mPN}"
- ! use compile || doins "${pPN}" "${pPN}.zwc"
- dodoc zshrc-example README*
-}
+auto-fu-zsh-99999999.ebuild \ No newline at end of file
diff --git a/app-shells/auto-fu-zsh/auto-fu-zsh-99999999.ebuild b/app-shells/auto-fu-zsh/auto-fu-zsh-99999999.ebuild
new file mode 100644
index 00000000..e1cff87e
--- /dev/null
+++ b/app-shells/auto-fu-zsh/auto-fu-zsh-99999999.ebuild
@@ -0,0 +1,105 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+inherit eutils
+
+pPN=${PN%-zsh}
+mPN="${pPN}.zsh"
+case ${PV} in
+99999999*)
+ EGIT_REPO_URI="git://github.com/hchbaw/${mPN}.git"
+ EGIT_PROJECT="${PN}.git"
+ EGIT_BRANCH="pu"
+ [ -n "${EVCS_OFFLINE}" ] || EGIT_REPACK=true
+ inherit git-2
+ PROPERTIES="live"
+ SRC_URI=""
+ KEYWORDS="";;
+*)
+ RESTRICT="mirror"
+ inherit vcs-snapshot
+ SRC_URI="http://github.com/hchbaw/${mPN}/tarball/v${PV} -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86";;
+esac
+
+DESCRIPTION="zsh automatic complete-word and list-choices: incremental completion"
+HOMEPAGE="https://github.com/hchbaw/auto-fu.zsh/"
+
+LICENSE="HPND"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+compile +kill-line"
+
+DEPEND="compile? ( app-shells/zsh )"
+
+DESTPATH="/usr/share/zsh/site-contrib/${pPN}"
+
+generate_example() {
+ echo "# Put something like the following into your ~/.zshrc
+
+# First, we set sane options for the standard completion system:
+
+autoload -Uz compinit is-at-least
+compinit -D -u
+zstyle ':completion:*' completer _oldlist _complete
+zstyle ':completion:*' list-colors \${(s.:.)LS_COLORS}
+zstyle ':completion:*' menu select=1 # interactive
+zstyle ':completion:*' accept-exact-dirs true
+zstyle ':completion:*' path-completion false
+if is-at-least 4.3.10
+then zstyle ':completion:*' format \"%B%F{yellow}%K{blue}%d%k%f%b\"
+else zstyle ':completion:*' format \"%B%d%b\"
+fi
+
+# Now we source ${PN}"
+ if use compile
+ then echo ". ${DESTPATH}/${pPN}
+auto-fu-install"
+ else echo ". ${DESTPATH}/${pPN}.zsh"
+ fi
+ echo "
+# Finally, we configure ${PN}
+
+zstyle ':auto-fu:highlight' input
+zstyle ':auto-fu:highlight' completion bold,fg=blue
+zstyle ':auto-fu:highlight' completion/one fg=blue
+zstyle ':auto-fu:var' postdisplay # \$'\\n-azfu-'
+#zstyle ':auto-fu:var' enable all
+#zstyle ':auto-fu:var' track-keymap-skip opp
+#zstyle ':auto-fu:var' disable magic-space
+zle-line-init() auto-fu-init
+zle -N zle-line-init
+zle -N zle-keymap-select auto-fu-zle-keymap-select"
+}
+
+src_prepare() {
+ (
+ umask 022
+ generate_example >"${S}"/zshrc-example
+ )
+ # Make Ctrl-D return correctly.
+ # In case of nonempty buffer act like kill-line or kill-whole-line.
+ if use kill-line
+ then epatch "${FILESDIR}"/kill-line.patch
+ else epatch "${FILESDIR}"/exit.patch
+ fi
+ # Reset color with "return":
+ epatch "${FILESDIR}"/reset-color.patch
+ # Make it work with older zsh versions:
+ epatch "${FILESDIR}"/zsh-compatibility.patch
+ epatch_user
+}
+
+src_compile() {
+ ! use compile || mPN="${mPN}" \
+ zsh -c 'source ${mPN} && auto-fu-zcompile ${PWD}/${mPN} ${PWD}' || die
+}
+
+src_install() {
+ insinto "${DESTPATH}"
+ doins "${mPN}"
+ ! use compile || doins "${pPN}" "${pPN}.zwc"
+ dodoc zshrc-example README*
+}
diff --git a/sys-fs/aufs/aufs-99999999.2-r1.ebuild b/sys-fs/aufs/aufs-99999999.2-r1.ebuild
index dc2169c0..5e904e0d 100644
--- a/sys-fs/aufs/aufs-99999999.2-r1.ebuild
+++ b/sys-fs/aufs/aufs-99999999.2-r1.ebuild
@@ -10,7 +10,7 @@ EGIT_BRANCH="aufs2.2"
EGIT_COMMIT=${EGIT_BRANCH}
EGIT_HAS_SUBMODULES=true
[ -n "${EVCS_OFFLINE}" ] || EGIT_REPACK=true
-inherit eutils git-2 linux-info eutils
+inherit eutils git-2 linux-info
DESCRIPTION="An entirely re-designed and re-implemented Unionfs"
HOMEPAGE="http://aufs.sourceforge.net/"
diff --git a/sys-fs/aufs/aufs-99999999.3-r2.ebuild b/sys-fs/aufs/aufs-99999999.3-r2.ebuild
index e382ecb3..da139c2c 100644
--- a/sys-fs/aufs/aufs-99999999.3-r2.ebuild
+++ b/sys-fs/aufs/aufs-99999999.3-r2.ebuild
@@ -10,7 +10,7 @@ EGIT_BRANCH="aufs3.0"
EGIT_COMMIT=${EGIT_BRANCH}
EGIT_HAS_SUBMODULES=true
[ -n "${EVCS_OFFLINE}" ] || EGIT_REPACK=true
-inherit eutils git-2 linux-info eutils
+inherit eutils git-2 linux-info
DESCRIPTION="An entirely re-designed and re-implemented Unionfs"
HOMEPAGE="http://aufs.sourceforge.net/"