summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2016-09-03 14:44:46 +0200
committerMartin Väth <martin@mvath.de>2016-09-03 14:44:46 +0200
commit982db69e8b02d31d242cd00f2a0bc39ebceb39be (patch)
treebd9109ac1e8d4e5426afe0e9de55d5f08e9c35a8
parentx11-misc/redshift: Copy old from gentoo repo to aovid gtk+3/introspection dep (diff)
downloadmv-982db69e8b02d31d242cd00f2a0bc39ebceb39be.tar.gz
mv-982db69e8b02d31d242cd00f2a0bc39ebceb39be.tar.bz2
mv-982db69e8b02d31d242cd00f2a0bc39ebceb39be.zip
Copy/bump ispell and some libs from gentoo repository to save from removal
-rw-r--r--app-dicts/ispell-de-alt/Manifest2
-rw-r--r--app-dicts/ispell-de-alt/ispell-de-alt-2-r1.ebuild30
-rw-r--r--app-dicts/ispell-de-alt/metadata.xml4
-rw-r--r--app-dicts/ispell-de/Manifest1
-rw-r--r--app-dicts/ispell-de/ispell-de-20160407.ebuild35
-rw-r--r--app-dicts/ispell-de/metadata.xml4
-rw-r--r--app-text/ispell/Manifest3
-rw-r--r--app-text/ispell/files/ispell-3.3.02-glibc-2.10.patch48
-rw-r--r--app-text/ispell/ispell-3.3.02-r1.ebuild61
-rw-r--r--app-text/ispell/ispell-3.4.00.ebuild62
-rw-r--r--app-text/ispell/metadata.xml4
11 files changed, 254 insertions, 0 deletions
diff --git a/app-dicts/ispell-de-alt/Manifest b/app-dicts/ispell-de-alt/Manifest
new file mode 100644
index 00000000..c013e555
--- /dev/null
+++ b/app-dicts/ispell-de-alt/Manifest
@@ -0,0 +1,2 @@
+DIST hk2-deutsch.tar.gz 375750 SHA256 6cc8d69ed02bf7a3ee58fa285e3692d22671aeeac2240a31812537b6e0bae655
+DIST hkgerman_2-patch-bj1.diff.gz 15187 SHA256 1dd73fd11b762c44bc9b4f4ee2a622322b8bccc27d4d40708ba3c128ad774414
diff --git a/app-dicts/ispell-de-alt/ispell-de-alt-2-r1.ebuild b/app-dicts/ispell-de-alt/ispell-de-alt-2-r1.ebuild
new file mode 100644
index 00000000..29d2effd
--- /dev/null
+++ b/app-dicts/ispell-de-alt/ispell-de-alt-2-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+RESTRICT="mirror"
+DESCRIPTION="German dictionary (traditional orthography) for ispell"
+HOMEPAGE="http://www.lasr.cs.ucla.edu/geoff/ispell-dictionaries.html"
+SRC_URI="ftp://ftp.informatik.uni-kiel.de/pub/kiel/dicts/hk${PV}-deutsch.tar.gz
+ http://www.j3e.de/ispell/hk2/hkgerman_2-patch-bj1.diff.gz"
+
+# GPL according to <http://bugs.debian.org/131124#25>
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 hppa ~mips ppc sparc x86"
+IUSE=""
+
+DEPEND="app-text/ispell:="
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"
+
+PATCHES=(hkgerman_2-patch-bj1.diff)
+
+src_install() {
+ insinto /usr/$(get_libdir)/ispell
+ doins deutsch.aff deutsch.hash
+ dosym deutsch.aff /usr/$(get_libdir)/ispell/de_DE_1901.aff
+ dosym deutsch.hash /usr/$(get_libdir)/ispell/de_DE_1901.hash
+ dodoc ANNOUNCE Changes Contributors README*
+}
diff --git a/app-dicts/ispell-de-alt/metadata.xml b/app-dicts/ispell-de-alt/metadata.xml
new file mode 100644
index 00000000..097975e3
--- /dev/null
+++ b/app-dicts/ispell-de-alt/metadata.xml
@@ -0,0 +1,4 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+</pkgmetadata>
diff --git a/app-dicts/ispell-de/Manifest b/app-dicts/ispell-de/Manifest
new file mode 100644
index 00000000..2814e71c
--- /dev/null
+++ b/app-dicts/ispell-de/Manifest
@@ -0,0 +1 @@
+DIST igerman98-20160407.tar.bz2 460772 SHA256 776058da1081d63883eaa47fa5de36cb4308b92e2a28988e7a7ab0de841576a3
diff --git a/app-dicts/ispell-de/ispell-de-20160407.ebuild b/app-dicts/ispell-de/ispell-de-20160407.ebuild
new file mode 100644
index 00000000..b5b8ddf6
--- /dev/null
+++ b/app-dicts/ispell-de/ispell-de-20160407.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+RESTRICT="mirror"
+MY_P=igerman98-${PV}
+
+DESCRIPTION="German and Swiss dictionaries for ispell"
+HOMEPAGE="http://j3e.de/ispell/igerman98/"
+SRC_URI="http://j3e.de/ispell/igerman98/dict/${MY_P}.tar.bz2"
+
+SLOT="0"
+LICENSE="GPL-2"
+IUSE=""
+KEYWORDS="alpha amd64 hppa mips ppc sparc x86"
+
+DEPEND="app-text/ispell:="
+
+S=${WORKDIR}/${MY_P}
+
+src_compile() {
+ for lang in de_DE de_AT de_CH; do
+ emake ispell/${lang}{.aff,.hash}
+ done
+}
+
+src_install () {
+ insinto /usr/$(get_libdir)/ispell
+ for lang in de_DE de_AT de_CH; do
+ doins ispell/${lang}{.aff,.hash}
+ done
+
+ dodoc Documentation/*
+ rm -f -- "${ED}/usr/share/doc/${PF}/GPL"*
+}
diff --git a/app-dicts/ispell-de/metadata.xml b/app-dicts/ispell-de/metadata.xml
new file mode 100644
index 00000000..097975e3
--- /dev/null
+++ b/app-dicts/ispell-de/metadata.xml
@@ -0,0 +1,4 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+</pkgmetadata>
diff --git a/app-text/ispell/Manifest b/app-text/ispell/Manifest
new file mode 100644
index 00000000..b801e23b
--- /dev/null
+++ b/app-text/ispell/Manifest
@@ -0,0 +1,3 @@
+DIST ispell-3.3.02-gentoo-0.3.diff.bz2 5912 SHA256 2ab38d0228b2aa4ec98f69ee1890c314c8d4e4f76d0614fb874e15ac60964d9d
+DIST ispell-3.3.02.tar.gz 619813 SHA256 7ff5aad2722ad80fa86766218b7bc622b25bad2d765ea942ba93c996b113ecb4
+DIST ispell-3.4.00.tar.gz 638770 SHA256 5dc42e458635f218032d3ae929528e5587b1e7247564f0e9f9d77d5ccab7aec2
diff --git a/app-text/ispell/files/ispell-3.3.02-glibc-2.10.patch b/app-text/ispell/files/ispell-3.3.02-glibc-2.10.patch
new file mode 100644
index 00000000..8ccd5cc7
--- /dev/null
+++ b/app-text/ispell/files/ispell-3.3.02-glibc-2.10.patch
@@ -0,0 +1,48 @@
+diff -ur ispell-3.3.02.orig/correct.c ispell-3.3.02/correct.c
+--- ispell-3.3.02.orig/correct.c 2009-08-06 18:28:32.000000000 +0300
++++ ispell-3.3.02/correct.c 2009-08-06 18:28:57.000000000 +0300
+@@ -247,7 +247,7 @@
+ struct flagent * sufent,
+ ichar_t savearea[MAX_CAPS][INPUTWORDLEN + MAXAFFIXLEN],
+ int * nsaved));
+-static char * getline P ((char * buf, int bufsize));
++static char * get_line P ((char * buf, int bufsize));
+ void askmode P ((void));
+ void copyout P ((unsigned char ** cc, int cnt));
+ static void lookharder P ((unsigned char * string));
+@@ -573,7 +573,7 @@
+
+ imove (li - 1, 0);
+ (void) putchar ('!');
+- if (getline ((char *) buf, sizeof buf) == NULL)
++ if (get_line ((char *) buf, sizeof buf) == NULL)
+ {
+ (void) putchar (7);
+ ierase ();
+@@ -598,7 +598,7 @@
+ (void) printf ("%s ", CORR_C_READONLY);
+ }
+ (void) printf (CORR_C_REPLACE_WITH);
+- if (getline ((char *) ctok, ctokl) == NULL)
++ if (get_line ((char *) ctok, ctokl) == NULL)
+ {
+ (void) putchar (7);
+ /* Put it back */
+@@ -666,7 +666,7 @@
+ unsigned char buf[100];
+ imove (li - 1, 0);
+ (void) printf (CORR_C_LOOKUP_PROMPT);
+- if (getline ((char *) buf, sizeof buf) == NULL)
++ if (get_line ((char *) buf, sizeof buf) == NULL)
+ {
+ (void) putchar (7);
+ ierase ();
+@@ -1585,7 +1585,7 @@
+ return;
+ }
+
+-static char * getline (s, len)
++static char * get_line (s, len)
+ register char * s;
+ register int len;
+ {
diff --git a/app-text/ispell/ispell-3.3.02-r1.ebuild b/app-text/ispell/ispell-3.3.02-r1.ebuild
new file mode 100644
index 00000000..54d4322e
--- /dev/null
+++ b/app-text/ispell/ispell-3.3.02-r1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+RESTRICT="mirror"
+inherit eutils multilib toolchain-funcs
+
+PATCH_VER="0.3"
+
+DESCRIPTION="fast screen-oriented spelling checker"
+HOMEPAGE="https://fmg-www.cs.ucla.edu/geoff/ispell.html"
+SRC_URI="https://fmg-www.cs.ucla.edu/geoff/tars/${P}.tar.gz
+ mirror://gentoo/${P}-gentoo-${PATCH_VER}.diff.bz2"
+
+LICENSE="HPND"
+SLOT="0/3.3.02"
+KEYWORDS="alpha amd64 ~arm hppa ~mips ppc sparc x86 ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND="
+ sys-apps/miscfiles
+ sys-libs/ncurses:0=
+"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ eapply "${FILESDIR}"/${P}-glibc-2.10.patch
+ eapply -p0 "${WORKDIR}"/${P}-gentoo-${PATCH_VER}.diff
+ sed -e "s:GENTOO_LIBDIR:$(get_libdir):" -i local.h || die
+ sed -e "s:\(^#define CC\).*:\1 \"$(tc-getCC)\":" -i local.h || die
+ sed -e "s:\(^#define CFLAGS\).*:\1 \"${CFLAGS}\":" -i config.X || die
+ eapply_user
+}
+
+src_configure() {
+ # Prepare config.sh for installation phase to avoid twice rebuild
+ emake -j1 config.sh
+ sed \
+ -e "s:^\(BINDIR='\)\(.*\):\1${ED}\2:" \
+ -e "s:^\(LIBDIR='\)\(.*\):\1${ED}\2:" \
+ -e "s:^\(MAN1DIR='\)\(.*\):\1${ED}\2:" \
+ -e "s:^\(MAN45DIR='\)\(.*\):\1${ED}\2:" \
+ < config.sh > config.sh.install
+}
+
+src_compile() {
+ emake -j1
+}
+
+src_install() {
+ mv config.sh.install config.sh
+ emake -j1 install
+ dodoc CHANGES Contributors README WISHES
+}
+
+pkg_postinst() {
+ echo
+ ewarn "If you just updated from an older version of ${PN} you *have* to re-emerge"
+ ewarn "all your dictionaries to avoid segmentation faults and other problems."
+ echo
+}
diff --git a/app-text/ispell/ispell-3.4.00.ebuild b/app-text/ispell/ispell-3.4.00.ebuild
new file mode 100644
index 00000000..4916709b
--- /dev/null
+++ b/app-text/ispell/ispell-3.4.00.ebuild
@@ -0,0 +1,62 @@
+# Copyright 2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+RESTRICT="mirror"
+inherit toolchain-funcs
+
+DESCRIPTION="fast screen-oriented spelling checker"
+HOMEPAGE="http://fmg-www.cs.ucla.edu/geoff/ispell.html"
+SRC_URI="http://fmg-www.cs.ucla.edu/geoff/tars/${P}.tar.gz"
+
+LICENSE="HPND"
+SLOT="0/3.4.00"
+KEYWORDS="alpha amd64 ~arm hppa ~mips ppc sparc x86 ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND="
+ sys-apps/miscfiles
+ sys-libs/ncurses:0=
+"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ sed -i \
+ -e 's:/usr/local/man:'"${EPREFIX}"'/usr/share/man:' \
+ -e 's:/usr/local/lib:'"${EPREFIX}"'/usr/'"$(get_libdir)/${PN}:" \
+ -e 's:/usr/local:'"${EPREFIX}"'/usr:' \
+ -- "${S}"/local.h.* || die
+ sed -i \
+ -e 's:\(^#define CC\).*:\1 "'"$(tc-getCC)"'":' \
+ -e 's:\(^#define CFLAGS\).*:\1 "'"${CFLAGS}"'":' \
+ -- "${S}"/config.X || die
+ eapply_user
+}
+
+src_configure() {
+ # Prepare config.sh for installation phase to avoid twice rebuild
+ emake -j1 config.sh
+ sed \
+ -e "s:^\(BINDIR='\)${EPREFIX}\(/usr.*\):\1${ED}\2:" \
+ -e "s:^\(LIBDIR='\)${EPREFIX}\(/usr.*\):\1${ED}\2:" \
+ -e "s:^\(MAN1DIR='\)${EPREFIX}\(/usr.*\):\1${ED}\2:" \
+ -e "s:^\(MAN45DIR='\)${EPREFIX}\(/usr.*\):\1${ED}\2:" \
+ < config.sh > config.sh.install
+}
+
+src_compile() {
+ emake -j1
+}
+
+src_install() {
+ mv config.sh.install config.sh
+ emake -j1 install
+ dodoc CHANGES Contributors README WISHES
+}
+
+pkg_postinst() {
+ echo
+ ewarn "If you just updated from an older version of ${PN} you *have* to re-emerge"
+ ewarn "all your dictionaries to avoid segmentation faults and other problems."
+ echo
+}
diff --git a/app-text/ispell/metadata.xml b/app-text/ispell/metadata.xml
new file mode 100644
index 00000000..097975e3
--- /dev/null
+++ b/app-text/ispell/metadata.xml
@@ -0,0 +1,4 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+</pkgmetadata>