summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2018-04-22 22:45:50 +0200
committerMartin Väth <martin@mvath.de>2018-04-22 22:45:50 +0200
commitbdb1ec734290fe72a24c61782d70cdb9790436bf (patch)
tree36547f96d825ad11e84dae63183d4945179e0295
parentdev-util/replacer: Version bump (diff)
downloadmv-bdb1ec734290fe72a24c61782d70cdb9790436bf.tar.gz
mv-bdb1ec734290fe72a24c61782d70cdb9790436bf.tar.bz2
mv-bdb1ec734290fe72a24c61782d70cdb9790436bf.zip
app-shells/zsh-syntax-highlighting: Alpha version bump
-rw-r--r--app-shells/zsh-syntax-highlighting/Manifest1
-rw-r--r--app-shells/zsh-syntax-highlighting/zsh-syntax-highlighting-0.6.0.ebuild14
-rw-r--r--app-shells/zsh-syntax-highlighting/zsh-syntax-highlighting-0.6.1_alpha20180411.ebuild70
-rw-r--r--app-shells/zsh-syntax-highlighting/zsh-syntax-highlighting-99999999.ebuild14
-rw-r--r--metadata/pkg_desc_index2
5 files changed, 90 insertions, 11 deletions
diff --git a/app-shells/zsh-syntax-highlighting/Manifest b/app-shells/zsh-syntax-highlighting/Manifest
index f0aaee2a..2c4488b8 100644
--- a/app-shells/zsh-syntax-highlighting/Manifest
+++ b/app-shells/zsh-syntax-highlighting/Manifest
@@ -1 +1,2 @@
DIST zsh-syntax-highlighting-0.6.0.tar.gz 111534 SHA256 e69db483e20228b72ccfa401e9ad6cf80d6edb48c68acca9102b50b311821b84 SHA512 bb83f41336e9010aa78ee5adc9a216ee53f3b4347041d1b273083940d9db4d0e4acd960150b28c41f6e5e8d00b029f00fca6f9a46955892e4547a9f2345e3b85
+DIST zsh-syntax-highlighting-0.6.1_alpha20180411.tar.gz 117022 SHA512 dac08cb2cf5df417aa57e9a9fad067b13ad1032d312345eea6b5c6c06667b436618c7a27cd4a98d0c9c34008f3fefec3f8fd694d615b493ca0b47b9ba721def8
diff --git a/app-shells/zsh-syntax-highlighting/zsh-syntax-highlighting-0.6.0.ebuild b/app-shells/zsh-syntax-highlighting/zsh-syntax-highlighting-0.6.0.ebuild
index 5d2b9820..ffc7617b 100644
--- a/app-shells/zsh-syntax-highlighting/zsh-syntax-highlighting-0.6.0.ebuild
+++ b/app-shells/zsh-syntax-highlighting/zsh-syntax-highlighting-0.6.0.ebuild
@@ -1,10 +1,12 @@
-# Copyright 2018 Gentoo Foundation
+# Copyright 2011-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
inherit readme.gentoo-r1
+RESTRICT="mirror"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
case ${PV} in
99999999*)
EGIT_REPO_URI="https://github.com/zsh-users/${PN}.git"
@@ -12,10 +14,12 @@ case ${PV} in
PROPERTIES="live"
SRC_URI=""
KEYWORDS="";;
+*alpha*)
+ EGIT_COMMIT="02a37dd919dc48e0821186e5f20e78bd0215f86a"
+ SRC_URI="https://github.com/zsh-users/${PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}-${EGIT_COMMIT}";;
*)
- RESTRICT="mirror"
- SRC_URI="https://github.com/zsh-users/${PN}/archive/${PV/_rc/-rc}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris";;
+ SRC_URI="https://github.com/zsh-users/${PN}/archive/${PV/_rc/-rc}.tar.gz -> ${P}.tar.gz";;
esac
DESCRIPTION="Fish shell like syntax highlighting for zsh"
@@ -44,7 +48,7 @@ src_prepare() {
"${S}/highlighters/main/main-highlighter.zsh" >/dev/null 2>&1 || \
sed -i -e '/for cdpath_dir/ilocal cdpath_dir' \
-- "${S}/highlighters/main/main-highlighter.zsh" || die
- eapply_user
+ default
}
src_compile() {
diff --git a/app-shells/zsh-syntax-highlighting/zsh-syntax-highlighting-0.6.1_alpha20180411.ebuild b/app-shells/zsh-syntax-highlighting/zsh-syntax-highlighting-0.6.1_alpha20180411.ebuild
new file mode 100644
index 00000000..ffc7617b
--- /dev/null
+++ b/app-shells/zsh-syntax-highlighting/zsh-syntax-highlighting-0.6.1_alpha20180411.ebuild
@@ -0,0 +1,70 @@
+# Copyright 2011-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit readme.gentoo-r1
+
+RESTRICT="mirror"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+case ${PV} in
+99999999*)
+ EGIT_REPO_URI="https://github.com/zsh-users/${PN}.git"
+ inherit git-r3
+ PROPERTIES="live"
+ SRC_URI=""
+ KEYWORDS="";;
+*alpha*)
+ EGIT_COMMIT="02a37dd919dc48e0821186e5f20e78bd0215f86a"
+ SRC_URI="https://github.com/zsh-users/${PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}-${EGIT_COMMIT}";;
+*)
+ SRC_URI="https://github.com/zsh-users/${PN}/archive/${PV/_rc/-rc}.tar.gz -> ${P}.tar.gz";;
+esac
+
+DESCRIPTION="Fish shell like syntax highlighting for zsh"
+HOMEPAGE="https://github.com/zsh-users/zsh-syntax-highlighting"
+
+LICENSE="HPND"
+SLOT="0"
+IUSE=""
+
+RDEPEND="app-shells/zsh"
+DEPEND=""
+
+DISABLE_AUTOFORMATTING="true"
+DOC_CONTENTS="In order to use ${CATEGORY}/${PN} add
+. /usr/share/zsh/site-contrib/${PN}/zsh-syntax-highlighting.zsh
+at the end of your ~/.zshrc
+For testing, you can also execute the above command in your zsh."
+
+MAKE_ARGS=(
+ "SHARE_DIR=${ED}/usr/share/zsh/site-contrib/${PN}"
+ "DOC_DIR=${ED}/usr/share/doc/${PF}"
+)
+
+src_prepare() {
+ grep -q 'local .*cdpath_dir' \
+ "${S}/highlighters/main/main-highlighter.zsh" >/dev/null 2>&1 || \
+ sed -i -e '/for cdpath_dir/ilocal cdpath_dir' \
+ -- "${S}/highlighters/main/main-highlighter.zsh" || die
+ default
+}
+
+src_compile() {
+ emake "${MAKE_ARGS[@]}"
+}
+
+src_install() {
+ emake "${MAKE_ARGS[@]}" install
+ readme.gentoo_create_doc
+}
+
+src_test() {
+ emake "${MAKE_ARGS[@]}" test
+ emake "${MAKE_ARGS[@]}" perf
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}
diff --git a/app-shells/zsh-syntax-highlighting/zsh-syntax-highlighting-99999999.ebuild b/app-shells/zsh-syntax-highlighting/zsh-syntax-highlighting-99999999.ebuild
index 5d2b9820..ffc7617b 100644
--- a/app-shells/zsh-syntax-highlighting/zsh-syntax-highlighting-99999999.ebuild
+++ b/app-shells/zsh-syntax-highlighting/zsh-syntax-highlighting-99999999.ebuild
@@ -1,10 +1,12 @@
-# Copyright 2018 Gentoo Foundation
+# Copyright 2011-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
inherit readme.gentoo-r1
+RESTRICT="mirror"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
case ${PV} in
99999999*)
EGIT_REPO_URI="https://github.com/zsh-users/${PN}.git"
@@ -12,10 +14,12 @@ case ${PV} in
PROPERTIES="live"
SRC_URI=""
KEYWORDS="";;
+*alpha*)
+ EGIT_COMMIT="02a37dd919dc48e0821186e5f20e78bd0215f86a"
+ SRC_URI="https://github.com/zsh-users/${PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}-${EGIT_COMMIT}";;
*)
- RESTRICT="mirror"
- SRC_URI="https://github.com/zsh-users/${PN}/archive/${PV/_rc/-rc}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris";;
+ SRC_URI="https://github.com/zsh-users/${PN}/archive/${PV/_rc/-rc}.tar.gz -> ${P}.tar.gz";;
esac
DESCRIPTION="Fish shell like syntax highlighting for zsh"
@@ -44,7 +48,7 @@ src_prepare() {
"${S}/highlighters/main/main-highlighter.zsh" >/dev/null 2>&1 || \
sed -i -e '/for cdpath_dir/ilocal cdpath_dir' \
-- "${S}/highlighters/main/main-highlighter.zsh" || die
- eapply_user
+ default
}
src_compile() {
diff --git a/metadata/pkg_desc_index b/metadata/pkg_desc_index
index ee7f8e63..b4d7fd49 100644
--- a/metadata/pkg_desc_index
+++ b/metadata/pkg_desc_index
@@ -41,7 +41,7 @@ app-shells/runtitle 2.10: Scripts to run commands and set the hard status line (
app-shells/schily-tools 2017.09.25 2018.04.17: Many tools from Joerg Schilling, including a POSIX compliant Bourne Shell
app-shells/set_prompt 3.0.0: An intelligent prompt for zsh or bash with status line (window title) support
app-shells/termcolors-mv 4.7: 256colors sample script and dircolors configuration for standard or 256 colors
-app-shells/zsh-syntax-highlighting 0.6.0 99999999: Fish shell like syntax highlighting for zsh
+app-shells/zsh-syntax-highlighting 0.6.0 0.6.1_alpha20180411 99999999: Fish shell like syntax highlighting for zsh
app-shells/zshrc-mv 3.11: A zshrc file initializing zsh specific interactive features
app-text/ispell 3.3.02-r1 3.4.00: fast screen-oriented spelling checker
app-text/lesspipe 1.83 1.84_alpha20180414 99999999: Wolfgang Friebel's preprocessor for sys-apps/less. Disable by appending colon