summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2017-07-27 07:18:07 +0200
committerMartin Väth <martin@mvath.de>2017-07-27 07:21:03 +0200
commitc88a1dc3c3c7685166d1a08abbf4c06db4b3ce74 (patch)
tree6997e8e6ac7488fbd51940170569703899fb4995
parentapp-portage/eix: Alpha version bump (diff)
downloadmv-c88a1dc3c3c7685166d1a08abbf4c06db4b3ce74.tar.gz
mv-c88a1dc3c3c7685166d1a08abbf4c06db4b3ce74.tar.bz2
mv-c88a1dc3c3c7685166d1a08abbf4c06db4b3ce74.zip
www-plugins/stylus: New ebuild
-rw-r--r--metadata/pkg_desc_index1
-rw-r--r--www-plugins/stylus/Manifest1
-rw-r--r--www-plugins/stylus/metadata.xml8
-rw-r--r--www-plugins/stylus/stylus-1.1.0.ebuild36
4 files changed, 46 insertions, 0 deletions
diff --git a/metadata/pkg_desc_index b/metadata/pkg_desc_index
index 1b2a5258..69314e03 100644
--- a/metadata/pkg_desc_index
+++ b/metadata/pkg_desc_index
@@ -120,6 +120,7 @@ www-plugins/locale-switcher 3-r1: Firefox plugin: button to switch GUI locale
www-plugins/noscript 2.9.0.14 5.0.7.1: Mozilla plugin: Restrict active contents like java/javascript/flash
www-plugins/requestpolicy 0.5.28-r1: Mozilla plugin: controll cross-site requests (increases privacy/security)
www-plugins/shumway 0.11.394: Mozilla plugin: Flashplayer emulation with javascript and html5
+www-plugins/stylus 1.1.0: Firefox plugin: Install themes and skins for many popular sites
www-plugins/xclear 1.8.2: Firefox plugin: button to clear URL
x11-drivers/nvidia-drivers 173.14.39-r2: NVIDIA Accelerated Graphics Driver
x11-libs/gtk+ 2.24.31-r1 3.22.16 3.22.17: Gimp ToolKit +
diff --git a/www-plugins/stylus/Manifest b/www-plugins/stylus/Manifest
new file mode 100644
index 00000000..50568efb
--- /dev/null
+++ b/www-plugins/stylus/Manifest
@@ -0,0 +1 @@
+DIST stylus_beta-1.1.0-an+fx.xpi 584681 SHA256 60d84b71bec74559ec4ac816edf971651ce8dfcc4ea720d360bae7e48717cf7e
diff --git a/www-plugins/stylus/metadata.xml b/www-plugins/stylus/metadata.xml
new file mode 100644
index 00000000..b919c846
--- /dev/null
+++ b/www-plugins/stylus/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>martin@mvath.de</email>
+ <name>Martin Väth</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/www-plugins/stylus/stylus-1.1.0.ebuild b/www-plugins/stylus/stylus-1.1.0.ebuild
new file mode 100644
index 00000000..8e07fec6
--- /dev/null
+++ b/www-plugins/stylus/stylus-1.1.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit mv_mozextension-r1 readme.gentoo-r1
+RESTRICT="mirror"
+
+DESCRIPTION="Firefox plugin: Install themes and skins for many popular sites"
+HOMEPAGE="https://addons.mozilla.org/en-US/firefox/addon/styl-us/"
+SRC_URI="https://addons.cdn.mozilla.net/user-media/addons/814814/${PN}_beta-${PV}-an+fx.xpi"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DISABLE_AUTOFORMATTING="true"
+DOC_CONTENTS="You will probably want to setup the \"Darker forum\" style.
+The old version could be found at
+ http://jesgue.homelinux.org/other-files/dark-gentoo-forums.css
+but meanwhile it is easier to surf with javascript activated to
+ http://userstyles.org/users/8172
+Note that you have to temporarily disable noscript for that site."
+
+INSTALL_ID=-i'{7a7a4a92-a2a0-41d1-9fd7-1e92480d612d}'
+
+moz_defaults "${INSTALL_ID}" firefox seamonkey
+
+src_install() {
+ moz_install "${INSTALL_ID}"
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}