summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2013-08-15 00:29:07 +0200
committerMartin Väth <martin@mvath.de>2015-10-11 10:48:50 +0200
commitccf0bd8d70549091d436fe4bb483b08104343f78 (patch)
treedf8eb75e74cc899e51b029752042e786ce88046c
parentBumps to support systemd: squash_dir, firewall-mv (diff)
downloadmv-ccf0bd8d70549091d436fe4bb483b08104343f78.tar.gz
mv-ccf0bd8d70549091d436fe4bb483b08104343f78.tar.bz2
mv-ccf0bd8d70549091d436fe4bb483b08104343f78.zip
Bump squash_dir. Fix chklref path. Fix EPREFIX usage
-rw-r--r--app-portage/trickyfetch/ChangeLog3
-rw-r--r--app-portage/trickyfetch/trickyfetch-8.1.ebuild2
-rw-r--r--app-shells/oh-my-zsh/ChangeLog3
-rw-r--r--app-shells/oh-my-zsh/oh-my-zsh-99999999.ebuild2
-rw-r--r--dev-tex/chklref/ChangeLog5
-rw-r--r--dev-tex/chklref/chklref-2.5.1-r1.ebuild (renamed from dev-tex/chklref/chklref-2.5.1.ebuild)10
-rw-r--r--eclass/ChangeLog3
-rw-r--r--eclass/mv_mozextension.eclass4
-rw-r--r--net-firewall/firewall-mv/ChangeLog3
-rw-r--r--net-firewall/firewall-mv/firewall-mv-6.10.ebuild4
-rw-r--r--sys-apps/less/ChangeLog3
-rw-r--r--sys-apps/less/less-460.ebuild2
-rw-r--r--sys-fs/squash_dir/ChangeLog10
-rw-r--r--sys-fs/squash_dir/Manifest2
-rw-r--r--sys-fs/squash_dir/squash_dir-13.1.ebuild (renamed from sys-fs/squash_dir/squash_dir-13.0.ebuild)12
15 files changed, 52 insertions, 16 deletions
diff --git a/app-portage/trickyfetch/ChangeLog b/app-portage/trickyfetch/ChangeLog
index 09a62ff5..7d7da7e5 100644
--- a/app-portage/trickyfetch/ChangeLog
+++ b/app-portage/trickyfetch/ChangeLog
@@ -4,6 +4,9 @@
*trickyfetch-8.1 (28 Jan 2013)
+ 14 Aug 2013; Martin Väth <martin@mvath.de>:
+ Simplify EPREFIX (without revision bump)
+
28 Jan 2013; Martin Väth <martin@mvath.de>:
Version bump, remove old ebuild.
diff --git a/app-portage/trickyfetch/trickyfetch-8.1.ebuild b/app-portage/trickyfetch/trickyfetch-8.1.ebuild
index 7d39eac0..3c06d73d 100644
--- a/app-portage/trickyfetch/trickyfetch-8.1.ebuild
+++ b/app-portage/trickyfetch/trickyfetch-8.1.ebuild
@@ -16,7 +16,7 @@ KEYWORDS="~amd64 ~x86"
IUSE="zsh-completion"
src_prepare() {
- sed -i -e "s'\\(PATH=.\\)/etc'\\1${EPREFIX%/}/etc'" \
+ sed -i -e "s'\\(PATH=.\\)/etc'\\1${EPREFIX}/etc'" \
-- "${S}/bin/trickyfetch"
epatch_user
}
diff --git a/app-shells/oh-my-zsh/ChangeLog b/app-shells/oh-my-zsh/ChangeLog
index a17871d5..3e774380 100644
--- a/app-shells/oh-my-zsh/ChangeLog
+++ b/app-shells/oh-my-zsh/ChangeLog
@@ -2,6 +2,9 @@
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 14 Aug 2013; Martin Väth <martin@mvath.de>:
+ Simplify EPREFIX (without revision bump)
+
21 Sep 2012; Martin Väth <martin@mvath.de>:
Bump to EAPI=5
diff --git a/app-shells/oh-my-zsh/oh-my-zsh-99999999.ebuild b/app-shells/oh-my-zsh/oh-my-zsh-99999999.ebuild
index f642db27..9b906190 100644
--- a/app-shells/oh-my-zsh/oh-my-zsh-99999999.ebuild
+++ b/app-shells/oh-my-zsh/oh-my-zsh-99999999.ebuild
@@ -21,7 +21,7 @@ PROPERTIES="live"
RDEPEND="app-shells/zsh"
ZSH_DEST="/usr/share/zsh/site-contrib/${PN}"
-ZSH_EDEST="${EPREFIX%/}${ZSH_DEST}"
+ZSH_EDEST="${EPREFIX}${ZSH_DEST}"
ZSH_TEMPLATE="templates/zshrc.zsh-template"
src_prepare() {
diff --git a/dev-tex/chklref/ChangeLog b/dev-tex/chklref/ChangeLog
index 23a41694..2707b6b5 100644
--- a/dev-tex/chklref/ChangeLog
+++ b/dev-tex/chklref/ChangeLog
@@ -2,6 +2,11 @@
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+*chkltex-2.5.1-r1 (14 Aug 2013)
+
+ 14 Aug 2013; Martin Väth <martin@mvath.de>:
+ Change install path to comply with texlive-2013
+
*chkltex-2.5.1 (11 Apr 2011)
21 Sep 2012; Martin Väth <martin@mvath.de>:
diff --git a/dev-tex/chklref/chklref-2.5.1.ebuild b/dev-tex/chklref/chklref-2.5.1-r1.ebuild
index 3dd8cd56..115c1f5a 100644
--- a/dev-tex/chklref/chklref-2.5.1.ebuild
+++ b/dev-tex/chklref/chklref-2.5.1-r1.ebuild
@@ -3,7 +3,7 @@
# $Header: $
EAPI=5
-inherit eutils # latex-package
+inherit eutils latex-package
RESTRICT="mirror"
DESCRIPTION="Finds out useless references in latex files or numbered environments that should not be"
@@ -23,6 +23,14 @@ src_prepare() {
epatch_user
}
+src_configure() {
+ econf --with-texmf-prefix="${EPREFIX}${TEXMF}"
+}
+
+src_compile() {
+ default
+}
+
src_install() {
default
dodoc README
diff --git a/eclass/ChangeLog b/eclass/ChangeLog
index bb4b5480..801bcefb 100644
--- a/eclass/ChangeLog
+++ b/eclass/ChangeLog
@@ -2,6 +2,9 @@
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 14 Aug 2013; Martin Väth <martin@mvath.de>:
+ Simplify EPREFIX
+
22 Sep 2012; Martin Väth <martin@mvath.de>:
Use AUTHOR tag. Use $ECLASS for message
diff --git a/eclass/mv_mozextension.eclass b/eclass/mv_mozextension.eclass
index 05561ad2..2c1405ee 100644
--- a/eclass/mv_mozextension.eclass
+++ b/eclass/mv_mozextension.eclass
@@ -105,8 +105,8 @@ mv_mozextension_src_install() {
local b d e i j k l s
MV_MOZ_PKG=()
MV_MOZ_DIR=()
- b="${EPREFIX%/}/usr/`get_libdir`/"
- e="${EPREFIX%/}/opt/"
+ b="${EPREFIX}/usr/`get_libdir`/"
+ e="${EPREFIX}/opt/"
mv_mozextension_calc '*fire*' 'www-client/firefox' "${b}firefox/browser"
mv_mozextension_calc '*fire*' 'www-client/firefox-bin' "${e}firefox/browser"
mv_mozextension_calc '*sea*' 'www-client/seamonkey' "${b}seamonkey"
diff --git a/net-firewall/firewall-mv/ChangeLog b/net-firewall/firewall-mv/ChangeLog
index 712c7dbd..8ef14e00 100644
--- a/net-firewall/firewall-mv/ChangeLog
+++ b/net-firewall/firewall-mv/ChangeLog
@@ -4,6 +4,9 @@
*firewall-mv-6.10 (10 Aug 2013)
+ 14 Aug 2013; Martin Väth <martin@mvath.de>:
+ Simplify EPREFIX (without revision bump)
+
10 Aug 2013; Martin Väth <martin@mvath.de>:
Version bump, remove old ebuild. Support systemd
diff --git a/net-firewall/firewall-mv/firewall-mv-6.10.ebuild b/net-firewall/firewall-mv/firewall-mv-6.10.ebuild
index 02fd2dda..fc6f38bf 100644
--- a/net-firewall/firewall-mv/firewall-mv-6.10.ebuild
+++ b/net-firewall/firewall-mv/firewall-mv-6.10.ebuild
@@ -19,8 +19,8 @@ DEPEND=""
src_prepare() {
sed -i \
- -e "s!/etc/!${EPREFIX%/}/etc/!g" \
- -e "s!/usr/!${EPREFIX%/}/usr/!g" \
+ -e "s!/etc/!${EPREFIX}/etc/!g" \
+ -e "s!/usr/!${EPREFIX}/usr/!g" \
firewall \
firewall.config \
systemd/*
diff --git a/sys-apps/less/ChangeLog b/sys-apps/less/ChangeLog
index 97b447ca..676d8014 100644
--- a/sys-apps/less/ChangeLog
+++ b/sys-apps/less/ChangeLog
@@ -4,6 +4,9 @@
*less-460.ebuild (13 Jul 2013)
+ 14 Aug 2013; Martin Väth <martin@mvath.de>:
+ Simplify EPREFIX (without revision bump)
+
13 Jul 2013; Martin Väth <martin@mvath.de>:
Bump less, less-select, and patch version
diff --git a/sys-apps/less/less-460.ebuild b/sys-apps/less/less-460.ebuild
index 6bd6476d..2941283e 100644
--- a/sys-apps/less/less-460.ebuild
+++ b/sys-apps/less/less-460.ebuild
@@ -50,7 +50,7 @@ src_prepare() {
if use less-select
then epatch "${SELECTDIR}/patches/less-${PATCHVER}-select.patch" || die
"${SELECTDIR}"/after-patch || die "${SELECTDIR}/after-patch failed"
- sed -i -e 's|\([^a-zA-Z]\)/etc/less-select-key.bin|\1'"${EPREFIX%/}"'/etc/less/select-key.bin|g' \
+ sed -i -e 's|\([^a-zA-Z]\)/etc/less-select-key.bin|\1'"${EPREFIX}"'/etc/less/select-key.bin|g' \
"${SELECTDIR}/bin/less-select" || die
fi
epatch "${FILESDIR}/${CODE2COLOR_P}.patch"
diff --git a/sys-fs/squash_dir/ChangeLog b/sys-fs/squash_dir/ChangeLog
index 207b8701..b08712fe 100644
--- a/sys-fs/squash_dir/ChangeLog
+++ b/sys-fs/squash_dir/ChangeLog
@@ -2,9 +2,17 @@
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+*squash_dir-13.1 (15 Aug 2013)
+
+ 15 Aug 2013; Martin Väth <martin@mvath.de>:
+ Version bump, remove old ebuild. Fix IGNORETOUCH for subdirectories
+
*squash_dir-13.0 (13 Aug 2013)
- 13 Auf 2013; Martin Väth <martin@mvath.de>:
+ 14 Aug 2013; Martin Väth <martin@mvath.de>:
+ Simplify EPREFIX usage (without version change)
+
+ 13 Aug 2013; Martin Väth <martin@mvath.de>:
Version bump, remove old ebuild. Support systemd
*squash_dir-12.10 (04 Aug 2013)
diff --git a/sys-fs/squash_dir/Manifest b/sys-fs/squash_dir/Manifest
index 28a8ef9a..9143c070 100644
--- a/sys-fs/squash_dir/Manifest
+++ b/sys-fs/squash_dir/Manifest
@@ -1 +1 @@
-DIST squash_dir-13.0.tar.gz 30660 SHA256 ed915083a5b50456077648adad9626a84309486f43b470f25907762f8e66fbcd SHA512 73efe1c20c9800d4c5b2bbce8e3d31ad59ecb062a1513be87bc7d9461e42ff10327e74cea3077c8696ce8c030a1fc0135cc7190d85c5b2bed59afd9f4de51e87 WHIRLPOOL e17670871737ae8141029cfb74bc7cfc6955b55056b6313081675bfe12edf50f90aedb96e65232b99ecc825144f1469be15a0bdbb42c9133b81d192294968103
+DIST squash_dir-13.1.tar.gz 30872 SHA256 94ac69ccef3ebb1b53a12a7479c3d7baacb16dbd4e30a2e42c22a6b4f0312457 SHA512 924cbd98da0772bd841fd0ea9c0d1e85c445247a177ef8b0f109f22c95dd777cf2e4a1cbb3de36d68af1b52afb8ffeb31d94f2a51eab2b73a1da23b2b3701f04 WHIRLPOOL e89b5f06d1b5f70e1e86c120758c2580ebb3480497c5c381624c6804d8d746e092085cc839ff9b51ad4f76bb954afa02bb2ec6daf6b4856f92c8726ffe34f2b2
diff --git a/sys-fs/squash_dir/squash_dir-13.0.ebuild b/sys-fs/squash_dir/squash_dir-13.1.ebuild
index 23a4befb..d60d39bb 100644
--- a/sys-fs/squash_dir/squash_dir-13.0.ebuild
+++ b/sys-fs/squash_dir/squash_dir-13.1.ebuild
@@ -25,19 +25,19 @@ RDEPEND="sys-fs/squashfs-tools
DEPEND=">=sys-devel/autoconf-2.65"
src_prepare() {
- if [ -n "${EPREFIX%/}" ]
+ if [ -n "${EPREFIX}" ]
then sed -i \
- -e "s\"'[^']*/etc/conf[.]d/${PN}'\"'${EPREFIX%/}/etc/conf.d/${PN}'\"g" \
+ -e "s\"'[^']*/etc/conf[.]d/${PN}'\"'${EPREFIX}/etc/conf.d/${PN}'\"g" \
"init.d/${PN}" || die
sed -i \
- -e "s\"=/etc/\"=${EPREFIX%/}/etc/\"" \
- -e "s\"=/usr/\"=${EPREFIX%/}/usr/\"" \
+ -e "s\"=/etc/\"=${EPREFIX}/etc/\"" \
+ -e "s\"=/usr/\"=${EPREFIX}/usr/\"" \
"systemd/${PN}@.service" || die
sed -i \
- -e "s\":/usr/sbin:/sbin'\":${EPREFIX%/}/usr/sbin:${EPREFIX%/}/sbin:/usr/sbin:/sbin'\"" \
+ -e "s\":/usr/sbin:/sbin'\":${EPREFIX}/usr/sbin:${EPREFIX}/sbin:/usr/sbin:/sbin'\"" \
"sbin/${PN}" || die
sed -i \
- -e "s\"'/lib/rc/bin:\":'${EPREFIX%/}/lib/rc/bin:/lib/rc/bin:\"" \
+ -e "s\"'/lib/rc/bin:\":'${EPREFIX}/lib/rc/bin:/lib/rc/bin:\"" \
"sbin/openrc-wrapper" || die
fi
epatch_user