summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2016-11-27 16:53:58 +0100
committerMartin Väth <martin@mvath.de>2016-11-27 16:53:58 +0100
commitd252a5f802b6491352229f648a8d91599113a0c8 (patch)
tree2619a982b3d2b5ae4f222f948405230347df22c8
parentRestore old version as different slot since new fails with palemoon (diff)
downloadmv-d252a5f802b6491352229f648a8d91599113a0c8.tar.gz
mv-d252a5f802b6491352229f648a8d91599113a0c8.tar.bz2
mv-d252a5f802b6491352229f648a8d91599113a0c8.zip
sci-mathematics/genius: Version bump
-rw-r--r--sci-mathematics/genius/Manifest1
-rw-r--r--sci-mathematics/genius/genius-1.0.21.ebuild (renamed from sci-mathematics/genius/genius-1.0.19.ebuild)43
2 files changed, 28 insertions, 16 deletions
diff --git a/sci-mathematics/genius/Manifest b/sci-mathematics/genius/Manifest
index 2e475c1f..e77c05c4 100644
--- a/sci-mathematics/genius/Manifest
+++ b/sci-mathematics/genius/Manifest
@@ -1,2 +1,3 @@
DIST genius-1.0.19.tar.xz 2447724 SHA256 e5a979d13ae39fb1ae176078dbb301222e6c7a1c2cda8d999bac3ff6a4a7e6c2
+DIST genius-1.0.21.tar.xz 2539784 SHA256 f8c06a4d0aefc1bc934e993aaf8f913451d06c2bae378da1071c3bacf39ed934
DIST genius-reference.pdf 1024944 SHA256 79011ae33ff781507185898ba76b156699061eda78ed16e15aa02195c896ee4b
diff --git a/sci-mathematics/genius/genius-1.0.19.ebuild b/sci-mathematics/genius/genius-1.0.21.ebuild
index e1296ea0..fb13052d 100644
--- a/sci-mathematics/genius/genius-1.0.19.ebuild
+++ b/sci-mathematics/genius/genius-1.0.21.ebuild
@@ -1,13 +1,15 @@
-# Copyright 2016 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
+# $Id$
EAPI=6
+GNOME2_LA_PUNT="yes"
+
inherit autotools gnome2
DESCRIPTION="Genius Mathematics Tool and the GEL Language"
HOMEPAGE="http://www.jirka.org/genius.html"
-SRC_URI="
- mirror://gnome/sources/${PN}/1.0/${P}.tar.xz
+SRC_URI="${SRC_URI}
doc? ( http://www.jirka.org/${PN}-reference.pdf )"
LICENSE="GPL-3"
@@ -18,47 +20,56 @@ IUSE="doc gnome nls"
RDEPEND="
dev-libs/glib:2
dev-libs/gmp:0=
- dev-libs/mpfr:0
+ dev-libs/mpfr:0=
dev-libs/popt
sys-libs/ncurses:0=
sys-libs/readline:0=
gnome? (
- app-text/scrollkeeper
- app-text/gnome-doc-utils
x11-libs/gtk+:2
gnome-base/libgnome
gnome-base/libgnomeui
gnome-base/libglade:2.0
x11-libs/gtksourceview:2.0
- x11-libs/vte:0 )"
+ x11-libs/vte:0 )
+"
DEPEND="${RDEPEND}
+ gnome? (
+ app-text/rarian
+ dev-util/gtk-update-icon-cache
+ app-text/gnome-doc-utils
+ )
dev-util/intltool
|| ( sys-devel/bison dev-util/yacc )
sys-devel/flex
- nls? ( sys-devel/gettext )"
-
-DOCS=(AUTHORS ChangeLog NEWS README TODO)
+ nls? ( sys-devel/gettext )
+"
src_prepare() {
eapply_user
if ! use gnome
- then sed -e "/GNOME_DOC_INIT/d" \
+ then sed \
+ -e "s/AC_PATH_PROG.\(SCROLLKEEPER_CONFIG\).*/\1=true/" \
+ -e "s/AC_PATH_PROG.\(GTK_UPDATE_ICON_CACHE\).*/\1=true/" \
configure.in >configure.ac
- rm configure.in
sed -i \
-e '/gnome-doc-utils\.make/d' \
help/Makefile.am
+ rm configure.in
eautoreconf
fi
}
src_configure() {
- gnome2_src_configure $(use_enable gnome) $(use_enable nls) \
- --disable-update-mimedb --disable-scrollkeeper \
- --disable-extra-gcc-optimization
+ gnome2_src_configure \
+ $(use_enable gnome) \
+ $(use_enable nls) \
+ $(usex gnome '' --disable-scrollkeeper) \
+ $(usex gnome '' --disable-update-mimedb) \
+ --disable-extra-gcc-optimization \
+ --disable-static
}
src_install() {
- use doc && dodoc "${DISTDIR}/${PN}-reference.pdf"
+ use doc && DOCS+=" ${DISTDIR}/${PN}-reference.pdf"
gnome2_src_install
}