summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2018-07-21 09:49:33 +0200
committerMartin Väth <martin@mvath.de>2018-07-21 22:59:39 +0200
commitdf491de93b2a061dee367e879fbe523428b8ff23 (patch)
treed65da01bf068964d52c88a3f1fbfc69cca8410e4
parentapp-shells/fast-syntax-highlighting media-tv/sundtek-tv: Version bumps (diff)
downloadmv-df491de93b2a061dee367e879fbe523428b8ff23.tar.gz
mv-df491de93b2a061dee367e879fbe523428b8ff23.tar.bz2
mv-df491de93b2a061dee367e879fbe523428b8ff23.zip
media-gfx/pqiv net-misc/sshstart: Version bump
-rw-r--r--media-gfx/pqiv/pqiv-2.10.4.ebuild77
-rw-r--r--metadata/pkg_desc_index4
-rw-r--r--net-misc/sshstart/Manifest2
-rw-r--r--net-misc/sshstart/sshstart-4.7.ebuild (renamed from net-misc/sshstart/sshstart-4.6.ebuild)0
4 files changed, 80 insertions, 3 deletions
diff --git a/media-gfx/pqiv/pqiv-2.10.4.ebuild b/media-gfx/pqiv/pqiv-2.10.4.ebuild
new file mode 100644
index 00000000..965df6bf
--- /dev/null
+++ b/media-gfx/pqiv/pqiv-2.10.4.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit linux-info toolchain-funcs xdg-utils
+
+SRC_URI="https://github.com/phillipberndt/pqiv/archive/${PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="powerful GTK based command-line image viewer with a minimal UI"
+HOMEPAGE="https://github.com/phillipberndt/pqiv http://www.pberndt.com/Programme/Linux/pqiv/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="archive ffmpeg gtk2 imagemagick kernel_linux libav pdf postscript webp"
+
+RDEPEND="
+ >=dev-libs/glib-2.32:2
+ >=x11-libs/cairo-1.6
+ gtk2? ( x11-libs/gtk+:2 )
+ !gtk2? ( x11-libs/gtk+:3 )
+ archive? ( app-arch/libarchive:0= )
+ ffmpeg? (
+ !libav? ( media-video/ffmpeg:0= )
+ libav? ( media-video/libav:0= )
+ )
+ imagemagick? ( media-gfx/imagemagick:0= )
+ pdf? ( app-text/poppler:0= )
+ postscript? ( app-text/libspectre:0= )
+ webp? ( media-libs/libwebp:0= )
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+doecho() {
+ echo "$@"
+ "$@" || die
+}
+
+pkg_setup() {
+ if use kernel_linux; then
+ CONFIG_CHECK="~INOTIFY_USER"
+ linux-info_pkg_setup
+ fi
+}
+
+src_configure() {
+ local backends="gdkpixbuf" gtkver=3
+ ! use gtk2 || gtkver=2
+ use archive && backends+=",archive,archive_cbx"
+ use ffmpeg || use libav && backends+=",libav"
+ use imagemagick && backends+=",wand"
+ use pdf && backends+=",poppler"
+ use postscript && backends+=",spectre"
+ use webp && backends+=",webp"
+
+ doecho ./configure \
+ --gtk-version=${gtkver} \
+ --backends-build=shared \
+ --backends=${backends} \
+ --prefix="${EPREFIX}/usr" \
+ --libdir="${EPREFIX}/usr/$(get_libdir)" \
+ --destdir="${ED}"
+}
+
+src_compile() {
+ tc-export CC
+ emake VERBOSE=1 CFLAGS="${CFLAGS}"
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+}
diff --git a/metadata/pkg_desc_index b/metadata/pkg_desc_index
index a89363d3..cfbdbca6 100644
--- a/metadata/pkg_desc_index
+++ b/metadata/pkg_desc_index
@@ -75,7 +75,7 @@ games-rpg/dsa-stats 1.0: calculate stat probabalities for the role playing game
games-rpg/m5figur-mv 4.0: LaTeX2e character sheet layout for the Midgard Role Playing Game (Edition M5)
mail-client/alpine 2.00-r7 2.21.1: alpine is an easy to use text-based based mail and news client
media-gfx/ipe 7.2.7: Drawing editor for creating figures in PDF or PS formats
-media-gfx/pqiv 2.10.2: powerful GTK based command-line image viewer with a minimal UI
+media-gfx/pqiv 2.10.2 2.10.4: powerful GTK based command-line image viewer with a minimal UI
media-libs/avidemux-core 2.7.1: Core libraries for simple video cutting, filtering and encoding tasks
media-libs/avidemux-plugins 2.7.1: Plugins for the video editor media-video/avidemux
media-tv/nvtv 0.4.7-r3: TV-Out for NVidia cards
@@ -90,7 +90,7 @@ net-dns/host 20070128-r1: A powerful command-line DNS query and test tool
net-dns/noip-updater 2.1.9-r4: no-ip.com dynamic DNS updater
net-firewall/firewall-mv 13.0: Initialize iptables and net-related sysctl variables
net-misc/openrdate 1.2: use TCP or UDP to retrieve the current time of another machine
-net-misc/sshstart 4.6: Start ssh-agent/ssh-add only if you really use ssh or friends
+net-misc/sshstart 4.7: Start ssh-agent/ssh-add only if you really use ssh or friends
net-print/foo2zjs 20160722: Support for printing to ZjStream-based printers
sci-geosciences/googleearth 7.1.8.3036-r1 7.3.0.3832-r1 7.3.1: A 3D interface to the planet
sci-mathematics/genius 1.0.21: Genius Mathematics Tool and the GEL Language
diff --git a/net-misc/sshstart/Manifest b/net-misc/sshstart/Manifest
index 5cbb1f03..8e8b620e 100644
--- a/net-misc/sshstart/Manifest
+++ b/net-misc/sshstart/Manifest
@@ -1 +1 @@
-DIST sshstart-4.6.tar.gz 4415 SHA512 b5245f804e731b06cbc9d4ea3699ef154d17846c46e85c1eb675073623c3f7cde62cc89044d2a8a2c0181bde3f473c7f8d09d28e449108cf39f2381d82907b91
+DIST sshstart-4.7.tar.gz 4459 SHA512 19e6cd50d22df065fb10974ff2b357a4bc596ffe1911761603988519f0adf662dd2b9e9e60fd1055f266a97943a2fe9331990a2da5c767f350eb0b03581e3a7c
diff --git a/net-misc/sshstart/sshstart-4.6.ebuild b/net-misc/sshstart/sshstart-4.7.ebuild
index ab637f2a..ab637f2a 100644
--- a/net-misc/sshstart/sshstart-4.6.ebuild
+++ b/net-misc/sshstart/sshstart-4.7.ebuild