summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2016-09-03 13:11:20 +0200
committerMartin Väth <martin@mvath.de>2016-09-03 13:11:20 +0200
commitedf5caa1d184ae6e619403e668a7ea15ffd19996 (patch)
treed93b761e2ce06e8fc66f67e03c2fe66e004f56e2
parentapp-text/recode: Copy from gentoo repository to fix WANT_AUTOMAKE (diff)
downloadmv-edf5caa1d184ae6e619403e668a7ea15ffd19996.tar.gz
mv-edf5caa1d184ae6e619403e668a7ea15ffd19996.tar.bz2
mv-edf5caa1d184ae6e619403e668a7ea15ffd19996.zip
games-action/gltron: Copy from gentoo repo to fix compilation with sed-4.2.1
-rw-r--r--games-action/gltron/Manifest2
-rw-r--r--games-action/gltron/files/gltron-0.70-configure.patch24
-rw-r--r--games-action/gltron/files/gltron-0.70-debian.patch35
-rw-r--r--games-action/gltron/files/gltron-0.70-gcc49.patch13
-rw-r--r--games-action/gltron/files/gltron-0.70-prototypes.patch24
-rw-r--r--games-action/gltron/gltron-0.70-r1.ebuild55
-rw-r--r--games-action/gltron/metadata.xml11
7 files changed, 164 insertions, 0 deletions
diff --git a/games-action/gltron/Manifest b/games-action/gltron/Manifest
new file mode 100644
index 00000000..6865d017
--- /dev/null
+++ b/games-action/gltron/Manifest
@@ -0,0 +1,2 @@
+DIST gltron-0.70-source.tar.gz 2182440 SHA256 e0c8ebb41a18a1f8d7302a9c2cb466f5b1dd63e9a9966c769075e6b6bdad8bb0
+DIST gltron.png 7570 SHA256 1f7262feb4f3bdff36573fe51dedd93905feb2ec9a54a3f8ec0a964489c40abd
diff --git a/games-action/gltron/files/gltron-0.70-configure.patch b/games-action/gltron/files/gltron-0.70-configure.patch
new file mode 100644
index 00000000..91414b39
--- /dev/null
+++ b/games-action/gltron/files/gltron-0.70-configure.patch
@@ -0,0 +1,24 @@
+configure.in is written poorly so it just stomps all over CFLAGS
+
+--- configure
++++ configure
+@@ -2805,7 +2805,7 @@
+ RANLIB="$ac_cv_prog_RANLIB"
+ fi
+
+-CFLAGS="-DSEPARATOR=\"'/'\""
++CFLAGS="$CFLAGS -DSEPARATOR=\"'/'\""
+
+ # Check whether --enable-warn or --disable-warn was given.
+ if test "${enable_warn+set}" = set; then
+@@ -2852,10 +2852,6 @@
+ else
+ enable_optimize=s
+ fi;
+-if test "x$enable_optimize" ; then
+- CFLAGS="$CFLAGS -O$enable_optimize"
+- CXXFLAGS="$CXXFLAGS -O$enable_optimize"
+-fi
+
+ # Check whether --with-sdl-prefix or --without-sdl-prefix was given.
+ if test "${with_sdl_prefix+set}" = set; then
diff --git a/games-action/gltron/files/gltron-0.70-debian.patch b/games-action/gltron/files/gltron-0.70-debian.patch
new file mode 100644
index 00000000..464cf592
--- /dev/null
+++ b/games-action/gltron/files/gltron-0.70-debian.patch
@@ -0,0 +1,35 @@
+Ripped from Debian patchset 6
+
+--- src/include/game/game_data.h
++++ src/include/game/game_data.h
+@@ -71,7 +71,7 @@
+ typedef struct AI {
+ int active;
+ int tdiff;
+- long lasttime;
++ unsigned int lasttime;
+ segment2 left, right, front, backleft;
+ } AI;
+
+--- src/include/video/fonttex.h
++++ src/include/video/fonttex.h
+@@ -10,7 +10,7 @@
+ int lower; /* lowest ascii character (normally: 32) */
+ int upper; /* highest ascii character (normally: 126) */
+
+- int *texID;
++ unsigned int *texID;
+
+ char *fontname;
+ char *bitmapname;
+--- src/video/trail.c
++++ src/video/trail.c
+@@ -19,7 +19,7 @@
+ n[1] = s->vStart.v[1] - s->vDirection.v[0];
+ tmp[0] = eye[0] - s->vStart.v[0];
+ tmp[1] = eye[1] - s->vStart.v[1];
+- if(n[0] == n[1] == 0) return length(tmp);
++ if(n[0] == 0 && n[1] == 0) return length(tmp);
+ return abs(scalarprod2(n, tmp) / length(n));
+ }
+
diff --git a/games-action/gltron/files/gltron-0.70-gcc49.patch b/games-action/gltron/files/gltron-0.70-gcc49.patch
new file mode 100644
index 00000000..4a1d5cbe
--- /dev/null
+++ b/games-action/gltron/files/gltron-0.70-gcc49.patch
@@ -0,0 +1,13 @@
+--- 1/lua/src/lib/liolib.c
++++ 1/lua/src/lib/liolib.c
+@@ -6,9 +6,9 @@
+ */
+
+
++#define __USE_MISC /* for mkstemp() */
+ #include <ctype.h>
+ #include <stdio.h>
+-#define __USE_MISC /* for mkstemp() */
+ #include <stdlib.h>
+ #include <string.h>
+ #include <time.h>
diff --git a/games-action/gltron/files/gltron-0.70-prototypes.patch b/games-action/gltron/files/gltron-0.70-prototypes.patch
new file mode 100644
index 00000000..d697f1ad
--- /dev/null
+++ b/games-action/gltron/files/gltron-0.70-prototypes.patch
@@ -0,0 +1,24 @@
+scripting.h declares these params as const so make sure they're the same.
+
+--- nebu/scripting/scripting.c
++++ nebu/scripting/scripting.c
+@@ -169,16 +169,16 @@
+ return status;
+ }
+
+-void scripting_RunFile(char *name) {
++void scripting_RunFile(const char *name) {
+ lua_dofile(L, name);
+ }
+
+-void scripting_Run(char *command) {
++void scripting_Run(const char *command) {
+ /* fprintf(stderr, "[command] %s\n", command); */
+ lua_dostring(L, command);
+ }
+
+-void scripting_RunFormat(char *format, ... ) {
++void scripting_RunFormat(const char *format, ... ) {
+ char buf[4096];
+ va_list ap;
+ va_start(ap, format);
diff --git a/games-action/gltron/gltron-0.70-r1.ebuild b/games-action/gltron/gltron-0.70-r1.ebuild
new file mode 100644
index 00000000..5aa79fe1
--- /dev/null
+++ b/games-action/gltron/gltron-0.70-r1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools eutils
+
+DESCRIPTION="3d tron, just like the movie"
+HOMEPAGE="http://gltron.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}-source.tar.gz
+ mirror://gentoo/${PN}.png"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+DEPEND="virtual/opengl
+ media-libs/libpng:0
+ media-libs/libsdl[sound,video]
+ media-libs/sdl-mixer[vorbis]
+ media-libs/sdl-sound[vorbis,mikmod]
+ media-libs/smpeg
+ media-libs/libmikmod"
+RDEPEND=${DEPEND}
+
+src_prepare() {
+ eapply -p0 "${FILESDIR}"/${P}-configure.patch
+ eapply -p0 "${FILESDIR}"/${P}-prototypes.patch
+ eapply -p0 "${FILESDIR}"/${P}-debian.patch
+ eapply "${FILESDIR}"/${P}-gcc49.patch
+ sed -i \
+ -e '/^gltron_LINK/s/$/ $(LDFLAGS)/' \
+ Makefile.in || die
+ mv configure.in configure.ac || die
+ sed -i -e 's/ #/#/' "${S}/nebu/scripting/Makefile.am" || die
+ eapply_user
+ eautoreconf
+}
+
+src_configure() {
+ # warn/debug/profile just modify CFLAGS, they aren't
+ # real options, so don't utilize USE flags here
+ econf \
+ --datadir=/usr/share/games \
+ --datarootdir=/usr/share \
+ --disable-warn \
+ --disable-debug \
+ --disable-profile
+}
+
+src_install() {
+ default
+ doicon "${DISTDIR}"/${PN}.png
+ make_desktop_entry ${PN} GLtron
+}
diff --git a/games-action/gltron/metadata.xml b/games-action/gltron/metadata.xml
new file mode 100644
index 00000000..06123063
--- /dev/null
+++ b/games-action/gltron/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">gltron</remote-id>
+ </upstream>
+</pkgmetadata>