summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2017-09-06 10:49:04 +0200
committerMartin Väth <martin@mvath.de>2017-09-06 10:49:04 +0200
commitfc5a06198bbdcfdb7a6d99f4a8677f6acc51ea49 (patch)
tree8bddf954dba6845e79c06ef2668a4535e21e116c
parentapp-portage/eix: Version bump (diff)
downloadmv-fc5a06198bbdcfdb7a6d99f4a8677f6acc51ea49.tar.gz
mv-fc5a06198bbdcfdb7a6d99f4a8677f6acc51ea49.tar.bz2
mv-fc5a06198bbdcfdb7a6d99f4a8677f6acc51ea49.zip
app-portage/eix: export AR for lto plugin test
-rw-r--r--app-portage/eix/eix-0.33.1_alpha6.ebuild4
-rw-r--r--app-portage/eix/eix-99999999.ebuild4
2 files changed, 6 insertions, 2 deletions
diff --git a/app-portage/eix/eix-0.33.1_alpha6.ebuild b/app-portage/eix/eix-0.33.1_alpha6.ebuild
index 06cbe5d0..e609e1ca 100644
--- a/app-portage/eix/eix-0.33.1_alpha6.ebuild
+++ b/app-portage/eix/eix-0.33.1_alpha6.ebuild
@@ -6,7 +6,7 @@ WANT_LIBTOOL=none
AUTOTOOLS_AUTO_DEPEND=no
MESON_AUTO_DEPEND=no
PLOCALES="de ru"
-inherit autotools bash-completion-r1 l10n meson_optional tmpfiles
+inherit autotools bash-completion-r1 l10n meson_optional tmpfiles toolchain-funcs
case ${PV} in
99999999*)
@@ -45,6 +45,8 @@ DEPEND="${BOTHDEPEND}
mesonflto() {
use meson && use strong-optimization || return 0
einfo "Checking whether compiler supports -flto and static archives"
+ local -x AR=$(tc-getAR)
+ local -x CXX=$(tc-getCXX)
bash contrib/meson-flto-test.sh && return
eerror "For app-portage/eix[meson strong-optimization] it is necessary"
eerror "that your compiler can access static archives with -flto."
diff --git a/app-portage/eix/eix-99999999.ebuild b/app-portage/eix/eix-99999999.ebuild
index 06cbe5d0..e609e1ca 100644
--- a/app-portage/eix/eix-99999999.ebuild
+++ b/app-portage/eix/eix-99999999.ebuild
@@ -6,7 +6,7 @@ WANT_LIBTOOL=none
AUTOTOOLS_AUTO_DEPEND=no
MESON_AUTO_DEPEND=no
PLOCALES="de ru"
-inherit autotools bash-completion-r1 l10n meson_optional tmpfiles
+inherit autotools bash-completion-r1 l10n meson_optional tmpfiles toolchain-funcs
case ${PV} in
99999999*)
@@ -45,6 +45,8 @@ DEPEND="${BOTHDEPEND}
mesonflto() {
use meson && use strong-optimization || return 0
einfo "Checking whether compiler supports -flto and static archives"
+ local -x AR=$(tc-getAR)
+ local -x CXX=$(tc-getCXX)
bash contrib/meson-flto-test.sh && return
eerror "For app-portage/eix[meson strong-optimization] it is necessary"
eerror "that your compiler can access static archives with -flto."