summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2013-01-14 20:28:40 +0100
committerMartin Väth <martin@mvath.de>2015-10-11 10:48:35 +0200
commitfc683c3b1c826e9f95096c3f119b0b18ebeeaa86 (patch)
tree2a1e0a0980b86b7aa885c315eca5fdb502b005b3
parentBump zshrc-mv (diff)
downloadmv-fc683c3b1c826e9f95096c3f119b0b18ebeeaa86.tar.gz
mv-fc683c3b1c826e9f95096c3f119b0b18ebeeaa86.tar.bz2
mv-fc683c3b1c826e9f95096c3f119b0b18ebeeaa86.zip
eix: Simplify handling of REPLACING_VERSIONS
-rw-r--r--app-portage/eix/ChangeLog5
-rw-r--r--app-portage/eix/eix-99999999.ebuild23
2 files changed, 10 insertions, 18 deletions
diff --git a/app-portage/eix/ChangeLog b/app-portage/eix/ChangeLog
index 81a3c50e..184c59b5 100644
--- a/app-portage/eix/ChangeLog
+++ b/app-portage/eix/ChangeLog
@@ -1,7 +1,10 @@
# ChangeLog for app-portage/eix
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 14 Jan 2013; Martin Väth <martin@mvath.de>
+ Simplify handling of REPLACING_VERSIONS
+
28 Sep 2012; Martin Väth <martin@mvath.de>
Bump to EAPI=5
diff --git a/app-portage/eix/eix-99999999.ebuild b/app-portage/eix/eix-99999999.ebuild
index 6a3ce43a..62ae5021 100644
--- a/app-portage/eix/eix-99999999.ebuild
+++ b/app-portage/eix/eix-99999999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
@@ -29,22 +29,11 @@ DEPEND="${RDEPEND}
sys-devel/gettext"
pkg_setup() {
- local i j eixcache
- for i in ${REPLACING_VERSIONS[*]}
- do case ${i} in
- 0.*)
- j=${i#0.}
- j=${j%%.*}
- [ "${j}" -gt 25 ] && continue
- [ "${j}" -eq 25 ] && {
- j=${i#0.25.}
- [ "${j%%.*}" -ge 3 ] && continue
- }
- eixcache=${EROOT}/var/cache/${PN}
- test -f "${eixcache}" && rm -f -- "${eixcache}"
- break;;
- esac
- done
+ case " ${REPLACING_VERSIONS}" in
+ *\ 0.[0-9].*|*\ 0.1[0-9].*|*\ 0.2[0-4].*|*\ 0.25.0*)
+ local eixcache="${EROOT}/var/cache/${PN}"
+ test -f "${eixcache}" && rm -f -- "${eixcache}";;
+ esac
}
src_prepare() {