summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2022-07-05 11:57:10 +0200
committerMartin Väth <martin@mvath.de>2022-07-05 11:57:10 +0200
commit254228dddd6119009ae3174f85d951c66fd63bee (patch)
tree8dfebc29bc19d2ed0961e43a9aa09fe9d49e2854
parentapp-shells/fast-syntax-highlighting: Remove the downloading security thread (diff)
downloadmv-254228dddd6119009ae3174f85d951c66fd63bee.tar.gz
mv-254228dddd6119009ae3174f85d951c66fd63bee.tar.bz2
mv-254228dddd6119009ae3174f85d951c66fd63bee.zip
media-video/pipewire: Version bump
Signed-off-by: Martin Väth <martin@mvath.de>
-rw-r--r--media-video/pipewire/Manifest2
-rw-r--r--media-video/pipewire/files/pipewire-0.3.52-pulse-path.patch78
-rw-r--r--media-video/pipewire/pipewire-0.3.53.ebuild (renamed from media-video/pipewire/pipewire-0.3.52.ebuild)1
-rw-r--r--metadata/pkg_desc_index4
4 files changed, 3 insertions, 82 deletions
diff --git a/media-video/pipewire/Manifest b/media-video/pipewire/Manifest
index cbb3bce1..6d6aa765 100644
--- a/media-video/pipewire/Manifest
+++ b/media-video/pipewire/Manifest
@@ -1 +1 @@
-DIST pipewire-0.3.52.tar.gz 1810238 BLAKE2B bb75eff5fe7700d0a303fbfed7910aebd82346a5a21c4a0d17c06e6991bc90bb6d4f6b9559c25788494cb11faff957523dcd7f0c4c8a40be11b81c63a5a9e5ef SHA512 30e9cf74c92babafe386f02a03bb5c41a8ee5591a02f15845cca1ee44f091ce68eb14d48943d43b680cb525026a19e0290997670f9a82156eaa72e974fe6d01a
+DIST pipewire-0.3.53.tar.gz 1783505 BLAKE2B 269466c6ba78cb85516dc714f3aa5d71cdf72a859b6e1a11c60062da6dcd56eefc78958fe026b9fd11d61fd6fbe6f2aac54a2a9fd77d4ee474687f5d54628c38 SHA512 50f23a7b71f3eb20657ff75de54a9f3056270bf05a5472ec9c7dea1c9d0ed391b6b09496d58b065c3cbc40f9be8088b6737cbf0731973498bcd5a8176c42d443
diff --git a/media-video/pipewire/files/pipewire-0.3.52-pulse-path.patch b/media-video/pipewire/files/pipewire-0.3.52-pulse-path.patch
deleted file mode 100644
index 09d8ffff..00000000
--- a/media-video/pipewire/files/pipewire-0.3.52-pulse-path.patch
+++ /dev/null
@@ -1,78 +0,0 @@
-https://gitlab.freedesktop.org/pipewire/pipewire/-/commit/4821c7ca2fe5e25ba018e9f5d4967f08d6bb816f
-
-From: Wim Taymans <wtaymans@redhat.com>
-Date: Thu, 9 Jun 2022 17:06:07 +0200
-Subject: [PATCH] pulse-server: don't append "/pulse" to PULSE_RUNTIME_PATH
-
-Fixes #2431
---- a/src/modules/module-protocol-pulse/server.c
-+++ b/src/modules/module-protocol-pulse/server.c
-@@ -460,7 +460,7 @@ static int parse_unix_address(const char *address, struct sockaddr_storage *addr
- if (address[0] != '/') {
- char runtime_dir[PATH_MAX];
-
-- if ((res = get_runtime_dir(runtime_dir, sizeof(runtime_dir), "pulse")) < 0)
-+ if ((res = get_runtime_dir(runtime_dir, sizeof(runtime_dir))) < 0)
- return res;
-
- res = snprintf(addr.sun_path, sizeof(addr.sun_path),
---- a/src/modules/module-protocol-pulse/utils.c
-+++ b/src/modules/module-protocol-pulse/utils.c
-@@ -50,27 +50,30 @@
- #include "log.h"
- #include "utils.h"
-
--int get_runtime_dir(char *buf, size_t buflen, const char *dir)
-+int get_runtime_dir(char *buf, size_t buflen)
- {
-- const char *runtime_dir;
-+ const char *runtime_dir, *dir = NULL;
- struct stat stat_buf;
- int res, size;
-
- runtime_dir = getenv("PULSE_RUNTIME_PATH");
-- if (runtime_dir == NULL)
-+ if (runtime_dir == NULL) {
- runtime_dir = getenv("XDG_RUNTIME_DIR");
--
-+ dir = "pulse";
-+ }
- if (runtime_dir == NULL) {
- pw_log_error("could not find a suitable runtime directory in"
- "$PULSE_RUNTIME_PATH and $XDG_RUNTIME_DIR");
- return -ENOENT;
- }
-
-- size = snprintf(buf, buflen, "%s/%s", runtime_dir, dir);
-+ size = snprintf(buf, buflen, "%s%s%s", runtime_dir,
-+ dir ? "/" : "", dir ? dir : "");
- if (size < 0)
- return -errno;
- if ((size_t) size >= buflen) {
-- pw_log_error("path %s/%s too long", runtime_dir, dir);
-+ pw_log_error("path %s%s%s too long", runtime_dir,
-+ dir ? "/" : "", dir ? dir : "");
- return -ENAMETOOLONG;
- }
-
-@@ -182,7 +185,7 @@ int create_pid_file(void) {
- FILE *f;
- int res;
-
-- if ((res = get_runtime_dir(pid_file, sizeof(pid_file), "pulse")) < 0)
-+ if ((res = get_runtime_dir(pid_file, sizeof(pid_file))) < 0)
- return res;
-
- if (strlen(pid_file) > PATH_MAX - sizeof("/pid")) {
---- a/src/modules/module-protocol-pulse/utils.h
-+++ b/src/modules/module-protocol-pulse/utils.h
-@@ -31,7 +31,7 @@
- struct client;
- struct pw_context;
-
--int get_runtime_dir(char *buf, size_t buflen, const char *dir);
-+int get_runtime_dir(char *buf, size_t buflen);
- int check_flatpak(struct client *client, pid_t pid);
- pid_t get_client_pid(struct client *client, int client_fd);
- const char *get_server_name(struct pw_context *context);
-GitLab
diff --git a/media-video/pipewire/pipewire-0.3.52.ebuild b/media-video/pipewire/pipewire-0.3.53.ebuild
index b16e3d3d..76dc5436 100644
--- a/media-video/pipewire/pipewire-0.3.52.ebuild
+++ b/media-video/pipewire/pipewire-0.3.53.ebuild
@@ -123,7 +123,6 @@ DOCS=( {README,INSTALL}.md NEWS )
PATCHES=(
"${FILESDIR}"/${PN}-0.3.25-enable-failed-mlock-warning.patch
- "${FILESDIR}"/${P}-pulse-path.patch
)
# limitsdfile related code taken from =sys-auth/realtime-base-0.1
diff --git a/metadata/pkg_desc_index b/metadata/pkg_desc_index
index f1e5b231..4fb07c87 100644
--- a/metadata/pkg_desc_index
+++ b/metadata/pkg_desc_index
@@ -37,7 +37,7 @@ app-portage/useflags 4.2: Print or save the current USE-flag state and compare w
app-portage/world-mv 3.20: Organize your world file and find installed packages or differences to @world
app-shells/auto-fu-zsh 0.0.1.12-r4 0.0.1.12_p0 99999999: zsh automatic complete-word and list-choices: incremental completion
app-shells/dash 99999999: Descendant of the NetBSD ash. POSIX compliant except for multibyte characters
-app-shells/fast-syntax-highlighting 1.6.6 99999999: Optimized and extended zsh-syntax-highlighting
+app-shells/fast-syntax-highlighting 1.6.6-r1 99999999: Optimized and extended zsh-syntax-highlighting
app-shells/oh-my-zsh 99999999: A ready-to-use zsh configuration with plugins
app-shells/push 3.4-r1: A POSIX shell function to treat a variable like an array, quoting args
app-shells/quoter 4.2-r1: Quote arguments or standard input for usage in POSIX shell by eval
@@ -82,7 +82,7 @@ media-tv/sundtek-tv 210803.071224: Sundtek MediaTV Pro III Drivers
media-tv/w_scan 20170107-r1: Scan for DVB-C/DVB-T/DVB-S channels without prior knowledge of frequencies
media-video/avidemux 2.7.8: Video editor designed for simple cutting, filtering and encoding tasks
media-video/avinfo 1.0_alpha15_p1-r1: Utility for displaying AVI information
-media-video/pipewire 0.3.52: Multimedia processing graphs
+media-video/pipewire 0.3.53: Multimedia processing graphs
media-video/video-mv 17.2: Frontends for using mplayer/mencoder, ffmpeg/libav, or tzap as video recorder
net-dialup/accounting 1.60.45.3.1-r1: Give statistics about dialup connections. Originally part of SuSE's smpppd
net-dialup/martian-modem 20100123-r3: ltmodem alternative driver providing support for Agere Systems winmodems