summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2022-07-10 15:06:19 +0200
committerMartin Väth <martin@mvath.de>2022-07-10 15:06:19 +0200
commit82d3d9f8a028f6c1b7ce930e6ab9085c6013b2fa (patch)
tree371fbe817d64f2ad390b537f220acf8c774cd448
parentapp-portage/logclean: Version bump (diff)
downloadmv-82d3d9f8a028f6c1b7ce930e6ab9085c6013b2fa.tar.gz
mv-82d3d9f8a028f6c1b7ce930e6ab9085c6013b2fa.tar.bz2
mv-82d3d9f8a028f6c1b7ce930e6ab9085c6013b2fa.zip
app-portage/eix: Version bump. meson.eclass: Update from gentoo repository
Signed-off-by: Martin Väth <martin@mvath.de>
-rw-r--r--app-portage/eix/Manifest2
-rw-r--r--app-portage/eix/eix-0.36.4.ebuild (renamed from app-portage/eix/eix-0.36.3.ebuild)0
-rw-r--r--eclass/ChangeLog4
-rw-r--r--eclass/meson.eclass25
-rw-r--r--eclass/mv_mozextension-r1.eclass2
-rw-r--r--metadata/pkg_desc_index2
6 files changed, 26 insertions, 9 deletions
diff --git a/app-portage/eix/Manifest b/app-portage/eix/Manifest
index b9f4ec66..a40241e9 100644
--- a/app-portage/eix/Manifest
+++ b/app-portage/eix/Manifest
@@ -1 +1 @@
-DIST eix-0.36.3.tar.xz 639864 BLAKE2B f74b7c4087e5145f3a2e6ee8b0034e5104de8ef81ec810f2d9fc75d161181f71396f27dc635466685650182473fdfb542f4cec6509ddee0a3bb0d7d620b7d42d SHA512 9fd7c64df6acf27e9ed07ee77ee7f209fb0fb2db9a3dbbc78c1f5b25e6d4786dffeea64bf8ddee3bfe4fe35445c8173103428e184c966964b2973d5737152679
+DIST eix-0.36.4.tar.xz 640776 BLAKE2B 32486b6ce5e5d2a32bb6fc8581bbc37da6cef9cac0cecbd3d0cc6db8bf5b6bcb3c0a31e28df462edcf06056d279a88e64b4c526b430ce40a0614c0367710243c SHA512 5b716cbd688bb5d8efadc7d47de9fb3238776ff10b11165abe02623421be82d17f2d51596d3f263219461188aa08974af1b559b4e43c31d9ee0682f21febb049
diff --git a/app-portage/eix/eix-0.36.3.ebuild b/app-portage/eix/eix-0.36.4.ebuild
index 8a8ed03d..8a8ed03d 100644
--- a/app-portage/eix/eix-0.36.3.ebuild
+++ b/app-portage/eix/eix-0.36.4.ebuild
diff --git a/eclass/ChangeLog b/eclass/ChangeLog
index c210c8f1..42aefa5e 100644
--- a/eclass/ChangeLog
+++ b/eclass/ChangeLog
@@ -100,3 +100,7 @@
required-use-warn: Make required-use-warn function non-internal
stardict: Drop outdated dependency
mv_mozextension-r1: Do no longer support seamonkey-bin
+
+ 10 Jul 2022; Martin Väth <martin@mvath.de>:
+ Update meson eclass
+ mv_mozextension-r1: Update docu
diff --git a/eclass/meson.eclass b/eclass/meson.eclass
index c9d20578..4656c277 100644
--- a/eclass/meson.eclass
+++ b/eclass/meson.eclass
@@ -51,12 +51,12 @@ inherit multiprocessing ninja-utils python-utils-r1 toolchain-funcs
EXPORT_FUNCTIONS src_configure src_compile src_test src_install
-_MESON_DEPEND=">=dev-util/meson-0.58.2-r1
- >=dev-util/ninja-1.8.2
+_MESON_DEPEND=">=dev-util/meson-0.59.4
+ ${NINJA_DEPEND}
dev-util/meson-format-array
"
-# @ECLASS-VARIABLE: MESON_AUTO_DEPEND
+# @ECLASS_VARIABLE: MESON_AUTO_DEPEND
# @DESCRIPTION:
# Set to 'no' to disable automatically adding to DEPEND. This lets
# ebuilds form conditional depends by using ${MESON_DEPEND} in
@@ -71,18 +71,18 @@ if [[ ${MESON_AUTO_DEPEND} != "no" ]] ; then
fi
__MESON_AUTO_DEPEND=${MESON_AUTO_DEPEND} # See top of eclass
-# @ECLASS-VARIABLE: BUILD_DIR
+# @ECLASS_VARIABLE: BUILD_DIR
# @DEFAULT_UNSET
# @DESCRIPTION:
# Build directory, location where all generated files should be placed.
# If this isn't set, it defaults to ${WORKDIR}/${P}-build.
-# @ECLASS-VARIABLE: EMESON_BUILDTYPE
+# @ECLASS_VARIABLE: EMESON_BUILDTYPE
# @DESCRIPTION:
# The buildtype value to pass to meson setup.
: ${EMESON_BUILDTYPE=plain}
-# @ECLASS-VARIABLE: EMESON_SOURCE
+# @ECLASS_VARIABLE: EMESON_SOURCE
# @DEFAULT_UNSET
# @DESCRIPTION:
# The location of the source files for the project; this is the source
@@ -298,6 +298,8 @@ meson_feature() {
meson_src_configure() {
debug-print-function ${FUNCNAME} "$@"
+ [[ -n "${NINJA_DEPEND}" ]] || ewarn "Unknown value '${NINJA}' for \${NINJA}"
+
local BUILD_CFLAGS=${BUILD_CFLAGS}
local BUILD_CPPFLAGS=${BUILD_CPPFLAGS}
local BUILD_CXXFLAGS=${BUILD_CXXFLAGS}
@@ -336,6 +338,16 @@ meson_src_configure() {
--build.pkg-config-path "${BUILD_PKG_CONFIG_PATH}${BUILD_PKG_CONFIG_PATH:+:}${EPREFIX}/usr/share/pkgconfig"
--pkg-config-path "${PKG_CONFIG_PATH}${PKG_CONFIG_PATH:+:}${EPREFIX}/usr/share/pkgconfig"
--native-file "$(_meson_create_native_file)"
+
+ # gcc[pch] is masked in profiles due to consistent bugginess
+ # without forcing this off, some packages may fail too (like gjs,
+ # bug #839549), but in any case, we don't want to bother attempting
+ # this.
+ -Db_pch=false
+
+ # It's Gentoo policy to not have builds die on blanket -Werror, as it's
+ # an upstream development matter. bug #754279.
+ -Dwerror=false
)
if [[ -n ${EMESON_BUILDTYPE} ]]; then
@@ -435,6 +447,7 @@ meson_install() {
local mesoninstallargs=(
-C "${BUILD_DIR}"
--destdir "${D}"
+ --no-rebuild
"$@"
)
diff --git a/eclass/mv_mozextension-r1.eclass b/eclass/mv_mozextension-r1.eclass
index 2f40c399..61b6bb89 100644
--- a/eclass/mv_mozextension-r1.eclass
+++ b/eclass/mv_mozextension-r1.eclass
@@ -106,7 +106,7 @@ moz_install$quoteargs
}"
}
-# @ECLASS-VARIABLE: MOZ_BDEPEND
+# @ECLASS_VARIABLE: MOZ_BDEPEND
# @DESCRIPTION:
# This is an eclass-generated depend expression needed for moz_unpack to work
MOZ_BDEPEND='app-arch/unzip'
diff --git a/metadata/pkg_desc_index b/metadata/pkg_desc_index
index a8b43289..13379284 100644
--- a/metadata/pkg_desc_index
+++ b/metadata/pkg_desc_index
@@ -26,7 +26,7 @@ app-misc/knapsack 7.3.1: A fast solver for the 0/1-knapsack problem with multipl
app-misc/machine-learning-mv 1.3: Some machine learning experiments
app-mobilephone/adb-sync 0_p20190101: Synchronize files between a PC and an Android device using ADB
app-portage/changelog-gitrepo 1.1: Create ChangeLog data for gentoo repositories from git
-app-portage/eix 0.36.3 99999999: Search and query ebuilds
+app-portage/eix 0.36.4 99999999: Search and query ebuilds
app-portage/etcat 1.0.2 99999999: Updated version of an old Portage information extractor
app-portage/find_cruft 5.2: find cruft files not managed by portage
app-portage/logclean 18.4.2: Keep only (compressed) logs of installed packages and cleanup emerge.log