summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2022-02-18 16:35:54 +0100
committerMartin Väth <martin@mvath.de>2022-02-18 16:35:54 +0100
commitfa99af575a788ccab92ec491f356827540acc420 (patch)
tree2c8866bfd2cbf7e8734f3d302689d877e4138dbe
parentMake pkgcheck happy (diff)
downloadmv-fa99af575a788ccab92ec491f356827540acc420.tar.gz
mv-fa99af575a788ccab92ec491f356827540acc420.tar.bz2
mv-fa99af575a788ccab92ec491f356827540acc420.zip
app-shells/schily-tools media-gfx/pqiv: Fix. Apply uclib patch always
Signed-off-by: Martin Väth <martin@mvath.de>
-rw-r--r--app-shells/schily-tools/files/fix-clone-uclibc.patch (renamed from app-shells/schily-tools/files/cdrtools-fix-clone-uclibc.patch)26
-rw-r--r--app-shells/schily-tools/schily-tools-2021.09.18.ebuild11
-rw-r--r--media-gfx/pqiv/pqiv-2.11.ebuild2
3 files changed, 19 insertions, 20 deletions
diff --git a/app-shells/schily-tools/files/cdrtools-fix-clone-uclibc.patch b/app-shells/schily-tools/files/fix-clone-uclibc.patch
index 9ffd28a5..a1c0011a 100644
--- a/app-shells/schily-tools/files/cdrtools-fix-clone-uclibc.patch
+++ b/app-shells/schily-tools/files/fix-clone-uclibc.patch
@@ -1,7 +1,9 @@
-diff -Naur cdrtools-3.02.orig/readcd/readcd.c cdrtools-3.02/readcd/readcd.c
---- cdrtools-3.02.orig/readcd/readcd.c 2016-01-24 11:15:19.000000000 -0500
-+++ cdrtools-3.02/readcd/readcd.c 2016-04-09 12:29:54.727635502 -0400
-@@ -257,7 +257,7 @@
+# https://bugs.gentoo.org/486782
+# Anthony G. Basile <blueness at gentoo.org>
+# This fixes a clash with clone() on uclibc.
+--- 1/readcd/readcd.c
++++ 1/readcd/readcd.c
+@@ -258,7 +258,7 @@
BOOL pifscan;
BOOL plot;
BOOL fulltoc;
@@ -10,7 +12,7 @@ diff -Naur cdrtools-3.02.orig/readcd/readcd.c cdrtools-3.02/readcd/readcd.c
BOOL edc_corr;
BOOL noerror;
BOOL nocorr;
-@@ -294,7 +294,7 @@
+@@ -296,7 +296,7 @@
error(_("\t-plot Print data suitable for gnuplot\n"));
#ifdef CLONE_WRITE
error(_("\t-fulltoc Retrieve the full TOC\n"));
@@ -19,16 +21,16 @@ diff -Naur cdrtools-3.02.orig/readcd/readcd.c cdrtools-3.02/readcd/readcd.c
error(_("\t-edc-corr Try to do user level Reed Solomon repair (experimental)\n"));
#endif
error(_("\ttimeout=# set the default SCSI command timeout to #.\n"));
-@@ -320,7 +320,7 @@
+@@ -322,7 +322,7 @@
}
/* CSTYLED */
--char opts[] = "debug#,d+,kdebug#,kd#,timeout#,quiet,q,verbose+,v+,Verbose+,V+,x+,xd#,silent,s,help,h,version,scanbus,dev*,scgopts*,sectors*,w,c2scan,cxscan,pi8scan,pifscan,plot,fulltoc,clone,edc-corr,noerror,nocorr,notrunc,retries#,factor,f*,speed#,ts&,overhead,meshpoints#";
-+char opts[] = "debug#,d+,kdebug#,kd#,timeout#,quiet,q,verbose+,v+,Verbose+,V+,x+,xd#,silent,s,help,h,version,scanbus,dev*,scgopts*,sectors*,w,c2scan,cxscan,pi8scan,pifscan,plot,fulltoc,clonetoc,edc-corr,noerror,nocorr,notrunc,retries#,factor,f*,speed#,ts&,overhead,meshpoints#";
+-char opts[] = "debug#,d+,kdebug#,kd#,timeout#,quiet,q,verbose+,v+,Verbose+,V+,x+,xd#,silent,s,help,h,version,scanbus,dev*,scgopts*,sectors*,w,c2scan,cxscan,pi8scan,pifscan,plot,fulltoc,clone,edc-corr,noerror,nocorr,notrunc,retries#,factor,f*,speed#,ts&,spt#,overhead,meshpoints#";
++char opts[] = "debug#,d+,kdebug#,kd#,timeout#,quiet,q,verbose+,v+,Verbose+,V+,x+,xd#,silent,s,help,h,version,scanbus,dev*,scgopts*,sectors*,w,c2scan,cxscan,pi8scan,pifscan,plot,fulltoc,clonetoc,edc-corr,noerror,nocorr,notrunc,retries#,factor,f*,speed#,ts&,spt#,overhead,meshpoints#";
EXPORT int
main(ac, av)
-@@ -397,7 +397,7 @@
+@@ -399,7 +399,7 @@
&scanbus, &dev, &scgopts, &sectors, &do_write,
&c2scan, &cxscan, &pi8scan, &pifscan,
&plot,
@@ -37,7 +39,7 @@ diff -Naur cdrtools-3.02.orig/readcd/readcd.c cdrtools-3.02/readcd/readcd.c
&edc_corr,
&noerror, &nocorr,
&notrunc, &retries, &do_factor, &filename,
-@@ -679,7 +679,7 @@
+@@ -681,7 +681,7 @@
if (filename || sectors || c2scan || cxscan || pi8scan || pifscan ||
meshpoints || fulltoc ||
@@ -46,7 +48,7 @@ diff -Naur cdrtools-3.02.orig/readcd/readcd.c cdrtools-3.02/readcd/readcd.c
dorw(scgp, filename, sectors);
} else {
doit(scgp);
-@@ -894,9 +894,9 @@
+@@ -896,9 +896,9 @@
if (params.name == NULL)
params.name = "/dev/null";
read_ftoc(scgp, &params, FALSE);
@@ -58,7 +60,7 @@ diff -Naur cdrtools-3.02.orig/readcd/readcd.c cdrtools-3.02/readcd/readcd.c
if (!edc_corr)
noerror = TRUE;
if (retries == MAX_RETRY)
-@@ -904,7 +904,7 @@
+@@ -906,7 +906,7 @@
if (params.name == NULL)
params.name = "/dev/null";
diff --git a/app-shells/schily-tools/schily-tools-2021.09.18.ebuild b/app-shells/schily-tools/schily-tools-2021.09.18.ebuild
index 46af6a1f..8f2c2ad4 100644
--- a/app-shells/schily-tools/schily-tools-2021.09.18.ebuild
+++ b/app-shells/schily-tools/schily-tools-2021.09.18.ebuild
@@ -16,7 +16,10 @@ HOMEPAGE="https://sourceforge.net/projects/schilytools/"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x86-solaris"
IUSE="acl caps doc nls split-usr suid unicode xattr"
-PATCHES=("${FILESDIR}"/strlcat-mapvers.patch)
+PATCHES=(
+ "${FILESDIR}"/fix-clone-uclibc.patch
+ "${FILESDIR}"/strlcat-mapvers.patch
+)
add_iuse_expand() {
local i j
@@ -94,12 +97,6 @@ cdrtools_os() {
src_schily_prepare() (
gnuconfig_update
- # This fixes a clash with clone() on uclibc. Upstream isn't
- # going to include this so let's try to carry it forward.
- # Contact me if it needs updating. Bug #486782.
- # Anthony G. Basile <blueness@gentoo.org>.
- use elibc_uclibc && eapply "${FILESDIR}"/cdrtool-fix-clone-uclibc.patch
-
# Remove profiled make files.
find -name '*_p.mk' -delete || die "delete *_p.mk"
diff --git a/media-gfx/pqiv/pqiv-2.11.ebuild b/media-gfx/pqiv/pqiv-2.11.ebuild
index 57303144..078f1e1e 100644
--- a/media-gfx/pqiv/pqiv-2.11.ebuild
+++ b/media-gfx/pqiv/pqiv-2.11.ebuild
@@ -46,7 +46,7 @@ src_configure() {
local backends="gdkpixbuf" gtkver=3
! use gtk2 || gtkver=2
use archive && backends+=",archive,archive_cbx"
- use ffmpeg || use libav && backends+=",libav"
+ use ffmpeg && backends+=",libav"
use imagemagick && backends+=",wand"
use pdf && backends+=",poppler"
use postscript && backends+=",spectre"