summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2018-01-10 23:28:46 +0100
committerMartin Väth <martin@mvath.de>2018-01-11 00:14:28 +0100
commit00d3f7368729807d2b063355195ba8a70581e9d5 (patch)
tree62c031bea8426035f4f518ffd040bf89e88f1966
parentmedia-video/avidemux: Fix L10N=sr-latn (diff)
downloadmv-00d3f7368729807d2b063355195ba8a70581e9d5.tar.gz
mv-00d3f7368729807d2b063355195ba8a70581e9d5.tar.bz2
mv-00d3f7368729807d2b063355195ba8a70581e9d5.zip
Remove avidemux which is now bumped in the gentoo repository
-rw-r--r--media-libs/avidemux-core/Manifest1
-rw-r--r--media-libs/avidemux-core/avidemux-core-2.7.0.ebuild115
-rw-r--r--media-libs/avidemux-core/metadata.xml20
-rw-r--r--media-libs/avidemux-plugins/Manifest1
-rw-r--r--media-libs/avidemux-plugins/avidemux-plugins-2.7.0.ebuild181
-rw-r--r--media-libs/avidemux-plugins/files/avidemux-plugins-2.6.20-optional-pulse.patch21
-rw-r--r--media-libs/avidemux-plugins/files/avidemux-plugins-2.6.4-optional-pulse.patch21
-rw-r--r--media-libs/avidemux-plugins/files/avidemux-plugins-abs.patch20
-rw-r--r--media-libs/avidemux-plugins/metadata.xml28
-rw-r--r--media-video/avidemux/Manifest1
-rw-r--r--media-video/avidemux/avidemux-2.7.0-r1.ebuild183
-rw-r--r--media-video/avidemux/metadata.xml19
-rw-r--r--metadata/pkg_desc_index3
-rw-r--r--profiles/use.local.desc13
14 files changed, 0 insertions, 627 deletions
diff --git a/media-libs/avidemux-core/Manifest b/media-libs/avidemux-core/Manifest
deleted file mode 100644
index a6bb62e8..00000000
--- a/media-libs/avidemux-core/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST avidemux_2.7.0.tar.gz 21474504 SHA512 7c92213d3bd2849dbdb5a1aff2acd6da231fd76c561b756fbf4a1d5a41e9705d609d7a35b6ca6b77ceb3bf5138f861cd24ed16d8fcec4fd713f09a2ff07e9015
diff --git a/media-libs/avidemux-core/avidemux-core-2.7.0.ebuild b/media-libs/avidemux-core/avidemux-core-2.7.0.ebuild
deleted file mode 100644
index f2e5e0f8..00000000
--- a/media-libs/avidemux-core/avidemux-core-2.7.0.ebuild
+++ /dev/null
@@ -1,115 +0,0 @@
-# Copyright 2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-RESTRICT="mirror"
-inherit cmake-utils flag-o-matic
-
-DESCRIPTION="Core libraries for media-video/avidemux"
-HOMEPAGE="http://fixounet.free.fr/avidemux"
-
-# Multiple licenses because of all the bundled stuff.
-LICENSE="GPL-1 GPL-2 MIT PSF-2 public-domain"
-SLOT="2.6"
-IUSE="debug nls nvenc sdl system-ffmpeg vaapi vdpau xv"
-
-if [[ ${PV} == *9999* ]] ; then
- MY_P=$P
- KEYWORDS=""
- PROPERTIES="live"
- EGIT_REPO_URI="https://github.com/mean00/${MY_P}2"
- inherit git-r3
-else
- MY_PN="${PN/-core/}"
- MY_P="${MY_PN}_${PV}"
- SRC_URI="mirror://sourceforge/${MY_PN}/${MY_PN}/${PV}/${MY_P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
-fi
-
-# Trying to use virtual; ffmpeg misses aac,cpudetection USE flags now though, are they needed?
-DEPEND="
- !<media-video/avidemux-${PV}:${SLOT}
- dev-db/sqlite:3
- sdl? ( media-libs/libsdl:0 )
- system-ffmpeg? ( >=virtual/ffmpeg-9:0[mp3,theora] )
- xv? ( x11-libs/libXv:0 )
- vaapi? ( x11-libs/libva:0 )
- vdpau? ( x11-libs/libvdpau:0 )
- nvenc? ( media-video/nvidia_video_sdk )
-"
-RDEPEND="
- $DEPEND
- nls? ( virtual/libintl:0 )
-"
-DEPEND="
- $DEPEND
- virtual/pkgconfig
- nls? ( sys-devel/gettext )
- !system-ffmpeg? ( dev-lang/yasm[nls=] )
-"
-
-S="${WORKDIR}/${MY_P}"
-CMAKE_USE_DIR="${S}/${PN/-/_}"
-
-DOCS=( AUTHORS README )
-
-src_setup() {
- CMAKE_MAKEFILE_GENERATOR=emake # ninja does not work, currently
-}
-
-src_prepare() {
- cmake-utils_src_prepare
-
- if use system-ffmpeg ; then
- # Preparations to support the system ffmpeg. Currently fails because it depends on files the system ffmpeg doesn't install.
- local error="Failed to remove ffmpeg."
-
- rm -rf cmake/admFFmpeg* cmake/ffmpeg* avidemux_core/ffmpeg_package buildCore/ffmpeg || die "${error}"
- sed -i -e 's/include(admFFmpegUtil)//g' \
- -e '/registerFFmpeg/d' avidemux/commonCmakeApplication.cmake || die "${error}"
- sed -i -e 's/include(admFFmpegBuild)//g' avidemux_core/CMakeLists.txt || die "${error}"
- fi
-}
-
-src_configure() {
- if test-flags-CXX -std=c++14 ; then
- append-cxxflags -std=c++14
- elif test-flags-CXX -std=c++11 ; then
- append-cxxflags -std=c++11
- fi
-
- # Add lax vector typing for PowerPC.
- if use ppc || use ppc64 ; then
- append-cflags -flax-vector-conversions
- fi
-
- # See bug 432322.
- use x86 && replace-flags -O0 -O1
-
- # Filter problematic flags
- filter-flags -fwhole-program -flto
-
- local mycmakeargs=(
- -DAVIDEMUX_SOURCE_DIR="'${S}'"
- -DGETTEXT="$(usex nls)"
- -DSDL="$(usex sdl)"
- -DLIBVA="$(usex vaapi)"
- -DVDPAU="$(usex vdpau)"
- -DXVIDEO="$(usex xv)"
- -DNVENC="$(usex nvenc)"
- )
-
- if use debug ; then
- mycmakeargs+=( -DVERBOSE=1 -DADM_DEBUG=1 )
- fi
-
- cmake-utils_src_configure
-}
-
-src_compile() {
- cmake-utils_src_compile -j1
-}
-
-src_install() {
- cmake-utils_src_install -j1
-}
diff --git a/media-libs/avidemux-core/metadata.xml b/media-libs/avidemux-core/metadata.xml
deleted file mode 100644
index 7c25b69d..00000000
--- a/media-libs/avidemux-core/metadata.xml
+++ /dev/null
@@ -1,20 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="person">
- <email>martin@mvath.de</email>
- <name>Martin Väth</name>
- <description>maintainer of the updates in the mv overlay</description>
- </maintainer>
- <maintainer type="project">
- <email>media-video@gentoo.org</email>
- <name>Gentoo Video project</name>
- </maintainer>
- <use>
- <flag name="nvenc">Adds support for NVIDIA Encoder (NVENC) API for hardware accelerated encoding on NVIDIA cards.</flag>
- <flag name="system-ffmpeg">Use the ffmpeg provided by the system.</flag>
- </use>
- <upstream>
- <remote-id type="sourceforge">avidemux</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/media-libs/avidemux-plugins/Manifest b/media-libs/avidemux-plugins/Manifest
deleted file mode 100644
index a6bb62e8..00000000
--- a/media-libs/avidemux-plugins/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST avidemux_2.7.0.tar.gz 21474504 SHA512 7c92213d3bd2849dbdb5a1aff2acd6da231fd76c561b756fbf4a1d5a41e9705d609d7a35b6ca6b77ceb3bf5138f861cd24ed16d8fcec4fd713f09a2ff07e9015
diff --git a/media-libs/avidemux-plugins/avidemux-plugins-2.7.0.ebuild b/media-libs/avidemux-plugins/avidemux-plugins-2.7.0.ebuild
deleted file mode 100644
index c1d4b105..00000000
--- a/media-libs/avidemux-plugins/avidemux-plugins-2.7.0.ebuild
+++ /dev/null
@@ -1,181 +0,0 @@
-# Copyright 2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-RESTRICT="mirror"
-PYTHON_COMPAT=( python{2_7,3_{4,5,6}} )
-
-inherit cmake-utils flag-o-matic python-any-r1
-
-DESCRIPTION="Plugins for media-video/avidemux"
-HOMEPAGE="http://fixounet.free.fr/avidemux"
-
-# Multiple licenses because of all the bundled stuff.
-LICENSE="GPL-1 GPL-2 MIT PSF-2 public-domain"
-SLOT="2.6"
-IUSE="aac aften a52 alsa amr dcaenc debug dts fdk fontconfig fribidi jack lame libsamplerate cpu_flags_x86_mmx nvenc opengl opus oss pulseaudio qt5 vorbis truetype twolame xv xvid x264 x265 vdpau vpx"
-
-MY_PN="${PN/-plugins/}"
-if [[ ${PV} == *9999* ]] ; then
- MY_P=$P
- KEYWORDS=""
- PROPERTIES="live"
- EGIT_REPO_URI="https://github.com/mean00/${MY_P}2"
- inherit git-r3
-else
- MY_P="${MY_PN}_${PV}"
- SRC_URI="mirror://sourceforge/${MY_PN}/${MY_PN}/${PV}/${MY_P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
-fi
-
-RDEPEND="
- ~media-libs/avidemux-core-${PV}:${SLOT}[vdpau?]
- ~media-video/avidemux-${PV}:${SLOT}[opengl?,qt5?]
- >=dev-lang/spidermonkey-1.5-r2:0=
- dev-libs/libxml2:2
- media-libs/a52dec:0
- media-libs/libass:0=
- media-libs/libmad:0
- media-libs/libmp4v2:0
- media-libs/libpng:0=
- virtual/libiconv:0
- aac? (
- media-libs/faac:0
- media-libs/faad2:0
- )
- aften? ( media-libs/aften:0 )
- alsa? ( >=media-libs/alsa-lib-1.0.3b-r2:0 )
- amr? ( media-libs/opencore-amr:0 )
- dcaenc? ( media-sound/dcaenc:0 )
- dts? ( media-libs/libdca:0 )
- fdk? ( media-libs/fdk-aac:0 )
- fontconfig? ( media-libs/fontconfig:1.0 )
- fribidi? ( dev-libs/fribidi:0 )
- jack? (
- media-sound/jack-audio-connection-kit:0
- libsamplerate? ( media-libs/libsamplerate:0 )
- )
- lame? ( media-sound/lame:0 )
- nvenc? ( media-video/nvidia_video_sdk )
- opus? ( media-libs/opus:0 )
- pulseaudio? ( media-sound/pulseaudio:0 )
- truetype? ( media-libs/freetype:2 )
- twolame? ( media-sound/twolame:0 )
- x264? ( media-libs/x264:0= )
- x265? ( media-libs/x265:0= )
- xv? (
- x11-libs/libX11:0
- x11-libs/libXext:0
- x11-libs/libXv:0
- )
- xvid? ( media-libs/xvid:0 )
- vorbis? ( media-libs/libvorbis:0 )
- vpx? ( media-libs/libvpx:0 )
-"
-DEPEND="${RDEPEND}
- oss? ( virtual/os-headers:0 )
- ${PYTHON_DEPS}"
-
-S="${WORKDIR}/${MY_P}"
-PATCHES=( "${FILESDIR}"/${PN}-2.6.20-optional-pulse.patch )
-
-src_setup() {
- CMAKE_MAKEFILE_GENERATOR=emake # ninja does not work, currently
-}
-
-src_prepare() {
- default
-}
-
-src_configure() {
- if test-flags-CXX -std=c++14 ; then
- append-cxxflags -std=c++14
- elif test-flags-CXX -std=c++11 ; then
- append-cxxflags -std=c++11
- elif use qt5 ; then
- die "For qt support a compiler with c++11 support is needed"
- fi
-
- # Add lax vector typing for PowerPC.
- if use ppc || use ppc64 ; then
- append-cflags -flax-vector-conversions
- fi
-
- # See bug 432322.
- use x86 && replace-flags -O0 -O1
-
- # Filter problematic flags
- filter-flags -fwhole-program -flto
-
- processes="buildPluginsCommon:avidemux_plugins
- buildPluginsCLI:avidemux_plugins"
- if use qt5 ; then
- processes+=" buildPluginsQt4:avidemux_plugins"
- export qt_ext=Qt5 QT_SELECT=5
- fi
-
- for process in ${processes} ; do
- local build="${process%%:*}"
-
- local mycmakeargs=(
- -DAVIDEMUX_SOURCE_DIR="'${S}'"
- -DPLUGIN_UI=$(echo ${build/buildPlugins/} | tr '[:lower:]' '[:upper:]')
- -DFAAC="$(usex aac)"
- -DFAAD="$(usex aac)"
- -DALSA="$(usex alsa)"
- -DAFTEN="$(usex aften)"
- -DDCAENC="$(usex dcaenc)"
- -DFDK_AAC="$(usex fdk)"
- -DOPENCORE_AMRWB="$(usex amr)"
- -DOPENCORE_AMRNB="$(usex amr)"
- -DLIBDCA="$(usex dts)"
- -DFONTCONFIG="$(usex fontconfig)"
- -DJACK="$(usex jack)"
- -DLAME="$(usex lame)"
- -DNVENC="$(usex nvenc)"
- -DOPUS="$(usex opus)"
- -DOSS="$(usex oss)"
- -DPULSEAUDIOSIMPLE="$(usex pulseaudio)"
- -DFREETYPE2="$(usex truetype)"
- -DTWOLAME="$(usex twolame)"
- -DX264="$(usex x264)"
- -DX265="$(usex x265)"
- -DXVIDEO="$(usex xv)"
- -DXVID="$(usex xvid)"
- -DVDPAU="$(usex vdpau)"
- -DVORBIS="$(usex vorbis)"
- -DLIBVORBIS="$(usex vorbis)"
- -DVPXDEC="$(usex vpx)"
- -DUSE_EXTERNAL_LIBA52=yes
- -DUSE_EXTERNAL_LIBASS=yes
- -DUSE_EXTERNAL_LIBMAD=yes
- -DUSE_EXTERNAL_LIBMP4V2=yes
- )
- if use qt5 ; then
- mycmakeargs+=( -DENABLE_QT5=True )
- fi
-
- ! use debug || mycmakeargs+=( -DVERBOSE=1 -DADM_DEBUG=1 )
-
- mkdir "${S}"/${build} || die "Can't create build folder."
-
- CMAKE_USE_DIR="${S}"/${process#*:} BUILD_DIR="${S}"/${build} cmake-utils_src_configure
- done
-}
-
-src_compile() {
- for process in ${processes} ; do
- BUILD_DIR="${S}/${process%%:*}" cmake-utils_src_compile
- done
-}
-
-src_install() {
- for process in ${processes} ; do
- # cmake-utils_src_install doesn't respect BUILD_DIR
- # and there sometimes is a preinstall phase present.
- pushd "${S}/${process%%:*}" > /dev/null || die
- grep '^preinstall/fast' Makefile && emake DESTDIR="${D}" preinstall/fast
- grep '^install/fast' Makefile && emake DESTDIR="${D}" install/fast
- popd > /dev/null || die
- done
-}
diff --git a/media-libs/avidemux-plugins/files/avidemux-plugins-2.6.20-optional-pulse.patch b/media-libs/avidemux-plugins/files/avidemux-plugins-2.6.20-optional-pulse.patch
deleted file mode 100644
index 2afc6f5c..00000000
--- a/media-libs/avidemux-plugins/files/avidemux-plugins-2.6.20-optional-pulse.patch
+++ /dev/null
@@ -1,21 +0,0 @@
---- 1/cmake/admCheckAudioDeviceLibs.cmake
-+++ 1/cmake/admCheckAudioDeviceLibs.cmake
-@@ -158,6 +158,8 @@
-
- MESSAGE(STATUS "Checking for PULSEAUDIOSIMPLE")
- MESSAGE(STATUS "*****************************")
-+
-+ IF (PULSEAUDIOSIMPLE)
- IF (PULSEAUDIOSIMPLE_INCLUDE_DIR AND PULSEAUDIOSIMPLE_LIBRARIES)
- # in cache already
- SET(PULSEAUDIOSIMPLE_FIND_QUIETLY TRUE)
-@@ -191,6 +193,9 @@
- MARK_AS_ADVANCED(PULSEAUDIOSIMPLE_INCLUDE_DIR PULSEAUDIOSIMPLE_LIBRARIES)
-
- APPEND_SUMMARY_LIST("Audio Device" "PulseAudio" "${USE_PULSE_SIMPLE}")
-+ ELSE (PULSEAUDIOSIMPLE)
-+ MESSAGE("${MSG_DISABLE_OPTION}")
-+ ENDIF (PULSEAUDIOSIMPLE)
- ELSE (UNIX AND NOT APPLE)
- SET(PULSEAUDIOSIMPLE_CAPABLE FALSE)
- ENDIF (UNIX AND NOT APPLE)
diff --git a/media-libs/avidemux-plugins/files/avidemux-plugins-2.6.4-optional-pulse.patch b/media-libs/avidemux-plugins/files/avidemux-plugins-2.6.4-optional-pulse.patch
deleted file mode 100644
index 78650aaa..00000000
--- a/media-libs/avidemux-plugins/files/avidemux-plugins-2.6.4-optional-pulse.patch
+++ /dev/null
@@ -1,21 +0,0 @@
---- a/cmake/admCheckAudioDeviceLibs.cmake
-+++ b/cmake/admCheckAudioDeviceLibs.cmake
-@@ -158,6 +158,8 @@
-
- MESSAGE(STATUS "Checking for PULSEAUDIOSIMPLE")
- MESSAGE(STATUS "*****************************")
-+
-+ IF (PULSEAUDIOSIMPLE)
- IF (PULSEAUDIOSIMPLE_INCLUDE_DIR AND PULSEAUDIOSIMPLE_LIBRARIES)
- # in cache already
- SET(PULSEAUDIOSIMPLE_FIND_QUIETLY TRUE)
-@@ -198,6 +200,9 @@
- MARK_AS_ADVANCED(PULSEAUDIOSIMPLE_INCLUDE_DIR PULSEAUDIOSIMPLE_LIBRARIES)
-
- APPEND_SUMMARY_LIST("Audio Device" "PulseAudio" "${USE_PULSE_SIMPLE}")
-+ ELSE (PULSEAUDIOSIMPLE)
-+ MESSAGE("${MSG_DISABLE_OPTION}")
-+ ENDIF (PULSEAUDIOSIMPLE)
- ELSE (UNIX AND NOT APPLE)
- SET(PULSEAUDIOSIMPLE_CAPABLE FALSE)
- ENDIF (UNIX AND NOT APPLE)
diff --git a/media-libs/avidemux-plugins/files/avidemux-plugins-abs.patch b/media-libs/avidemux-plugins/files/avidemux-plugins-abs.patch
deleted file mode 100644
index 223cc26c..00000000
--- a/media-libs/avidemux-plugins/files/avidemux-plugins-abs.patch
+++ /dev/null
@@ -1,20 +0,0 @@
---- 1/avidemux_plugins/ADM_videoFilters6/telecide/Telecide_getFrame.cpp
-+++ 1/avidemux_plugins/ADM_videoFilters6/telecide/Telecide_getFrame.cpp
-@@ -240,7 +240,7 @@
- {
- // The chosen frame doesn't match the prediction.
- if (predicted_metric == 0) mismatch = 0.0;
-- else mismatch = (100.0*abs(predicted_metric - lowest))/predicted_metric;
-+ else mismatch = (100.0*abs(int64_t(predicted_metric) - int64_t(lowest)))/predicted_metric;
- if (mismatch < gthresh)
- {
- // It's close enough, so use the predicted one.
-@@ -283,7 +283,7 @@
- {
- // The chosen frame doesn't match the prediction.
- if (predicted_metric == 0) mismatch = 0.0;
-- else mismatch = (100.0*abs(predicted_metric - lowest))/predicted_metric;
-+ else mismatch = (100.0*abs(int64_t(predicted_metric) - int64_t(lowest)))/predicted_metric;
- if ((int) mismatch <= gthresh)
- {
- // It's close enough, so use the predicted one.
diff --git a/media-libs/avidemux-plugins/metadata.xml b/media-libs/avidemux-plugins/metadata.xml
deleted file mode 100644
index b242e77f..00000000
--- a/media-libs/avidemux-plugins/metadata.xml
+++ /dev/null
@@ -1,28 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="person">
- <email>martin@mvath.de</email>
- <name>Martin Väth</name>
- <description>maintainer of the updates in the mv overlay</description>
- </maintainer>
- <maintainer type="project">
- <email>media-video@gentoo.org</email>
- <name>Gentoo Video project</name>
- </maintainer>
- <use>
- <flag name="aften">Enable A/52 (AC-3) audio encoder support.</flag>
- <flag name="amr">Enable Adaptive Multi-Rate format support via <pkg>media-libs/opencore-amr</pkg>.</flag>
- <flag name="dcaenc">Enable DTS Coherent Acoustics audio encoder support via <pkg>media-sound/dcaenc</pkg>.</flag>
- <flag name="fdk">Adds support for encoding AAC using <pkg>media-libs/fdk-aac</pkg>.</flag>
- <flag name="fribidi">Enable unicode bidirectional algorithm support via <pkg>dev-libs/fribidi</pkg>.</flag>
- <flag name="nvenc">Adds support for NVIDIA Encoder (NVENC) API for hardware accelerated encoding on NVIDIA cards.</flag>
- <flag name="opus">Adds support for the Opus codec via <pkg>media-libs/opus</pkg>.</flag>
- <flag name="twolame">Enable TwoLAME support via <pkg>media-sound/twolame</pkg>, an optimised MPEG Audio Layer 2 (MP2) encoder.</flag>
- <flag name="vpx">Enable WebM VP8 Codec SDK support via <pkg>media-libs/libvpx</pkg>.</flag>
- <flag name="x265">Enables HEVC support with <pkg>media-libs/x265</pkg>.</flag>
- </use>
- <upstream>
- <remote-id type="sourceforge">avidemux</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/media-video/avidemux/Manifest b/media-video/avidemux/Manifest
deleted file mode 100644
index a6bb62e8..00000000
--- a/media-video/avidemux/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST avidemux_2.7.0.tar.gz 21474504 SHA512 7c92213d3bd2849dbdb5a1aff2acd6da231fd76c561b756fbf4a1d5a41e9705d609d7a35b6ca6b77ceb3bf5138f861cd24ed16d8fcec4fd713f09a2ff07e9015
diff --git a/media-video/avidemux/avidemux-2.7.0-r1.ebuild b/media-video/avidemux/avidemux-2.7.0-r1.ebuild
deleted file mode 100644
index e3804ecd..00000000
--- a/media-video/avidemux/avidemux-2.7.0-r1.ebuild
+++ /dev/null
@@ -1,183 +0,0 @@
-# Copyright 2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-RESTRICT="mirror"
-
-inherit cmake-utils desktop flag-o-matic l10n xdg-utils
-
-DESCRIPTION="Video editor designed for simple cutting, filtering and encoding tasks"
-HOMEPAGE="http://fixounet.free.fr/avidemux"
-
-# Multiple licenses because of all the bundled stuff.
-LICENSE="GPL-1 GPL-2 MIT PSF-2 public-domain"
-SLOT="2.6"
-IUSE="debug opengl nls nvenc qt5 sdl vaapi vdpau xv"
-PLOCALES="ca cs de el es fr it ja pt_BR ru sr sr@latin tr"
-for i in ${PLOCALES}; do
- i=${i//_/-}
- IUSE+=" l10n_${i/@latin/-Latn}"
-done
-QA_DT_NEEDED=".*/libADM_UI_Cli6\.so"
-
-if [[ ${PV} == *9999* ]] ; then
- MY_P=$P
- KEYWORDS=""
- PROPERTIES="live"
- EGIT_REPO_URI="git://gitorious.org/${MY_PN}2-6/${MY_P}2-6.git https://git.gitorious.org/${MY_P}2-6/${MY_P}2-6.git"
- EGIT_REPO_URI="https://github.com/mean00/${MY_P}2"
- inherit git-r3
-else
- MY_P="${PN}_${PV}"
- SRC_URI="mirror://sourceforge/${PN}/${PN}/${PV}/${MY_P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
-fi
-
-DEPEND="
- ~media-libs/avidemux-core-${PV}:${SLOT}[nls?,sdl?,vaapi?,vdpau?,xv?,nvenc?]
- opengl? ( virtual/opengl:0 )
- qt5? ( dev-qt/qtgui:5 )
- vaapi? ( x11-libs/libva:0 )
- nvenc? ( amd64? ( media-video/nvidia_video_sdk:0 ) )
-"
-RDEPEND="$DEPEND
- nls? ( virtual/libintl:0 )
-"
-PDEPEND="~media-libs/avidemux-plugins-${PV}:${SLOT}[opengl?,qt5?]"
-
-S="${WORKDIR}/${MY_P}"
-
-DOCS=( AUTHORS README )
-
-src_prepare() {
- local i j
- export LINGUAS=
- for i in ${PLOCALES}; do
- i=${i//_/-}
- use l10n_${i/@latin/-Latn} && LINGUAS+=${LINGUAS:+ }${i}
- done
-
- processes="buildCli:avidemux/cli"
- if use qt5 ; then
- processes+=" buildQt4:avidemux/qt4"
- fi
-
- for process in ${processes} ; do
- CMAKE_USE_DIR="${S}"/${process#*:} cmake-utils_src_prepare
- done
-
- # Fix icon name -> avidemux-2.6.png
- sed -i -e "/^Icon/ s:${PN}:${PN}-2.6:" ${PN}2.desktop || die "Icon name fix failed."
-
- # The desktop file is broken. It uses avidemux2 instead of avidemux3
- # so it will actually launch avidemux-2.5 if it is installed.
- sed -i -e "/^Exec/ s:${PN}2:${PN}3:" ${PN}2.desktop || die "Desktop file fix failed."
- sed -i -re '/^Exec/ s:(avidemux3_)gtk:\1qt'$(usex qt5 5 4)':' ${PN}2.desktop || die "Desktop file fix failed."
-
- # Fix QA warnings that complain a trailing ; is missing and Application is deprecated.
- sed -i -e 's/Application;AudioVideo/AudioVideo;/g' ${PN}2.desktop || die "Desktop file fix failed."
-
- # Now rename the desktop file to not collide with 2.5.
- mv ${PN}2.desktop ${PN}-2.6.desktop || die "Collision rename failed."
-
- # Remove "Build Option" dialog because it doesn't reflect what the GUI can or has been built with. (Bug #463628)
- sed -i -e '/Build Option/d' avidemux/common/ADM_commonUI/myOwnMenu.h || die "Couldn't remove \"Build Option\" dialog."
-
- # Fix underlinking with gold
- sed -i -e 's/-lm/-lXext -lm/' avidemux/qt4/CMakeLists.txt || die
- sed -i -e 's/{QT_QTGUI_LIBRARY}/{QT_QTGUI_LIBRARY} -lXext/' \
- avidemux/common/ADM_render/CMakeLists.txt || die
- default
-}
-
-src_configure() {
- if test-flags-CXX -std=c++14 ; then
- append-cxxflags -std=c++14
- elif test-flags-CXX -std=c++11 ; then
- append-cxxflags -std=c++11
- elif use qt5 ; then
- die "For qt support a compiler with c++11 support is needed"
- fi
-
- # Add lax vector typing for PowerPC.
- if use ppc || use ppc64 ; then
- append-cflags -flax-vector-conversions
- fi
-
- # See bug 432322.
- use x86 && replace-flags -O0 -O1
-
- # Filter problematic flags
- filter-flags -ftracer -flto
-
- local mycmakeargs=(
- -DAVIDEMUX_SOURCE_DIR="'${S}'"
- -DGETTEXT="$(usex nls)"
- -DSDL="$(usex sdl)"
- -DLIBVA="$(usex vaapi)"
- -DVDPAU="$(usex vdpau)"
- -DXVIDEO="$(usex xv)"
- )
-
- ! use debug || mycmakeargs+=(
- -DVERBOSE=1
- -DCMAKE_BUILD_TYPE=Debug
- -DADM_DEBUG=1
- )
-
- if use qt5 ; then
- mycmakeargs+=( -DENABLE_QT5=True )
- export qt_ext=Qt5 QT_SELECT=5
- processes+=" buildQt4:avidemux/qt4"
- fi
-
- for process in ${processes} ; do
- local build="${WORKDIR}/${P}_build/${process%%:*}"
- CMAKE_USE_DIR="${S}"/${process#*:} BUILD_DIR="${build}" cmake-utils_src_configure
- done
-}
-
-src_compile() {
- for process in ${processes} ; do
- local build="${WORKDIR}/${P}_build/${process%%:*}"
- BUILD_DIR="${build}" cmake-utils_src_compile
- done
-}
-
-src_test() {
- for process in ${processes} ; do
- local build="${WORKDIR}/${P}_build/${process%%:*}"
- BUILD_DIR="${build}" cmake-utils_src_test
- done
-}
-
-src_install() {
- for process in ${processes} ; do
- local build="${WORKDIR}/${P}_build/${process%%:*}"
- BUILD_DIR="${build}" cmake-utils_src_install
- done
-
- if [[ -f "${ED}"/usr/bin/avidemux3_cli ]] ; then
- fperms +x /usr/bin/avidemux3_cli
- fi
-
- if [[ -f "${ED}"/usr/bin/avidemux3_jobs ]] ; then
- fperms +x /usr/bin/avidemux3_jobs
- fi
-
- cd "${S}" || die "Can't enter source folder."
- newicon ${PN}_icon.png ${PN}-2.6.png
-
- if use qt5; then
- fperms +x /usr/bin/avidemux3_qt5
- domenu ${PN}-2.6.desktop
- fi
-}
-
-pkg_postinst() {
- xdg_desktop_database_update
-}
-
-pkg_postrm() {
- xdg_desktop_database_update
-}
diff --git a/media-video/avidemux/metadata.xml b/media-video/avidemux/metadata.xml
deleted file mode 100644
index 644f63a4..00000000
--- a/media-video/avidemux/metadata.xml
+++ /dev/null
@@ -1,19 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="person">
- <email>martin@mvath.de</email>
- <name>Martin Väth</name>
- <description>maintainer of the updates in the mv overlay</description>
- </maintainer>
- <maintainer type="project">
- <email>media-video@gentoo.org</email>
- <name>Gentoo Video project</name>
- </maintainer>
- <use>
- <flag name="nvenc">Adds support for NVIDIA Encoder (NVENC) API for hardware accelerated encoding on NVIDIA cards.</flag>
- </use>
- <upstream>
- <remote-id type="sourceforge">avidemux</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/metadata/pkg_desc_index b/metadata/pkg_desc_index
index bf733240..ba34e0e0 100644
--- a/metadata/pkg_desc_index
+++ b/metadata/pkg_desc_index
@@ -74,12 +74,9 @@ games-rpg/m5figur-mv 2.8.2: LaTeX2e character sheet layout for the Midgard Role
games-rpg/magus 1.3.1 1.3.3 99999999: A character generator for the popular German role playing game Midgard
mail-client/alpine 2.00-r7 2.21: alpine is an easy to use text-based based mail and news client
media-gfx/pqiv 2.10.2: powerful GTK based command-line image viewer with a minimal UI
-media-libs/avidemux-core 2.7.0: Core libraries for media-video/avidemux
-media-libs/avidemux-plugins 2.7.0: Plugins for media-video/avidemux
media-tv/nvtv 0.4.7-r3: TV-Out for NVidia cards
media-tv/sundtek-tv 180105.120323: Sundtek MediaTV Pro III Drivers
media-tv/w_scan 20170107-r1: Scan for DVB-C/DVB-T/DVB-S channels without prior knowledge of frequencies
-media-video/avidemux 2.7.0-r1: Video editor designed for simple cutting, filtering and encoding tasks
media-video/avinfo 1.0_alpha15_p1: Utility for displaying AVI information
media-video/video-mv 12.1: Frontends for using mplayer/mencoder, ffmpeg/libav, or tzap as video recorder
net-dialup/accounting 1.60.45.3.1: Give statistics about dialup connections. Originally part of SuSE's smpppd
diff --git a/profiles/use.local.desc b/profiles/use.local.desc
index 2c0ace70..eea3b825 100644
--- a/profiles/use.local.desc
+++ b/profiles/use.local.desc
@@ -158,23 +158,10 @@ mail-client/alpine:passfile - Adds support for caching passwords into a file bet
mail-client/alpine:smime - Enable support for S/MIME
media-gfx/pqiv:archive - Enable support for images in archives and cbX comic book files
media-gfx/pqiv:gtk2 - Use gtk:2 instead of gtk:3
-media-libs/avidemux-core:nvenc - Adds support for NVIDIA Encoder (NVENC) API for hardware accelerated encoding on NVIDIA cards.
-media-libs/avidemux-core:system-ffmpeg - Use the ffmpeg provided by the system.
-media-libs/avidemux-plugins:aften - Enable A/52 (AC-3) audio encoder support.
-media-libs/avidemux-plugins:amr - Enable Adaptive Multi-Rate format support via media-libs/opencore-amr.
-media-libs/avidemux-plugins:dcaenc - Enable DTS Coherent Acoustics audio encoder support via media-sound/dcaenc.
-media-libs/avidemux-plugins:fdk - Adds support for encoding AAC using media-libs/fdk-aac.
-media-libs/avidemux-plugins:fribidi - Enable unicode bidirectional algorithm support via dev-libs/fribidi.
-media-libs/avidemux-plugins:nvenc - Adds support for NVIDIA Encoder (NVENC) API for hardware accelerated encoding on NVIDIA cards.
-media-libs/avidemux-plugins:opus - Adds support for the Opus codec via media-libs/opus.
-media-libs/avidemux-plugins:twolame - Enable TwoLAME support via media-sound/twolame, an optimised MPEG Audio Layer 2 (MP2) encoder.
-media-libs/avidemux-plugins:vpx - Enable WebM VP8 Codec SDK support via media-libs/libvpx.
-media-libs/avidemux-plugins:x265 - Enables HEVC support with media-libs/x265.
media-tv/sundtek-tv:ld-preload-env - Install LD_PRELOAD in /etc/env.d/50sundtek-tv
media-tv/sundtek-tv:ld-preload-file - Install /etc/ld.so.preload
media-tv/sundtek-tv:pax_kernel - Mark package which is necessary if you use a PAX kernel
media-tv/w_scan:plp-id-zero - Apply experimental patch to force plp_id to 0 for DVB-T2. Seems to be necessary at least with some tuners in some regions
-media-video/avidemux:nvenc - Adds support for NVIDIA Encoder (NVENC) API for hardware accelerated encoding on NVIDIA cards.
net-dns/noip-updater:ezipupd - Use user/group ezipupd instead of nobody: Useful if you restrict outgoing network traffic for user nobody
net-libs/wvstreams:boost - Use dev-libs/boost to provide TR1-compatible functional interface. This USE flag is only needed with GCC earlier than version 4.1, or with other compilares not providing said interface.
net-misc/sshstart:keychain - Pull in keychain as dependency. Not required, but recommended for smoother operation.