summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2018-05-09 11:41:38 +0200
committerMartin Väth <martin@mvath.de>2018-05-09 16:14:36 +0200
commit0ce56cba824dff11f345ea47bf99883ccd290534 (patch)
tree10a81add65e11c7e1cfffe3ea8f42255772622c3
parentapp-portage/portage-bashrc-mv: Version bump (diff)
downloadmv-0ce56cba824dff11f345ea47bf99883ccd290534.tar.gz
mv-0ce56cba824dff11f345ea47bf99883ccd290534.tar.bz2
mv-0ce56cba824dff11f345ea47bf99883ccd290534.zip
app-shells/schily-tools: Version bump. Fix compilation w/ gcc-8
-rw-r--r--app-shells/schily-tools/Manifest2
-rw-r--r--app-shells/schily-tools/schily-tools-2017.09.25.ebuild13
-rw-r--r--app-shells/schily-tools/schily-tools-2018.05.02.ebuild (renamed from app-shells/schily-tools/schily-tools-2018.04.17.ebuild)15
-rw-r--r--metadata/pkg_desc_index2
4 files changed, 25 insertions, 7 deletions
diff --git a/app-shells/schily-tools/Manifest b/app-shells/schily-tools/Manifest
index 3973e204..da2b3212 100644
--- a/app-shells/schily-tools/Manifest
+++ b/app-shells/schily-tools/Manifest
@@ -1,2 +1,2 @@
DIST schily-2017-09-25.tar.bz2 4182173 SHA512 79b532f2ed0332f69edbd2dbe83e4acfdff5b4cfc0f8ade341ee0289375d824e3ad19816e3fc25ef3a108ffa8b9437000bd55f68c41bb187d45455c573fc316a
-DIST schily-2018-04-17.tar.bz2 4220307 SHA512 06f975ab996226fa3136ed875d2623e21c37e7eccec8ba0785d567bf0763750af8876b377607608edb0e9e3a7d02057178690878b5865d2b6cfcb2c7208d089e
+DIST schily-2018-05-02.tar.bz2 4218317 SHA512 f9021607cbfea6ea052d70d96dd879d17e93f9298dffe5f152cb4c8d4015345ff0417e953daba38779d1fe19a82d09ccd5f16f0e59323f376d015ff780712340
diff --git a/app-shells/schily-tools/schily-tools-2017.09.25.ebuild b/app-shells/schily-tools/schily-tools-2017.09.25.ebuild
index a9cb4d02..d09ebd73 100644
--- a/app-shells/schily-tools/schily-tools-2017.09.25.ebuild
+++ b/app-shells/schily-tools/schily-tools-2017.09.25.ebuild
@@ -120,11 +120,18 @@ src_schily_prepare() (
local tcCXX=$(tc-getCXX)
sed -i -e "/cc-config.sh/s|\$(C_ARCH:%64=%) \$(CCOM_DEF)|${tcCC} ${tcCC}|" \
rules1.top || die "sed rules1.top"
+ # -e "s|^\(DEFCCOM_DEF=\).*|\1\t${tcCC}|" \
sed -i -e "/^CC_COM_DEF=/s|gcc|${tcCC}|" \
- -e "/^CC++_COM_DEF=/s|g++|${tcCXX}|" \
+ -e "/^CC++_COM_DEF=/s|g[+][+]|${tcCXX}|" \
-e "/COPTOPT=/s|-O||" \
- -e 's|$(GCCOPTOPT)||' \
+ -e 's|[$][(]GCCOPTOPT[)]||' \
+ -e 's|[$][(]GCC_OPTXX[)]||' \
cc-gcc.rul || die "sed cc-gcc.rul"
+ sed -i -e "/^CC_COM_DEF=/s|clang|${tcCC}|" \
+ -e "/^CC++_COM_DEF=/s|clang[+][+]|${tcCXX}|" \
+ -e "/COPTOPT=/s|-O||" \
+ -e 's|[$][(]CLANGOPTXX[)]||' \
+ cc-clang.rul || die "sed cc-gcc.rul"
sed -i -e "s|^#\(CONFFLAGS +=\).*|\1\t-cc=${tcCC}|" \
rules.cnf || die "sed rules.cnf"
@@ -140,6 +147,7 @@ src_schily_prepare() (
-e "s|^\(INS_BASE=\).*|\1\t${ED}/usr|" \
-e "s|^\(INS_RBASE=\).*|\1\t${ED}|" \
-e "s|^\(DEFINSGRP=\).*|\1\t0|" \
+ -e "s|^\(DEFCCOM=\).*|\1\t${tcCC}|" \
-e '/^DEFUMASK/s,002,022,g' \
Defaults.${os} || die "sed Schily make setup"
)
@@ -161,6 +169,7 @@ targets() {
src_prepare() {
default
filter-flags -fPIE -pie '-flto*' -fwhole-program -fno-common
+ append-cflags $(test-flags-CC -fno-strict-overflow)
src_schily_prepare
sed -i -e '1s!man1/sh\.1!man1/bosh.1!' -- "${S}/sh/"{jsh,pfsh}.1 || die
sed -i \
diff --git a/app-shells/schily-tools/schily-tools-2018.04.17.ebuild b/app-shells/schily-tools/schily-tools-2018.05.02.ebuild
index 2b37466e..b52de00e 100644
--- a/app-shells/schily-tools/schily-tools-2018.04.17.ebuild
+++ b/app-shells/schily-tools/schily-tools-2018.05.02.ebuild
@@ -124,11 +124,18 @@ src_schily_prepare() (
local tcCXX=$(tc-getCXX)
sed -i -e "/cc-config.sh/s|\$(C_ARCH:%64=%) \$(CCOM_DEF)|${tcCC} ${tcCC}|" \
rules1.top || die "sed rules1.top"
+ # -e "s|^\(DEFCCOM_DEF=\).*|\1\t${tcCC}|" \
sed -i -e "/^CC_COM_DEF=/s|gcc|${tcCC}|" \
- -e "/^CC++_COM_DEF=/s|g++|${tcCXX}|" \
+ -e "/^CC++_COM_DEF=/s|g[+][+]|${tcCXX}|" \
-e "/COPTOPT=/s|-O||" \
- -e 's|$(GCCOPTOPT)||' \
+ -e 's|[$][(]GCCOPTOPT[)]||' \
+ -e 's|[$][(]GCC_OPTXX[)]||' \
cc-gcc.rul || die "sed cc-gcc.rul"
+ sed -i -e "/^CC_COM_DEF=/s|clang|${tcCC}|" \
+ -e "/^CC++_COM_DEF=/s|clang[+][+]|${tcCXX}|" \
+ -e "/COPTOPT=/s|-O||" \
+ -e 's|[$][(]CLANGOPTXX[)]||' \
+ cc-clang.rul || die "sed cc-gcc.rul"
sed -i -e "s|^#\(CONFFLAGS +=\).*|\1\t-cc=${tcCC}|" \
rules.cnf || die "sed rules.cnf"
@@ -144,6 +151,7 @@ src_schily_prepare() (
-e "s|^\(INS_BASE=\).*|\1\t${ED}/usr|" \
-e "s|^\(INS_RBASE=\).*|\1\t${ED}|" \
-e "s|^\(DEFINSGRP=\).*|\1\t0|" \
+ -e "s|^\(DEFCCOM=\).*|\1\t${tcCC}|" \
-e '/^DEFUMASK/s,002,022,g' \
Defaults.${os} || die "sed Schily make setup"
)
@@ -165,6 +173,7 @@ targets() {
src_prepare() {
default
filter-flags -fPIE -pie '-flto*' -fwhole-program -fno-common
+ append-cflags $(test-flags-CC -fno-strict-overflow)
src_schily_prepare
sed -i -e '1s!man1/sh\.1!man1/bosh.1!' -- "${S}/sh/"{jsh,pfsh}.1 || die
sed -i \
@@ -402,7 +411,7 @@ src_install() {
fi
if ! use system-libschily && use renameschily_libschily
then for i in error fexecve fnmatch getline {,f,s}printf strlen
- do mv -- "${ED}"/usr/share/man/man3/{,schily-}${i}.3 || die
+ do mv -v -- "${ED}"/usr/share/man/man3/{,schily-}${i}.3 || die
done
fi
}
diff --git a/metadata/pkg_desc_index b/metadata/pkg_desc_index
index 8200d3b3..6a4726cf 100644
--- a/metadata/pkg_desc_index
+++ b/metadata/pkg_desc_index
@@ -38,7 +38,7 @@ app-shells/oh-my-zsh 99999999: A ready-to-use zsh configuration with plugins
app-shells/push 3.1: A POSIX shell function to treat a variable like an array, quoting args
app-shells/quoter 4.1: Quote arguments or standard input for usage in POSIX shell by eval
app-shells/runtitle 2.10: Scripts to run commands and set the hard status line (windows title)
-app-shells/schily-tools 2017.09.25 2018.04.17: Many tools from Joerg Schilling, including a POSIX compliant Bourne Shell
+app-shells/schily-tools 2017.09.25 2018.05.02: Many tools from Joerg Schilling, including a POSIX compliant Bourne Shell
app-shells/set_prompt 3.0.0: An intelligent prompt for zsh or bash with status line (window title) support
app-shells/termcolors-mv 4.7: 256colors sample script and dircolors configuration for standard or 256 colors
app-shells/zsh-syntax-highlighting 0.6.0 0.6.1_alpha20180411 99999999: Fish shell like syntax highlighting for zsh