summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <mvath@google.com>2018-11-24 22:30:43 +0100
committerMartin Väth <mvath@google.com>2018-11-24 22:30:43 +0100
commit19cdbf120ef2c932a472df20f9e5fa6c7d8d1ae6 (patch)
tree7bd345f31194030473153af8aa317614b4de01f5
parentsys-apps/less: Version bump (diff)
downloadmv-19cdbf120ef2c932a472df20f9e5fa6c7d8d1ae6.tar.gz
mv-19cdbf120ef2c932a472df20f9e5fa6c7d8d1ae6.tar.bz2
mv-19cdbf120ef2c932a472df20f9e5fa6c7d8d1ae6.zip
app-shells, media-tv: Version bumps
Signed-off-by: Martin Väth <mvath@google.com>
-rw-r--r--app-shells/schily-tools/Manifest2
-rw-r--r--app-shells/schily-tools/metadata.xml1
-rw-r--r--app-shells/schily-tools/schily-tools-2018.11.22.ebuild (renamed from app-shells/schily-tools/schily-tools-2018.10.30.ebuild)23
-rw-r--r--app-shells/zsh-autosuggestions/Manifest4
-rw-r--r--app-shells/zsh-autosuggestions/zsh-autosuggestions-0.5.0.ebuild (renamed from app-shells/zsh-autosuggestions/zsh-autosuggestions-0.4.3.ebuild)4
-rw-r--r--app-shells/zsh-autosuggestions/zsh-autosuggestions-0.5.1_alpha20181118.ebuild (renamed from app-shells/zsh-autosuggestions/zsh-autosuggestions-0.4.4_alpha20180717.ebuild)4
-rw-r--r--app-shells/zsh-autosuggestions/zsh-autosuggestions-99999999.ebuild4
-rw-r--r--media-tv/sundtek-tv/Manifest2
-rw-r--r--media-tv/sundtek-tv/sundtek-tv-181113.203858.ebuild (renamed from media-tv/sundtek-tv/sundtek-tv-181023.121417.ebuild)0
-rw-r--r--metadata/pkg_desc_index6
-rw-r--r--profiles/use.local.desc1
11 files changed, 31 insertions, 20 deletions
diff --git a/app-shells/schily-tools/Manifest b/app-shells/schily-tools/Manifest
index 0d22d6de..8827086c 100644
--- a/app-shells/schily-tools/Manifest
+++ b/app-shells/schily-tools/Manifest
@@ -1 +1 @@
-DIST schily-2018-10-30.tar.bz2 4311065 SHA512 72765d11eff52f744a707605a53365da69037c3d982c7b8f4cee98f109f856ee28af3420f63c3fe5a7890649c4eb0fa4dd69d367b7ec41026f288d6237c98d96
+DIST schily-2018-11-22.tar.bz2 4309542 SHA512 35771a2842da0c53d6a432f985db4f7738d943a6a53b641eb6fe1d7cf3a257e49eb85bbcf0949c433346660c6a26a135f6d75b865dc89c208a7644e61a171df8
diff --git a/app-shells/schily-tools/metadata.xml b/app-shells/schily-tools/metadata.xml
index c2029fcf..30c2edc7 100644
--- a/app-shells/schily-tools/metadata.xml
+++ b/app-shells/schily-tools/metadata.xml
@@ -16,6 +16,7 @@
<flag name="renameschily_calc">Rename calc to scalc for compatibility with sci-mathematics/calc</flag>
<flag name="renameschily_compare">Rename compare to scompare for compatibility with imagemagick</flag>
<flag name="renameschily_count">Rename count to scount for compatibility with sys-devel/llvm</flag>
+ <flag name="renameschily_getopt">Rename count to scount for compatibility with sys-devel/llvm</flag>
<flag name="renameschily_jsh">Rename jsh to sjsh for compatibility with app-shells/heirloom-sh</flag>
<flag name="renameschily_man2html">Rename man2html to sman2html for compatibility with sys-apps/man</flag>
<flag name="renameschily_libschily">Rename some manpages from libschily for compatibility with sys-apps/man</flag>
diff --git a/app-shells/schily-tools/schily-tools-2018.10.30.ebuild b/app-shells/schily-tools/schily-tools-2018.11.22.ebuild
index 51fd38c4..6a3175a5 100644
--- a/app-shells/schily-tools/schily-tools-2018.10.30.ebuild
+++ b/app-shells/schily-tools/schily-tools-2018.11.22.ebuild
@@ -33,7 +33,7 @@ add_iuse_expand() {
done
}
add_iuse_expand renameschily \
- +calc +compare +count +jsh +libschily +man2html +p
+ +calc +compare +count +getopt +jsh +libschily +man2html +p
add_iuse_expand schilytools +bosh +calc +calltree +cdrtools \
+change +compare +copy +count +cpp +cstyle +cut \
+hdump label +lndir +man2html manmake +match +mdigest mountcd \
@@ -43,6 +43,7 @@ add_iuse_expand schilytools +bosh +calc +calltree +cdrtools \
COMMON="!!app-cdr/cdrtools[-schily-tools(-)]
!!app-arch/star
!renameschily_libschily? ( !sys-apps/man )
+!renameschily_getopt? ( !sys-apps/man )
schilytools_calc? (
!renameschily_calc? ( !sci-mathematics/calc )
)
@@ -174,13 +175,18 @@ src_schily_prepare() (
targets=""
+have_target() {
+ case " ${targets} " in
+ *" ${1} "*)
+ return 0;;
+ esac
+ return 1
+}
+
targets() {
local i
for i
- do case " ${targets} " in
- *" ${i} "*)
- continue;;
- esac
+ do have_target "${i}" && continue
mv -v UNUSED_TARGETS/??"${i}" TARGETS || die
targets=${targets}${targets:+\ }${i}
done
@@ -470,10 +476,13 @@ src_install() {
docompress -x /usr/share/man/help
fi
if use renameschily_libschily; then
- for i in error fexecve fnmatch getline {,f,s}printf strlen
- do mv -v -- "${ED}"/usr/share/man/man3/{,schily-}${i}.3 || die
+ for i in error fexecve fnmatch getline {,f,s}printf strlen; do
+ mv -v -- "${ED}"/usr/share/man/man3/{,schily-}${i}.3 || die
done
fi
+ if use renameschily_getopt && have_target libgetopt; then
+ mv -v -- "${ED}"/usr/share/man/man3/{,schily-}getopt.3 || die
+ fi
}
pkg_postinst() {
diff --git a/app-shells/zsh-autosuggestions/Manifest b/app-shells/zsh-autosuggestions/Manifest
index e1e7f83e..803053c9 100644
--- a/app-shells/zsh-autosuggestions/Manifest
+++ b/app-shells/zsh-autosuggestions/Manifest
@@ -1,2 +1,2 @@
-DIST zsh-autosuggestions-0.4.3.tar.gz 20243 SHA512 c9be728bfd4cea67cc580548bda4c1b043e275a5a6f0c2134120e7e62e4522da2eddfff4c9414b5d6f28210d2f0b0f5bf008e7275c977c81bd61194f653c922c
-DIST zsh-autosuggestions-0.4.4_alpha20180717.tar.gz 21861 SHA512 6be82b3b03bef731c416c0e3be9c9f876584037dc9619f96bbc1246c393f3df7b0ee0ebdd14a6da4bde021fbe3b9551212b2732165646fa18eb13805e9e24b24
+DIST zsh-autosuggestions-0.5.0.tar.gz 23018 SHA512 0b26d56bd01c6a47e9a3815a5c1210b6c967c8d182544c6c2f94c02ac8135d0306a12055f1e786c9a78c2acc0f23a7b65b51410bc46408253a46cdec8e30312a
+DIST zsh-autosuggestions-0.5.1_alpha20181118.tar.gz 22752 SHA512 8e8e503c9a4d486736f8bd5b4bc8afdf1d155a42dccd90a99b529084c0007798e2b9c5292e88b143deb9856fa4c49d4f5fc8a35ef2f8d898b88fc532115e0873
diff --git a/app-shells/zsh-autosuggestions/zsh-autosuggestions-0.4.3.ebuild b/app-shells/zsh-autosuggestions/zsh-autosuggestions-0.5.0.ebuild
index a8d0db2f..42fb35e8 100644
--- a/app-shells/zsh-autosuggestions/zsh-autosuggestions-0.4.3.ebuild
+++ b/app-shells/zsh-autosuggestions/zsh-autosuggestions-0.5.0.ebuild
@@ -16,11 +16,11 @@ case ${PV} in
SRC_URI=""
KEYWORDS="";;
*alpha*)
- EGIT_COMMIT="fa5d9c0ff5fb202545e12c98dae086d91d70ba50"
+ EGIT_COMMIT="4838222dde4e286b6861bb83bc21f0a3d50b7a5f"
SRC_URI="https://github.com/zsh-users/${PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
S="${WORKDIR}/${PN}-${EGIT_COMMIT}";;
*)
- SRC_URI="https://github.com/zsh-users/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz";;
+ SRC_URI="https://github.com/zsh-users/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz";;
esac
DESCRIPTION="Fish-like autosuggestions for zsh"
diff --git a/app-shells/zsh-autosuggestions/zsh-autosuggestions-0.4.4_alpha20180717.ebuild b/app-shells/zsh-autosuggestions/zsh-autosuggestions-0.5.1_alpha20181118.ebuild
index a8d0db2f..42fb35e8 100644
--- a/app-shells/zsh-autosuggestions/zsh-autosuggestions-0.4.4_alpha20180717.ebuild
+++ b/app-shells/zsh-autosuggestions/zsh-autosuggestions-0.5.1_alpha20181118.ebuild
@@ -16,11 +16,11 @@ case ${PV} in
SRC_URI=""
KEYWORDS="";;
*alpha*)
- EGIT_COMMIT="fa5d9c0ff5fb202545e12c98dae086d91d70ba50"
+ EGIT_COMMIT="4838222dde4e286b6861bb83bc21f0a3d50b7a5f"
SRC_URI="https://github.com/zsh-users/${PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
S="${WORKDIR}/${PN}-${EGIT_COMMIT}";;
*)
- SRC_URI="https://github.com/zsh-users/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz";;
+ SRC_URI="https://github.com/zsh-users/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz";;
esac
DESCRIPTION="Fish-like autosuggestions for zsh"
diff --git a/app-shells/zsh-autosuggestions/zsh-autosuggestions-99999999.ebuild b/app-shells/zsh-autosuggestions/zsh-autosuggestions-99999999.ebuild
index a8d0db2f..42fb35e8 100644
--- a/app-shells/zsh-autosuggestions/zsh-autosuggestions-99999999.ebuild
+++ b/app-shells/zsh-autosuggestions/zsh-autosuggestions-99999999.ebuild
@@ -16,11 +16,11 @@ case ${PV} in
SRC_URI=""
KEYWORDS="";;
*alpha*)
- EGIT_COMMIT="fa5d9c0ff5fb202545e12c98dae086d91d70ba50"
+ EGIT_COMMIT="4838222dde4e286b6861bb83bc21f0a3d50b7a5f"
SRC_URI="https://github.com/zsh-users/${PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
S="${WORKDIR}/${PN}-${EGIT_COMMIT}";;
*)
- SRC_URI="https://github.com/zsh-users/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz";;
+ SRC_URI="https://github.com/zsh-users/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz";;
esac
DESCRIPTION="Fish-like autosuggestions for zsh"
diff --git a/media-tv/sundtek-tv/Manifest b/media-tv/sundtek-tv/Manifest
index fae36f7d..9782ec0d 100644
--- a/media-tv/sundtek-tv/Manifest
+++ b/media-tv/sundtek-tv/Manifest
@@ -1 +1 @@
-DIST sundtek_installer_181023.121417.sh 37073351 SHA512 73cb4ca918db04ba0b962cc81577c1620d4b650fc9366b118160e743e267c63f13e1b0b0ec3c2a9094e68a5b505956964a48cf22d8a32e45e342a1c8361c6b58
+DIST sundtek_installer_181113.203858.sh 37078287 SHA512 e3f3e236e4bcc365f7d5fb45e9b5732214a679f39f79e6963a56d301694d55276865338eea7429594199eda167a79d3c6ebe4c42b415c083d755e78e5b9993e7
diff --git a/media-tv/sundtek-tv/sundtek-tv-181023.121417.ebuild b/media-tv/sundtek-tv/sundtek-tv-181113.203858.ebuild
index 8ce8d456..8ce8d456 100644
--- a/media-tv/sundtek-tv/sundtek-tv-181023.121417.ebuild
+++ b/media-tv/sundtek-tv/sundtek-tv-181113.203858.ebuild
diff --git a/metadata/pkg_desc_index b/metadata/pkg_desc_index
index a1e171fd..a8a367e4 100644
--- a/metadata/pkg_desc_index
+++ b/metadata/pkg_desc_index
@@ -40,10 +40,10 @@ app-shells/oh-my-zsh 99999999: A ready-to-use zsh configuration with plugins
app-shells/push 3.1-r2: A POSIX shell function to treat a variable like an array, quoting args
app-shells/quoter 4.1-r1: Quote arguments or standard input for usage in POSIX shell by eval
app-shells/runtitle 2.10: Scripts to run commands and set the hard status line (windows title)
-app-shells/schily-tools 2018.10.30: Many tools from Joerg Schilling, including a POSIX compliant Bourne Shell
+app-shells/schily-tools 2018.11.22: Many tools from Joerg Schilling, including a POSIX compliant Bourne Shell
app-shells/set_prompt 3.1: An intelligent prompt for zsh or bash with status line (window title) support
app-shells/termcolors-mv 4.7-r1: 256colors sample script and dircolors configuration for standard or 256 colors
-app-shells/zsh-autosuggestions 0.4.3 0.4.4_alpha20180717 99999999: Fish-like autosuggestions for zsh
+app-shells/zsh-autosuggestions 0.5.0 0.5.1_alpha20181118 99999999: Fish-like autosuggestions for zsh
app-shells/zsh-syntax-highlighting 0.6.0 0.6.1_alpha20180411 99999999: Fish shell like syntax highlighting for zsh
app-shells/zshrc-mv 4.10: A zshrc file initializing zsh specific interactive features
app-text/ispell 3.3.02-r1 3.4.00: fast screen-oriented spelling checker
@@ -79,7 +79,7 @@ media-gfx/pqiv 2.10.4: powerful GTK based command-line image viewer with a minim
media-libs/avidemux-core 2.7.1: Core libraries for simple video cutting, filtering and encoding tasks
media-libs/avidemux-plugins 2.7.1: Plugins for the video editor media-video/avidemux
media-tv/nvtv 0.4.7-r3: TV-Out for NVidia cards
-media-tv/sundtek-tv 181023.121417: Sundtek MediaTV Pro III Drivers
+media-tv/sundtek-tv 181113.203858: Sundtek MediaTV Pro III Drivers
media-tv/w_scan 20170107-r1: Scan for DVB-C/DVB-T/DVB-S channels without prior knowledge of frequencies
media-video/avidemux 2.7.1: Video editor designed for simple cutting, filtering and encoding tasks
media-video/avinfo 1.0_alpha15_p1: Utility for displaying AVI information
diff --git a/profiles/use.local.desc b/profiles/use.local.desc
index 036ce88e..437b0a60 100644
--- a/profiles/use.local.desc
+++ b/profiles/use.local.desc
@@ -27,6 +27,7 @@ app-shells/dash:vanilla - Let echo escapes and -n work as decided by upstream
app-shells/schily-tools:renameschily_calc - Rename calc to scalc for compatibility with sci-mathematics/calc
app-shells/schily-tools:renameschily_compare - Rename compare to scompare for compatibility with imagemagick
app-shells/schily-tools:renameschily_count - Rename count to scount for compatibility with sys-devel/llvm
+app-shells/schily-tools:renameschily_getopt - Rename count to scount for compatibility with sys-devel/llvm
app-shells/schily-tools:renameschily_jsh - Rename jsh to sjsh for compatibility with app-shells/heirloom-sh
app-shells/schily-tools:renameschily_libschily - Rename some manpages from libschily for compatibility with sys-apps/man
app-shells/schily-tools:renameschily_man2html - Rename man2html to sman2html for compatibility with sys-apps/man