summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2016-08-06 09:14:49 +0200
committerMartin Väth <martin@mvath.de>2016-08-06 09:14:49 +0200
commit1a8d49c5a468c11856dc34da368cd8c1936b53fc (patch)
treeaae966cd537778e64281b42bad19d7d76f797fb2
parentapp-shells/auto-fu-zsh: Use identical ebuilds for all versions (diff)
downloadmv-1a8d49c5a468c11856dc34da368cd8c1936b53fc.tar.gz
mv-1a8d49c5a468c11856dc34da368cd8c1936b53fc.tar.bz2
mv-1a8d49c5a468c11856dc34da368cd8c1936b53fc.zip
app-portage/etcat: Versioned ebuild. Remove python3 hacks
-rw-r--r--app-portage/etcat/Manifest1
-rw-r--r--app-portage/etcat/etcat-1.0.0.ebuild39
-rw-r--r--app-portage/etcat/etcat-99999999.ebuild25
3 files changed, 55 insertions, 10 deletions
diff --git a/app-portage/etcat/Manifest b/app-portage/etcat/Manifest
new file mode 100644
index 00000000..696b84b0
--- /dev/null
+++ b/app-portage/etcat/Manifest
@@ -0,0 +1 @@
+DIST etcat-1.0.0.tar.gz 40260 SHA256 b722c26645d71c31cb6ff5759edc2d947935a89b5b2a4704dffab6fab83f9ccf
diff --git a/app-portage/etcat/etcat-1.0.0.ebuild b/app-portage/etcat/etcat-1.0.0.ebuild
new file mode 100644
index 00000000..3cb01d46
--- /dev/null
+++ b/app-portage/etcat/etcat-1.0.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( pypy python2_7 python3_3 python3_4 python3_5 )
+
+case ${PV} in
+99999999*)
+ EGIT_REPO_URI="git://github.com/proteusx/${PN}.git"
+ inherit git-r3
+ PROPERTIES="live"
+ KEYWORDS=""
+ SRC_URI="";;
+*)
+ RESTRICT="mirror"
+ SRC_URI="https://github.com/proteusx/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+esac
+inherit python-single-r1
+
+DESCRIPTION="Updated version of an old Portage information extractor"
+HOMEPAGE="https://github.com/proteusx/etcat/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND="app-portage/gentoolkit[${PYTHON_USEDEP}]"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+src_prepare() {
+ python_fix_shebang "${S}"
+ eapply_user
+}
+
+src_install() {
+ dobin "${PN}"
+}
diff --git a/app-portage/etcat/etcat-99999999.ebuild b/app-portage/etcat/etcat-99999999.ebuild
index 22bd6af5..3cb01d46 100644
--- a/app-portage/etcat/etcat-99999999.ebuild
+++ b/app-portage/etcat/etcat-99999999.ebuild
@@ -4,28 +4,33 @@
EAPI=6
PYTHON_COMPAT=( pypy python2_7 python3_3 python3_4 python3_5 )
-EGIT_REPO_URI="git://github.com/proteusx/${PN}.git"
-inherit git-r3 python-single-r1
+
+case ${PV} in
+99999999*)
+ EGIT_REPO_URI="git://github.com/proteusx/${PN}.git"
+ inherit git-r3
+ PROPERTIES="live"
+ KEYWORDS=""
+ SRC_URI="";;
+*)
+ RESTRICT="mirror"
+ SRC_URI="https://github.com/proteusx/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+esac
+inherit python-single-r1
DESCRIPTION="Updated version of an old Portage information extractor"
HOMEPAGE="https://github.com/proteusx/etcat/"
-SRC_URI=""
-PROPERTIES="live"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS=""
IUSE=""
RDEPEND="app-portage/gentoolkit[${PYTHON_USEDEP}]"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
src_prepare() {
- sed -i -e 's/ / /g' \
- -e 's/^\(.*[ ]\)\?print \(.*\)$/\1print(\2)/' \
- -e 's/^\(.*[ ]\)\?\(except .*\), \(.*\)$/\1\2 as \3/' \
- -- "${S}/${PN}"
- python_fix_shebang --force "${S}"
+ python_fix_shebang "${S}"
eapply_user
}