summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2017-11-04 08:31:59 +0100
committerMartin Väth <martin@mvath.de>2017-11-04 08:31:59 +0100
commit20c01f3384e26264aa3694eeb62eacd442e9e2b2 (patch)
treeff02c235763e016c28ab26fae2d87a110c1ea480
parentwww-plugins/noscript: Version bump (diff)
downloadmv-20c01f3384e26264aa3694eeb62eacd442e9e2b2.tar.gz
mv-20c01f3384e26264aa3694eeb62eacd442e9e2b2.tar.bz2
mv-20c01f3384e26264aa3694eeb62eacd442e9e2b2.zip
Fix and use manifest.json parsing when possible
-rw-r--r--eclass/mv_mozextension-r1.eclass4
-rw-r--r--www-plugins/google-translation/Manifest2
-rw-r--r--www-plugins/no-color/no-color-0.9.1.ebuild4
-rw-r--r--www-plugins/stylus/stylus-1.1.4.2.ebuild6
4 files changed, 6 insertions, 10 deletions
diff --git a/eclass/mv_mozextension-r1.eclass b/eclass/mv_mozextension-r1.eclass
index 94fb5bb1..454cd1bc 100644
--- a/eclass/mv_mozextension-r1.eclass
+++ b/eclass/mv_mozextension-r1.eclass
@@ -357,10 +357,10 @@ moz_getid() {
else file=${dir}/manifest.json
test -f "${file}" || die "cannot find ${dir}/{install.rdf,manifest.json}"
sub='^[[:space:]]*["'\''][iI][dD]["'\''][[:space:]]*:[[:space:]]*'
- sub=${sub}'["'\'']\(.*\)["'\''][[:space:]]*,[[:space:]]*$/\1'
+ sub=${sub}'["'\'']\(.*\)["'\''][[:space:]]*,\?[[:space:]]*$/\1'
res=$(sed -n -e "s/${sub}/p" -- "${file}") || res=
fi
- [ -n "${res}" ] || die "failed to determine id from ${file} $sub"
+ [ -n "${res}" ] || die "failed to determine id from ${file}"
eval ${var}=\${res}
}
diff --git a/www-plugins/google-translation/Manifest b/www-plugins/google-translation/Manifest
index 6c6df6f6..554e8dd0 100644
--- a/www-plugins/google-translation/Manifest
+++ b/www-plugins/google-translation/Manifest
@@ -1 +1 @@
-DIST google_translation-2.6-an+fx.xpi 15349 SHA256 1cadd4d685ae884bb6fe01893a0b139910e853ba45d11b08eae6d3e04c7604cb SHA512 b781a1ef0446b24c7aad36cb025ee7a28994c89862f1cd0479d6a051c5f53dc37c2887dbdbacedeb8d114dafa8db004c6cbb6dc25dbbc69377df57b9a7ab605f
+DIST google_translation-2.6-an+fx.xpi 15349 SHA512 b781a1ef0446b24c7aad36cb025ee7a28994c89862f1cd0479d6a051c5f53dc37c2887dbdbacedeb8d114dafa8db004c6cbb6dc25dbbc69377df57b9a7ab605f
diff --git a/www-plugins/no-color/no-color-0.9.1.ebuild b/www-plugins/no-color/no-color-0.9.1.ebuild
index 485794d8..e9356058 100644
--- a/www-plugins/no-color/no-color-0.9.1.ebuild
+++ b/www-plugins/no-color/no-color-0.9.1.ebuild
@@ -14,6 +14,4 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
-INSTALL_ID='{ae443e4d-02db-4eef-bcc2-0f1b17edb941}'
-
-moz_defaults -i"${INSTALL_ID}" firefox seamonkey
+moz_defaults firefox seamonkey
diff --git a/www-plugins/stylus/stylus-1.1.4.2.ebuild b/www-plugins/stylus/stylus-1.1.4.2.ebuild
index 4cdea2e6..c3210c6d 100644
--- a/www-plugins/stylus/stylus-1.1.4.2.ebuild
+++ b/www-plugins/stylus/stylus-1.1.4.2.ebuild
@@ -22,12 +22,10 @@ but meanwhile it is easier to surf with javascript activated to
http://userstyles.org/users/8172
Note that you have to temporarily disable noscript for that site."
-INSTALL_ID=-i'{7a7a4a92-a2a0-41d1-9fd7-1e92480d612d}'
-
-moz_defaults "${INSTALL_ID}" firefox seamonkey
+moz_defaults firefox seamonkey
src_install() {
- moz_install "${INSTALL_ID}"
+ moz_install
readme.gentoo_create_doc
}