summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2018-06-24 08:06:33 +0200
committerMartin Väth <martin@mvath.de>2018-06-24 08:06:33 +0200
commit44e7a5c86a4579e4aaf716b2f71ef106fdf447ef (patch)
treea0d40012d83610182dd6234fd219566de826c36f
parentdev-tex/chklref: EAPI=7 (diff)
downloadmv-44e7a5c86a4579e4aaf716b2f71ef106fdf447ef.tar.gz
mv-44e7a5c86a4579e4aaf716b2f71ef106fdf447ef.tar.bz2
mv-44e7a5c86a4579e4aaf716b2f71ef106fdf447ef.zip
alpha version bumps
-rw-r--r--app-shells/fast-syntax-highlighting/Manifest1
-rw-r--r--app-shells/fast-syntax-highlighting/fast-syntax-highlighting-1.21.ebuild2
-rw-r--r--app-shells/fast-syntax-highlighting/fast-syntax-highlighting-1.22_alpha20180721.ebuild50
-rw-r--r--app-shells/fast-syntax-highlighting/fast-syntax-highlighting-99999999.ebuild2
-rw-r--r--metadata/pkg_desc_index4
-rw-r--r--sys-fs/squashfuse/Manifest1
-rw-r--r--sys-fs/squashfuse/squashfuse-0.1.103.ebuild2
-rw-r--r--sys-fs/squashfuse/squashfuse-0.1.104_alpha20180721.ebuild56
8 files changed, 113 insertions, 5 deletions
diff --git a/app-shells/fast-syntax-highlighting/Manifest b/app-shells/fast-syntax-highlighting/Manifest
index b3ab4a23..1772decb 100644
--- a/app-shells/fast-syntax-highlighting/Manifest
+++ b/app-shells/fast-syntax-highlighting/Manifest
@@ -1 +1,2 @@
DIST fast-syntax-highlighting-1.21.tar.gz 259840 SHA512 b39e52b62ada6647cf59c145dfec79baed6da09dad43648a50d6b39c21f2bcb98f9f881cba1bb5c7dbc2828c4522c95e18ad9753741860d3ca6ba00c1cf671d6
+DIST fast-syntax-highlighting-1.22_alpha20180721.tar.gz 266481 SHA512 8f586bb1cab60c7569c963b56d6b43618e51f4e2114a4279ce47db96279260835e9c5da93ac187b217913a7aa31f25569bd7815ff8fd9cb196c912eb6add158f
diff --git a/app-shells/fast-syntax-highlighting/fast-syntax-highlighting-1.21.ebuild b/app-shells/fast-syntax-highlighting/fast-syntax-highlighting-1.21.ebuild
index d636d94d..b40002f6 100644
--- a/app-shells/fast-syntax-highlighting/fast-syntax-highlighting-1.21.ebuild
+++ b/app-shells/fast-syntax-highlighting/fast-syntax-highlighting-1.21.ebuild
@@ -15,7 +15,7 @@ case ${PV} in
SRC_URI=""
KEYWORDS="";;
*alpha*)
- EGIT_COMMIT="7bec6e57829e1020165a03371ea38a4adae7176d"
+ EGIT_COMMIT="3361bb62d66540eda6dfa23f3df34125c27d420f"
SRC_URI="https://github.com/zdharma/${PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
S="${WORKDIR}/${PN}-${EGIT_COMMIT}";;
*)
diff --git a/app-shells/fast-syntax-highlighting/fast-syntax-highlighting-1.22_alpha20180721.ebuild b/app-shells/fast-syntax-highlighting/fast-syntax-highlighting-1.22_alpha20180721.ebuild
new file mode 100644
index 00000000..b40002f6
--- /dev/null
+++ b/app-shells/fast-syntax-highlighting/fast-syntax-highlighting-1.22_alpha20180721.ebuild
@@ -0,0 +1,50 @@
+# Copyright 2011-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit readme.gentoo-r1
+
+RESTRICT="mirror"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+case ${PV} in
+99999999*)
+ EGIT_REPO_URI="https://github.com/zdharma/${PN}.git"
+ inherit git-r3
+ PROPERTIES="live"
+ SRC_URI=""
+ KEYWORDS="";;
+*alpha*)
+ EGIT_COMMIT="3361bb62d66540eda6dfa23f3df34125c27d420f"
+ SRC_URI="https://github.com/zdharma/${PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}-${EGIT_COMMIT}";;
+*)
+ SRC_URI="https://github.com/zdharma/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz";;
+esac
+
+DESCRIPTION="Optimized and extended zsh-syntax-highlighting"
+HOMEPAGE="https://github.com/zdharma/fast-syntax-highlighting/"
+
+LICENSE="HPND"
+SLOT="0"
+IUSE=""
+
+RDEPEND="app-shells/zsh"
+DEPEND=""
+
+src_install() {
+ local DISABLE_AUTOFORMATTING DOC_CONTENTS dir
+ dir="/usr/share/zsh/site-contrib/${PN}"
+ DISABLE_AUTOFORMATTING="true"
+ DOC_CONTENTS="In order to use ${CATEGORY}/${PN} add
+. ${EPREFIX}${dir}/fast-syntax-highlighting.plugin.zsh"'
+at the end of your ~/.zshrc
+For testing, you can also execute the above command in your zsh.'
+ readme.gentoo_create_doc
+ insinto "${dir}"
+ doins -r *
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}
diff --git a/app-shells/fast-syntax-highlighting/fast-syntax-highlighting-99999999.ebuild b/app-shells/fast-syntax-highlighting/fast-syntax-highlighting-99999999.ebuild
index d636d94d..b40002f6 100644
--- a/app-shells/fast-syntax-highlighting/fast-syntax-highlighting-99999999.ebuild
+++ b/app-shells/fast-syntax-highlighting/fast-syntax-highlighting-99999999.ebuild
@@ -15,7 +15,7 @@ case ${PV} in
SRC_URI=""
KEYWORDS="";;
*alpha*)
- EGIT_COMMIT="7bec6e57829e1020165a03371ea38a4adae7176d"
+ EGIT_COMMIT="3361bb62d66540eda6dfa23f3df34125c27d420f"
SRC_URI="https://github.com/zdharma/${PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
S="${WORKDIR}/${PN}-${EGIT_COMMIT}";;
*)
diff --git a/metadata/pkg_desc_index b/metadata/pkg_desc_index
index 8ec61ce8..115403dd 100644
--- a/metadata/pkg_desc_index
+++ b/metadata/pkg_desc_index
@@ -35,7 +35,7 @@ app-portage/world-mv 3.19: Organize your world file and find installed packages
app-shells/auto-fu-zsh 0.0.1.12-r4 0.0.1.12_p0 99999999: zsh automatic complete-word and list-choices: incremental completion
app-shells/command-not-found 0.4.5: search ARCH database for packages with similar commands
app-shells/dash 99999999: Descendant of the NetBSD ash. POSIX compliant except for multibyte characters
-app-shells/fast-syntax-highlighting 1.21 99999999: Optimized and extended zsh-syntax-highlighting
+app-shells/fast-syntax-highlighting 1.21 1.22_alpha20180721 99999999: Optimized and extended zsh-syntax-highlighting
app-shells/oh-my-zsh 99999999: A ready-to-use zsh configuration with plugins
app-shells/push 3.1: A POSIX shell function to treat a variable like an array, quoting args
app-shells/quoter 4.1: Quote arguments or standard input for usage in POSIX shell by eval
@@ -107,7 +107,7 @@ sys-boot/grub-cfg-mv 1.5: A grub.cfg library/example for GRUB2
sys-fs/emount 3.0.4: mount/unmount create/remove dm-crypt filesystems according to your /etc/fstab
sys-fs/squash_dir 13.14: Keep directories compressed with squashfs. Useful for portage tree, texmf-dist
sys-fs/squashfs-tools 4.3.1_alpha20180612 99999999: Tool for creating compressed filesystem type squashfs
-sys-fs/squashfuse 0.1.103: FUSE filesystem to mount squashfs archives
+sys-fs/squashfuse 0.1.103 0.1.104_alpha20180721: FUSE filesystem to mount squashfs archives
sys-fs/squashmount 16.1.0 19.0.2: Keep directories compressed with squashfs. Useful for portage tree, texmf-dist
sys-kernel/kccmp 0.3-r1: A simple tool for comparing two linux kernel .config files
sys-kernel/kernel 4.7: A POSIX shell script to compile the kernel with user permissions
diff --git a/sys-fs/squashfuse/Manifest b/sys-fs/squashfuse/Manifest
index e515fde1..8e696f4a 100644
--- a/sys-fs/squashfuse/Manifest
+++ b/sys-fs/squashfuse/Manifest
@@ -1 +1,2 @@
DIST squashfuse-0.1.103.tar.gz 58729 SHA512 f5b671661ede6bbb4e20562113812a1326d2c450e1427d48a5e8d8e71ba4c47554a44d222f85919162270cca513c2c583af9ef7e0c53693baa926347b9a543b2
+DIST squashfuse-0.1.104_alpha20180721.tar.gz 58749 SHA512 8d8e84e87ec09e9f6313d8654252f967d434859a12bb64cffb25283e740ece6d13f2669a5cb4a19a37a127da9aa7c3b24a13c803a70d78425589751e9fc17b20
diff --git a/sys-fs/squashfuse/squashfuse-0.1.103.ebuild b/sys-fs/squashfuse/squashfuse-0.1.103.ebuild
index 23ba3c41..3d888958 100644
--- a/sys-fs/squashfuse/squashfuse-0.1.103.ebuild
+++ b/sys-fs/squashfuse/squashfuse-0.1.103.ebuild
@@ -10,7 +10,7 @@ HOMEPAGE="https://github.com/vasi/squashfuse"
case ${PV} in
*alpha*)
- EGIT_COMMIT="e275db06955d3dc455d55d25c015a6b64b1e4756"
+ EGIT_COMMIT="0b48352ed7a89d920bb6792ac59f9f6775088f02"
SRC_URI="https://github.com/vasi/squashfuse/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
S=${WORKDIR}/${PN}-${EGIT_COMMIT}
alpha=:;;
diff --git a/sys-fs/squashfuse/squashfuse-0.1.104_alpha20180721.ebuild b/sys-fs/squashfuse/squashfuse-0.1.104_alpha20180721.ebuild
new file mode 100644
index 00000000..3d888958
--- /dev/null
+++ b/sys-fs/squashfuse/squashfuse-0.1.104_alpha20180721.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+RESTRICT="mirror"
+inherit autotools flag-o-matic
+
+DESCRIPTION="FUSE filesystem to mount squashfs archives"
+HOMEPAGE="https://github.com/vasi/squashfuse"
+
+case ${PV} in
+*alpha*)
+ EGIT_COMMIT="0b48352ed7a89d920bb6792ac59f9f6775088f02"
+ SRC_URI="https://github.com/vasi/squashfuse/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+ S=${WORKDIR}/${PN}-${EGIT_COMMIT}
+ alpha=:;;
+*)
+ SRC_URI="https://github.com/vasi/squashfuse/archive/${PV}/${P}.tar.gz"
+ alpha=false;;
+esac
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~arm-linux ~x86-linux"
+IUSE="lz4 lzma lzo static-libs +zlib zstd"
+REQUIRED_USE="|| ( lz4 lzma lzo zlib zstd )"
+
+COMMON_DEPEND="
+ >=sys-fs/fuse-2.8.6:=
+ lzma? ( >=app-arch/xz-utils-5.0.4:= )
+ zlib? ( >=sys-libs/zlib-1.2.5-r2:= )
+ lzo? ( >=dev-libs/lzo-2.06:= )
+ lz4? ( >=app-arch/lz4-0_p106:= )
+ zstd? ( >=app-arch/zstd-1.0:= )
+"
+DEPEND="${COMMON_DEPEND}"
+RDEPEND="${COMMON_DEPEND}"
+
+src_prepare() {
+ ! $alpha || sed -i -e '1s:\[0\.1\.100\]:['"${PV}"']:' configure.ac || die
+ AT_M4DIR=${S}/m4 eautoreconf
+ default
+}
+
+src_configure() {
+ filter-flags '-flto*' -fwhole-program -fno-common
+ local myconf=(
+ $(use lz4 || echo --without-lz4)
+ $(use lzma || echo --without-xz)
+ $(use lzo || echo --without-lzo)
+ $(use zlib || echo --without-zlib)
+ $(use zstd || echo --without-zstd)
+ $(use static-libs || echo --disable-static)
+ )
+ econf "${myconf[@]}"
+}