summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2017-04-10 21:51:42 +0200
committerMartin Väth <martin@mvath.de>2017-04-10 21:51:42 +0200
commit82c16b5264e57ffc1fc839fd33e364e08c73d1c0 (patch)
tree97db6269288715ce3bcff3d9b748b390df124e80
parentsys-apps/less: Version bump (diff)
downloadmv-82c16b5264e57ffc1fc839fd33e364e08c73d1c0.tar.gz
mv-82c16b5264e57ffc1fc839fd33e364e08c73d1c0.tar.bz2
mv-82c16b5264e57ffc1fc839fd33e364e08c73d1c0.zip
app-portage/eix: alpha Version bump
-rw-r--r--app-portage/eix/Manifest1
-rw-r--r--app-portage/eix/eix-0.32.8_alpha0.ebuild90
-rw-r--r--app-portage/eix/eix-99999999.ebuild2
3 files changed, 92 insertions, 1 deletions
diff --git a/app-portage/eix/Manifest b/app-portage/eix/Manifest
index 70ca4c9a..0a7a5e6e 100644
--- a/app-portage/eix/Manifest
+++ b/app-portage/eix/Manifest
@@ -1 +1,2 @@
DIST eix-0.32.7.tar.xz 595632 SHA256 2b91365568fd1b87754f25ef4f177c0997d374885fcded74d52bd7cbbe02cc37
+DIST eix-0.32.8_alpha0.tar.gz 650562 SHA256 84d3022752454d40cdf0840a0616b15e1c91cddfd6e0277042be4307de18cc3e
diff --git a/app-portage/eix/eix-0.32.8_alpha0.ebuild b/app-portage/eix/eix-0.32.8_alpha0.ebuild
new file mode 100644
index 00000000..87372310
--- /dev/null
+++ b/app-portage/eix/eix-0.32.8_alpha0.ebuild
@@ -0,0 +1,90 @@
+# Copyright 2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+RESTRICT="mirror"
+WANT_LIBTOOL=none
+PLOCALES="de ru"
+inherit autotools bash-completion-r1 l10n tmpfiles
+
+case ${PV} in
+99999999*)
+ EGIT_REPO_URI="git://github.com/vaeth/${PN}.git"
+ inherit git-r3
+ SRC_URI=""
+ PROPERTIES="live";;
+*)
+ RESTRICT="mirror"
+ EGIT_COMMIT="c9f99fbef7e0cd16d40bc081ae8d8a82c341be46"
+ SRC_URI="https://github.com/vaeth/${PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}-${EGIT_COMMIT}";;
+esac
+
+DESCRIPTION="Search and query ebuilds"
+HOMEPAGE="https://github.com/vaeth/eix/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE="debug +dep doc nls optimization +required-use security strong-optimization strong-security sqlite swap-remote tools"
+
+BOTHDEPEND="nls? ( virtual/libintl )
+ sqlite? ( >=dev-db/sqlite-3:= )"
+RDEPEND="${BOTHDEPEND}
+ >=app-shells/push-2.0-r2
+ >=app-shells/quoter-3.0-r2"
+DEPEND="${BOTHDEPEND}
+ >=sys-devel/gettext-0.19.6"
+
+pkg_setup() {
+ # remove stale cache file to prevent collisions
+ local old_cache="${EROOT}var/cache/${PN}"
+ test -f "${old_cache}" && rm -f -- "${old_cache}"
+}
+
+src_prepare() {
+ sed -i -e "s'/'${EPREFIX}/'" -- "${S}"/tmpfiles.d/eix.conf || die
+ eapply_user
+ eautopoint
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_with sqlite) \
+ $(use_with doc extra-doc) \
+ $(use_enable nls) \
+ $(use_enable tools separate-tools) \
+ $(use_enable security) \
+ $(use_enable optimization) \
+ $(use_enable strong-security) \
+ $(use_enable strong-optimization) \
+ $(use_enable debug debugging) \
+ $(use_enable swap-remote) \
+ $(use_with prefix always-accept-keywords) \
+ $(use_with dep dep-default) \
+ $(use_with required-use required-use-default) \
+ --with-zsh-completion \
+ --with-portage-rootpath="${ROOTPATH}" \
+ --with-eprefix-default="${EPREFIX}"
+}
+
+src_install() {
+ default
+ dobashcomp bash/eix
+ dotmpfiles tmpfiles.d/eix.conf
+}
+
+pkg_postinst() {
+ local obs="${EROOT}var/cache/eix.previous"
+ if test -f "${obs}"; then
+ ewarn "Found obsolete ${obs}, please remove it"
+ fi
+ tmpfiles_process eix.conf
+}
+
+pkg_postrm() {
+ if [ -z "${REPLACED_BY_VERSION}" ]; then
+ rm -rf -- "${EROOT}var/cache/${PN}"
+ fi
+}
diff --git a/app-portage/eix/eix-99999999.ebuild b/app-portage/eix/eix-99999999.ebuild
index 62b4c4e4..87372310 100644
--- a/app-portage/eix/eix-99999999.ebuild
+++ b/app-portage/eix/eix-99999999.ebuild
@@ -15,7 +15,7 @@ case ${PV} in
PROPERTIES="live";;
*)
RESTRICT="mirror"
- EGIT_COMMIT="134e88780e6fcc6d89f52bf1312917371b7a320d"
+ EGIT_COMMIT="c9f99fbef7e0cd16d40bc081ae8d8a82c341be46"
SRC_URI="https://github.com/vaeth/${PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
S="${WORKDIR}/${PN}-${EGIT_COMMIT}";;
esac